source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 1450

Revision 1450, 6.0 KB checked in by owa, 14 years ago (diff)

new upstream

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8Version: 2.6.5
9Release: 1%{?_dist_release}
10Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: mono-devel mono-web
14BuildRequires: mono-data-sqlite mono-data-oracle mono-jscript mono-extras mono-nunit
15BuildRequires: pkgconfig
16# One of the test runs requires this
17BuildRequires: sqlite
18# This must be manually entered according to xsp's protocol version
19# Since this package is currently noarch, and mod_mono's name is different
20# on different distros, we can't use this... yet
21#Requires: mod_mono >= %{version}
22
23%description
24The XSP server is a small Web server that hosts the Mono System.Web
25classes for running what is commonly known as ASP.NET.
26
27
28%prep
29%setup -q
30
31%build
32export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
33# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
34./configure \
35        --prefix=%{_prefix} \
36        --libexecdir=%{_prefix}/lib \
37    --libdir=%{_prefix}/lib \
38    --mandir=%{_prefix}/share/man \
39    --infodir=%{_prefix}/share/info \
40    --sysconfdir=%{_sysconfdir}
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
47make install DESTDIR=$RPM_BUILD_ROOT
48mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
49mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc NEWS README
59%{_bindir}/*
60%{_prefix}/lib/xsp
61%{mono_dir}/gac/Mono.WebServer
62%{mono_dir}/1.0/Mono.WebServer.dll
63%{mono_dir}/gac/Mono.WebServer2
64%{mono_dir}/2.0/Mono.WebServer2.dll
65%{mono_dir}/gac/xsp
66%{mono_dir}/1.0/xsp.exe
67%{mono_dir}/gac/xsp2
68%{mono_dir}/2.0/xsp2.exe
69%{mono_dir}/gac/mod-mono-server
70%{mono_dir}/1.0/mod-mono-server.exe
71%{mono_dir}/gac/mod-mono-server2
72%{mono_dir}/2.0/mod-mono-server2.exe
73%{mono_dir}/gac/fastcgi-mono-server
74%{mono_dir}/1.0/fastcgi-mono-server.exe
75%{mono_dir}/gac/fastcgi-mono-server2
76%{mono_dir}/2.0/fastcgi-mono-server2.exe
77%{_datadir}/pkgconfig/*
78%{_mandir}/*/*
79
80
81%changelog
82* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
83- updated xsp to 2.6.5
84
85* Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
86- updated xsp to 2.6.4
87
88* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
89- updated xsp to 2.6.3
90
91* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
92- updated to 2.6
93- rebuilt with new toolchain
94
95* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
96- updated to 2.4.3
97
98* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
99- changed Group to Applications/Internet
100
101* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
102- updated to 2.4
103
104* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
105- initial build for VineSeed
106        - updated xsp to 2.0
107        - added japanese summary
108        - applied vine versioning policy
109        - spec in utf-8
110
111* Tue Apr 22 2008 wberrier@suse.de
112- update to 1.9.1 (bugfix release)
113  - Output date header (instead of asp.net doing it)
114* Tue Mar 25 2008 wberrier@suse.de
115- update to 1.9
116  - minor test updates
117  - BaseRequestBroker fix: Check if the request ID is valid inside
118  the lock.
119* Mon Jan 14 2008 wberrier@suse.de
120- update to 1.2.6
121  - FastCGI support
122* Thu Aug 30 2007 wberrier@suse.de
123- xsp_1.2.5_p5_final.patch: Fix for regression in the request
124  broker
125* Fri Aug 17 2007 wberrier@suse.de
126- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
127  - bugs: 81699, 81906, 82379, 82057
128  - fixes ability to handle large (GB) uploads (needed for iFolder)
129* Fri Aug  3 2007 wberrier@suse.de
130- Update to 1.2.5
131  - More robust exception handling
132  - Fixed permissions bits for non executable scripts
133  - virtual host support
134  - New Documentation for Mono.WebServer
135  - Improved event handling
136* Tue Jun  5 2007 wberrier@novell.com
137- Remove unnecessary path defines (prefix, sysconfdir)
138- Update to 1.2.4
139  - fix some race conditions and crashes
140  - add tracing support
141* Fri Apr 13 2007 wberrier@novell.com
142- add %%debug_package so debug packages get created
143* Wed Apr 11 2007 wberrier@novell.com
144- Add mono dep/req for older distros
145* Thu Mar  1 2007 wberrier@suse.de
146- Update Update to 1.2.3
147  - Bug fix #80230 (prevents possible nullref)
148  - Support for response header encoding
149* Mon Jan 22 2007 ro@suse.de
150- drop requires for gnome-filesystem
151* Sat Dec  2 2006 wberrier@suse.de
152- Update to 1.2.1 (Fate #301111)
153  - Bugfixes:
154  - close the connection if there's an error reading the headers
155  (including assembly loading exceptions due to a bad installation).
156  - kill the warning that everyone is worried about.
157* Fri Oct 20 2006 wberrier@suse.de
158- Update to 1.1.18
159  - 2.0 updates
160* Thu Oct 19 2006 wberrier@suse.de
161- Add mono-devel to fix bnc #213576 (missing provides)
162* Tue Sep  5 2006 wberrier@suse.de
163- Update to 1.1.17.1 bugfix release
164- Read from the stream, not the socket as the socket data is
165  encrypted when using SSL.
166* Wed Aug 30 2006 wberrier@suse.de
167- Update to 1.1.17
168  - Added support for X.509 client certificates
169  - Update to handle newly created AppDomains
170* Mon Jul 31 2006 wberrier@suse.de
171- update to 1.1.16.1
172- better connection handling
173- fixes bugs: 77698,78034,78621
174* Tue Apr 25 2006 wberrier@suse.de
175- Security update (remove all the duplicated slashes
176  and don't do an extra Replace on non-windows.) and minor fix for
177  [#78034].
178* Wed Jan 25 2006 mls@suse.de
179- converted neededforbuild to BuildRequires
180* Fri Jan  6 2006 wberrier@suse.de
181- Update to 1.1.13, clean up deps
182* Thu Nov 10 2005 wberrier@suse.de
183- Update to 1.1.10, set libdir to lib/
184* Fri Oct  7 2005 wberrier@suse.de
185- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
186  libexec, so I disabled the patch)
187* Tue Jul 19 2005 sbrabec@suse.cz
188- Build as noarch (#81109).
189* Fri Jul 15 2005 sbrabec@suse.cz
190- Updated to version 1.0.9 (#96776).
191* Mon Feb 21 2005 clahey@suse.de
192- Updated to 1.0.6.
193* Sun Feb  6 2005 ro@suse.de
194- use /usr/lib/mono
195* Mon Dec 13 2004 clahey@suse.de
196- New package.
Note: See TracBrowser for help on using the repository browser.