source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 2014

Revision 2014, 6.3 KB checked in by owa, 14 years ago (diff)

mono to 2.8

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8Version: 2.8
9Release: 1%{?_dist_release}
10Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: mono-devel mono-web
14BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
15BuildRequires: pkgconfig
16# One of the test runs requires this
17BuildRequires: sqlite
18# This must be manually entered according to xsp's protocol version
19# Since this package is currently noarch, and mod_mono's name is different
20# on different distros, we can't use this... yet
21#Requires: mod_mono >= %{version}
22
23%description
24The XSP server is a small Web server that hosts the Mono System.Web
25classes for running what is commonly known as ASP.NET.
26
27
28%prep
29%setup -q
30
31%build
32export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
33# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
34./configure \
35        --prefix=%{_prefix} \
36        --libexecdir=%{_prefix}/lib \
37    --libdir=%{_prefix}/lib \
38    --mandir=%{_prefix}/share/man \
39    --infodir=%{_prefix}/share/info \
40    --sysconfdir=%{_sysconfdir}
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
47make install DESTDIR=$RPM_BUILD_ROOT
48mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
49mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc NEWS README
59%{_bindir}/*
60%{_prefix}/lib/xsp
61%{mono_dir}/gac/Mono.WebServer2
62%{mono_dir}/gac/fastcgi-mono-server2
63%{mono_dir}/gac/fastcgi-mono-server4
64%{mono_dir}/gac/mod-mono-server2
65%{mono_dir}/gac/mod-mono-server4
66%{mono_dir}/gac/xsp2
67%{mono_dir}/gac/xsp4
68%{mono_dir}/2.0/Mono.WebServer2.dll
69%{mono_dir}/2.0/fastcgi-mono-server2.exe
70%{mono_dir}/2.0/mod-mono-server2.exe
71%{mono_dir}/2.0/xsp2.exe
72%{mono_dir}/4.0/Mono.WebServer2.dll
73%{mono_dir}/4.0/fastcgi-mono-server4.exe
74%{mono_dir}/4.0/mod-mono-server4.exe
75%{mono_dir}/4.0/xsp4.exe
76%{_prefix}/lib/monodoc/sources/Mono.WebServer.*
77%{_datadir}/pkgconfig/*
78%{_mandir}/*/*
79
80
81%changelog
82* Fri Oct 08 2010 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
83- updated xsp to 2.8
84- rebuilt with mono-2.8
85- dropt BR: mono-jscript
86
87* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
88- rebuild with rpm-4.8.1 for pkg-config file
89
90* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
91- updated xsp to 2.6.5
92
93* Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
94- updated xsp to 2.6.4
95
96* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
97- updated xsp to 2.6.3
98
99* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
100- updated to 2.6
101- rebuilt with new toolchain
102
103* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
104- updated to 2.4.3
105
106* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
107- changed Group to Applications/Internet
108
109* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
110- updated to 2.4
111
112* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
113- initial build for VineSeed
114        - updated xsp to 2.0
115        - added japanese summary
116        - applied vine versioning policy
117        - spec in utf-8
118
119* Tue Apr 22 2008 wberrier@suse.de
120- update to 1.9.1 (bugfix release)
121  - Output date header (instead of asp.net doing it)
122* Tue Mar 25 2008 wberrier@suse.de
123- update to 1.9
124  - minor test updates
125  - BaseRequestBroker fix: Check if the request ID is valid inside
126  the lock.
127* Mon Jan 14 2008 wberrier@suse.de
128- update to 1.2.6
129  - FastCGI support
130* Thu Aug 30 2007 wberrier@suse.de
131- xsp_1.2.5_p5_final.patch: Fix for regression in the request
132  broker
133* Fri Aug 17 2007 wberrier@suse.de
134- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
135  - bugs: 81699, 81906, 82379, 82057
136  - fixes ability to handle large (GB) uploads (needed for iFolder)
137* Fri Aug  3 2007 wberrier@suse.de
138- Update to 1.2.5
139  - More robust exception handling
140  - Fixed permissions bits for non executable scripts
141  - virtual host support
142  - New Documentation for Mono.WebServer
143  - Improved event handling
144* Tue Jun  5 2007 wberrier@novell.com
145- Remove unnecessary path defines (prefix, sysconfdir)
146- Update to 1.2.4
147  - fix some race conditions and crashes
148  - add tracing support
149* Fri Apr 13 2007 wberrier@novell.com
150- add %%debug_package so debug packages get created
151* Wed Apr 11 2007 wberrier@novell.com
152- Add mono dep/req for older distros
153* Thu Mar  1 2007 wberrier@suse.de
154- Update Update to 1.2.3
155  - Bug fix #80230 (prevents possible nullref)
156  - Support for response header encoding
157* Mon Jan 22 2007 ro@suse.de
158- drop requires for gnome-filesystem
159* Sat Dec  2 2006 wberrier@suse.de
160- Update to 1.2.1 (Fate #301111)
161  - Bugfixes:
162  - close the connection if there's an error reading the headers
163  (including assembly loading exceptions due to a bad installation).
164  - kill the warning that everyone is worried about.
165* Fri Oct 20 2006 wberrier@suse.de
166- Update to 1.1.18
167  - 2.0 updates
168* Thu Oct 19 2006 wberrier@suse.de
169- Add mono-devel to fix bnc #213576 (missing provides)
170* Tue Sep  5 2006 wberrier@suse.de
171- Update to 1.1.17.1 bugfix release
172- Read from the stream, not the socket as the socket data is
173  encrypted when using SSL.
174* Wed Aug 30 2006 wberrier@suse.de
175- Update to 1.1.17
176  - Added support for X.509 client certificates
177  - Update to handle newly created AppDomains
178* Mon Jul 31 2006 wberrier@suse.de
179- update to 1.1.16.1
180- better connection handling
181- fixes bugs: 77698,78034,78621
182* Tue Apr 25 2006 wberrier@suse.de
183- Security update (remove all the duplicated slashes
184  and don't do an extra Replace on non-windows.) and minor fix for
185  [#78034].
186* Wed Jan 25 2006 mls@suse.de
187- converted neededforbuild to BuildRequires
188* Fri Jan  6 2006 wberrier@suse.de
189- Update to 1.1.13, clean up deps
190* Thu Nov 10 2005 wberrier@suse.de
191- Update to 1.1.10, set libdir to lib/
192* Fri Oct  7 2005 wberrier@suse.de
193- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
194  libexec, so I disabled the patch)
195* Tue Jul 19 2005 sbrabec@suse.cz
196- Build as noarch (#81109).
197* Fri Jul 15 2005 sbrabec@suse.cz
198- Updated to version 1.0.9 (#96776).
199* Mon Feb 21 2005 clahey@suse.de
200- Updated to 1.0.6.
201* Sun Feb  6 2005 ro@suse.de
202- use /usr/lib/mono
203* Mon Dec 13 2004 clahey@suse.de
204- New package.
Note: See TracBrowser for help on using the repository browser.