source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 1901

Revision 1901, 6.1 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8Version: 2.6.5
9Release: 2%{?_dist_release}
10Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: mono-devel mono-web
14BuildRequires: mono-data-sqlite mono-data-oracle mono-jscript mono-extras mono-nunit
15BuildRequires: pkgconfig
16# One of the test runs requires this
17BuildRequires: sqlite
18# This must be manually entered according to xsp's protocol version
19# Since this package is currently noarch, and mod_mono's name is different
20# on different distros, we can't use this... yet
21#Requires: mod_mono >= %{version}
22
23%description
24The XSP server is a small Web server that hosts the Mono System.Web
25classes for running what is commonly known as ASP.NET.
26
27
28%prep
29%setup -q
30
31%build
32export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
33# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
34./configure \
35        --prefix=%{_prefix} \
36        --libexecdir=%{_prefix}/lib \
37    --libdir=%{_prefix}/lib \
38    --mandir=%{_prefix}/share/man \
39    --infodir=%{_prefix}/share/info \
40    --sysconfdir=%{_sysconfdir}
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
47make install DESTDIR=$RPM_BUILD_ROOT
48mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
49mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc NEWS README
59%{_bindir}/*
60%{_prefix}/lib/xsp
61%{mono_dir}/gac/Mono.WebServer
62%{mono_dir}/1.0/Mono.WebServer.dll
63%{mono_dir}/gac/Mono.WebServer2
64%{mono_dir}/2.0/Mono.WebServer2.dll
65%{mono_dir}/gac/xsp
66%{mono_dir}/1.0/xsp.exe
67%{mono_dir}/gac/xsp2
68%{mono_dir}/2.0/xsp2.exe
69%{mono_dir}/gac/mod-mono-server
70%{mono_dir}/1.0/mod-mono-server.exe
71%{mono_dir}/gac/mod-mono-server2
72%{mono_dir}/2.0/mod-mono-server2.exe
73%{mono_dir}/gac/fastcgi-mono-server
74%{mono_dir}/1.0/fastcgi-mono-server.exe
75%{mono_dir}/gac/fastcgi-mono-server2
76%{mono_dir}/2.0/fastcgi-mono-server2.exe
77%{_datadir}/pkgconfig/*
78%{_mandir}/*/*
79
80
81%changelog
82* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
83- rebuild with rpm-4.8.1 for pkg-config file
84
85* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
86- updated xsp to 2.6.5
87
88* Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
89- updated xsp to 2.6.4
90
91* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
92- updated xsp to 2.6.3
93
94* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
95- updated to 2.6
96- rebuilt with new toolchain
97
98* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
99- updated to 2.4.3
100
101* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
102- changed Group to Applications/Internet
103
104* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
105- updated to 2.4
106
107* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
108- initial build for VineSeed
109        - updated xsp to 2.0
110        - added japanese summary
111        - applied vine versioning policy
112        - spec in utf-8
113
114* Tue Apr 22 2008 wberrier@suse.de
115- update to 1.9.1 (bugfix release)
116  - Output date header (instead of asp.net doing it)
117* Tue Mar 25 2008 wberrier@suse.de
118- update to 1.9
119  - minor test updates
120  - BaseRequestBroker fix: Check if the request ID is valid inside
121  the lock.
122* Mon Jan 14 2008 wberrier@suse.de
123- update to 1.2.6
124  - FastCGI support
125* Thu Aug 30 2007 wberrier@suse.de
126- xsp_1.2.5_p5_final.patch: Fix for regression in the request
127  broker
128* Fri Aug 17 2007 wberrier@suse.de
129- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
130  - bugs: 81699, 81906, 82379, 82057
131  - fixes ability to handle large (GB) uploads (needed for iFolder)
132* Fri Aug  3 2007 wberrier@suse.de
133- Update to 1.2.5
134  - More robust exception handling
135  - Fixed permissions bits for non executable scripts
136  - virtual host support
137  - New Documentation for Mono.WebServer
138  - Improved event handling
139* Tue Jun  5 2007 wberrier@novell.com
140- Remove unnecessary path defines (prefix, sysconfdir)
141- Update to 1.2.4
142  - fix some race conditions and crashes
143  - add tracing support
144* Fri Apr 13 2007 wberrier@novell.com
145- add %%debug_package so debug packages get created
146* Wed Apr 11 2007 wberrier@novell.com
147- Add mono dep/req for older distros
148* Thu Mar  1 2007 wberrier@suse.de
149- Update Update to 1.2.3
150  - Bug fix #80230 (prevents possible nullref)
151  - Support for response header encoding
152* Mon Jan 22 2007 ro@suse.de
153- drop requires for gnome-filesystem
154* Sat Dec  2 2006 wberrier@suse.de
155- Update to 1.2.1 (Fate #301111)
156  - Bugfixes:
157  - close the connection if there's an error reading the headers
158  (including assembly loading exceptions due to a bad installation).
159  - kill the warning that everyone is worried about.
160* Fri Oct 20 2006 wberrier@suse.de
161- Update to 1.1.18
162  - 2.0 updates
163* Thu Oct 19 2006 wberrier@suse.de
164- Add mono-devel to fix bnc #213576 (missing provides)
165* Tue Sep  5 2006 wberrier@suse.de
166- Update to 1.1.17.1 bugfix release
167- Read from the stream, not the socket as the socket data is
168  encrypted when using SSL.
169* Wed Aug 30 2006 wberrier@suse.de
170- Update to 1.1.17
171  - Added support for X.509 client certificates
172  - Update to handle newly created AppDomains
173* Mon Jul 31 2006 wberrier@suse.de
174- update to 1.1.16.1
175- better connection handling
176- fixes bugs: 77698,78034,78621
177* Tue Apr 25 2006 wberrier@suse.de
178- Security update (remove all the duplicated slashes
179  and don't do an extra Replace on non-windows.) and minor fix for
180  [#78034].
181* Wed Jan 25 2006 mls@suse.de
182- converted neededforbuild to BuildRequires
183* Fri Jan  6 2006 wberrier@suse.de
184- Update to 1.1.13, clean up deps
185* Thu Nov 10 2005 wberrier@suse.de
186- Update to 1.1.10, set libdir to lib/
187* Fri Oct  7 2005 wberrier@suse.de
188- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
189  libexec, so I disabled the patch)
190* Tue Jul 19 2005 sbrabec@suse.cz
191- Build as noarch (#81109).
192* Fri Jul 15 2005 sbrabec@suse.cz
193- Updated to version 1.0.9 (#96776).
194* Mon Feb 21 2005 clahey@suse.de
195- Updated to 1.0.6.
196* Sun Feb  6 2005 ro@suse.de
197- use /usr/lib/mono
198* Mon Dec 13 2004 clahey@suse.de
199- New package.
Note: See TracBrowser for help on using the repository browser.