source: projects/specs/trunk/x/xscreensaver/xscreensaver-vl.spec @ 8154

Revision 8154, 25.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define modular_conf  1
2
3%define default_text  %{_datadir}/doc/HTML/README-Accessibility
4
5%define pam_ver       1.1
6%define autoconf_ver  2.65
7
8%define update_po     1
9
10Buildroot:       %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12Summary:         X screen saver and locker
13Summary(ja):     X ウィンドウシステム・スクリーンセーバ
14Name:            xscreensaver
15Version:         5.26
16Release:         1%{?_dist_release}
17Epoch:           1
18License:         BSD
19Group:           User Interface/X
20URL:             http://www.jwz.org/xscreensaver/
21
22Source0:         http://www.jwz.org/xscreensaver/xscreensaver-%{version}%{?beta_ver}.tar.gz
23%if %{modular_conf}
24Source10:        update-xscreensaver-hacks
25%endif
26Patch1:          xscreensaver-5.00b5-sanitize-hacks.patch
27Patch3:          xscreensaver-5.05-addopts-jwz.patch
28Patch21:         xscreensaver-5.05-webcollage-default-nonet.patch
29Patch22:         xscreensaver-5.05-penetrate-font.patch
30Requires:        xscreensaver-base = %{epoch}:%{version}-%{release}
31Requires:        xscreensaver-extras = %{epoch}:%{version}-%{release}
32Requires:        xscreensaver-gl-extras = %{epoch}:%{version}-%{release}
33
34%package base
35Summary:         A minimal installation of xscreensaver
36Group:           User Interface/Desktops
37BuildRequires:   autoconf
38BuildRequires:   bc
39BuildRequires:   desktop-file-utils
40BuildRequires:   gawk
41BuildRequires:   gettext
42BuildRequires:   libtool
43BuildRequires:   pam-devel > %{pam_ver}
44BuildRequires:   sed
45BuildRequires:   xdg-utils
46BuildRequires:   xorg-x11-proto-devel
47BuildRequires:   libX11-devel
48BuildRequires:   libXScrnSaver-devel
49BuildRequires:   libXext-devel
50BuildRequires:   libXinerama-devel
51BuildRequires:   libXmu-devel
52BuildRequires:   libXpm-devel
53BuildRequires:   libXt-devel
54BuildRequires:   libXxf86misc-devel
55BuildRequires:   libXxf86vm-devel
56BuildRequires:   gtk2-devel     
57BuildRequires:   libjpeg-devel
58BuildRequires:   libglade2-devel
59Requires:        %{_sysconfdir}/pam.d/system-auth
60Requires:        pam > %{pam_ver}
61Requires:        xdg-utils
62Requires:        xorg-x11-resutils
63Requires:        xorg-x11-fonts-ISO8859-1-100dpi
64
65%package extras
66Summary:         An enhanced set of screensavers
67Group:           User Interface/Desktops
68BuildRequires:   desktop-backgrounds
69Requires:        %{name}-base = %{epoch}:%{version}-%{release}
70
71%package gl-base
72Summary:         A base package for screensavers that require OpenGL
73Group:           User Interface/Desktops
74Requires:        %{name}-base = %{epoch}:%{version}-%{release}
75
76%package gl-extras
77Summary:         An enhanced set of screensavers that require OpenGL
78Group:           User Interface/Desktops
79Provides:        xscreensaver-gl = %{epoch}:%{version}-%{release}
80Obsoletes:       xscreensaver-gl <= 1:5.00
81BuildRequires:   libGL-devel
82BuildRequires:   libGLU-devel
83%if %{modular_conf}
84Requires:        %{name}-gl-base = %{epoch}:%{version}-%{release}
85%else
86Requires:        %{name}-base = %{epoch}:%{version}-%{release}
87%endif
88
89%package extras-gss
90Summary:         Desktop files of extras for gnome-screensaver
91Group:           User Interface/Desktops
92Requires:        %{name}-extras = %{epoch}:%{version}-%{release}
93Requires:        gnome-screensaver
94
95%package gl-extras-gss
96Summary:         Desktop files of gl-extras for gnome-screensaver
97Group:           User Interface/Desktops
98Requires:        %{name}-gl-extras = %{epoch}:%{version}-%{release}
99Requires:        gnome-screensaver
100
101
102%description
103A modular screen saver and locker for the X Window System.
104More than 200 display modes are included in this package.
105
106This is a metapackage for installing all default packages
107related to XScreenSaver.
108
109%description base
110A modular screen saver and locker for the X Window System.
111This package contains the bare minimum needed to blank and
112lock your screen.  The graphical display modes are the
113"xscreensaver-extras" and "xscreensaver-gl-extras" packages.
114
115%description extras
116A modular screen saver and locker for the X Window System.
117This package contains a variety of graphical screen savers for
118your mind-numbing, ambition-eroding, time-wasting, hypnotized
119viewing pleasure.
120
121%description gl-base
122A modular screen saver and locker for the X Window System.
123This package contains minimal files to make screensaver hacks
124that require OpenGL work for XScreenSaver.
125
126%description gl-extras
127A modular screen saver and locker for the X Window System.
128This package contains a variety of OpenGL-based (3D) screen
129savers for your mind-numbing, ambition-eroding, time-wasting,
130hypnotized viewing pleasure.
131
132%description extras-gss
133This package contains desktop files of extras screensavers
134for gnome-screensaver compatibility.
135
136%description gl-extras-gss
137This package contains desktop files of gl-extras screensavers
138for gnome-screensaver compatibility.
139
140
141
142%prep
143%setup -q -n %{name}-%{version}%{?beta_ver}
144
145%patch1 -p1 -b .sanitize-hacks
146## %patch3 -p1 -b .opts
147## %patch21 -p1 -b .nonet
148## %patch22 -p1 -b .font
149
150change_option(){
151   set +x
152   ADFILE=$1
153   if [ ! -f ${ADFILE}.opts ] ; then
154      cp -p $ADFILE ${ADFILE}.opts
155   fi
156   shift
157
158   for ARG in "$@" ; do
159      TYPE=`echo $ARG | sed -e 's|=.*$||'`
160      VALUE=`echo $ARG | sed -e 's|^.*=||'`
161
162      eval sed -i \
163         -e \'s\|\^\\\(\\\*$TYPE\:\[ \\t\]\[ \\t\]\*\\\)\[\^ \\t\]\.\*\$\|\\1$VALUE\|\' \
164         $ADFILE
165   done
166   set -x
167}
168
169silence_hack(){
170   set +x
171   ADFILE=$1
172   if [ ! -f ${ADFILE}.hack ] ; then
173      cp -p $ADFILE ${ADFILE}.hack
174   fi
175   shift
176
177   for hack in "$@" ; do
178      eval sed -i \
179         -e \'\/\^\[ \\t\]\[ \\t\]\*$hack\/s\|\^\|-\|g\' \
180         -e \'s\|\^@GL_\.\*@.*\\\(GL\:\[ \\t\]\[ \\t\]\*$hack\\\)\|-\\t\\1\|g\' \
181         $ADFILE
182   done
183   set -x
184}
185
186# change some files to UTF-8
187for f in \
188   driver/XScreenSaver.ad.in \
189   hacks/glx/sproingies.man \
190   ; do
191   iconv -f ISO-8859-1 -t UTF-8 $f > $f.tmp || cp -p $f $f.tmp
192   touch -r $f $f.tmp
193   mv $f.tmp $f
194done
195
196# change some options
197change_option driver/XScreenSaver.ad.in \
198   captureStderr=False \
199   passwdTimeout=0:00:15 \
200   grabDesktopImages=False \
201   lock=True \
202   splash=False \
203   ignoreUninstalledPrograms=True \
204   textProgram=fortune\ -s
205
206# silence the following hacks by default
207silence_hack driver/XScreenSaver.ad.in \
208   bsod flag
209
210# record time, version
211eval sed -i.ver \
212   -e \'s\|version \[45\]\.\[0-9a-z\]\[0-9a-z\]\*\|version %{version}-`echo \
213      %{release} | sed -e 's|\.[a-z][a-z0-9].*$||'`\|\' \
214      driver/XScreenSaver.ad.in
215
216eval sed -i.date \
217   -e \'s\|\[0-9\].\*-.\*-20\[0-9\]\[0-9\]\|`LANG=C date -u +'%%d-%%b-%%Y'`\|g\' \
218   driver/XScreenSaver.ad.in
219
220eval sed -i.ver \
221   -e \'s\|\(\[0-9\].\*-.\*-20\[0-9\]\[0-9\]\)\|\(`LANG=C \
222      date -u +'%%d-%%b-%%Y'`\)\|g\' \
223   -e \'s\|\\\(5.\[0-9\]\[0-9\]\\\)[a-z]\[0-9\]\[0-9\]\*\|\\\1\|\' \
224   -e \'s\|5.\[0-9\]\[0-9\]\|%{version}-`echo %{release} | \
225      sed -e 's|\.[a-zA-Z][a-zA-Z0-9].*$||'`\|\' \
226   utils/version.h
227
228# move man entry to 6x.
229for f in `find hacks -name Makefile.in` ; do
230   sed -i.mansuf \
231      -e '/^mansuffix/s|6|6x|'\
232      $f
233done
234
235# search first 6x entry, next 1 entry for man pages
236sed -i.manentry -e 's@man %%s@man 6x %%s 2>/dev/null || man 1 %%s @' \
237   driver/XScreenSaver.ad.in
238
239# suppress rpmlint booing.
240# suppress about pam config (although this is
241# not the fault of xscreensaver.pam ......).
242#sed -i.rpmlint -n -e '1,5p' driver/xscreensaver.pam
243
244if [ -x %{_datadir}/libtool/config.guess ]; then
245  # use system-wide copy
246   cp -p %{_datadir}/libtool/config.{sub,guess} .
247fi
248
249# fix for desktop-file-utils 0.14+
250sed -i.icon -e 's|xscreensaver\.xpm|xscreensaver|' \
251   driver/screensaver-properties.desktop.in
252
253%build
254autoconf
255
256chmod 755 ./config.guess
257archdir=`./config.guess`
258mkdir $archdir
259cd $archdir
260
261export CFLAGS="${CFLAGS:-${RPM_OPT_FLAGS}}"
262
263CONFIG_OPTS="--prefix=%{_prefix} --with-pam --without-shadow --without-kerberos"
264CONFIG_OPTS="$CONFIG_OPTS --without-setuid-hacks"
265CONFIG_OPTS="$CONFIG_OPTS --with-text-file=%{default_text}"
266CONFIG_OPTS="$CONFIG_OPTS --with-x-app-defaults=%{_datadir}/X11/app-defaults"
267CONFIG_OPTS="$CONFIG_OPTS --disable-root-passwd"
268CONFIG_OPTS="$CONFIG_OPTS --with-browser=xdg-open"
269
270# This is flaky:
271# CONFIG_OPTS="$CONFIG_OPTS --with-login-manager"
272
273ln -s ../configure .
274%configure $CONFIG_OPTS
275rm -f configure
276
277%if %{update_po}
278( cd po ; make generate_potfiles_in update-po )
279%endif
280
281make %{?_smp_mflags}
282
283%if %{modular_conf}
284# Make XScreenSavar.ad modular
285CONFD=xscreensaver
286rm -rf $CONFD
287mkdir $CONFD
288
289# preserve the original adfile
290cp -p driver/XScreenSaver.ad $CONFD
291
292# First split XScreenSaver.ad into 3 parts
293cat driver/XScreenSaver.ad | \
294   sed -n -e '1,/\*programs/p' > $CONFD/XScreenSaver.ad.header
295cat driver/XScreenSaver.ad | sed -e '1,/\*programs/d' | \
296   sed -n -e '1,/\\n$/p' > $CONFD/XScreenSaver.ad.hacks
297cat driver/XScreenSaver.ad | sed -e '1,/\\n$/d' > $CONFD/XScreenSaver.ad.tail
298
299# Seperate XScreenSaver.ad.hacks into each hacks
300cd $CONFD
301mkdir hacks.conf.d ; cp -p XScreenSaver.ad.hacks hacks.conf.d/xscreensaver.conf
302cd ..
303
304%endif
305
306%install
307archdir=`./config.guess`
308cd $archdir
309
310rm -rf ${RPM_BUILD_ROOT}
311
312# We have to make sure these directories exist,
313# or nothing will be installed into them.
314#
315mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
316
317make install_prefix=$RPM_BUILD_ROOT INSTALL="install -c -p" install
318
319desktop-file-install --vendor "" --delete-original       \
320   --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
321   --add-only-show-in GNOME                              \
322   --add-category    DesktopSettings                     \
323%if 0
324   --add-category X-Red-Hat-Base                         \
325%else
326   --remove-category Appearance                          \
327   --remove-category AdvancedSettings                    \
328   --remove-category Application                         \
329%endif
330   $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
331
332# This function prints a list of things that get installed.
333# It does this by parsing the output of a dummy run of "make install".
334list_files() {
335   echo "%%defattr(-,root,root,-)"
336   make -s install_prefix=${RPM_BUILD_ROOT} INSTALL=true "$@"  \
337      | sed -n -e 's@.* \(/[^ ]*\)$@\1@p'                      \
338      | sed    -e "s@^${RPM_BUILD_ROOT}@@"                     \
339               -e "s@/[a-z][a-z]*/\.\./@/@"                    \
340      | sed    -e 's@\(.*/man/.*\)@%%doc \1\*@'                      \
341               -e 's@\(.*/pam\.d/\)@%%config(noreplace) \1@'    \
342      | sort  \
343      | uniq
344}
345
346# Generate three lists of files for the three packages.
347#
348dd=%{_builddir}/%{name}-%{version}%{?beta_ver}
349
350# In case rpm -bi --short-circuit is tried multiple times:
351rm -f $dd/*.files
352
353(  cd hacks     ; list_files install ) >  $dd/extras.files
354(  cd hacks/glx ; list_files install ) >  $dd/gl-extras.files
355(  cd driver    ; list_files install ) >  $dd/base.files
356
357# Move %%{_bindir}/xscreensaver-gl-helper to gl-base
358# (bug 336331).
359%if %{modular_conf}
360echo "%%defattr(-,root,root,-)" >> $dd/gl-base.files
361
362sed -i -e '/xscreensaver-gl-helper/d' $dd/gl-extras.files
363pushd $RPM_BUILD_ROOT
364for dir in `find . -name \*xscreensaver-gl-helper\*` ; do
365   echo "${dir#.}" >> $dd/gl-base.files
366done
367popd
368sed -i -e 's|^\(%{_mandir}.*\)$|\1*|' $dd/gl-base.files
369%endif
370
371%if %{modular_conf}
372# install update script
373mkdir -p $RPM_BUILD_ROOT%{_sbindir}
374install -cpm 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sbindir}
375echo "%{_sbindir}/update-xscreensaver-hacks" >> $dd/base.files
376
377# make hack conf modular
378mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xscreensaver
379mkdir -p $RPM_BUILD_ROOT%{_datadir}/xscreensaver/hacks.conf.d
380cp -p xscreensaver/XScreenSaver.ad* \
381   $RPM_BUILD_ROOT%{_sysconfdir}/xscreensaver
382cp -p xscreensaver/hacks.conf.d/xscreensaver.conf \
383   $RPM_BUILD_ROOT%{_datadir}/xscreensaver/hacks.conf.d/
384
385for adfile in xscreensaver/XScreenSaver.ad.* ; do
386   filen=`basename $adfile`
387   echo "%%config(noreplace) %{_sysconfdir}/xscreensaver/$filen" >> $dd/base.files
388done
389echo -n "%%verify(not size md5 mtime) " >> $dd/base.files
390echo "%{_sysconfdir}/xscreensaver/XScreenSaver.ad" >> \
391   $dd/base.files
392echo "%{_datadir}/xscreensaver/hacks.conf.d/xscreensaver.conf" \
393   >> $dd/base.files
394
395# check symlink
396rm -f $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults/XScreenSaver
397
398pushd $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
399pushd ../../../..
400if [ ! $(pwd) == $RPM_BUILD_ROOT ] ; then
401   echo "Possibly symlink broken"
402   exit 1
403fi
404popd
405popd
406
407ln -sf ../../../..%{_sysconfdir}/xscreensaver/XScreenSaver.ad \
408   $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults/XScreenSaver
409
410%endif
411
412# add documents
413pushd $dd &> /dev/null
414for f in README* ; do
415   echo "%%doc $f" >> $dd/base.files
416done
417popd
418
419# add directory
420pushd $RPM_BUILD_ROOT
421for dir in `find . -type d | grep xscreensaver` ; do
422   echo "%%dir ${dir#.}" >> $dd/base.files
423done
424popd
425
426%find_lang %{name}
427cat %{name}.lang | uniq >> $dd/base.files
428
429# suppress rpmlint booing
430# sanitize path in script file
431for f in ${RPM_BUILD_ROOT}%{_bindir}/xscreensaver-getimage-* \
432   ${RPM_BUILD_ROOT}%{_libexecdir}/xscreensaver/vidwhacker \
433   ${RPM_BUILD_ROOT}%{_bindir}/xscreensaver-text ; do
434   if [ -f $f ] ; then
435      sed -i -e 's|%{_prefix}//bin|%{_bindir}|g' $f
436   fi
437done
438
439# create desktop entry for gnome-screensaver
440create_desktop(){
441   COMMAND=`cat $1 | sed -n -e 's|^<screen.*name=\"\([^ ][^ ]*\)\".*$|\1|p'`
442   NAME=`cat $1 | sed -n -e 's|^<screen.*_label=\"\(.*\)\">.*$|\1|p'`
443   ARG=`cat $1 | sed -n -e 's|^.*<command arg=\"\([^ ][^ ]*\)\".*$|\1|p'`
444   ARG=`echo $ARG`
445   COMMENT="`cat $1 | sed -e '1,/_description/d' | \
446     sed -e '/_description/q' | sed -e '/_description/d'`"
447   COMMENT=`echo $COMMENT`
448
449# webcollage treatment
450   if [ "x$COMMAND" = "xwebcollage" ] ; then
451      ARG="$ARG -directory %{_datadir}/backgrounds/images"
452   fi
453
454   if [ "x$NAME" = "x" ] ; then NAME=$COMMAND ; fi
455
456   rm -f $2
457   echo "[Desktop Entry]" >> $2
458   echo "Encoding=UTF-8" >> $2
459   echo "Name=$NAME" >> $2
460   echo "Comment=$COMMENT" >> $2
461   echo "TryExec=$COMMAND" >> $2
462   echo "Exec=$COMMAND $ARG" >> $2
463   echo "StartupNotify=false" >> $2
464   echo "Type=Application" >> $2
465   echo "Categories=GNOME;Screensaver;" >> $2
466}
467
468cd $dd
469
470SAVERDIR=%{_datadir}/applications/screensavers
471mkdir -p ${RPM_BUILD_ROOT}${SAVERDIR}
472echo "%%dir $SAVERDIR" >> base.files
473
474for list in *extras.files ; do
475
476   glist=gnome-$list
477   rm -f $glist
478
479   echo "%%defattr(-,root,root,-)" > $glist
480##  move the owner of $SAVERDIR to -base
481##   echo "%%dir $SAVERDIR" >> $glist
482
483   set +x
484   for xml in `cat $list | grep xml$` ; do
485      file=${RPM_BUILD_ROOT}${xml}
486      desktop=xscreensaver-`basename $file`
487      desktop=${desktop%.xml}.desktop
488
489      echo + create_desktop $file  ${RPM_BUILD_ROOT}${SAVERDIR}/$desktop
490      create_desktop $file  ${RPM_BUILD_ROOT}${SAVERDIR}/$desktop
491      echo ${SAVERDIR}/$desktop >> $glist
492   done
493   set -x
494done
495
496# Make sure all files are readable by all, and writable only by owner.
497#
498chmod -R a+r,u+w,og-w ${RPM_BUILD_ROOT}
499
500%clean
501rm -rf ${RPM_BUILD_ROOT}
502
503%if %{modular_conf}
504%post base
505%{_sbindir}/update-xscreensaver-hacks
506exit 0
507%endif
508
509%files
510%defattr(-,root,root,-)
511
512%files -f base.files base
513%defattr(-,root,root,-)
514
515%files -f extras.files extras
516%defattr(-,root,root,-)
517
518%if %{modular_conf}
519%files -f gl-base.files gl-base
520%defattr(-,root,root,-)
521%endif
522
523%files -f gl-extras.files gl-extras
524%defattr(-,root,root,-)
525
526%files -f gnome-extras.files extras-gss
527%defattr(-,root,root,-)
528
529%files -f gnome-gl-extras.files gl-extras-gss
530%defattr(-,root,root,-)
531
532%changelog
533* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.26-1
534- new upstream release
535
536* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.20-1
537- new upstream release
538
539* Wed Feb 15 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.15-1
540- new upstream release
541
542* Sun Oct 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.12-1
543- new upstream release
544
545* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.11-1
546- new upstream release
547- drop Patch3, Patch21, Patch22
548
549* Wed May 21 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.05-1
550- new upstream release
551- remove unneeded patches
552
553* Sat Sep  9 2006 Ryoichi INAGAKI <daisuke@linux.or.jp> 4.18-0vl3
554- rebuilt for Vine Linux 4.0
555- changed Group to User Interface/X
556
557* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.18-0vl2
558- add Patch3 to use htmlview by default
559- add Patch5 to use blank screen by default instead of random screensaver
560- move desktopfile to %{_datadir}/applications/
561
562* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.18-0vl1
563- new upstream release
564
565* Wed Dec 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.14-0vl1
566- new upstream release
567
568* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.06-4vl2
569- update ja.po
570- copy xscreensaver.xpm to /usr/share/pixmaps directory
571
572* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.06-4vl1
573- merged with rawhide release
574- build on gnome2.1.5/gtk2.2
575  * Fri Nov 29 2002 Tim Powers <timp@redhat.com> 1:4.06-4
576  - call autoconf instead of autoconf-2.53
577  * Mon Nov 11 2002 Bill Nottingham <notting@redhat.com> 4.06-3
578  - put glade tweaks back in
579  - switch pam package to not specify directories, to work on multilib
580    arches
581  * Fri Nov  8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.06-1
582  - add a BuildPrereq on bc, which configure requires
583  - replace use of fortune with an innocuous-and-editable stand-in script in
584    %{stand_in_path}
585  - define FORTUNE_PROGRAM at compile-time to force apps to use what's specified
586    even if it doesn't happen to be installed at compile-time
587  * Sun Sep  2 2002 Bill Nottingham <notting@redhat.com> 4.05-6
588  - fix typo (#73246)
589  * Wed Aug 28 2002 Bill Nottingham <notting@redhat.com> 4.05-5
590  - revert to non-gtk unlock dialog
591  - fix translations
592  * Mon Aug 12 2002 Bill Nottingham <notting@redhat.com> 4.05-4
593  - twiddle titlebar (#67844)
594  - fix extraneous text (#70975)
595  - tweak desktop entry (#69502)
596  * Fri Aug 9 2002 Yu Shao <yshao@redhat.com> 4.05-3
597  - use GTK_IM_MODULE=gtk-im-context-simple in lock widget
598  - to avoid CJK IM weirdness (#70655, #68216)
599  - xscreensaver-rh-imcjk.patch
600  * Wed Jul 17 2002 Elliot Lee <sopwith@redhat.com> 4.05-2
601  - Add fortune-mod to buildprereq to make beehive happy
602  - Fix find_lang usage - install translations properly by specifying datadir
603  * Tue Jun 11 2002 Bill Nottingham <notting@redhat.com> 4.05-1
604  - update to 4.05
605  - use gtk2 lock widget (<jacob@ximian.com>)
606  - some Red Hat-ifications
607  - fix critical (#63916)
608  * Mon Jun 10 2002 Bill Nottingham <notting@redhat.com> 4.04-2
609  - remove no longer needed xloadimage dependency
610  * Mon Jun  3 2002 Bill Nottingham <notting@redhat.com> 4.04-1
611  - update to 4.04, gtk2 property dialog is now mainline
612  * Thu May 16 2002 Bill Nottingham <notting@redhat.com> 4.03-1
613  - update to 4.03
614  - use gtk2 properties dialog
615
616* Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.01-2vl5
617- rebuilt with new toolchain
618
619* Sun Mar 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.01-2vl4
620- provides screensaver capplet entry for control-center
621
622* Wed Mar 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.01-2vl2
623- change Requires fortune-mod ( not file-depend )
624
625* Tue Mar 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.01-2vl1
626- merged with rawhide release
627
628* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com> 4.01-2
629- don't show screensavers that aren't available
630
631* Sun Feb 24 2002 Bill Nottingham <notting@redhat.com>
632- update to 4.01
633
634* Mon Feb 11 2002 Bill Nottingham <notting@redhat.com>
635- update to 4.00
636
637* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
638- automated rebuild
639
640* Thu Aug 23 2001 Bill Nottingham <notting@redhat.com>
641- fix segfault on ia64 (#52336)
642
643* Thu Aug  9 2001 Bill Nottingham <notting@redhat.com>
644- never mind, back to 3.33 (wheeee)
645- hack window-id back in for the time being
646- disable memlimit so GL works
647
648* Mon Jul 23 2001 Bill Nottingham <notting@redhat.com>
649- oops, back to 3.32 for now
650- remove optflags override (oops)
651- add pam-devel buildprereq
652
653* Mon Jul 16 2001 Bill Nottingham <notting@redhat.com>
654- update to 3.33, fix broken last build
655- fix build weirdness on some package sets (#48905)
656- don't document non-existent options for forest (#49139)
657
658* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
659- Bump release + rebuild.
660
661* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
662- putting in tree for David
663
664* Tue May 22 2001 David Sainty <dsainty@redhat.com>
665- added DPMS options to command line help
666
667* Sun Apr 22 2001 Bill Nottingham <notting@redhat.com>
668- update to 3.32
669- add patch to specify DPMS settings on the command line
670
671* Wed Apr 11 2001 Bill Nottingham <notting@redhat.com>
672- update to 3.31
673
674* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
675- fix extrusion exclusion (#34742)
676
677* Tue Apr  3 2001 Bill Nottingham <notting@redhat.com>
678- disable GL screensavers by default (bleah)
679
680* Mon Feb 19 2001 Bill Nottingham <notting@redhat.com>
681- update to 3.29 (#27437)
682
683* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
684- update to 3.27
685
686* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
687- rebuild because of broken fileutils
688
689* Fri Nov 10 2000 Bill Nottingham <notting@redhat.com>
690- 3.26
691
692* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
693- Up Epoch and release
694
695* Wed Jul 26 2000 Bill Nottingham <notting@redhat.com>
696- hey, vidmode works again
697
698* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
699- update to 3.25
700
701* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
702- automatic rebuild
703
704* Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
705- xscreensaver.kss is not a %%config file.
706
707* Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
708- tweak kss module (#11872)
709
710* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
711- modify PAM configuration to use system-auth
712
713* Thu May 18 2000 Preston Brown <pbrown@redhat.com>
714- added Red Hat screensaver (waving flag has logo now).
715
716* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
717- tweaks for ia64
718
719* Mon Apr 10 2000 Bill Nottingham <notting@redhat.com>
720- turn off xf86vidmode ext, so that binaries built against XFree86 4.0
721  work on 3.x servers
722
723* Wed Apr  5 2000 Bill Nottingham <notting@redhat.com>
724- turn off gnome support for now
725
726* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
727- update to 3.24
728
729* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
730- wmconfig entry gone.
731
732* Mon Jan 31 2000 Bill Nottingham <notting@redhat.com>
733- update to 3.23
734
735* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
736- rebuild to fix GL depdencies
737
738* Tue Dec 14 1999 Bill Nottingham <notting@redhat.com>
739- everyone in GL
740- single package again
741
742* Fri Dec 10 1999 Bill Nottingham <notting@redhat.com>
743- update to 3.22
744- turn off xf86vmode on alpha
745
746* Tue Dec  7 1999 Bill Nottingham <notting@redhat.com>
747- mmm... hardware accelerated GL on i386. :) :)
748
749* Mon Nov 22 1999 Bill Nottingham <notting@redhat.com>
750- 3.21
751- use shm on alpha, let's see what breaks
752
753* Tue Nov 16 1999 Bill Nottingham <notting@redhat.com>
754- update to 3.20
755
756* Wed Nov  3 1999 Bill Nottingham <notting@redhat.com>
757- update to 3.19
758
759* Thu Oct 14 1999 Bill Nottingham <notting@redhat.com>
760- update to 3.18
761
762* Sat Sep 25 1999 Bill Nottingham <notting@redhat.com>
763- add a '-oneshot' single time lock option.
764
765* Mon Sep 20 1999 Bill Nottingham <notting@redhat.com>
766- take webcollage out of random list (for people who pay for bandwidth)
767
768* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
769- patch webcollage to use xloadimage
770- in the random list, run petri with -size 2 to save memory
771- extend RPM silliness to man pages, too.
772
773* Mon Jul 19 1999 Bill Nottingham <notting@redhat.com>
774- update to 3.17
775- add a little RPM silliness to package GL stuff if it's built
776
777* Thu Jun 24 1999 Bill Nottingham <notting@redhat.com>
778- update to 3.16
779
780* Mon May 10 1999 Bill Nottingham <notting@redhat.com>
781- update to 3.12
782
783* Tue May  4 1999 Bill Nottingham <notting@redhat.com>
784- remove security problem introduced earlier
785
786* Wed Apr 28 1999 Bill Nottingham <notting@redhat.com>
787- update to 3.10
788
789* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
790- kill setuid the Right Way(tm)
791
792* Mon Apr 12 1999 Bill Nottingham <notting@redhat.com>
793- fix xflame on alpha
794
795* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
796- upgrade to 3.09, fixes vmware interaction problems.
797
798* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
799- remove setuid bit. Really. I mean it.
800
801* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
802- auto rebuild in the new build environment (release 3)
803
804* Fri Mar 19 1999 Bill Nottingham <notting@redhat.com>
805- kill setuid, since pam works OK
806
807* Tue Mar 16 1999 Bill Nottingham <notting@redhat.com>
808- update to 3.08
809
810* Wed Feb 24 1999 Bill Nottingham <notting@redhat.com>
811- wmconfig returns, and no one is safe...
812
813* Tue Feb 23 1999 Bill Nottingham <notting@redhat.com>
814- remove bsod from random list because it's confusing people???? *sigh*
815
816* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
817- call libtoolize to get it to compile cleanely on the arm
818
819* Tue Jan  5 1999 Bill Nottingham <notting@redhat.com>
820- update to 3.07
821
822* Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
823- update to 3.06
824
825* Tue Nov 17 1998 Bill Nottingham <notting@redhat.com>
826- update to 3.04
827
828* Thu Nov 12 1998 Bill Nottingham <notting@redhat.com>
829- update to 3.02
830- PAMify
831
832* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
833- take out Noseguy module b/c of possible TMv
834- install modules in /usr/X11R6/lib/xscreensaver
835- don't compile support for xshm on the alpha
836- properly buildrooted
837- updated to version 2.34
838
839* Fri Aug  7 1998 Bill Nottingham <notting@redhat.com>
840- update to 2.27
841
842* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
843- translations modified for de
844
845* Mon Jun 08 1998 Erik Troan <ewt@redhat.com>
846- added fix for argv0 buffer overflow
847
848* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
849- translations modified for de, fr, tr
850
851* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
852- updated from 2.10 to 2.16
853- added buildroot
854
855* Sat Oct 25 1997 Marc Ewing <marc@redhat.com>
856- wmconfig
857
858* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
859- new version, configure
860
861* Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
862- built against glibc
863
Note: See TracBrowser for help on using the repository browser.