source: projects/specs/trunk/x/xsane/xsane-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define gimpdirs %(/bin/ls -d %{_libdir}/gimp/*/plug-ins 2> /dev/null)
2Name: xsane
3Summary: XSane is a graphical frontend for scanners. It uses the library SANE.
4Summary: SANE スキャナインタフェースの Xウィンドウ用フロントエンドです
5Version: 0.995
6Release: 1%{?_dist_release}
7Source: http://www.xsane.org/download/%{name}-%{version}.tar.gz
8%{?nosrc:NoSource:     0}
9License: GPL
10URL: http://www.xsane.org/
11Group: Applications/Multimedia
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: sane >= 1.0.0, gtk2, glib2, atk, pango, zlib
14BuildRequires: sane-devel, gtk2-devel, atk-devel, pango-devel
15BuildRequires: gimp >= 1.3.23
16BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel,zlib-devel
17BuildRequires: sed, glibc-common
18
19%description
20Xsane is a grahical frontend for sane. Install this if you want a grahpical
21frontend for sane for use in the X Windowing System.
22
23%description -l ja
24XSane は、多くのスキャナ、デジタルカメラ、その他の画像取り込み装置に対応
25した SANE スキャナインタフェースの Xウィンドウ用フロントエンドです。
26XSane は GTK+ で書かれ、画像取り込みや取込み画像の操作を行うことができま
27す。
28
29%prep
30%setup -q
31
32# correct some links in html documents
33cd doc
34DOCFILE=sane-backends-doc.html
35cat ${DOCFILE} | sed 's,/usr/local/share,%{_datadir},' > ${DOCFILE}.new
36[ -f  ${DOCFILE}.new ] && mv -f ${DOCFILE}.new ${DOCFILE}
37DOCFILE=sane-xsane-gimp-doc.html
38cat ${DOCFILE} | sed 's,/usr/local/bin,%{_bindir},' > ${DOCFILE}.new
39[ -f  ${DOCFILE}.new ] && mv -f ${DOCFILE}.new ${DOCFILE}
40ICONFILE=sane-logo2.jpg
41[ -f %{_datadir}/sane/${ICONFILE} ] && cp %{_datadir}/sane/${ICONFILE} ./
42
43%build
44%configure --enable-gimp
45make
46
47%install
48%__rm -rf $RPM_BUILD_ROOT
49%makeinstall
50
51cp src/*.xpm $RPM_BUILD_ROOT%{_datadir}/sane/%{name}
52
53if (echo "%{gimpdirs}" | grep -q plug-ins) ;then
54        for D in %{gimpdirs} ; do
55                mkdir -p $RPM_BUILD_ROOT${D}
56                %__ln_s -f %{_bindir}/xsane $RPM_BUILD_ROOT${D}/xsane
57        done
58fi
59
60# prepare applnk
61%define applnkdir /etc/X11/applnk/Graphics
62%define icondir %{_datadir}/sane/%{name}
63
64mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
65cat > $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop <<EOF
66[Desktop Entry]
67Encoding=UTF-8
68Name=XSane
69Name[ja]=XSane スキャナ操作
70Comment=Scanner program
71Comment[ja]=スキャナを操作するツールです
72Terminal=false
73Type=Application
74Icon=%{icondir}/xsane-48x48.xpm
75Exec=xsane
76MultipleArgs=false
77Categories=Application;Graphics;
78EOF
79
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(-,root,root)
86%doc xsane.*
87%{_bindir}/*
88%{_mandir}/*/*
89%{_datadir}/sane/*
90%{_datadir}/locale/*/LC_MESSAGES/*
91%{_libdir}/gimp/*/plug-ins/*
92%config(missingok) %{_datadir}/applications/*
93
94%changelog
95* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.995-1vl5
96- applied new versioning policy
97- updated script to create %{name}.desktop
98
99* Mon Dec 24 2007 Shu KONNO <owa@bg.wakwak.com> 0.995-0vl1
100- new upstream
101- updated xsane.desktop
102
103* Sat Jan 08 2005 Satoshi MACHINO <machino@vinelinux.org> 0.96-0vl1
104- new upstream version (xsane-0.96)
105- fixed spec file
106        -- cleaned up
107        -- added Requires: sane >= 1.0.0, gtk2, glib2, atk, pango, zlib
108        -- added BuildRequires: sane-devel, gtk2-devel, atk-devel, pango-devel
109        -- added BuildRequires: gimp >= 1.3.23
110        -- added BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel,zlib-devel
111
112* Fri Oct 25 2002 Tomoya TAKA <taka@vinelinux.org> 0.89-0vl1
113- new upstream release
114
115* Mon May 13 2002 Satoshi MACHINO <machino@vinelinux.org> xsane-0.86-0vl1
116- updated xsane-0.86
117
118* Wed Apr 4 2002 Masaki Shinomiya <shino@pos.to>
119- 0.84-0vl1 for Vine Linux-2.x
120- 0.84-0.1
121- symlink for gimp listed in %file section
122- some html-documents
123- set %_sysconfdir to /etc for RedHat6.x/Vine2.x
124- RPM Group move to Applications/Multimedia
125
126* Tue Mar 12 2002 Masaki Shinomiya <shino@pos.to>
127- 0.84-0
128- bugfix in %post script
129
130* Sun Dec 23 2001 Masaki Shinomiya <shino@pos.to>
131- 0.82-0.1
132- use mocros as possible, nosrc
133
134* Thu Jul 5 2001 Masaki Shinomiya <shino@pos.to>
135- 0.79-0test
136- remove the patch of the tooltips
137
138* Thu Jul 5 2001 Masaki Shinomiya <shino@pos.to>
139- 0.78-1vl2
140- fixed script for gimp plug-in setup
141
142* Sat Jun 23 2001 Masaki Shinomiya <shino@pos.to>
143- rename for VinePlus. program registoration for gnome
144
145* Tue Jun 19 2001 Masaki Shinomiya <shino@pos.to>
146- patch to provide proper fonts for the tooltips
147
148* Thu Jun 14 2001 Masaki Shinomiya <shino@pos.to>
149- 0.78-1
150- escape confliction of the document file 'sane-pnm-doc.html' with one from SANE
151
152* Sun Jun 3 2001 Masaki Shinomiya <shino@pos.to>
153- 0.77-1
154
155* Mon May 21 2001 Masaki Shinomiya <shino@pos.to>
156- 0.76-1
157- refined script for gimp plug-in setup
158
159* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
160- 0.64-0vl1
161- updated to 0.64 (hope it'll be compatible with gimp-1.1.27...)
162
163* Mon Oct 16 2000 Jun Nishii <jun@vinelinux.org>
164- 0.61-0vl3
165- build with gimp-1.1.27
166
167* Mon Sep 25 2000 Jun Nishii <jun@vinelinux.org>
168- 0.61-0vl2
169- build with gimp-1.1.25
170
171* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
172- 0.61-0vl1
173
174* Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
175- 0.51-0vl1
176
177* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
178- changed group
179
180* Mon Jul 26 1999 Tim Powers <timp@redhat.com>
181- update to 0.30
182- added %defattr
183- built for 6.1
184
185* Thu Apr 22 1999 Preston Brown <pbrown@redhat.com>
186- initial RPM for PowerTools 6.0
187
188
189
190
191
192
Note: See TracBrowser for help on using the repository browser.