source: projects/specs/trunk/x/xosview/xosview-vl.spec @ 521

Revision 521, 8.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define desktop_file 1
2%if %{desktop_file}
3%define desktop_file_utils_version 0.2.90
4%endif
5
6Summary: An X Window System utility for monitoring system resources.
7Summary(ja): X Window System のシステムリソースモニタ
8Name: xosview
9Version: 1.8.3
10Release: 1%{?_dist_release}
11Exclusiveos: Linux
12Source0: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13URL: http://xosview.sourceforge.net/
14Source1: xosview.png
15Patch0: xosview-non-i386.patch
16Patch1: xosview-io_h.patch
17Patch2: xosview-ppc.patch
18Patch3: xosview-rpath.patch
19Patch5: xosview-1.7.1-s390.patch
20Patch6: xosview-1.8.0-proc.patch
21Patch7: xosview-1.7.3-gcc3.patch
22Patch8: xosview-1.8.0-procstat.patch
23Patch9: xosview-1.8.0-strip.patch
24License: GPL/BSD
25Group: Applications/System
26Buildroot: %{_tmppath}/%{name}-%{version}-root
27# XXX ia64 needs porting work
28ExcludeArch: alpha ia64 sparc
29
30BuildRequires: libX11-devel
31%if %{desktop_file}
32BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
33%endif
34
35%description
36The xosview utility displays a set of bar graphs which show the
37current system state, including memory usage, CPU usage, system load,
38etc. Xosview runs under the X Window System.
39
40%description -l ja
41xosview は,メモリ・CPU の使用率やシステム負荷など,現在のシステムの
42状態をグラフで表示するユーティリティです.xosview は X Window System
43上で動作します.
44
45
46%prep
47%setup -q
48#%patch0 -p0
49#%patch1 -p0
50#%patch2 -p1 -b .ppc
51#%patch3 -p0
52#%patch5 -p1 -b .s390
53#%patch6 -p1 -b .proc
54#%patch7 -p1 -b .gcc3
55#%patch8 -p1 -b .procstat
56#%patch9 -p1 -b .strip
57
58# --- XXX Cruft Alert!
59rm -f linux/*.o
60
61%build
62export CXX=g++
63%{__cp} /usr/share/libtool/config.* config/
64CXXFLAGS="$RPM_OPT_FLAGS -Wno-deprecated -DHAVE_SNPRINTF" %configure --disable-linux-memstat
65
66make all
67
68
69%install
70rm -rf %{buildroot}
71mkdir -p %{buildroot}{%{_bindir},%{_mandir}/man1,%{_datadir}/X11/app-defaults} \
72         %{buildroot}%{_datadir}/icons
73
74make install PREFIX_TO_USE=$RPM_BUILD_ROOT%{_prefix} \
75     XAPPLOADDIR=$RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
76install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/icons
77
78chmod u-s %{buildroot}%{_bindir}/*
79
80%if %{desktop_file}
81mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications/
82desktop="%{buildroot}%{_datadir}/applications/xosview.desktop"
83%else
84mkdir -p %{buildroot}/etc/X11/applnk/Utilities
85desktop="%{buildroot}/etc/X11/applnk/Utilities/xosview.desktop"
86%endif
87cat > $desktop <<EOF
88[Desktop Entry]
89Encoding=UTF-8
90Categories=Application;System;
91name=xosview
92Comment=OS resource statistics Viewer
93Exec=xosview
94Terminal=false
95Type=Application
96Icon=/usr/share/icons/xosview.png
97EOF
98
99%clean
100rm -rf %{buildroot}
101
102
103%files
104%defattr(-,root,root,0755)
105%doc README* TODO CHANGES
106%{_bindir}/xosview
107%{_mandir}/man1/*
108%{_datadir}/X11/app-defaults/XOsview
109%{_datadir}/icons/*
110%if %{desktop_file}
111%{_datadir}/applications/*
112%else
113/etc/X11/applnk/Utilities/xosview.desktop
114%endif
115
116%changelog
117* Thu Jun  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
118- rebuilt with xorg-x11 7.3
119- fixed installed location
120- added -DHAVE_SNPRINTF flags to CXXFLAGS
121- spec in UTF-8
122
123* Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.3-0vl2
124- rebuilt with new toolchain
125
126* Mon Jan  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
127- new upstream release
128- changed %desktop_file to 1
129
130* Wed Jul 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
131- new upstream release, work on kernel 2.6
132- dropped Patches (which were merged into upstream)
133- added BuildRequires: XOrg-devel
134
135* Thu Mar 20 2003 IWAI Masaharu <iwai@alib.jp> 1.8.0-9vl2
136- add README*, TODO and CHANGES in the document directory
137
138* Wed Nov 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.0-9vl1
139- based on 1.8.0-9 from Rawhide and built for Vine Linux
140- built with new toolchain environment
141- %%define desktop_file 0 for Vine
142- the previous Vine version was 1.7.1-2vl5. The changelog was as follows:
143
144  - Fri Mar 15 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.7.1-2vl5
145  - rebuilt with glibc > 2.2
146
147  - Wed Jul 18 2001 <sagami@vinelinux.org>
148  - 1.7.1-2vl5: use %%{ix86} for _arch instead of i386 :-)
149
150  - Tue Feb 20 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
151  - 1.7.1-2vl4
152  - add alpha patch (%%patch1) from Kondara
153  - include alpha, again
154
155  - Thu Jan 25 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
156  - 1.7.1-2vl3
157  - ExcludeArch: alpha :-P
158  - added Japanese summary and description
159
160  - Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.7.1-2vl2
161  - build on gcc-2.95.3
162  - added patch0 for i386
163  - partially used rpmmacros
164
165  - Wed Feb 16 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
166  - 1.7.1-2vl1
167  - modified spec for ppc archtecture
168
169* Tue Sep 17 2002 Than Ngo <than@redhat.com> 1.8.0-9
170- Adjust some patch files (bug #74141)
171
172* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
173- rebuilt with gcc-3.2 (we hope)
174
175* Wed Jul 24 2002 Than Ngo <than@redhat.com> 1.8.0-7
176- desktop file issue (bug #69551)
177
178* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 1.8.0-6
179- build using gcc-3.2-0.1
180
181* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.0-5
182- automated rebuild
183
184* Thu Jun 20 2002 Than Ngo <than@redhat.com> 1.8.0-4
185- Don't forcibly strip binaries
186
187* Sun Jun 2 2002 Than Ngo <than@redhat.com> 1.8.0-3
188- fix a bug in cpumeter (bug #64798)
189
190* Thu May 23 2002 Tim Powers <timp@redhat.com>
191- automated rebuild
192
193* Wed Apr 24 2002 Karsten Hopp <karsten@redhat.de> 1.8.0-1
194- update to current version
195- redo .proc patch
196- change URLs
197
198* Fri Feb 22 2002 Than Ngo <than@redhat.com> 1.7.3-10
199- rebuild in new environment.
200
201* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
202- automated rebuild
203
204* Tue Dec 18 2001 Than Ngo <than@redhat.com> 1.7.3-8
205- xosview +net goes into hard loop (bug #57150)
206- add patch for building against g++ 3
207- use RPM_OPT_FLAG
208
209* Wed Nov 14 2001 Than Ngo <than@redhat.com> 1.7.3-7
210- added missing Icon in desktop file
211- fixed Url
212
213* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
214- rebuild with new gcc and binutils
215
216* Tue Apr 10 2001 Phil Knirsch <pknirsch@redhat.de>
217- Fix for s390 patch to actually work
218
219* Tue Mar 20 2001 Preston Brown <pbrown@redhat.com>
220- fix up .desktop entry
221
222* Sun Feb 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
223- fix typo
224
225* Sun Feb 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
226- adjusted s390 patches
227
228* Wed Jan 31 2001 Preston Brown <pbrown@redhat.com>
229- upgrade to 1.7.3, fixes (#11380)
230
231* Mon Jan 15 2001 Than Ngo <than@redhat.com>
232- ported to ibm s/390
233
234* Tue Jul 25 2000 Jeff Johnson <jbj@redhat.com>
235- migrate wmconfig to applnk.
236
237* Fri Jul 14 2000 Jeff Johnson <jbj@redhat.com>
238- rebuild the auto-rebuild.
239- exclude alpha and i164 for now.
240
241* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
242- automatic rebuild
243
244* Tue Jul  2 2000 Jakub Jelinek <jakub@redhat.com>
245- Rebuild with new C++
246
247* Fri Jun  2 2000 Jeff Johnson <jbj@redhat.com>
248- rebuild for 7.0
249
250* Mon Feb 14 2000 Matt Wilson <msw@redhat.com>
251- rebuild on i386
252
253* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
254- compress man pages.
255
256* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
257- auto rebuild in the new build environment (release 2)
258
259* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
260- updated to 1.7.1.
261
262* Wed Mar  3 1999 Matt Wilson <msw@redhat.com>
263- updated to 1.7.0
264
265* Fri Feb  5 1999 Bill Nottingham <notting@redhat.com>
266- build against new libstdc++, build on arm
267
268* Tue Dec 22 1998 Jeff Johnson <jbj@redhat.com>
269- update to 1.6.2.a.
270
271* Tue Jun 16 1998 Jeff Johnson <jbj@redhat.com>
272- add sparc/alpha functionality.
273- add %clean
274
275* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
276- translations modified for de
277
278* Mon Jun 01 1998 Erik Troan <ewt@redhat.com>
279- how the hell did this get setuid root?
280
281* Thu May 07 1998 Prospector System <bugs@redhat.com>
282- translations modified for de, fr, tr
283
284* Wed Apr 29 1998 Cristian Gafton <gafton@redhat.com>
285- upgraded to 1.5.1 (so that it compiles with egcs)
286- buildroot
287
288* Tue Nov  4 1997 Erik Troan <ewt@redhat.com>
289- commented out line causing core dumps when exiting
290
291* Fri Oct 24 1997 Marc Ewing <marc@redhat.com>
292- wmconfig
293
294* Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
295- built against glibc
Note: See TracBrowser for help on using the repository browser.