source: projects/specs/trunk/x/xosview/xosview-vl.spec @ 10776

Revision 10776, 8.2 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define desktop_file 1
2%if %{desktop_file}
3%define desktop_file_utils_version 0.2.90
4%endif
5
6Summary:        An X Window System utility for monitoring system resources.
7Summary(ja):    X Window System のシステムリソースモニタ
8Name:           xosview
9Version:        1.16
10Release:        2%{?_dist_release}
11
12Group:          Applications/System
13# The netbsd/swapinternal.{cc,h} source files are BSD only (with
14# advertising), but neither file is used in the linux version of
15# xosview.  Instead, the source files used are linux/swapmeter.{cc,h},
16# both of which fall under the GPL. All other files are either GPL
17# based, or can fall under either the BSD or GPL copyright.
18License: GPL+
19URL:            http://www.pogo.org.uk/~mark/xosview/
20Source0:        http://www.pogo.org.uk/~mark/xosview/releases/xosview-%{version}.tar.gz
21# An old png file is being used for the icon.  It is located at:
22Source1:        http://roxos.sunsite.dk/dev-contrib/guido/XOsview.png
23Patch0:         xosview-1.11-app-def.patch
24Patch1:         xosview-aarch64.patch
25
26Buildroot:      %{_tmppath}/%{name}-%{version}-root
27# XXX ia64 needs porting work
28ExcludeArch: alpha ia64 sparc
29
30BuildRequires: libX11-devel
31BuildRequires: libXpm-devel
32%if %{desktop_file}
33BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
34%endif
35Requires: xorg-x11-fonts-misc
36
37%description
38The xosview utility displays a set of bar graphs which show the
39current system state, including memory usage, CPU usage, system load,
40etc. Xosview runs under the X Window System.
41
42%description -l ja
43xosview は,メモリ・CPU の使用率やシステム負荷など,現在のシステムの
44状態をグラフで表示するユーティリティです.xosview は X Window System
45上で動作します.
46
47
48%prep
49%setup -q
50%patch0 -p1
51%patch1 -p1
52
53
54%build
55%{__make} %{?_smp_mflags} OPTFLAGS="%{optflags}"
56
57cat > %{name}.desktop <<EOF
58[Desktop Entry]
59Encoding=UTF-8
60Name=OS Resource Viewer
61Name[ja]=OS リソースビューア
62Comment=
63Exec=xosview
64Terminal=false
65Type=Application
66Icon=xosview
67Categories=Utility;System;
68EOF
69
70
71%install
72%{__rm} -rf %{buildroot}
73%{__install} -d %{buildroot}%{_bindir}   \
74    %{buildroot}%{_mandir}/man1          \
75    %{buildroot}%{_datadir}/icons        \
76    %{buildroot}%{_datadir}/applications \
77    %{buildroot}%{_datadir}/X11/app-defaults
78
79%{__make} install PREFIX=%{buildroot}%{_prefix} INSTALL="%{__install} -p"
80
81%{__install} -p -m 0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/%{name}.png
82%{__install} -p -m 0644 -D Xdefaults %{buildroot}%{_datadir}/X11/app-defaults/XOsview
83desktop-file-install --dir %{buildroot}%{_datadir}/applications %{name}.desktop
84
85
86%clean
87rm -rf %{buildroot}
88
89
90%files
91%defattr(-,root,root,-)
92%doc CHANGES COPYING COPYING.GPL README README.linux TODO Xdefaults
93%{_bindir}/%{name}
94%{_mandir}/man1/%{name}.1*
95%{_datadir}/icons/%{name}.png
96%{_datadir}/X11/app-defaults/XOsview
97%{_datadir}/applications/%{name}.desktop
98
99
100%changelog
101* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 1.16-2
102- rebuild with gcc-5.4.0
103
104* Fri Apr  3 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.16-1
105- updated to 1.16
106
107* Thu Mar 22 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2-1
108- new upstream release; new upstream location
109- spec revamp based on Fedora
110
111* Thu Jun  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
112- rebuilt with xorg-x11 7.3
113- fixed installed location
114- added -DHAVE_SNPRINTF flags to CXXFLAGS
115- spec in UTF-8
116
117* Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.3-0vl2
118- rebuilt with new toolchain
119
120* Mon Jan  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
121- new upstream release
122- changed %desktop_file to 1
123
124* Wed Jul 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
125- new upstream release, work on kernel 2.6
126- dropped Patches (which were merged into upstream)
127- added BuildRequires: XOrg-devel
128
129* Thu Mar 20 2003 IWAI Masaharu <iwai@alib.jp> 1.8.0-9vl2
130- add README*, TODO and CHANGES in the document directory
131
132* Wed Nov 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.0-9vl1
133- based on 1.8.0-9 from Rawhide and built for Vine Linux
134- built with new toolchain environment
135- %%define desktop_file 0 for Vine
136- the previous Vine version was 1.7.1-2vl5. The changelog was as follows:
137
138  - Fri Mar 15 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.7.1-2vl5
139  - rebuilt with glibc > 2.2
140
141  - Wed Jul 18 2001 <sagami@vinelinux.org>
142  - 1.7.1-2vl5: use %%{ix86} for _arch instead of i386 :-)
143
144  - Tue Feb 20 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
145  - 1.7.1-2vl4
146  - add alpha patch (%%patch1) from Kondara
147  - include alpha, again
148
149  - Thu Jan 25 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
150  - 1.7.1-2vl3
151  - ExcludeArch: alpha :-P
152  - added Japanese summary and description
153
154  - Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.7.1-2vl2
155  - build on gcc-2.95.3
156  - added patch0 for i386
157  - partially used rpmmacros
158
159  - Wed Feb 16 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
160  - 1.7.1-2vl1
161  - modified spec for ppc archtecture
162
163* Tue Sep 17 2002 Than Ngo <than@redhat.com> 1.8.0-9
164- Adjust some patch files (bug #74141)
165
166* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
167- rebuilt with gcc-3.2 (we hope)
168
169* Wed Jul 24 2002 Than Ngo <than@redhat.com> 1.8.0-7
170- desktop file issue (bug #69551)
171
172* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 1.8.0-6
173- build using gcc-3.2-0.1
174
175* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.0-5
176- automated rebuild
177
178* Thu Jun 20 2002 Than Ngo <than@redhat.com> 1.8.0-4
179- Don't forcibly strip binaries
180
181* Sun Jun 2 2002 Than Ngo <than@redhat.com> 1.8.0-3
182- fix a bug in cpumeter (bug #64798)
183
184* Thu May 23 2002 Tim Powers <timp@redhat.com>
185- automated rebuild
186
187* Wed Apr 24 2002 Karsten Hopp <karsten@redhat.de> 1.8.0-1
188- update to current version
189- redo .proc patch
190- change URLs
191
192* Fri Feb 22 2002 Than Ngo <than@redhat.com> 1.7.3-10
193- rebuild in new environment.
194
195* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
196- automated rebuild
197
198* Tue Dec 18 2001 Than Ngo <than@redhat.com> 1.7.3-8
199- xosview +net goes into hard loop (bug #57150)
200- add patch for building against g++ 3
201- use RPM_OPT_FLAG
202
203* Wed Nov 14 2001 Than Ngo <than@redhat.com> 1.7.3-7
204- added missing Icon in desktop file
205- fixed Url
206
207* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
208- rebuild with new gcc and binutils
209
210* Tue Apr 10 2001 Phil Knirsch <pknirsch@redhat.de>
211- Fix for s390 patch to actually work
212
213* Tue Mar 20 2001 Preston Brown <pbrown@redhat.com>
214- fix up .desktop entry
215
216* Sun Feb 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
217- fix typo
218
219* Sun Feb 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
220- adjusted s390 patches
221
222* Wed Jan 31 2001 Preston Brown <pbrown@redhat.com>
223- upgrade to 1.7.3, fixes (#11380)
224
225* Mon Jan 15 2001 Than Ngo <than@redhat.com>
226- ported to ibm s/390
227
228* Tue Jul 25 2000 Jeff Johnson <jbj@redhat.com>
229- migrate wmconfig to applnk.
230
231* Fri Jul 14 2000 Jeff Johnson <jbj@redhat.com>
232- rebuild the auto-rebuild.
233- exclude alpha and i164 for now.
234
235* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
236- automatic rebuild
237
238* Tue Jul  2 2000 Jakub Jelinek <jakub@redhat.com>
239- Rebuild with new C++
240
241* Fri Jun  2 2000 Jeff Johnson <jbj@redhat.com>
242- rebuild for 7.0
243
244* Mon Feb 14 2000 Matt Wilson <msw@redhat.com>
245- rebuild on i386
246
247* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
248- compress man pages.
249
250* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
251- auto rebuild in the new build environment (release 2)
252
253* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
254- updated to 1.7.1.
255
256* Wed Mar  3 1999 Matt Wilson <msw@redhat.com>
257- updated to 1.7.0
258
259* Fri Feb  5 1999 Bill Nottingham <notting@redhat.com>
260- build against new libstdc++, build on arm
261
262* Tue Dec 22 1998 Jeff Johnson <jbj@redhat.com>
263- update to 1.6.2.a.
264
265* Tue Jun 16 1998 Jeff Johnson <jbj@redhat.com>
266- add sparc/alpha functionality.
267- add %clean
268
269* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
270- translations modified for de
271
272* Mon Jun 01 1998 Erik Troan <ewt@redhat.com>
273- how the hell did this get setuid root?
274
275* Thu May 07 1998 Prospector System <bugs@redhat.com>
276- translations modified for de, fr, tr
277
278* Wed Apr 29 1998 Cristian Gafton <gafton@redhat.com>
279- upgraded to 1.5.1 (so that it compiles with egcs)
280- buildroot
281
282* Tue Nov  4 1997 Erik Troan <ewt@redhat.com>
283- commented out line causing core dumps when exiting
284
285* Fri Oct 24 1997 Marc Ewing <marc@redhat.com>
286- wmconfig
287
288* Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
289- built against glibc
Note: See TracBrowser for help on using the repository browser.