source: projects/specs/trunk/x/xorg-x11-xkb-utils/xorg-x11-xkb-utils-vl.spec @ 8064

Revision 8064, 5.8 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1Summary: X.Org X11 xkb utilities
2Summary(ja): X.Org X11 xkb ユーティリティ
3Name: xorg-x11-xkb-utils
4Version: 7.7
5Release: 2%{?_dist_release}
6License: MIT/X11
7Group: User Interface/X
8URL: http://www.x.org
9
10# use the macro so the doc dir is changed automagically
11%define xkbutils_version 1.0.4
12Source0: ftp://ftp.x.org/pub/individual/app/xkbutils-%{xkbutils_version}.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/xkbcomp-1.2.4.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/xkbevd-1.1.3.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/xkbprint-1.0.3.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/app/setxkbmap-1.3.0.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20BuildRequires: libxkbfile-devel
21BuildRequires: libX11-devel
22BuildRequires: libXaw-devel >= 1.0.5
23BuildRequires: libXt-devel
24BuildRequires: libXext-devel
25BuildRequires: libXpm-devel
26BuildRequires: bison
27BuildRequires: flex
28Provides: setxkbmap, xkbcomp, xkbevd, xkbprint, xkbutils
29Obsoletes: XFree86
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: Takemikaduchi
34
35%description
36X.Org X11 xkb utilities
37
38%prep
39%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
40
41%build
42export CFLAGS="$RPM_OPT_FLAGS -DHAVE_STRCASECMP"
43for pkg in xkbutils setxkbmap xkbcomp xkbevd xkbprint ; do
44    pushd $pkg-*
45    %configure
46    make
47    popd
48done
49
50%install
51rm -rf $RPM_BUILD_ROOT
52for pkg in xkbutils setxkbmap xkbcomp xkbevd xkbprint ; do
53    pushd $pkg-*
54    make install DESTDIR=$RPM_BUILD_ROOT
55    popd
56done
57rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/xkbcomp.pc
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(-,root,root,-)
64%doc xkbutils-%{xkbutils_version}/AUTHORS xkbutils-%{xkbutils_version}/COPYING xkbutils-%{xkbutils_version}/INSTALL
65%doc xkbutils-%{xkbutils_version}/NEWS xkbutils-%{xkbutils_version}/README xkbutils-%{xkbutils_version}/ChangeLog
66%{_bindir}/setxkbmap
67%{_bindir}/xkbbell
68%{_bindir}/xkbcomp
69%{_bindir}/xkbevd
70%{_bindir}/xkbprint
71%{_bindir}/xkbvleds
72%{_bindir}/xkbwatch
73%{_mandir}/man1/setxkbmap.1*
74%{_mandir}/man1/xkbcomp.1*
75%{_mandir}/man1/xkbevd.1*
76%{_mandir}/man1/xkbprint.1*
77%{_mandir}/man1/xkbbell.1*
78%{_mandir}/man1/xkbvleds.1*
79%{_mandir}/man1/xkbwatch.1*
80
81%changelog
82* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
83- xkbevd-1.1.3
84
85* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
86- xkbutils-1.0.4
87
88* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
89- xkbcomp-1.2.4
90- setxkbmap-1.3.0
91
92* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
93- xkbcomp-1.2.3
94
95* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
96- delete Obsoletes: xorg-x11
97
98* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
99- xkbprint-1.0.3
100
101* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
102- xkbevd-1.1.2
103- add BuildRequires: bison, flex
104
105* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
106- xkbutils-1.0.3
107- xkbcomp-1.2.0
108- xkbevd-1.1.1
109- setxkbmap-1.2.0
110
111* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
112- xkbutils-1.0.2
113- xkbcomp-1.1.1
114- xkbevd-1.1.0
115- xkbprint-1.0.2
116- setxkbmap-1.1.0
117
118* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
119- rebuild with libXaw.so.7 (libXaw-1.0.5)
120
121* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
122- xkbcomp 1.0.5
123
124* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
125- new versioning policy
126
127* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
128- initial build for Vine Linux
129
130* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-3
131- Rebuild for ppc toolchain bug
132
133* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-2
134- rebuild for toolchain bug
135
136* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-1
137- setxkbmap 1.0.4
138- Arbitrary version number bump, to match X.org release numbering.  Why not.
139
140* Mon Jan 08 2007 Adam Jackson <ajax@redhat.com> 1.0.2-3
141- From OLPC: jam -DHAVE_STRCASECMP into CFLAGS to make xkbcomp (and therefore
142  X server startup) slightly less painfully slow.
143
144* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
145- rebuild
146
147* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
148- Added xkbutils_version macro, which can be used in the Version field
149  in the future, to help prevent accidental bumping of the package version.
150
151* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
152- Update setxkbmap, xkbevd, and xkbcomp
153
154* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
155- bump again for double-long bug on ppc(64)
156
157* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
158- rebuilt for new gcc4.1 snapshot and glibc changes
159
160* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
161- Updated all apps to version 1.0.1 from X11R7.0
162
163* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
164- Updated all apps to version 1.0.0 from X11R7 RC4.
165- Changed manpage dir from man1x to man1 to match upstream default.
166
167* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
168- Change from "Conflicts" to "Obsoletes: XFree86, xorg-x11" for upgrades.
169- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
170
171* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
172- Updated to xkbutils-0.99.1, setxkbmap-0.99.2, xkbcomp-0.99.1, xkbevd-0.99.2,
173  xkbprint-0.99.1 from X11R7 RC2.
174
175* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
176- Updated xkbutils to version 0.99.0 from X11R7 RC1.  The upstream tarball
177  changed, but the version stayed the same.  <sigh>
178- Updated setxkbmap, xkbcomp, xkbevd, xkbprint.
179- Change manpage location to 'man1x' in file manifest.
180- Iterate over packages with for loop instead of serialized code duplication.
181
182* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
183- Use Fedora-Extras style BuildRoot tag.
184- Update BuildRequires to use new library package names.
185- Tidy up spec file a bit.
186
187* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
188- Initial build.
Note: See TracBrowser for help on using the repository browser.