source: projects/specs/trunk/x/xorg-x11-xkb-utils/xorg-x11-xkb-utils-vl.spec @ 2357

Revision 2357, 5.2 KB checked in by Takemikaduchi, 14 years ago (diff)

update xorg packages

Line 
1Summary: X.Org X11 xkb utilities
2Summary(ja): X.Org X11 xkb ユーティリティ
3Name: xorg-x11-xkb-utils
4Version: 7.5
5Release: 3%{?_dist_release}
6License: MIT/X11
7Group: User Interface/X
8URL: http://www.x.org
9
10# use the macro so the doc dir is changed automagically
11%define xkbutils_version 1.0.3
12Source0: ftp://ftp.x.org/pub/individual/app/xkbutils-%{xkbutils_version}.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/xkbcomp-1.2.0.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/xkbevd-1.1.2.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/xkbprint-1.0.2.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/app/setxkbmap-1.2.0.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20BuildRequires: libxkbfile-devel
21BuildRequires: libX11-devel
22BuildRequires: libXaw-devel >= 1.0.5
23BuildRequires: libXt-devel
24BuildRequires: libXext-devel
25BuildRequires: libXpm-devel
26BuildRequires: bison
27BuildRequires: flex
28Provides: setxkbmap, xkbcomp, xkbevd, xkbprint, xkbutils
29Obsoletes: XFree86, xorg-x11
30
31%description
32X.Org X11 xkb utilities
33
34%prep
35%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
36
37%build
38export CFLAGS="$RPM_OPT_FLAGS -DHAVE_STRCASECMP"
39for pkg in xkbutils setxkbmap xkbcomp xkbevd xkbprint ; do
40    pushd $pkg-*
41    %configure
42    make
43    popd
44done
45
46%install
47rm -rf $RPM_BUILD_ROOT
48for pkg in xkbutils setxkbmap xkbcomp xkbevd xkbprint ; do
49    pushd $pkg-*
50    make install DESTDIR=$RPM_BUILD_ROOT
51    popd
52done
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(-,root,root,-)
59%doc xkbutils-%{xkbutils_version}/AUTHORS xkbutils-%{xkbutils_version}/COPYING xkbutils-%{xkbutils_version}/INSTALL
60%doc xkbutils-%{xkbutils_version}/NEWS xkbutils-%{xkbutils_version}/README xkbutils-%{xkbutils_version}/ChangeLog
61%{_bindir}/setxkbmap
62%{_bindir}/xkbbell
63%{_bindir}/xkbcomp
64%{_bindir}/xkbevd
65%{_bindir}/xkbprint
66%{_bindir}/xkbvleds
67%{_bindir}/xkbwatch
68%{_mandir}/man1/setxkbmap.1*
69%{_mandir}/man1/xkbcomp.1*
70%{_mandir}/man1/xkbevd.1*
71%{_mandir}/man1/xkbprint.1*
72%{_mandir}/man1/xkbbell.1*
73%{_mandir}/man1/xkbvleds.1*
74%{_mandir}/man1/xkbwatch.1*
75
76%changelog
77* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
78- xkbevd-1.1.2
79- add BuildRequires: bison, flex
80
81* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
82- xkbutils-1.0.3
83- xkbcomp-1.2.0
84- xkbevd-1.1.1
85- setxkbmap-1.2.0
86
87* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
88- xkbutils-1.0.2
89- xkbcomp-1.1.1
90- xkbevd-1.1.0
91- xkbprint-1.0.2
92- setxkbmap-1.1.0
93
94* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
95- rebuild with libXaw.so.7 (libXaw-1.0.5)
96
97* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
98- xkbcomp 1.0.5
99
100* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
101- new versioning policy
102
103* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
104- initial build for Vine Linux
105
106* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-3
107- Rebuild for ppc toolchain bug
108
109* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-2
110- rebuild for toolchain bug
111
112* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-1
113- setxkbmap 1.0.4
114- Arbitrary version number bump, to match X.org release numbering.  Why not.
115
116* Mon Jan 08 2007 Adam Jackson <ajax@redhat.com> 1.0.2-3
117- From OLPC: jam -DHAVE_STRCASECMP into CFLAGS to make xkbcomp (and therefore
118  X server startup) slightly less painfully slow.
119
120* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
121- rebuild
122
123* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
124- Added xkbutils_version macro, which can be used in the Version field
125  in the future, to help prevent accidental bumping of the package version.
126
127* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
128- Update setxkbmap, xkbevd, and xkbcomp
129
130* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
131- bump again for double-long bug on ppc(64)
132
133* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
134- rebuilt for new gcc4.1 snapshot and glibc changes
135
136* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
137- Updated all apps to version 1.0.1 from X11R7.0
138
139* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
140- Updated all apps to version 1.0.0 from X11R7 RC4.
141- Changed manpage dir from man1x to man1 to match upstream default.
142
143* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
144- Change from "Conflicts" to "Obsoletes: XFree86, xorg-x11" for upgrades.
145- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
146
147* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
148- Updated to xkbutils-0.99.1, setxkbmap-0.99.2, xkbcomp-0.99.1, xkbevd-0.99.2,
149  xkbprint-0.99.1 from X11R7 RC2.
150
151* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
152- Updated xkbutils to version 0.99.0 from X11R7 RC1.  The upstream tarball
153  changed, but the version stayed the same.  <sigh>
154- Updated setxkbmap, xkbcomp, xkbevd, xkbprint.
155- Change manpage location to 'man1x' in file manifest.
156- Iterate over packages with for loop instead of serialized code duplication.
157
158* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
159- Use Fedora-Extras style BuildRoot tag.
160- Update BuildRequires to use new library package names.
161- Tidy up spec file a bit.
162
163* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
164- Initial build.
Note: See TracBrowser for help on using the repository browser.