source: projects/specs/trunk/x/xorg-x11-xkb-utils/xorg-x11-xkb-utils-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: X.Org X11 xkb utilities
2Summary(ja): X.Org X11 xkb ユーティリティ
3Name: xorg-x11-xkb-utils
4Version: 7.5
5Release: 1%{?_dist_release}
6License: MIT/X11
7Group: User Interface/X
8URL: http://www.x.org
9
10# use the macro so the doc dir is changed automagically
11%define xkbutils_version 1.0.2
12Source0: ftp://ftp.x.org/pub/individual/app/xkbutils-%{xkbutils_version}.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/xkbcomp-1.1.1.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/xkbevd-1.1.0.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/xkbprint-1.0.2.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/app/setxkbmap-1.1.0.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20BuildRequires: libxkbfile-devel
21BuildRequires: libX11-devel
22BuildRequires: libXaw-devel >= 1.0.5
23BuildRequires: libXt-devel
24BuildRequires: libXext-devel
25BuildRequires: libXpm-devel
26Provides: setxkbmap, xkbcomp, xkbevd, xkbprint, xkbutils
27Obsoletes: XFree86, xorg-x11
28
29%description
30X.Org X11 xkb utilities
31
32%prep
33%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
34
35%build
36export CFLAGS="$RPM_OPT_FLAGS -DHAVE_STRCASECMP"
37for pkg in xkbutils setxkbmap xkbcomp xkbevd xkbprint ; do
38    pushd $pkg-*
39    %configure
40    make
41    popd
42done
43
44%install
45rm -rf $RPM_BUILD_ROOT
46for pkg in xkbutils setxkbmap xkbcomp xkbevd xkbprint ; do
47    pushd $pkg-*
48    make install DESTDIR=$RPM_BUILD_ROOT
49    popd
50done
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(-,root,root,-)
57%doc xkbutils-%{xkbutils_version}/AUTHORS xkbutils-%{xkbutils_version}/COPYING xkbutils-%{xkbutils_version}/INSTALL
58%doc xkbutils-%{xkbutils_version}/NEWS xkbutils-%{xkbutils_version}/README xkbutils-%{xkbutils_version}/ChangeLog
59%{_bindir}/setxkbmap
60%{_bindir}/xkbbell
61%{_bindir}/xkbcomp
62%{_bindir}/xkbevd
63%{_bindir}/xkbprint
64%{_bindir}/xkbvleds
65%{_bindir}/xkbwatch
66%{_mandir}/man1/setxkbmap.1*
67%{_mandir}/man1/xkbcomp.1*
68%{_mandir}/man1/xkbevd.1*
69%{_mandir}/man1/xkbprint.1*
70
71%changelog
72* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
73- xkbutils-1.0.2
74- xkbcomp-1.1.1
75- xkbevd-1.1.0
76- xkbprint-1.0.2
77- setxkbmap-1.1.0
78
79* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
80- rebuild with libXaw.so.7 (libXaw-1.0.5)
81
82* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
83- xkbcomp 1.0.5
84
85* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
86- new versioning policy
87
88* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
89- initial build for Vine Linux
90
91* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-3
92- Rebuild for ppc toolchain bug
93
94* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-2
95- rebuild for toolchain bug
96
97* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-1
98- setxkbmap 1.0.4
99- Arbitrary version number bump, to match X.org release numbering.  Why not.
100
101* Mon Jan 08 2007 Adam Jackson <ajax@redhat.com> 1.0.2-3
102- From OLPC: jam -DHAVE_STRCASECMP into CFLAGS to make xkbcomp (and therefore
103  X server startup) slightly less painfully slow.
104
105* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
106- rebuild
107
108* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
109- Added xkbutils_version macro, which can be used in the Version field
110  in the future, to help prevent accidental bumping of the package version.
111
112* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
113- Update setxkbmap, xkbevd, and xkbcomp
114
115* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
116- bump again for double-long bug on ppc(64)
117
118* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
119- rebuilt for new gcc4.1 snapshot and glibc changes
120
121* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
122- Updated all apps to version 1.0.1 from X11R7.0
123
124* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
125- Updated all apps to version 1.0.0 from X11R7 RC4.
126- Changed manpage dir from man1x to man1 to match upstream default.
127
128* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
129- Change from "Conflicts" to "Obsoletes: XFree86, xorg-x11" for upgrades.
130- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
131
132* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
133- Updated to xkbutils-0.99.1, setxkbmap-0.99.2, xkbcomp-0.99.1, xkbevd-0.99.2,
134  xkbprint-0.99.1 from X11R7 RC2.
135
136* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
137- Updated xkbutils to version 0.99.0 from X11R7 RC1.  The upstream tarball
138  changed, but the version stayed the same.  <sigh>
139- Updated setxkbmap, xkbcomp, xkbevd, xkbprint.
140- Change manpage location to 'man1x' in file manifest.
141- Iterate over packages with for loop instead of serialized code duplication.
142
143* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
144- Use Fedora-Extras style BuildRoot tag.
145- Update BuildRequires to use new library package names.
146- Tidy up spec file a bit.
147
148* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
149- Initial build.
Note: See TracBrowser for help on using the repository browser.