source: projects/specs/trunk/x/xorg-x11-xinit/xorg-x11-xinit-vl.spec @ 8508

Revision 8508, 11.7 KB checked in by shaolin, 10 years ago (diff)
  • xorg-x11-xinit: exec startfluxbox, not fluxbox
Line 
1%define pkgname xinit
2
3Summary:     X.Org X11 X Window System xinit startup scripts
4Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
5Name:      xorg-x11-%{pkgname}
6Version:   1.3.3
7Release:   2%{?_dist_release}
8License:   MIT/X11
9Group:     User Interface/X
10URL:       http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
13Source10: xinitrc-common
14Source11: xinitrc
15Source12: Xclients
16Source13: Xmodmap
17Source14: Xresources
18# NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
19#       here instead of the xdm package.
20Source16: Xsession
21Source17: localuser.sh
22Source18: xinit-compat.desktop
23Source100: ck-xinit-session.c
24
25Patch1: xinit-1.3.0-client-session.patch
26Patch2: xinit-1.0.7-poke-ck.patch
27Patch3: xinit-1.0.9-unset.patch
28
29Patch10: xinit-1.3.0-vine.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32BuildRequires: pkgconfig
33BuildRequires: libX11-devel
34BuildRequires: ConsoleKit-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: libtool
38BuildRequires: dbus-devel
39BuildRequires: xorg-x11-util-macros
40# NOTE: startx needs xauth in order to run, but that is not picked up
41#       automatically by rpm.  (Bug #173684)
42Requires: xauth
43# next two are for localuser.sh
44Requires: coreutils
45Requires: xorg-x11-server-utils
46Requires: ConsoleKit-x11
47Requires: ConsoleKit-libs
48Requires: dbus-x11
49
50# NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
51# modularization.  These Obsoletes lines ensure upgrades work smoothly.
52Obsoletes: XFree86, XOrg
53
54# NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
55# so the xinitrc package became unnecessary.  The xdm configs/scripts move
56# to the xdm package.
57Obsoletes: xinitrc
58Provides: xinitrc
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: Takemikaduchi
63
64%description
65X.Org X11 X Window System xinit startup scripts
66
67%description -l ja
68X.Org X11 X Window System の xinit スタートアップ・スクリプト
69
70%package session
71Summary: Display manager support for ~/.xsession and ~/.Xclients
72Group: User Interface/X
73
74%description
75X.Org X11 X Window System xinit startup scripts
76
77%description session
78Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
79
80%prep
81%setup -q -n %{pkgname}-%{version}
82%patch1 -p1 -b .client-session
83#%patch2 -p1 -b .poke-ck
84%patch3 -p1 -b .unset
85%patch10 -p1 -b .vine
86
87%build
88autoreconf -i
89%configure
90# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
91# Makefile.am and submit it in a bug report or check into CVS.
92make XINITDIR=/etc/X11/xinit
93%{__cc} -o ck-xinit-session \
94        `pkg-config --cflags ck-connector dbus-1` $RPM_OPT_FLAGS \
95        $RPM_SOURCE_DIR/ck-xinit-session.c \
96        `pkg-config --libs ck-connector dbus-1`
97
98%install
99rm -rf $RPM_BUILD_ROOT
100# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
101# Makefile.am and submit it in a bug report or check into CVS.
102%makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
103install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
104install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
105
106# Install custom xinitrc, etc.
107{
108    install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
109
110    for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
111        install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
112    done
113
114    install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
115    install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
116
117    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
118    install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
119
120    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
121}
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%files
127%defattr(-,root,root,-)
128%doc COPYING README ChangeLog
129%{_bindir}/startx
130%{_bindir}/xinit
131%{_bindir}/ck-xinit-session
132%dir %{_sysconfdir}/X11
133%dir %{_sysconfdir}/X11/xinit
134%{_sysconfdir}/X11/xinit/xinitrc
135%{_sysconfdir}/X11/xinit/xinitrc-common
136%config(noreplace) %{_sysconfdir}/X11/Xmodmap
137%config(noreplace) %{_sysconfdir}/X11/Xresources
138%dir %{_sysconfdir}/X11/xinit/Xclients.d
139%{_sysconfdir}/X11/xinit/Xclients
140%{_sysconfdir}/X11/xinit/Xsession
141%dir %{_sysconfdir}/X11/xinit/xinitrc.d
142%{_sysconfdir}/X11/xinit/xinitrc.d/*
143#%dir %{_mandir}/man1
144%{_mandir}/man1/startx.1*
145%{_mandir}/man1/xinit.1*
146
147%files session
148%defattr(-, root, root)
149%{_datadir}/xsessions/xinit-compat.desktop
150
151%changelog
152* Wed Jun 04 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.3-2
153- exec startfluxbox instead of fluxbox
154
155* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-1
156- new upstream release
157
158* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
159- new upstream release
160
161* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
162- new upstream release
163
164* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
165- new upstream release
166- update Patch1, Patch10
167
168* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
169- new upstream release
170- updated SOURCE12, SOURCE100
171- Install xinitrc-common non-executable.
172- added a new subpackage to add ~/.xsessions and ~/.Xclients
173  to session list
174
175* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
176- new upstream release
177
178* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
179- add Requires: dbus-x11
180
181* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
182- add LXDE to Xclients
183
184* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
185- new upstream release
186
187* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
188- fix typo in Xsession (<BTS:644>)
189
190* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
191- new upstream release
192
193* Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
194- spec in UTF-8
195- modify Source16: add CK_XINIT_SESSION calls
196
197* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
198- add Patch10 to set display resolution.
199
200* Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
201- initial build for Vine Linux
202
203* Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
204- Try opening the console-kit session after the user's UID has already
205  been granted access to the server by localuser.sh, so that console-kit-daemon
206  can connect and ask the server for information just by having switch to the
207  user's UID (#287941).
208
209* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
210- xinit 1.0.7
211
212* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
213- Rebuild for build id
214
215* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
216- Bump release
217
218* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
219- Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
220
221* Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
222- Fix bug 212167, CVE-2006-5214
223
224* Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
225- Fix Xsession to run the login shell inside the setgid ssh-agent, rather
226  than the other way around. This preserves LD_LIBRARY_PRELOAD.
227        Patch from Stefan Becker, bug 164869.
228
229* Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
230- Remove xinput.sh. Bug 244963.
231
232* Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
233- localuser.sh: Run silently.
234
235* Sun Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
236- Don't install INSTALL
237
238* Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
239- disable SCIM by default in non-Asian languages #237054
240  If you want to use SCIM, use im-chooser to enable it.
241
242* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
243- Man pages are now in section 1, not in section 1x
244
245* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
246- Also BR xorg-x11-util-macros since we autoreconf
247
248* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
249- Add ConsoleKit support (#233183)
250
251* Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
252- Bump EVR to fix 6 to 7 updates.
253
254* Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
255- start client in its own session with no controlling tty
256  (bug 214649)
257
258* Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
259- Update Xsession to not use switchdesk for the hard coded kde and twm
260  cases.
261
262* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
263- rebuilt for unwind info generation, broken in gcc-4.1.1-21
264
265* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
266- Bump and rebuild.
267
268* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
269- Move hardcoded xsetroot background color to fallback cases (#205901).
270
271* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
272- Start ssh-agent for startx also (#169259).
273
274* Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
275- Fix SourceN line for localuser.sh to not collide.
276
277* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
278- Added localuser.sh.
279
280* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
281- Added fix to Xclients script, based on patch from bug (#190799)
282
283* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
284- rebuild
285
286* Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
287- Implemented changes to xinput.sh based on suggestions from (#194458)
288
289* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
290- Added documentation to doc macro.
291
292* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
293- Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
294
295* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
296- Added "BuildRequires: pkgconfig" for bug (#194187)
297
298* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
299- Update xinit to 1.0.2
300
301* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
302- Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
303
304* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
305- bump again for double-long bug on ppc(64)
306
307* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
308- rebuilt for new gcc4.1 snapshot and glibc changes
309
310* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
311- Updated to xinit 1.0.1 from X11R7.0
312
313* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
314- Updated to xinit 1.0.0 from X11R7 RC4.
315- Changed manpage dir from man1x to man1 to match upstream default.
316
317* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
318- Add "Requires: xauth" for startx, to fix bug (#173684)
319
320* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
321- Do not provide xinit anymore, gdm has been fixed and that breaks things
322  with the obsoletes
323
324* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
325- Added Xsession script from xinitrc, as it is very similar codebase, which
326  shares "xinitrc-common" anyway, and all of the display managers use it.
327
328* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
329- Updated to xinit 0.99.3 from X11R7 RC2.
330
331* Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
332- Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
333  monolithic and modular X.  This will be removed however for FC5.
334
335* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
336- Import custom Red Hat xinit scripts from xinitrc package.
337- Obsolete xinitrc package, as we include the scripts/configs here now.
338- Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
339
340* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
341- Updated to xinit 0.99.2 from X11R7 RC1.
342- Change manpage location to 'man1x' in file manifest.
343
344* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
345- Use Fedora-Extras style BuildRoot tag.
346- Update BuildRequires to use new library package names.
347- Tidy up spec file a bit.
348
349* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
350- Initial build.
Note: See TracBrowser for help on using the repository browser.