source: projects/specs/trunk/x/xorg-x11-xinit/xorg-x11-xinit-vl.spec @ 4616

Revision 4616, 11.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define pkgname xinit
2
3Summary:     X.Org X11 X Window System xinit startup scripts
4Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
5Name:      xorg-x11-%{pkgname}
6Version:   1.3.1
7Release:   1%{?_dist_release}
8License:   MIT/X11
9Group:     User Interface/X
10URL:       http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
13Source10: xinitrc-common
14Source11: xinitrc
15Source12: Xclients
16Source13: Xmodmap
17Source14: Xresources
18# NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
19#       here instead of the xdm package.
20Source16: Xsession
21Source17: localuser.sh
22Source18: xinit-compat.desktop
23Source100: ck-xinit-session.c
24
25Patch1: xinit-1.3.0-client-session.patch
26Patch2: xinit-1.0.7-poke-ck.patch
27Patch3: xinit-1.0.9-unset.patch
28
29Patch10: xinit-1.3.0-vine.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32BuildRequires: pkgconfig
33BuildRequires: libX11-devel
34BuildRequires: ConsoleKit-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: libtool
38BuildRequires: dbus-devel
39BuildRequires: xorg-x11-util-macros
40# NOTE: startx needs xauth in order to run, but that is not picked up
41#       automatically by rpm.  (Bug #173684)
42Requires: xauth
43# next two are for localuser.sh
44Requires: coreutils
45Requires: xorg-x11-server-utils
46Requires: ConsoleKit-x11
47Requires: ConsoleKit-libs
48Requires: dbus-x11
49
50# NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
51# modularization.  These Obsoletes lines ensure upgrades work smoothly.
52Obsoletes: XFree86, XOrg
53
54# NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
55# so the xinitrc package became unnecessary.  The xdm configs/scripts move
56# to the xdm package.
57Obsoletes: xinitrc
58Provides: xinitrc
59
60Vendor: Project Vine
61Distribution: Vine Linux
62
63%description
64X.Org X11 X Window System xinit startup scripts
65
66%description -l ja
67X.Org X11 X Window System の xinit スタートアップ・スクリプト
68
69%package session
70Summary: Display manager support for ~/.xsession and ~/.Xclients
71Group: User Interface/X
72
73%description
74X.Org X11 X Window System xinit startup scripts
75
76%description session
77Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
78
79%prep
80%setup -q -n %{pkgname}-%{version}
81%patch1 -p1 -b .client-session
82#%patch2 -p1 -b .poke-ck
83%patch3 -p1 -b .unset
84%patch10 -p1 -b .vine
85
86%build
87autoreconf -i
88%configure
89# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
90# Makefile.am and submit it in a bug report or check into CVS.
91make XINITDIR=/etc/X11/xinit
92%{__cc} -o ck-xinit-session \
93        `pkg-config --cflags ck-connector dbus-1` $RPM_OPT_FLAGS \
94        $RPM_SOURCE_DIR/ck-xinit-session.c \
95        `pkg-config --libs ck-connector dbus-1`
96
97%install
98rm -rf $RPM_BUILD_ROOT
99# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
100# Makefile.am and submit it in a bug report or check into CVS.
101%makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
102install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
103install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
104
105# Install custom xinitrc, etc.
106{
107    install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
108
109    for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
110        install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
111    done
112
113    install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
114    install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
115
116    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
117    install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
118
119    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
120}
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(-,root,root,-)
127%doc COPYING README ChangeLog
128%{_bindir}/startx
129%{_bindir}/xinit
130%{_bindir}/ck-xinit-session
131%dir %{_sysconfdir}/X11
132%dir %{_sysconfdir}/X11/xinit
133%{_sysconfdir}/X11/xinit/xinitrc
134%{_sysconfdir}/X11/xinit/xinitrc-common
135%config(noreplace) %{_sysconfdir}/X11/Xmodmap
136%config(noreplace) %{_sysconfdir}/X11/Xresources
137%dir %{_sysconfdir}/X11/xinit/Xclients.d
138%{_sysconfdir}/X11/xinit/Xclients
139%{_sysconfdir}/X11/xinit/Xsession
140%dir %{_sysconfdir}/X11/xinit/xinitrc.d
141%{_sysconfdir}/X11/xinit/xinitrc.d/*
142#%dir %{_mandir}/man1
143%{_mandir}/man1/startx.1*
144%{_mandir}/man1/xinit.1*
145
146%files session
147%defattr(-, root, root)
148%{_datadir}/xsessions/xinit-compat.desktop
149
150%changelog
151* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
152- new upstream release
153
154* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
155- new upstream release
156- update Patch1, Patch10
157
158* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
159- new upstream release
160- updated SOURCE12, SOURCE100
161- Install xinitrc-common non-executable.
162- added a new subpackage to add ~/.xsessions and ~/.Xclients
163  to session list
164
165* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
166- new upstream release
167
168* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
169- add Requires: dbus-x11
170
171* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
172- add LXDE to Xclients
173
174* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
175- new upstream release
176
177* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
178- fix typo in Xsession (<BTS:644>)
179
180* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
181- new upstream release
182
183* Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
184- spec in UTF-8
185- modify Source16: add CK_XINIT_SESSION calls
186
187* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
188- add Patch10 to set display resolution.
189
190* Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
191- initial build for Vine Linux
192
193* Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
194- Try opening the console-kit session after the user's UID has already
195  been granted access to the server by localuser.sh, so that console-kit-daemon
196  can connect and ask the server for information just by having switch to the
197  user's UID (#287941).
198
199* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
200- xinit 1.0.7
201
202* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
203- Rebuild for build id
204
205* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
206- Bump release
207
208* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
209- Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
210
211* Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
212- Fix bug 212167, CVE-2006-5214
213
214* Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
215- Fix Xsession to run the login shell inside the setgid ssh-agent, rather
216  than the other way around. This preserves LD_LIBRARY_PRELOAD.
217        Patch from Stefan Becker, bug 164869.
218
219* Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
220- Remove xinput.sh. Bug 244963.
221
222* Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
223- localuser.sh: Run silently.
224
225* Sat Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
226- Don't install INSTALL
227
228* Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
229- disable SCIM by default in non-Asian languages #237054
230  If you want to use SCIM, use im-chooser to enable it.
231
232* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
233- Man pages are now in section 1, not in section 1x
234
235* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
236- Also BR xorg-x11-util-macros since we autoreconf
237
238* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
239- Add ConsoleKit support (#233183)
240
241* Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
242- Bump EVR to fix 6 to 7 updates.
243
244* Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
245- start client in its own session with no controlling tty
246  (bug 214649)
247
248* Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
249- Update Xsession to not use switchdesk for the hard coded kde and twm
250  cases.
251
252* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
253- rebuilt for unwind info generation, broken in gcc-4.1.1-21
254
255* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
256- Bump and rebuild.
257
258* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
259- Move hardcoded xsetroot background color to fallback cases (#205901).
260
261* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
262- Start ssh-agent for startx also (#169259).
263
264* Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
265- Fix SourceN line for localuser.sh to not collide.
266
267* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
268- Added localuser.sh.
269
270* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
271- Added fix to Xclients script, based on patch from bug (#190799)
272
273* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
274- rebuild
275
276* Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
277- Implemented changes to xinput.sh based on suggestions from (#194458)
278
279* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
280- Added documentation to doc macro.
281
282* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
283- Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
284
285* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
286- Added "BuildRequires: pkgconfig" for bug (#194187)
287
288* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
289- Update xinit to 1.0.2
290
291* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
292- Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
293
294* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
295- bump again for double-long bug on ppc(64)
296
297* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
298- rebuilt for new gcc4.1 snapshot and glibc changes
299
300* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
301- Updated to xinit 1.0.1 from X11R7.0
302
303* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
304- Updated to xinit 1.0.0 from X11R7 RC4.
305- Changed manpage dir from man1x to man1 to match upstream default.
306
307* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
308- Add "Requires: xauth" for startx, to fix bug (#173684)
309
310* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
311- Do not provide xinit anymore, gdm has been fixed and that breaks things
312  with the obsoletes
313
314* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
315- Added Xsession script from xinitrc, as it is very similar codebase, which
316  shares "xinitrc-common" anyway, and all of the display managers use it.
317
318* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
319- Updated to xinit 0.99.3 from X11R7 RC2.
320
321* Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
322- Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
323  monolithic and modular X.  This will be removed however for FC5.
324
325* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
326- Import custom Red Hat xinit scripts from xinitrc package.
327- Obsolete xinitrc package, as we include the scripts/configs here now.
328- Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
329
330* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
331- Updated to xinit 0.99.2 from X11R7 RC1.
332- Change manpage location to 'man1x' in file manifest.
333
334* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
335- Use Fedora-Extras style BuildRoot tag.
336- Update BuildRequires to use new library package names.
337- Tidy up spec file a bit.
338
339* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
340- Initial build.
Note: See TracBrowser for help on using the repository browser.