source: projects/specs/trunk/x/xorg-x11-xinit/xorg-x11-xinit-vl.spec @ 10990

Revision 10990, 11.9 KB checked in by iwaim, 7 years ago (diff)

xorg-x11-xinit 1.3.4-2

Line 
1%define pkgname xinit
2
3Summary:     X.Org X11 X Window System xinit startup scripts
4Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
5Name:      xorg-x11-%{pkgname}
6Version:   1.3.4
7Release:   2%{?_dist_release}
8License:   MIT/X11
9Group:     User Interface/X
10URL:       http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
13Source10: xinitrc-common
14Source11: xinitrc
15Source12: Xclients
16Source13: Xmodmap
17Source14: Xresources
18# NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
19#       here instead of the xdm package.
20Source16: Xsession
21Source17: localuser.sh
22Source18: xinit-compat.desktop
23Source100: ck-xinit-session.c
24
25Patch1: xinit-1.3.4-client-session.patch
26Patch2: xinit-1.0.7-poke-ck.patch
27Patch3: xinit-1.0.9-unset.patch
28
29Patch10: xinit-1.3.4-vine.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32BuildRequires: pkgconfig
33BuildRequires: libX11-devel
34BuildRequires: ConsoleKit-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: libtool
38BuildRequires: dbus-devel
39BuildRequires: xorg-x11-util-macros
40# NOTE: startx needs xauth in order to run, but that is not picked up
41#       automatically by rpm.  (Bug #173684)
42Requires: xauth
43# next two are for localuser.sh
44Requires: coreutils
45Requires: xorg-x11-server-utils
46Requires: ConsoleKit-x11
47Requires: ConsoleKit-libs
48Requires: dbus-x11
49
50# NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
51# modularization.  These Obsoletes lines ensure upgrades work smoothly.
52Obsoletes: XFree86, XOrg
53
54# NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
55# so the xinitrc package became unnecessary.  The xdm configs/scripts move
56# to the xdm package.
57Obsoletes: xinitrc
58Provides: xinitrc
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: Takemikaduchi
63
64%description
65X.Org X11 X Window System xinit startup scripts
66
67%description -l ja
68X.Org X11 X Window System の xinit スタートアップ・スクリプト
69
70%package session
71Summary: Display manager support for ~/.xsession and ~/.Xclients
72Group: User Interface/X
73
74%description session
75Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
76
77%prep
78%setup -q -n %{pkgname}-%{version}
79%patch1 -p1 -b .client-session
80#%patch2 -p1 -b .poke-ck
81%patch3 -p1 -b .unset
82%patch10 -p1 -b .vine
83
84%build
85autoreconf -i
86%configure
87# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
88# Makefile.am and submit it in a bug report or check into CVS.
89make XINITDIR=/etc/X11/xinit
90%{__cc} -o ck-xinit-session \
91        `pkg-config --cflags ck-connector dbus-1` $RPM_OPT_FLAGS \
92        $RPM_SOURCE_DIR/ck-xinit-session.c \
93        `pkg-config --libs ck-connector dbus-1`
94
95%install
96rm -rf $RPM_BUILD_ROOT
97# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
98# Makefile.am and submit it in a bug report or check into CVS.
99%makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
100install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
101install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
102
103# Install custom xinitrc, etc.
104{
105    install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
106
107    for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
108        install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
109    done
110
111    install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
112    install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
113
114    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
115    install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
116
117    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
118}
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%files
124%defattr(-,root,root,-)
125%doc COPYING README ChangeLog
126%{_bindir}/startx
127%{_bindir}/xinit
128%{_bindir}/ck-xinit-session
129%dir %{_sysconfdir}/X11
130%dir %{_sysconfdir}/X11/xinit
131%{_sysconfdir}/X11/xinit/xinitrc
132%{_sysconfdir}/X11/xinit/xinitrc-common
133%config(noreplace) %{_sysconfdir}/X11/Xmodmap
134%config(noreplace) %{_sysconfdir}/X11/Xresources
135%dir %{_sysconfdir}/X11/xinit/Xclients.d
136%{_sysconfdir}/X11/xinit/Xclients
137%{_sysconfdir}/X11/xinit/Xsession
138%dir %{_sysconfdir}/X11/xinit/xinitrc.d
139%{_sysconfdir}/X11/xinit/xinitrc.d/*
140#%dir %{_mandir}/man1
141%{_mandir}/man1/startx.1*
142%{_mandir}/man1/xinit.1*
143
144%files session
145%defattr(-, root, root)
146%{_datadir}/xsessions/xinit-compat.desktop
147
148%changelog
149* Sat Apr  8 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.3.4-2
150- update Source12: [BTS:0003071]
151 - add MATE
152
153* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.4-1
154- new upstream release
155- update Patch1 (xinit-1.3.4-client-session.patch)
156- update Patch10 (xinit-1.3.4-vine.patch)
157
158* Wed Jun 04 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.3-2
159- exec startfluxbox instead of fluxbox
160
161* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-1
162- new upstream release
163
164* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
165- new upstream release
166
167* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
168- new upstream release
169
170* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
171- new upstream release
172- update Patch1, Patch10
173
174* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
175- new upstream release
176- updated SOURCE12, SOURCE100
177- Install xinitrc-common non-executable.
178- added a new subpackage to add ~/.xsessions and ~/.Xclients
179  to session list
180
181* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
182- new upstream release
183
184* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
185- add Requires: dbus-x11
186
187* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
188- add LXDE to Xclients
189
190* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
191- new upstream release
192
193* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
194- fix typo in Xsession (<BTS:644>)
195
196* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
197- new upstream release
198
199* Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
200- spec in UTF-8
201- modify Source16: add CK_XINIT_SESSION calls
202
203* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
204- add Patch10 to set display resolution.
205
206* Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
207- initial build for Vine Linux
208
209* Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
210- Try opening the console-kit session after the user's UID has already
211  been granted access to the server by localuser.sh, so that console-kit-daemon
212  can connect and ask the server for information just by having switch to the
213  user's UID (#287941).
214
215* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
216- xinit 1.0.7
217
218* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
219- Rebuild for build id
220
221* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
222- Bump release
223
224* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
225- Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
226
227* Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
228- Fix bug 212167, CVE-2006-5214
229
230* Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
231- Fix Xsession to run the login shell inside the setgid ssh-agent, rather
232  than the other way around. This preserves LD_LIBRARY_PRELOAD.
233        Patch from Stefan Becker, bug 164869.
234
235* Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
236- Remove xinput.sh. Bug 244963.
237
238* Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
239- localuser.sh: Run silently.
240
241* Sun Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
242- Don't install INSTALL
243
244* Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
245- disable SCIM by default in non-Asian languages #237054
246  If you want to use SCIM, use im-chooser to enable it.
247
248* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
249- Man pages are now in section 1, not in section 1x
250
251* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
252- Also BR xorg-x11-util-macros since we autoreconf
253
254* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
255- Add ConsoleKit support (#233183)
256
257* Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
258- Bump EVR to fix 6 to 7 updates.
259
260* Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
261- start client in its own session with no controlling tty
262  (bug 214649)
263
264* Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
265- Update Xsession to not use switchdesk for the hard coded kde and twm
266  cases.
267
268* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
269- rebuilt for unwind info generation, broken in gcc-4.1.1-21
270
271* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
272- Bump and rebuild.
273
274* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
275- Move hardcoded xsetroot background color to fallback cases (#205901).
276
277* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
278- Start ssh-agent for startx also (#169259).
279
280* Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
281- Fix SourceN line for localuser.sh to not collide.
282
283* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
284- Added localuser.sh.
285
286* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
287- Added fix to Xclients script, based on patch from bug (#190799)
288
289* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
290- rebuild
291
292* Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
293- Implemented changes to xinput.sh based on suggestions from (#194458)
294
295* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
296- Added documentation to doc macro.
297
298* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
299- Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
300
301* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
302- Added "BuildRequires: pkgconfig" for bug (#194187)
303
304* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
305- Update xinit to 1.0.2
306
307* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
308- Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
309
310* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
311- bump again for double-long bug on ppc(64)
312
313* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
314- rebuilt for new gcc4.1 snapshot and glibc changes
315
316* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
317- Updated to xinit 1.0.1 from X11R7.0
318
319* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
320- Updated to xinit 1.0.0 from X11R7 RC4.
321- Changed manpage dir from man1x to man1 to match upstream default.
322
323* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
324- Add "Requires: xauth" for startx, to fix bug (#173684)
325
326* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
327- Do not provide xinit anymore, gdm has been fixed and that breaks things
328  with the obsoletes
329
330* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
331- Added Xsession script from xinitrc, as it is very similar codebase, which
332  shares "xinitrc-common" anyway, and all of the display managers use it.
333
334* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
335- Updated to xinit 0.99.3 from X11R7 RC2.
336
337* Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
338- Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
339  monolithic and modular X.  This will be removed however for FC5.
340
341* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
342- Import custom Red Hat xinit scripts from xinitrc package.
343- Obsolete xinitrc package, as we include the scripts/configs here now.
344- Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
345
346* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
347- Updated to xinit 0.99.2 from X11R7 RC1.
348- Change manpage location to 'man1x' in file manifest.
349
350* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
351- Use Fedora-Extras style BuildRoot tag.
352- Update BuildRequires to use new library package names.
353- Tidy up spec file a bit.
354
355* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
356- Initial build.
Note: See TracBrowser for help on using the repository browser.