source: projects/specs/trunk/x/xorg-x11-xinit/xorg-x11-xinit-vl.spec @ 9108

Revision 9108, 11.9 KB checked in by Takemikaduchi, 9 years ago (diff)

xserver-1.16.2

Line 
1%define pkgname xinit
2
3Summary:     X.Org X11 X Window System xinit startup scripts
4Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
5Name:      xorg-x11-%{pkgname}
6Version:   1.3.4
7Release:   1%{?_dist_release}
8License:   MIT/X11
9Group:     User Interface/X
10URL:       http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
13Source10: xinitrc-common
14Source11: xinitrc
15Source12: Xclients
16Source13: Xmodmap
17Source14: Xresources
18# NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
19#       here instead of the xdm package.
20Source16: Xsession
21Source17: localuser.sh
22Source18: xinit-compat.desktop
23Source100: ck-xinit-session.c
24
25Patch1: xinit-1.3.4-client-session.patch
26Patch2: xinit-1.0.7-poke-ck.patch
27Patch3: xinit-1.0.9-unset.patch
28
29Patch10: xinit-1.3.4-vine.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32BuildRequires: pkgconfig
33BuildRequires: libX11-devel
34BuildRequires: ConsoleKit-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: libtool
38BuildRequires: dbus-devel
39BuildRequires: xorg-x11-util-macros
40# NOTE: startx needs xauth in order to run, but that is not picked up
41#       automatically by rpm.  (Bug #173684)
42Requires: xauth
43# next two are for localuser.sh
44Requires: coreutils
45Requires: xorg-x11-server-utils
46Requires: ConsoleKit-x11
47Requires: ConsoleKit-libs
48Requires: dbus-x11
49
50# NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
51# modularization.  These Obsoletes lines ensure upgrades work smoothly.
52Obsoletes: XFree86, XOrg
53
54# NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
55# so the xinitrc package became unnecessary.  The xdm configs/scripts move
56# to the xdm package.
57Obsoletes: xinitrc
58Provides: xinitrc
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: Takemikaduchi
63
64%description
65X.Org X11 X Window System xinit startup scripts
66
67%description -l ja
68X.Org X11 X Window System の xinit スタートアップ・スクリプト
69
70%package session
71Summary: Display manager support for ~/.xsession and ~/.Xclients
72Group: User Interface/X
73
74%description
75X.Org X11 X Window System xinit startup scripts
76
77%description session
78Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
79
80%prep
81%setup -q -n %{pkgname}-%{version}
82%patch1 -p1 -b .client-session
83#%patch2 -p1 -b .poke-ck
84%patch3 -p1 -b .unset
85%patch10 -p1 -b .vine
86
87%build
88autoreconf -i
89%configure
90# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
91# Makefile.am and submit it in a bug report or check into CVS.
92make XINITDIR=/etc/X11/xinit
93%{__cc} -o ck-xinit-session \
94        `pkg-config --cflags ck-connector dbus-1` $RPM_OPT_FLAGS \
95        $RPM_SOURCE_DIR/ck-xinit-session.c \
96        `pkg-config --libs ck-connector dbus-1`
97
98%install
99rm -rf $RPM_BUILD_ROOT
100# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
101# Makefile.am and submit it in a bug report or check into CVS.
102%makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
103install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
104install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
105
106# Install custom xinitrc, etc.
107{
108    install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
109
110    for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
111        install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
112    done
113
114    install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
115    install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
116
117    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
118    install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
119
120    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
121}
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%files
127%defattr(-,root,root,-)
128%doc COPYING README ChangeLog
129%{_bindir}/startx
130%{_bindir}/xinit
131%{_bindir}/ck-xinit-session
132%dir %{_sysconfdir}/X11
133%dir %{_sysconfdir}/X11/xinit
134%{_sysconfdir}/X11/xinit/xinitrc
135%{_sysconfdir}/X11/xinit/xinitrc-common
136%config(noreplace) %{_sysconfdir}/X11/Xmodmap
137%config(noreplace) %{_sysconfdir}/X11/Xresources
138%dir %{_sysconfdir}/X11/xinit/Xclients.d
139%{_sysconfdir}/X11/xinit/Xclients
140%{_sysconfdir}/X11/xinit/Xsession
141%dir %{_sysconfdir}/X11/xinit/xinitrc.d
142%{_sysconfdir}/X11/xinit/xinitrc.d/*
143#%dir %{_mandir}/man1
144%{_mandir}/man1/startx.1*
145%{_mandir}/man1/xinit.1*
146
147%files session
148%defattr(-, root, root)
149%{_datadir}/xsessions/xinit-compat.desktop
150
151%changelog
152* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.4-1
153- new upstream release
154- update Patch1 (xinit-1.3.4-client-session.patch)
155- update Patch10 (xinit-1.3.4-vine.patch)
156
157* Wed Jun 04 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.3-2
158- exec startfluxbox instead of fluxbox
159
160* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-1
161- new upstream release
162
163* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
164- new upstream release
165
166* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
167- new upstream release
168
169* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
170- new upstream release
171- update Patch1, Patch10
172
173* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
174- new upstream release
175- updated SOURCE12, SOURCE100
176- Install xinitrc-common non-executable.
177- added a new subpackage to add ~/.xsessions and ~/.Xclients
178  to session list
179
180* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
181- new upstream release
182
183* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
184- add Requires: dbus-x11
185
186* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
187- add LXDE to Xclients
188
189* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
190- new upstream release
191
192* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
193- fix typo in Xsession (<BTS:644>)
194
195* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
196- new upstream release
197
198* Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
199- spec in UTF-8
200- modify Source16: add CK_XINIT_SESSION calls
201
202* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
203- add Patch10 to set display resolution.
204
205* Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
206- initial build for Vine Linux
207
208* Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
209- Try opening the console-kit session after the user's UID has already
210  been granted access to the server by localuser.sh, so that console-kit-daemon
211  can connect and ask the server for information just by having switch to the
212  user's UID (#287941).
213
214* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
215- xinit 1.0.7
216
217* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
218- Rebuild for build id
219
220* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
221- Bump release
222
223* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
224- Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
225
226* Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
227- Fix bug 212167, CVE-2006-5214
228
229* Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
230- Fix Xsession to run the login shell inside the setgid ssh-agent, rather
231  than the other way around. This preserves LD_LIBRARY_PRELOAD.
232        Patch from Stefan Becker, bug 164869.
233
234* Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
235- Remove xinput.sh. Bug 244963.
236
237* Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
238- localuser.sh: Run silently.
239
240* Sun Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
241- Don't install INSTALL
242
243* Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
244- disable SCIM by default in non-Asian languages #237054
245  If you want to use SCIM, use im-chooser to enable it.
246
247* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
248- Man pages are now in section 1, not in section 1x
249
250* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
251- Also BR xorg-x11-util-macros since we autoreconf
252
253* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
254- Add ConsoleKit support (#233183)
255
256* Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
257- Bump EVR to fix 6 to 7 updates.
258
259* Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
260- start client in its own session with no controlling tty
261  (bug 214649)
262
263* Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
264- Update Xsession to not use switchdesk for the hard coded kde and twm
265  cases.
266
267* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
268- rebuilt for unwind info generation, broken in gcc-4.1.1-21
269
270* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
271- Bump and rebuild.
272
273* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
274- Move hardcoded xsetroot background color to fallback cases (#205901).
275
276* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
277- Start ssh-agent for startx also (#169259).
278
279* Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
280- Fix SourceN line for localuser.sh to not collide.
281
282* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
283- Added localuser.sh.
284
285* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
286- Added fix to Xclients script, based on patch from bug (#190799)
287
288* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
289- rebuild
290
291* Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
292- Implemented changes to xinput.sh based on suggestions from (#194458)
293
294* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
295- Added documentation to doc macro.
296
297* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
298- Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
299
300* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
301- Added "BuildRequires: pkgconfig" for bug (#194187)
302
303* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
304- Update xinit to 1.0.2
305
306* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
307- Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
308
309* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
310- bump again for double-long bug on ppc(64)
311
312* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
313- rebuilt for new gcc4.1 snapshot and glibc changes
314
315* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
316- Updated to xinit 1.0.1 from X11R7.0
317
318* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
319- Updated to xinit 1.0.0 from X11R7 RC4.
320- Changed manpage dir from man1x to man1 to match upstream default.
321
322* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
323- Add "Requires: xauth" for startx, to fix bug (#173684)
324
325* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
326- Do not provide xinit anymore, gdm has been fixed and that breaks things
327  with the obsoletes
328
329* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
330- Added Xsession script from xinitrc, as it is very similar codebase, which
331  shares "xinitrc-common" anyway, and all of the display managers use it.
332
333* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
334- Updated to xinit 0.99.3 from X11R7 RC2.
335
336* Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
337- Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
338  monolithic and modular X.  This will be removed however for FC5.
339
340* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
341- Import custom Red Hat xinit scripts from xinitrc package.
342- Obsolete xinitrc package, as we include the scripts/configs here now.
343- Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
344
345* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
346- Updated to xinit 0.99.2 from X11R7 RC1.
347- Change manpage location to 'man1x' in file manifest.
348
349* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
350- Use Fedora-Extras style BuildRoot tag.
351- Update BuildRequires to use new library package names.
352- Tidy up spec file a bit.
353
354* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
355- Initial build.
Note: See TracBrowser for help on using the repository browser.