source: projects/specs/trunk/x/xorg-x11-xfs/xorg-x11-xfs-vl.spec @ 2203

Revision 2203, 11.4 KB checked in by Takemikaduchi, 13 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1Summary: X.Org X11 xfs font server
2Summary(ja): X.Org X11 xfs フォントサーバ
3Name: xorg-x11-xfs
4Version: 1.1.1
5Release: 1%{?_dist_release}
6License: MIT/X11
7Group: System Environment/Daemons
8URL: http://www.x.org
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11Source0: ftp://ftp.x.org/pub/individual/app/xfs-%{version}.tar.bz2
12Source1: ftp://ftp.x.org/pub/individual/app/xfsinfo-1.0.3.tar.bz2
13Source2: ftp://ftp.x.org/pub/individual/app/fslsfonts-1.0.3.tar.bz2
14Source3: ftp://ftp.x.org/pub/individual/app/fstobdf-1.0.4.tar.bz2
15Source4: ftp://ftp.x.org/pub/individual/app/showfont-1.0.3.tar.bz2
16Source10:  xfs.init
17Source11:  xfs.config
18
19BuildRequires: pkgconfig
20# xfs needs 'fontsproto' to build, as indicated by ./configure
21BuildRequires: xorg-x11-proto-devel
22# FIXME: xfs needs xtrans to build, but autotools doesn't detect it missing
23BuildRequires: xorg-x11-xtrans-devel
24BuildRequires: libFS-devel
25BuildRequires: libXfont-devel
26BuildRequires: libX11-devel
27# FIXME: xfs needs freetype-devel to build, but autotools doesn't detect it missing
28BuildRequires: freetype2-devel
29BuildRequires: libfontenc-devel
30
31# Make sure libXfont provides the catalogue FPE.
32Requires: libXfont
33
34Obsoletes: XFree86-xfs, XOrg-xfs
35Provides: xfs
36Provides: XOrg-xfs = 7.0
37
38Requires(pre): util-linux, shadow-utils
39Requires(post): initscripts, grep, sed, coreutils
40Requires(preun): initscripts, chkconfig
41Requires(postun): initscripts
42
43# xfs initscript runtime dependencies
44Requires: initscripts, fontconfig, sed, findutils
45Requires: coreutils
46Requires: mkfontdir, mkfontscale, ttmkfdir
47# end of xfs initscript runtime dependencies
48
49%description
50X.Org X11 xfs font server
51
52%package utils
53Summary: X.Org X11 font server utilities
54Summary(ja): X.Org X11 フォントサーバユーティリティ
55Group: User Interface/X
56
57Conflicts: XOrg-xfs < 7.0
58
59%description utils
60X.Org X11 font server utilities
61
62%prep
63%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
64
65%build
66
67# Build xfs
68{
69   pushd xfs-*
70   %configure --disable-devel-docs
71   make configdir=%{_sysconfdir}/X11/fs
72   popd
73}
74
75for pkg in xfsinfo fslsfonts fstobdf showfont ; do
76   pushd ${pkg}-*
77   %configure
78   make
79   popd
80done
81
82%install
83rm -rf $RPM_BUILD_ROOT
84# Install xfs
85{
86   pushd xfs-*
87   %makeinstall configdir=$RPM_BUILD_ROOT%{_sysconfdir}/X11/fs
88   popd
89}
90
91for pkg in xfsinfo fslsfonts fstobdf showfont ; do
92   pushd ${pkg}-*
93   make install DESTDIR=$RPM_BUILD_ROOT
94   popd
95done
96
97# Install the modified xfs config file and initscript
98{
99   mkdir -p $RPM_BUILD_ROOT/etc/{X11/fs,rc.d/init.d}
100   install -c -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/xfs
101   install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/X11/fs/config
102}
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%triggerpostun -- XFree86-xfs
108{
109  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
110  /sbin/chkconfig --add xfs
111  /sbin/service xfs condrestart || :
112} &> /dev/null || :
113
114%triggerpostun -- XOrg-xfs
115{
116  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
117  /sbin/chkconfig --add xfs
118  /sbin/service xfs condrestart || :
119} &> /dev/null || :
120
121%pre
122{
123  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
124  # Upgrade path:
125  if [ "$1" -gt "1" ] ; then
126    if [ -e "/usr/X11R6/lib/X11/fs/config" ] ; then
127      cat <<-EOF > "/etc/X11/fs/xfs-migrate"
128        On upgrades, we now must determine if we are upgrading from monolithic
129        xfs or modular xfs by checking for the existance of the old monolithic
130        xfs config file.  If found, we know it is a monolith->modular upgrade,
131        so we set this flag file in order for xfs.init to perform a "restart"
132        instead of a "reload" in the 'condrestart'.  See bug #173271 for
133        details.
134EOF
135    fi
136  fi
137} &> /dev/null || : # Silence output, and ignore errors (Bug #91822)
138
139%post
140{
141  # Install section
142  /sbin/chkconfig --add xfs
143  #------------------------------------------------------------------------
144  # Upgrade section
145  if [ "$1" -gt "1" ] ; then
146    XORG_CONFIG=/etc/X11/xorg.conf
147    XFSCONFIG=/etc/X11/fs/config
148
149    # XFS config file upgrade munging
150    if [ -f $XFSCONFIG ] ; then
151      # Remove Speedo font directories from xfs config if present to avoid
152      # bug reports about xfs complaining about empty directories in syslog.
153      perl -p -i -e 's#^.*/.*/Speedo.*\n##' $XFSCONFIG
154
155      # On upgrades, remove /usr/X11R6 font path elements from the XFS config file
156      if grep -q "/usr/X11R6/lib/X11/fonts" $XFSCONFIG &> /dev/null ; then
157        for fpe in misc:unscaled 75dpi:unscaled 100dpi:unscaled Type1 ; do
158          perl -p -i -e "s#/usr/X11R6/lib/X11/fonts/${fpe}#%{_x11fontdir}/${fpe}#g" $XFSCONFIG
159        done
160      fi
161    fi
162  fi ; # End Upgrade section
163}
164
165%preun
166{
167  if [ "$1" = "0" ]; then
168    /sbin/service xfs stop &> /dev/null || :
169    /sbin/chkconfig --del xfs || :
170  fi
171}
172
173%postun
174{
175  if [ "$1" -gt "1" ]; then
176    /sbin/service xfs condrestart &> /dev/null || :
177  fi
178}
179
180%files
181%defattr(-,root,root,-)
182%doc xfs-%{version}/AUTHORS xfs-%{version}/COPYING
183%doc xfs-%{version}/NEWS xfs-%{version}/README xfs-%{version}/ChangeLog
184%{_bindir}/xfs
185%dir %{_sysconfdir}/X11
186%dir %{_sysconfdir}/X11/fs
187%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/X11/fs/config
188%{_mandir}/man1/xfs.1*
189%{_sysconfdir}/rc.d/init.d/xfs
190
191%files utils
192%{_bindir}/fslsfonts
193%{_bindir}/fstobdf
194%{_bindir}/showfont
195%{_bindir}/xfsinfo
196%{_mandir}/man1/fslsfonts.1*
197%{_mandir}/man1/fstobdf.1*
198%{_mandir}/man1/showfont.1*
199%{_mandir}/man1/xfsinfo.1*
200
201%changelog
202* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
203- xfs-1.1.1
204- xfsinfo-1.0.3
205- fslsfonts-1.0.3
206- fstobdf-1.0.4
207- showfont-1.0.3
208
209* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
210- xfs-1.1.0
211
212* Sun May 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.8-1
213- new upstream release
214  - xfs-1.0.8, xfsinfo-1.0.2, fslsfont-1.0.2,
215    fstobdf-1.0.3, showfont-1.0.2
216
217* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
218- add version-release to Obsoletes: XOrg-xfs
219
220* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-3
221- add version-release to Provides: XOrg-xfs
222
223* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
224- add Provides: XOrg-xfs for compatibility
225
226* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
227- initial build for Vine Linux
228
229* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.0.5-2
230- Autorebuild for GCC 4.3
231
232* Tue Oct 02 2007 Adam Jackson <ajax@redhat.com> 1:1.0.5-1
233- xfs 1.0.5
234
235* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 1:1.0.4-2
236- Rebuild for ppc toolchain bug
237
238* Fri Jul 27 2007 Bill Nottingham <notting@redhat.com> - 1:1.0.4-2
239- don't run by default any more, as it's not used by default
240- remove explicit restorecon dependency (#215142)
241
242* Fri Jun 22 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 1:1.0.4-1
243- Require catalogue capable libXfont.
244- Drop xfs.config.in, just use catalogue font path.
245- Stop xorg.conf munging madness.
246
247* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1:1.0.2-4
248- Don't install INSTALL
249
250* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.0.2-3.1
251- rebuild
252
253* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.2-3
254- Added xfs documentation to doc macro.
255- Use "make install" instead of makeinstall macro.
256- Clean up source file URLs.
257
258* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
259- Fix BuildRequires (#191856).
260
261* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-1
262- Update xfs and fstobdf
263
264* Wed Mar 01 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-4
265- Fix all rpm scriptlets "upgrade" tests to only execute on upgrades.
266
267* Sat Feb 25 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
268- Redirect output of "rm -rf fonts.dir" to /dev/null in xfs.init
269
270* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-2.1
271- bump again for double-long bug on ppc(64)
272
273* Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
274- Removed invocation of fc-cache from xfs initscript for bug (#179362)
275- Redirect stderr to /dev/null to squelch an unwanted error xfs.init (#155349)
276- Replace "s#^/.*:[a-z]*$##g" with "s#:unscaled$##g" in xfs.init for (#179491)
277- Cosmetic cleanups to spec file to satiate the banshees.
278
279* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
280- rebuilt for new gcc4.1 snapshot and glibc changes
281
282* Wed Jan 16 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
283- Updated all tarballs to version 1.0.1 from X11R7.0
284
285* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> 1:1.0.0-2
286- fix rpm post script (#176009, <ville.skytta@iki.fi>)
287
288* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
289- Updated all tarballs to version 1.0.0 from X11R7 RC4.
290- Get default X font directory with font-utils package 'fontdir' pkgconfig
291  variable.
292- Change manpage dir from man1x back to man1 to match upstream.
293
294* Tue Nov 15 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.2-4
295- require initscripts instead of /etc/init.d/functions
296
297* Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
298- Updated xfs pre script to check for the existance of the old monolithic
299  /usr/X11R6/lib/X11/fs/config xfs config file, and set a migration flag
300  file.
301- Updated xfs.init to check for the existance of the migration flag file,
302  and perform an xfs 'restart' instead of a 'reload' if migrating.  Users
303  will now have to restart their X server, or reconnect the xfs server to
304  the X server after a migration to modular X.
305- Changed upgrade comparison typo from 2 to 1 in xfs post script.
306
307* Mon Nov 14 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
308- Added temporary "BuildRequires: libXfont-devel >= 0.99.2-3" and
309  "Requires: libXfont-devel >= 0.99.2-3" to ensure early-testers of
310  pre-rawhide modular X have installed the work around for (#172997).
311
312* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
313- Updated to xfs-0.99.2 and fstobdf-0.99.2 from X11R7 RC2
314- Added Epoch 1 to package, and set the version number to the xfs 0.99.2
315  version.
316
317* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
318- Added showfont-0.99.1 from X11R7 RC1 release.
319
320* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
321- Updated all packages to version 0.99.1 from X11R7 RC1.
322- Bump package version to 6.99.99.901 (the RC1 CVS tag).
323- Change manpage location to 'man1x' in file manifest.
324- Converted xfs.config to xfs.config.in, and added code to spec file to
325  generate xfs.config depending on what the system _x11fontdir is.
326- Complete and total rewrite of xfs postinstall script to use "sed -i"
327  and complete restructuring, which removed a lot of the super craptasticness
328  that had been sitting there for years.
329
330* Wed Oct 03 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-4
331- Use Fedora-Extras style BuildRoot tag
332- Update BuildRequires to use new library package names
333- Remove unnecessary BuildRequires on 'install', and fix pkgconfig dep
334
335* Thu Aug 25 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-3
336- Install the initscript and xfs config file in the correct location as they
337  were inadvertently interchanged in previous builds.
338
339* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
340- Ported the xfs related rpm scripts over from monolithic packaging, and
341  added up to date Requires(*) dependencies for all of them.
342- Flagged xfs config file as config(noreplace)
343- Added build and runtime dependencies to xfs subpackage as best as could be
344  determined by analyzing ./configure output, and building in minimalized
345  build root environment.
346
347* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
348- Initial build.
Note: See TracBrowser for help on using the repository browser.