source: projects/specs/trunk/x/xorg-x11-xdm/xorg-x11-xdm-vl.spec @ 5538

Revision 5538, 10.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname xdm
2
3Summary: X.Org X11 xdm - X Display Manager
4Summary(ja): X.Org X11 xdm - X ディスプレイマネージャ
5Name: xorg-x11-%{pkgname}
6Version: 1.1.11
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0: ftp://ftp.x.org/pub/individual/app/xdm-%{version}.tar.bz2
14Source1: Xsetup_0
15Source11: xdm.pamd
16Source13: xserver.pamd
17
18Patch11: xdm-1.0.5-sessreg-utmp-fix-bug177890.patch
19
20# FIXME: Temporary build dependencies for autotool dependence.
21BuildRequires: autoconf, automake, libtool
22
23BuildRequires: pkgconfig
24BuildRequires: xorg-x11-util-macros
25BuildRequires: xorg-x11-xtrans-devel
26BuildRequires: libXaw-devel
27BuildRequires: libXmu-devel
28BuildRequires: libXt-devel
29BuildRequires: libSM-devel
30BuildRequires: libICE-devel
31BuildRequires: libXext-devel
32BuildRequires: libXpm-devel
33BuildRequires: libX11-devel
34BuildRequires: libXdmcp-devel
35BuildRequires: libXau-devel
36BuildRequires: libXinerama-devel
37BuildRequires: pam-devel
38
39Provides: xdm
40
41Obsoletes: XFree86-xdm, XOrg-xdm
42Obsoletes: xinitrc
43
44# NOTE: xorg-x11-filesystem is required by all packages that put files into
45# /usr/lib/X11 or /usr/include/X11 to ensure that on OS upgrades, they are
46# real directories, and not symbolic links.
47Requires(pre): xorg-x11-filesystem
48
49Requires: pam
50
51# We want to use the system Xsession script
52Requires: xorg-x11-xinit
53
54%description
55X.Org X11 xdm - X Display Manager
56
57%description -l ja
58X.Org X11 xdm - X ディスプレイマネージャ
59
60%prep
61%setup -q -n %{pkgname}-%{version}
62
63%patch11 -p0 -b .sessreg-utmp-fix-bug177890
64
65%build
66# FIXME: Work around pointer aliasing warnings from compiler for now
67export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
68# NOTE: We invoke aclocal/automake/autoconf to enable the changes present in
69# xdm-0.99.3-xdm-app-defaults-in-datadir.patch & xdm-0.99.3-xdm-configdir.patch
70#aclocal
71#libtoolize --force
72#automake
73#autoconf
74autoreconf -if
75%configure \
76        --disable-static \
77        --disable-xprint \
78        --with-xdmconfigdir=%{_sysconfdir}/X11/xdm \
79        --with-xdmscriptdir=%{_sysconfdir}/X11/xdm \
80        --with-pixmapdir=%{_datadir}/xdm/pixmaps
81
82make %{?_smp_mflags}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make install DESTDIR=$RPM_BUILD_ROOT
87
88# FIXME: Remove all libtool archives (*.la) from modules directory.  This
89# should be fixed in upstream Makefile.am or whatever.
90find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f --
91
92install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm/Xsetup_0
93
94# Install pam xdm config files
95{
96   mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
97   install -c -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/xserver
98   install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/xdm
99}
100
101rm -f $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm/Xsession
102(cd $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm; ln -sf ../xinit/Xsession .)
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%files
108%defattr(-,root,root,-)
109%doc AUTHORS COPYING INSTALL NEWS README ChangeLog
110%{_bindir}/xdm
111%dir %{_sysconfdir}/X11/xdm
112# NOTE: The Xaccess file from our "xinitrc" package had no customizations,
113# and was out of sync with upstream, so we ship the upstream one now.
114%{_sysconfdir}/X11/xdm/Xaccess
115%{_sysconfdir}/X11/xdm/Xresources
116%{_sysconfdir}/X11/xdm/Xservers
117%{_sysconfdir}/X11/xdm/xdm-config
118# NOTE: In Fedora Core 4 and earlier, most of these config files and scripts
119# were kept in the "xinitrc" package as forked copies, however they were
120# quite out of date, and did not contain anything useful, so we now ship the
121# upstream files and can patch them as needed to make changes.
122%{_sysconfdir}/X11/xdm/GiveConsole
123%{_sysconfdir}/X11/xdm/TakeConsole
124%{_sysconfdir}/X11/xdm/Xreset
125%{_sysconfdir}/X11/xdm/Xsession
126%{_sysconfdir}/X11/xdm/Xsetup_0
127%{_sysconfdir}/X11/xdm/Xstartup
128%{_sysconfdir}/X11/xdm/Xwilling
129# NOTE: For security, upgrades of this package will install the new pam.d
130# files and make backup copies by default.  'noreplace' is intentionally avoided
131# here.
132%config %attr(0644,root,root) %{_sysconfdir}/pam.d/xdm
133%config %attr(0644,root,root) %{_sysconfdir}/pam.d/xserver
134%dir %{_datadir}/X11
135# NOTE: We intentionally default to OS supplied file being favoured here on
136# OS upgrades.
137%config %{_datadir}/X11/app-defaults/Chooser
138%dir %{_datadir}/xdm
139%dir %{_datadir}/xdm/pixmaps
140%{_datadir}/xdm/pixmaps/xorg-bw.xpm
141%{_datadir}/xdm/pixmaps/xorg.xpm
142%dir %{_libdir}/X11/xdm
143%{_libdir}/X11/xdm/chooser
144%{_libdir}/X11/xdm/libXdmGreet.so
145%{_mandir}/man1/*.1*
146
147%changelog
148* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.11-1
149- new upstream release
150- remove Patch10
151
152* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.10-1
153- new upstream release
154
155* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-1
156- new upstream release
157
158* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.8-1
159- new upstream release
160
161* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
162- initial build for Vine Linux
163
164* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.1.6-3
165- Autorebuild for GCC 4.3
166
167* Fri Aug 24 2007 Ray Strode <rstrode@redhat.com> 1:1.1.6-2
168- Use system Xsession script (bug 244264)
169
170* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 1:1.1.6-1
171- Update to 1.1.6
172
173* Sat Aug 11 2007 Dave Airlie <airlied@redhat.com> 1:1.1.5-1
174- Update to 1.1.5
175
176* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:1.1.3-1
177- Update to 1.1.3
178
179* Mon Jul 24 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-5.fc6
180- Added xdm-1.0.5-sessreg-utmp-fix-bug177890.patch to restore GiveConsole to
181  what we shipped in 6.8.2, and also fix bug (#177890)
182
183* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-4.fc6
184- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
185
186* Mon Jul 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-3.fc6
187- Added pam_keyinit.so support to xdm.pamd and xserver.pamd (#198631)
188- Flag pam.d{xdm,xserver} as attr(0644,root,root) replaceable config files.
189- Flag app-defaults/Chooser as a replaceable config file.
190- Add conditional {dist} flag to Release field.
191
192* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.5-2
193- rebuild
194
195* Wed Jun 28 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-1
196- Updated xdm to version 1.0.5.
197- Remove xdm-1.0.4-setuid.diff as it is integrated in 1.0.5
198
199* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.4-4
200- Add missing documentation to doc macro.
201- Clean cruft out of specfile.
202
203* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.4-3
204- Added xdm-1.0.4-setuid.diff to fix potential security issue (#196094)
205- Added temporary "BuildRequires: autoconf, automake, libtool" dependencies
206  for mock builds, for as long as we need to run autotools at compile time.
207
208* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.4-2
209- Fix BuildRequires (#191858)
210
211* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.4-1
212- Updated to version 1.0.4
213
214* Fri Mar 31 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.3-1
215- Updated to version 1.0.3.  Forcibly relibtoolize to avoid present and future
216  bogons on libXdmGreet.so losing the .so extension.
217
218* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
219- bump again for double-long bug on ppc(64)
220
221* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
222- rebuilt for new gcc4.1 snapshot and glibc changes
223
224* Mon Jan 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
225- Updated xdm to version 1.0.1 from X11R7.
226- Added --with-xdmscriptdir option to ./configure to put scripts in /etc
227- Updated xdm-1.0.1-redhat-xdm-config-fix.patch to work with xdm 1.0.1
228
229* Thu Nov 24 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-6
230- Updated xdm.pamd to work with recent pam changes, and bumped the minimum
231  pam requirement up to 0.78-0 for FC5 builds. (#170661)
232- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", as the xdm package
233  puts files into /usr/lib/X11, so we have to make sure it is not a symlink.
234- Removed "filesystem" package dependency, as xorg-x11-filesystem carries
235  that dependency now, so it can be updated in one spot.
236- Added missing "BuildRequires: pkgconfig".
237- Added xdm-0.99.3-xdm-app-defaults-in-datadir.patch to force app-defaults
238  files to install into _datadir instead of _libdir.
239- Added xdm-0.99.3-xdm-scripts-in-configdir.patch to put the xdm scripts in
240  _sysconfdir, and removed older xdm-0.99.3-xdm-configdir.patch which hacked
241  up Makefile.in.  Fixes a typo that caused Xreset to not get installed
242  properly also.
243
244* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.3-5
245- require newer filesystem package (#172610)
246
247* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.3-4
248- install scripts into /etc/X11/xdm instead of %%{_libdir} (#173081)
249- use our Xsetup_0 instead of xorg one (#173083)
250
251* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-3
252- Added "Obsoletes: xinitrc", as xdm now provides files that were previously
253  part of that package.  xorg-x11-xinit now provides the xinitrc scripts.
254
255* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-2
256- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME.
257- Added xdm-0.99.3-redhat-xdm-config-fix.patch which merges in an
258  xdm-config fix present in the forked Red Hat xdm-config from the FC4
259  xinitrc package, which invokes Xwilling with "-s /bin/bash" instead
260  of "-c" to fix bug (#86505).
261- Removed ancient xdm rpm preinstall script, as it should be unnecessary now.
262
263* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-1
264- Update xdm to 0.99.3 from X11R7 RC2.
265
266* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.3
267- Build with -fno-strict-aliasing to work around possible pointer aliasing
268  issues
269
270* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.2
271- It is _sysconfdir not _sysconfigdir goofball!
272- Add {_sysconfdir}/pam.d/xdm and {_sysconfdir}/pam.d/xserver files that were
273  missing from file manifest.
274
275* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.1
276- Make sure all dirs are owned that xdm creates.
277- Misc spec file cleanups
278
279* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.0
280- Update xdm to 0.99.2 from X11R7 RC1.
281- Update to CVS snapshot from 20051031
282- Add Epoch 1, and change package to use the xdm version number.  Later, if
283  we decide to rename the package to "xdm", we can drop the Epoch tag.
284- Disable Xprint support
285- Use _smp_mflags
286- Add xdm-0.99.2-to-20051031.patch to pick up fixes from CVS head that allow
287  us to set the config dir and other dirs.
288
289* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
290- Use Fedora-Extras style BuildRoot tag
291- Update BuildRequires to use new library package names
292
293* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
294- Initial build.
Note: See TracBrowser for help on using the repository browser.