source: projects/specs/trunk/x/xorg-x11-xdm/xorg-x11-xdm-vl.spec @ 521

Revision 521, 10.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkgname xdm
2
3Summary: X.Org X11 xdm - X Display Manager
4Summary(ja): X.Org X11 xdm - X ディスプレイマネージャ
5Name: xorg-x11-%{pkgname}
6Version: 1.1.9
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0: ftp://ftp.x.org/pub/individual/app/xdm-%{version}.tar.bz2
14Source1: Xsetup_0
15Source10: xdm.init
16Source11: xdm.pamd
17Source13: xserver.pamd
18
19# NOTE: Change xdm-config to invoke Xwilling with "-s /bin/bash" instead
20# of "-c" to fix bug (#86505)
21Patch10: xdm-1.0.1-redhat-xdm-config-fix.patch
22Patch11: xdm-1.0.5-sessreg-utmp-fix-bug177890.patch
23
24# FIXME: Temporary build dependencies for autotool dependence.
25BuildRequires: autoconf, automake, libtool
26
27BuildRequires: pkgconfig
28BuildRequires: xorg-x11-util-macros
29BuildRequires: xorg-x11-xtrans-devel
30BuildRequires: libXaw-devel
31BuildRequires: libXmu-devel
32BuildRequires: libXt-devel
33BuildRequires: libSM-devel
34BuildRequires: libICE-devel
35BuildRequires: libXext-devel
36BuildRequires: libXpm-devel
37BuildRequires: libX11-devel
38BuildRequires: libXdmcp-devel
39BuildRequires: libXau-devel
40BuildRequires: libXinerama-devel
41BuildRequires: pam-devel
42
43Provides: xdm
44
45Obsoletes: XFree86-xdm, XOrg-xdm
46Obsoletes: xinitrc
47
48# NOTE: xorg-x11-filesystem is required by all packages that put files into
49# /usr/lib/X11 or /usr/include/X11 to ensure that on OS upgrades, they are
50# real directories, and not symbolic links.
51Requires(pre): xorg-x11-filesystem
52
53Requires: pam
54
55# We want to use the system Xsession script
56Requires: xorg-x11-xinit
57
58%description
59X.Org X11 xdm - X Display Manager
60
61%description -l ja
62X.Org X11 xdm - X ディスプレイマネージャ
63
64%prep
65%setup -q -n %{pkgname}-%{version}
66
67%patch10 -p0 -b .redhat-xdm-config-fix
68%patch11 -p0 -b .sessreg-utmp-fix-bug177890
69
70%build
71# FIXME: Work around pointer aliasing warnings from compiler for now
72export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
73# NOTE: We invoke aclocal/automake/autoconf to enable the changes present in
74# xdm-0.99.3-xdm-app-defaults-in-datadir.patch & xdm-0.99.3-xdm-configdir.patch
75aclocal ; libtoolize --force ; automake ; autoconf
76%configure \
77        --disable-static \
78        --disable-xprint \
79        --with-xdmconfigdir=%{_sysconfdir}/X11/xdm \
80        --with-xdmscriptdir=%{_sysconfdir}/X11/xdm \
81        --with-pixmapdir=%{_datadir}/xdm/pixmaps
82
83make %{?_smp_mflags}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87make install DESTDIR=$RPM_BUILD_ROOT
88
89# FIXME: Remove all libtool archives (*.la) from modules directory.  This
90# should be fixed in upstream Makefile.am or whatever.
91find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f --
92
93install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm/Xsetup_0
94
95# Install pam xdm config files
96{
97   mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
98   install -c -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/xserver
99   install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/xdm
100}
101
102rm -f $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm/Xsession
103(cd $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm; ln -sf ../xinit/Xsession .)
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(-,root,root,-)
110%doc AUTHORS COPYING INSTALL NEWS README ChangeLog
111%{_bindir}/xdm
112%{_bindir}/xdmshell
113%dir %{_sysconfdir}/X11/xdm
114# NOTE: The Xaccess file from our "xinitrc" package had no customizations,
115# and was out of sync with upstream, so we ship the upstream one now.
116%{_sysconfdir}/X11/xdm/Xaccess
117%{_sysconfdir}/X11/xdm/Xresources
118%{_sysconfdir}/X11/xdm/Xservers
119%{_sysconfdir}/X11/xdm/xdm-config
120# NOTE: In Fedora Core 4 and earlier, most of these config files and scripts
121# were kept in the "xinitrc" package as forked copies, however they were
122# quite out of date, and did not contain anything useful, so we now ship the
123# upstream files and can patch them as needed to make changes.
124%{_sysconfdir}/X11/xdm/GiveConsole
125%{_sysconfdir}/X11/xdm/TakeConsole
126%{_sysconfdir}/X11/xdm/Xreset
127%{_sysconfdir}/X11/xdm/Xsession
128%{_sysconfdir}/X11/xdm/Xsetup_0
129%{_sysconfdir}/X11/xdm/Xstartup
130%{_sysconfdir}/X11/xdm/Xwilling
131# NOTE: For security, upgrades of this package will install the new pam.d
132# files and make backup copies by default.  'noreplace' is intentionally avoided
133# here.
134%config %attr(0644,root,root) %{_sysconfdir}/pam.d/xdm
135%config %attr(0644,root,root) %{_sysconfdir}/pam.d/xserver
136%dir %{_datadir}/X11
137# NOTE: We intentionally default to OS supplied file being favoured here on
138# OS upgrades.
139%config %{_datadir}/X11/app-defaults/Chooser
140%dir %{_datadir}/xdm
141%dir %{_datadir}/xdm/pixmaps
142%{_datadir}/xdm/pixmaps/xorg-bw.xpm
143%{_datadir}/xdm/pixmaps/xorg.xpm
144%dir %{_libdir}/X11/xdm
145%{_libdir}/X11/xdm/chooser
146%{_libdir}/X11/xdm/libXdmGreet.so
147%{_mandir}/man1/*.1*
148
149%changelog
150* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-1
151- new upstream release
152
153* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.8-1
154- new upstream release
155
156* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
157- initial build for Vine Linux
158
159* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.1.6-3
160- Autorebuild for GCC 4.3
161
162* Fri Aug 24 2007 Ray Strode <rstrode@redhat.com> 1:1.1.6-2
163- Use system Xsession script (bug 244264)
164
165* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 1:1.1.6-1
166- Update to 1.1.6
167
168* Sat Aug 11 2007 Dave Airlie <airlied@redhat.com> 1:1.1.5-1
169- Update to 1.1.5
170
171* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:1.1.3-1
172- Update to 1.1.3
173
174* Mon Jul 24 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-5.fc6
175- Added xdm-1.0.5-sessreg-utmp-fix-bug177890.patch to restore GiveConsole to
176  what we shipped in 6.8.2, and also fix bug (#177890)
177
178* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-4.fc6
179- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
180
181* Mon Jul 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-3.fc6
182- Added pam_keyinit.so support to xdm.pamd and xserver.pamd (#198631)
183- Flag pam.d{xdm,xserver} as attr(0644,root,root) replaceable config files.
184- Flag app-defaults/Chooser as a replaceable config file.
185- Add conditional {dist} flag to Release field.
186
187* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.5-2
188- rebuild
189
190* Wed Jun 28 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-1
191- Updated xdm to version 1.0.5.
192- Remove xdm-1.0.4-setuid.diff as it is integrated in 1.0.5
193
194* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.4-4
195- Add missing documentation to doc macro.
196- Clean cruft out of specfile.
197
198* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.4-3
199- Added xdm-1.0.4-setuid.diff to fix potential security issue (#196094)
200- Added temporary "BuildRequires: autoconf, automake, libtool" dependencies
201  for mock builds, for as long as we need to run autotools at compile time.
202
203* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.4-2
204- Fix BuildRequires (#191858)
205
206* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.4-1
207- Updated to version 1.0.4
208
209* Fri Mar 31 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.3-1
210- Updated to version 1.0.3.  Forcibly relibtoolize to avoid present and future
211  bogons on libXdmGreet.so losing the .so extension.
212
213* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
214- bump again for double-long bug on ppc(64)
215
216* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
217- rebuilt for new gcc4.1 snapshot and glibc changes
218
219* Mon Jan 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
220- Updated xdm to version 1.0.1 from X11R7.
221- Added --with-xdmscriptdir option to ./configure to put scripts in /etc
222- Updated xdm-1.0.1-redhat-xdm-config-fix.patch to work with xdm 1.0.1
223
224* Thu Nov 24 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-6
225- Updated xdm.pamd to work with recent pam changes, and bumped the minimum
226  pam requirement up to 0.78-0 for FC5 builds. (#170661)
227- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", as the xdm package
228  puts files into /usr/lib/X11, so we have to make sure it is not a symlink.
229- Removed "filesystem" package dependency, as xorg-x11-filesystem carries
230  that dependency now, so it can be updated in one spot.
231- Added missing "BuildRequires: pkgconfig".
232- Added xdm-0.99.3-xdm-app-defaults-in-datadir.patch to force app-defaults
233  files to install into _datadir instead of _libdir.
234- Added xdm-0.99.3-xdm-scripts-in-configdir.patch to put the xdm scripts in
235  _sysconfdir, and removed older xdm-0.99.3-xdm-configdir.patch which hacked
236  up Makefile.in.  Fixes a typo that caused Xreset to not get installed
237  properly also.
238
239* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.3-5
240- require newer filesystem package (#172610)
241
242* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.3-4
243- install scripts into /etc/X11/xdm instead of %%{_libdir} (#173081)
244- use our Xsetup_0 instead of xorg one (#173083)
245
246* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-3
247- Added "Obsoletes: xinitrc", as xdm now provides files that were previously
248  part of that package.  xorg-x11-xinit now provides the xinitrc scripts.
249
250* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-2
251- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME.
252- Added xdm-0.99.3-redhat-xdm-config-fix.patch which merges in an
253  xdm-config fix present in the forked Red Hat xdm-config from the FC4
254  xinitrc package, which invokes Xwilling with "-s /bin/bash" instead
255  of "-c" to fix bug (#86505).
256- Removed ancient xdm rpm preinstall script, as it should be unnecessary now.
257
258* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-1
259- Update xdm to 0.99.3 from X11R7 RC2.
260
261* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.3
262- Build with -fno-strict-aliasing to work around possible pointer aliasing
263  issues
264
265* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.2
266- It is _sysconfdir not _sysconfigdir goofball!
267- Add {_sysconfdir}/pam.d/xdm and {_sysconfdir}/pam.d/xserver files that were
268  missing from file manifest.
269
270* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.1
271- Make sure all dirs are owned that xdm creates.
272- Misc spec file cleanups
273
274* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.0
275- Update xdm to 0.99.2 from X11R7 RC1.
276- Update to CVS snapshot from 20051031
277- Add Epoch 1, and change package to use the xdm version number.  Later, if
278  we decide to rename the package to "xdm", we can drop the Epoch tag.
279- Disable Xprint support
280- Use _smp_mflags
281- Add xdm-0.99.2-to-20051031.patch to pick up fixes from CVS head that allow
282  us to set the config dir and other dirs.
283
284* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
285- Use Fedora-Extras style BuildRoot tag
286- Update BuildRequires to use new library package names
287
288* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
289- Initial build.
Note: See TracBrowser for help on using the repository browser.