source: projects/specs/trunk/x/xorg-x11-utils/xorg-x11-utils-vl.spec @ 5538

Revision 5538, 6.2 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname utils
2
3Summary: X.Org X11 X client utilities
4Summary(ja): X.Org X11 X クライアントユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0:  ftp://ftp.x.org/pub/individual/app/xdpyinfo-1.3.0.tar.bz2
14Source1:  ftp://ftp.x.org/pub/individual/app/xdriinfo-1.0.4.tar.bz2
15Source2:  ftp://ftp.x.org/pub/individual/app/xev-1.1.0.tar.bz2
16Source3:  ftp://ftp.x.org/pub/individual/app/xfd-1.1.0.tar.bz2
17Source4:  ftp://ftp.x.org/pub/individual/app/xfontsel-1.0.3.tar.bz2
18Source5:  ftp://ftp.x.org/pub/individual/app/xlsatoms-1.1.0.tar.bz2
19Source6:  ftp://ftp.x.org/pub/individual/app/xlsclients-1.1.2.tar.bz2
20Source7:  ftp://ftp.x.org/pub/individual/app/xlsfonts-1.0.3.tar.bz2
21Source8:  ftp://ftp.x.org/pub/individual/app/xprop-1.2.1.tar.bz2
22Source9:  ftp://ftp.x.org/pub/individual/app/xvinfo-1.1.1.tar.bz2
23Source10: ftp://ftp.x.org/pub/individual/app/xwininfo-1.1.2.tar.bz2
24
25Source100: edid-decode-20100205.tar.xz
26Source101: make-edid-decode-snapshot.sh
27
28BuildRequires: pkgconfig
29BuildRequires: libdmx-devel
30BuildRequires: libGL-devel
31BuildRequires: libXaw-devel >= 1.0.5
32BuildRequires: libXext-devel
33BuildRequires: libXft-devel
34BuildRequires: libXi-devel
35BuildRequires: libXinerama-devel
36BuildRequires: libXpm-devel
37BuildRequires: libXt-devel
38BuildRequires: libXtst-devel
39BuildRequires: libXv-devel
40BuildRequires: libXxf86dga-devel
41BuildRequires: libXxf86misc-devel
42BuildRequires: libXxf86vm-devel
43
44BuildRequires: xcb-util-devel
45BuildRequires: xz
46
47# FIXME: check if still needed for X11R7
48Requires(pre): filesystem
49
50Provides: xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo
51
52Vendor: Project Vine
53Distribution: Vine Linux
54
55%description
56A collection of client utilities which can be used to query the X server
57for various information, view and select fonts, etc.
58
59%prep
60%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a100
61
62%build
63# Build all apps
64{
65   for app in * ; do
66      pushd $app
67      if [ -e ./configure ]; then
68        %configure
69      fi
70      make
71      popd
72   done
73}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77# Install all apps
78{
79   for app in * ; do
80      pushd $app
81      make install DESTDIR=$RPM_BUILD_ROOT
82      popd
83   done
84}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(-,root,root,-)
91%doc
92%{_bindir}/edid-decode
93%{_bindir}/xdpyinfo
94%{_bindir}/xdriinfo
95%{_bindir}/xev
96%{_bindir}/xfd
97%{_bindir}/xfontsel
98%{_bindir}/xlsatoms
99%{_bindir}/xlsclients
100%{_bindir}/xlsfonts
101%{_bindir}/xprop
102%{_bindir}/xvinfo
103%{_bindir}/xwininfo
104%dir %{_datadir}/X11
105%{_datadir}/X11/app-defaults/XFontSel
106%{_datadir}/X11/app-defaults/Xfd
107%{_mandir}/man1/xdpyinfo.1*
108%{_mandir}/man1/xdriinfo.1*
109%{_mandir}/man1/xev.1*
110%{_mandir}/man1/xfd.1*
111%{_mandir}/man1/xfontsel.1*
112%{_mandir}/man1/xlsatoms.1*
113%{_mandir}/man1/xlsclients.1*
114%{_mandir}/man1/xlsfonts.1*
115%{_mandir}/man1/xprop.1*
116%{_mandir}/man1/xvinfo.1*
117%{_mandir}/man1/xwininfo.1*
118
119%changelog
120* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
121- xdpyinfo-1.3.0
122
123* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
124- xlsclients-1.1.2
125- xprop-1.2.1
126- xwininfo-1.1.2
127
128* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
129- xdpyinfo-1.2.0
130- xdriinfo-1.0.4
131
132* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
133- xev-1.1.0
134- xfd-1.1.0
135- xprop-1.2.0
136- xwininfo-1.1.1
137- xfontsel-1.0.3
138- xlsatoms-1.1.0
139- xlsclients-1.1.1
140- xlsfonts-1.0.3
141- xvinfo-1.1.1
142- add BuildRequires: xcb-utils-devel, xz
143
144* Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-2
145- add edid-decode snapshot
146
147* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
148- xdpyinfo-1.1.0
149- xdriinfo-1.0.3
150- xev-1.0.4
151- xlsatoms-1.0.2
152- xlsclient-1.0.2
153- xprop-1.1.0
154- xvinfo-1.1.0
155- xwininfo-1.0.5
156
157* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
158- rebuild with libXaw.so.7 (libXaw-1.0.5)
159
160* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
161- xdpyinfo 1.0.3
162- xev 1.0.3
163- xprop 1.0.4
164- xwininfo 1.0.4
165
166* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
167- initial build for Vine Linux
168
169* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.3-2
170- Autorebuild for GCC 4.3
171
172* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
173- xdriinfo 1.0.2
174- xwininfo 1.0.3
175- Bump to 7.3
176
177* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 7.2-1
178- xfontsel 1.0.2, xlsfonts 1.0.2, xvinfo 1.0.2, xprop 1.0.3
179
180* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 7.1-4
181- xdpyinfo 1.0.2
182
183* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-3
184- Fix man page glob and rebuild for FC7.
185
186* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
187- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
188- Add 'dist' tag to package release string.
189
190* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
191- rebuild
192
193* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
194- Bump package version to 7.1 to reflect the X11 release the utilities
195  are aggregated from.
196- Updated to xdriinfo-1.0.1, xev-1.0.2, xwininfo-1.0.2 from X11R7.1
197
198* Wed May 31 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
199- Fix BuildRequires (#191966)
200
201* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
202- Remove a spurious Xprint dependency from xdpyinfo.
203
204* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
205- bump again for double-long bug on ppc(64)
206
207* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
208- rebuilt for new gcc4.1 snapshot and glibc changes
209
210* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
211- Updated all tarballs to versions from X11R7.0
212
213* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
214- Updated all tarballs to version 1.0.0 from X11R7 RC4.
215- Changed manpage dir from man1x to man1 to match upstream RC4 default.
216- Moved all app-defaults files from _libdir to _datadir
217
218* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
219- require newer filesystem package (#172610)
220
221* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-2
222- rebuild
223
224* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
225- Initial build, with all apps taken from X11R7 RC2
226- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
227  some packages.
Note: See TracBrowser for help on using the repository browser.