source: projects/specs/trunk/x/xorg-x11-utils/xorg-x11-utils-vl.spec @ 2203

Revision 2203, 5.9 KB checked in by Takemikaduchi, 14 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1%define pkgname utils
2
3Summary: X.Org X11 X client utilities
4Summary(ja): X.Org X11 X クライアントユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.5
7Release: 3%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0:  ftp://ftp.x.org/pub/individual/app/xdpyinfo-1.1.0.tar.bz2
14Source1:  ftp://ftp.x.org/pub/individual/app/xdriinfo-1.0.3.tar.bz2
15Source2:  ftp://ftp.x.org/pub/individual/app/xev-1.1.0.tar.bz2
16Source3:  ftp://ftp.x.org/pub/individual/app/xfd-1.1.0.tar.bz2
17Source4:  ftp://ftp.x.org/pub/individual/app/xfontsel-1.0.3.tar.bz2
18Source5:  ftp://ftp.x.org/pub/individual/app/xlsatoms-1.1.0.tar.bz2
19Source6:  ftp://ftp.x.org/pub/individual/app/xlsclients-1.1.1.tar.bz2
20Source7:  ftp://ftp.x.org/pub/individual/app/xlsfonts-1.0.3.tar.bz2
21Source8:  ftp://ftp.x.org/pub/individual/app/xprop-1.2.0.tar.bz2
22Source9:  ftp://ftp.x.org/pub/individual/app/xvinfo-1.1.1.tar.bz2
23Source10: ftp://ftp.x.org/pub/individual/app/xwininfo-1.1.1.tar.bz2
24
25Source100: edid-decode-20100205.tar.xz
26Source101: make-edid-decode-snapshot.sh
27
28BuildRequires: pkgconfig
29BuildRequires: libdmx-devel
30BuildRequires: libGL-devel
31BuildRequires: libXaw-devel >= 1.0.5
32BuildRequires: libXext-devel
33BuildRequires: libXft-devel
34BuildRequires: libXi-devel
35BuildRequires: libXinerama-devel
36BuildRequires: libXpm-devel
37BuildRequires: libXt-devel
38BuildRequires: libXtst-devel
39BuildRequires: libXv-devel
40BuildRequires: libXxf86dga-devel
41BuildRequires: libXxf86misc-devel
42BuildRequires: libXxf86vm-devel
43
44BuildRequires: xcb-util-devel
45BuildRequires: xz
46
47# FIXME: check if still needed for X11R7
48Requires(pre): filesystem
49
50Provides: xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo
51
52%description
53A collection of client utilities which can be used to query the X server
54for various information, view and select fonts, etc.
55
56%prep
57%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a100
58
59%build
60# Build all apps
61{
62   for app in * ; do
63      pushd $app
64      if [ -e ./configure ]; then
65        %configure
66      fi
67      make
68      popd
69   done
70}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74# Install all apps
75{
76   for app in * ; do
77      pushd $app
78      make install DESTDIR=$RPM_BUILD_ROOT
79      popd
80   done
81}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(-,root,root,-)
88%doc
89%{_bindir}/edid-decode
90%{_bindir}/xdpyinfo
91%{_bindir}/xdriinfo
92%{_bindir}/xev
93%{_bindir}/xfd
94%{_bindir}/xfontsel
95%{_bindir}/xlsatoms
96%{_bindir}/xlsclients
97%{_bindir}/xlsfonts
98%{_bindir}/xprop
99%{_bindir}/xvinfo
100%{_bindir}/xwininfo
101%dir %{_datadir}/X11
102%{_datadir}/X11/app-defaults/XFontSel
103%{_datadir}/X11/app-defaults/Xfd
104%{_mandir}/man1/xdpyinfo.1*
105%{_mandir}/man1/xdriinfo.1*
106%{_mandir}/man1/xev.1*
107%{_mandir}/man1/xfd.1*
108%{_mandir}/man1/xfontsel.1*
109%{_mandir}/man1/xlsatoms.1*
110%{_mandir}/man1/xlsclients.1*
111%{_mandir}/man1/xlsfonts.1*
112%{_mandir}/man1/xprop.1*
113%{_mandir}/man1/xvinfo.1*
114%{_mandir}/man1/xwininfo.1*
115
116%changelog
117* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
118- xdpyinfo-1.2.0
119- xev-1.1.0
120- xfd-1.1.0
121- xprop-1.2.0
122- xwininfo-1.1.1
123- xfontsel-1.0.3
124- xlsatoms-1.1.0
125- xlsclients-1.1.1
126- xlsfonts-1.0.3
127- xvinfo-1.1.1
128- add BuildRequires: xcb-utils-devel, xz
129
130* Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-2
131- add edid-decode snapshot
132
133* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
134- xdpyinfo-1.1.0
135- xdriinfo-1.0.3
136- xev-1.0.4
137- xlsatoms-1.0.2
138- xlsclient-1.0.2
139- xprop-1.1.0
140- xvinfo-1.1.0
141- xwininfo-1.0.5
142
143* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
144- rebuild with libXaw.so.7 (libXaw-1.0.5)
145
146* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
147- xdpyinfo 1.0.3
148- xev 1.0.3
149- xprop 1.0.4
150- xwininfo 1.0.4
151
152* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
153- initial build for Vine Linux
154
155* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.3-2
156- Autorebuild for GCC 4.3
157
158* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
159- xdriinfo 1.0.2
160- xwininfo 1.0.3
161- Bump to 7.3
162
163* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 7.2-1
164- xfontsel 1.0.2, xlsfonts 1.0.2, xvinfo 1.0.2, xprop 1.0.3
165
166* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 7.1-4
167- xdpyinfo 1.0.2
168
169* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-3
170- Fix man page glob and rebuild for FC7.
171
172* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
173- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
174- Add 'dist' tag to package release string.
175
176* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
177- rebuild
178
179* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
180- Bump package version to 7.1 to reflect the X11 release the utilities
181  are aggregated from.
182- Updated to xdriinfo-1.0.1, xev-1.0.2, xwininfo-1.0.2 from X11R7.1
183
184* Wed May 31 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
185- Fix BuildRequires (#191966)
186
187* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
188- Remove a spurious Xprint dependency from xdpyinfo.
189
190* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
191- bump again for double-long bug on ppc(64)
192
193* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
194- rebuilt for new gcc4.1 snapshot and glibc changes
195
196* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
197- Updated all tarballs to versions from X11R7.0
198
199* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
200- Updated all tarballs to version 1.0.0 from X11R7 RC4.
201- Changed manpage dir from man1x to man1 to match upstream RC4 default.
202- Moved all app-defaults files from _libdir to _datadir
203
204* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
205- require newer filesystem package (#172610)
206
207* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-2
208- rebuild
209
210* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
211- Initial build, with all apps taken from X11R7 RC2
212- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
213  some packages.
Note: See TracBrowser for help on using the repository browser.