source: projects/specs/trunk/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 9775

Revision 9775, 11.9 KB checked in by Takemikaduchi, 8 years ago (diff)

kernel-4.1, xserver-1.17.2, VirtualBox?-4.3.32, etc.

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.7
7Release: 6%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.7.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.6.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.1.0.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.5.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.6.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.7.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.9.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.4.3.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.1.0.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.5.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.2.3.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.1.1.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.3.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.3.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62BuildRequires: libXcursor-devel
63# ENDNOTE
64
65# xrdb requires the C preprocessor to work properly
66Requires: cpp
67
68Requires: libXrandr
69
70Provides: iceauth rgb sessreg xcmsdb xgamma xhost
71Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
72Provides: xsetroot xstdcmap xvidtune
73
74# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
75# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
76# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
77# them to ensure upgrades work.
78Obsoletes: XFree86
79
80Vendor: Project Vine
81Distribution: Vine Linux
82Packager: Takemikaduchi
83
84%description
85A collection of utilities used to tweak and query the runtime configuration
86of the X server.
87
88%prep
89%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
90
91## %patch1100 -p0 -b .datadir-rgbpath-fix
92## %patch1700 -p1 -b .buffer-stomp
93## %patch1710 -p1 -b .xaw7
94
95
96%build
97
98# Build all apps
99{
100   for app in * ; do
101      pushd $app
102      case $app in
103         rgb-*)
104            # FIXME: run autotools junk to kick in our patch
105            autoreconf -if
106            %configure ;# --with-rgb-db=%{_datadir}/X11
107            ;;
108         xset-*)
109            # FIXME: run autotools junk to kick in our patch
110            aclocal --force
111            automake -f
112            autoconf
113            %configure
114            ;;
115         xvidtune-*)
116            # FIXME: run autotools junk to kick in our patch
117            autoreconf -if
118            %configure
119            ;;
120         *)
121            %configure
122            ;;
123      esac
124
125      make
126      popd
127   done
128}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132# Install all apps
133{
134   for app in * ; do
135      pushd $app
136      case $app in
137         *)
138            make install DESTDIR=$RPM_BUILD_ROOT
139            ;;
140      esac
141      popd
142   done
143}
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%defattr(-,root,root,-)
150%doc
151%{_bindir}/iceauth
152%{_bindir}/sessreg
153%{_bindir}/showrgb
154%{_bindir}/xcmsdb
155%{_bindir}/xgamma
156%{_bindir}/xhost
157%{_bindir}/xkeystone
158%{_bindir}/xmodmap
159%{_bindir}/xrandr
160%{_bindir}/xrdb
161%{_bindir}/xrefresh
162%{_bindir}/xset
163%{_bindir}/xsetmode
164%{_bindir}/xsetpointer
165%{_bindir}/xsetroot
166%{_bindir}/xstdcmap
167%{_bindir}/xvidtune
168%dir %{_datadir}/X11
169%{_datadir}/X11/rgb.txt
170%{_datadir}/X11/app-defaults/Xvidtune
171%{_mandir}/man1/iceauth.1*
172%{_mandir}/man1/sessreg.1*
173%{_mandir}/man1/showrgb.1*
174%{_mandir}/man1/xcmsdb.1*
175%{_mandir}/man1/xgamma.1*
176%{_mandir}/man1/xhost.1*
177%{_mandir}/man1/xmodmap.1*
178%{_mandir}/man1/xrandr.1*
179%{_mandir}/man1/xrdb.1*
180%{_mandir}/man1/xrefresh.1*
181%{_mandir}/man1/xset.1*
182%{_mandir}/man1/xsetmode.1*
183%{_mandir}/man1/xsetpointer.1*
184%{_mandir}/man1/xsetroot.1*
185%{_mandir}/man1/xstdcmap.1*
186%{_mandir}/man1/xvidtune.1*
187
188%changelog
189* Sun Oct 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-6
190- xcmsdb-1.0.5
191- xgamma-1.0.6
192- xhost-1.0.7
193- xmodmap-1.0.9
194
195* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-5
196- iceauth-1.0.7
197- sessreg-1.1.0
198
199* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-4
200- rgb-1.0.6
201- xrandr-1.4.3
202
203* Wed Apr 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-3
204- xrandr-1.4.2
205
206* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
207- iceauth-1.0.6
208- xhost-1.0.6
209- xmodmap-1.0.8
210- xrandr-1.4.1
211- xrdb-1.1.0
212- xrefresh-1.0.5
213- xset-1.2.3
214
215* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
216- rgb-1.0.5
217- sessreg-1.0.8
218- xrandr-1.4.0
219- xsetroot-1.1.1
220- xstdcmap-1.0.3
221- xvidtune-1.0.3
222
223* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-8
224- xmodmap-1.0.7
225
226* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-7
227- xgamma-1.0.5
228- xhost-1.0.5
229- xmodmap-1.0.6
230
231* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-6
232- xcmsdb-1.0.4
233
234* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
235- sessreg-1.0.7
236
237* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
238- iceauth-1.0.5
239- xcmsdb-1.0.3
240- xrandr-1.3.5
241- xset-1.2.2
242
243* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
244- delete Obsoletes: xorg-x11
245
246* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
247- xrdb-1.0.9
248  (including security fix for CVE-2011-0465)
249
250* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
251- xrdb-1.0.8
252
253* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
254- xgamma-1.0.4
255- xrdb-1.0.7
256- xrefresh-1.0.4
257- xset-1.2.1
258
259* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
260- iceauth-1.0.4
261- rgb-1.0.4
262- sessreg-1.0.6
263- xcmsdb-1.0.3
264- xhost-1.0.4
265- xmodmap-1.0.5
266- xrandr-1.3.4
267- xset-1.2.0
268- xsetroot-1.1.0
269- xstdcmap-1.0.2
270- xvidtune-1.0.2
271- drop Patch1100,1700,1710
272- add BuildRequires: libXcursor-devel
273- fix %%files
274
275* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
276- iceauth-1.0.3
277- sessreg-1.0.5
278- xcmsdb-1.0.2
279- xgamma-1.0.3
280- xhost-1.0.3
281- xmodmap-1.0.4
282- xrandr-1.3.2
283- xrdb-1.0.6
284- xrefresh-1.0.3
285- xset-1.1.0
286- xsetroot-1.0.3
287- drop xtrap (deprecated upstream)
288
289* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
290- xrandr-1.3.0
291
292* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
293- xrandr-1.2.99.4
294
295* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
296- rebuild with libXaw.so.7 (libXaw-1.0.5)
297
298* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
299- rgb 1.0.3
300- sessreg 1.0.4
301- xhost 1.0.2
302- xrandr 1.2.3
303- xrdb 1.0.5
304- xset 1.0.4
305- xsetpointer 1.0.1
306
307* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
308- new versioning policy
309
310* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
311- initial build for Vine Linux
312
313* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
314- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
315- xrandr-1.2.2-verify-crtc-against-prev-config.patch
316- Patches from upstream to fix some bug in xrandr app
317
318* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
319- sessreg 1.0.3
320- xgamma 1.0.2
321- xmodmap 1.0.3
322- xrdb 1.0.4
323- xset 1.0.3
324- xsetroot 1.0.2
325- Bump to 7.3
326
327* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
328- Rebuild for ppc toolchain bug
329
330* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
331- rebuild for toolchain bug
332
333* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
334- iceauth 1.0.2
335
336* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
337- xrandr 1.2.2
338
339* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
340- xrandr 1.2.1
341
342* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
343- Superstition bump to 7.2
344- xrandr 1.2.0
345
346* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
347- Fix man page globs and rebuild for FC7.
348
349* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
350- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
351
352* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
353- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
354- Add 'dist' tag to package release string.
355
356* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
357- rebuild
358
359- Update to rgb-1.0.2 from X11R7.1
360
361* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
362- Bump the package version to 7.1 to have it match the X11 release that the
363  tarballs came from going forward.
364- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
365- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
366
367* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
368- Clean up Source lines in spec file, and other minor cleanups.
369
370* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
371- Added a whackload of BuildRequires for bug (#191987)
372
373* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
374- Updated xmodmap, xrandr, xrdb, and xset.
375
376* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
377- Eliminate a spurious Xprint dependency from xset.
378
379* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
380- Drop lbxproxy, LBX is deprecated upstream
381- Update to xhost 1.0.1
382
383* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
384- bump again for double-long bug on ppc(64)
385
386* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
387- rebuilt for new gcc4.1 snapshot and glibc changes
388
389* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
390- Updated all packages to the versions from X11R7.0
391
392* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
393- Updated all packages to version 1.0.0 from X11R7 RC4
394- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
395- Updated lbxproxy-datadir-AtomControl-fix.patch
396- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
397- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
398
399* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
400- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
401
402* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
403- Bump "filesystem" Requires(pre) to 2.3.7-1.
404
405* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
406- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
407  independent data files from libdir to datadir.
408- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
409  data files from libdir to datadir.
410- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
411  into datadir.
412
413* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
414- require newer filesystem package (#172610)
415
416* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
417- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
418- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
419
420* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
421- Initial build, with all apps taken from X11R7 RC2
422- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
423  some packages.
Note: See TracBrowser for help on using the repository browser.