source: projects/specs/trunk/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 8381

Revision 8381, 11.6 KB checked in by Takemikaduchi, 10 years ago (diff)

xserver-1.14.6

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.7
7Release: 3%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.6.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.5.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.0.8.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.4.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.5.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.6.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.8.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.4.2.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.1.0.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.5.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.2.3.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.1.1.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.3.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.3.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62BuildRequires: libXcursor-devel
63# ENDNOTE
64
65# xrdb requires the C preprocessor to work properly
66Requires: cpp
67
68Requires: libXrandr
69
70Provides: iceauth rgb sessreg xcmsdb xgamma xhost
71Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
72Provides: xsetroot xstdcmap xvidtune
73
74# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
75# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
76# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
77# them to ensure upgrades work.
78Obsoletes: XFree86
79
80Vendor: Project Vine
81Distribution: Vine Linux
82Packager: Takemikaduchi
83
84%description
85A collection of utilities used to tweak and query the runtime configuration
86of the X server.
87
88%prep
89%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
90
91## %patch1100 -p0 -b .datadir-rgbpath-fix
92## %patch1700 -p1 -b .buffer-stomp
93## %patch1710 -p1 -b .xaw7
94
95
96%build
97
98# Build all apps
99{
100   for app in * ; do
101      pushd $app
102      case $app in
103         rgb-*)
104            # FIXME: run autotools junk to kick in our patch
105            autoreconf -if
106            %configure ;# --with-rgb-db=%{_datadir}/X11
107            ;;
108         xset-*)
109            # FIXME: run autotools junk to kick in our patch
110            aclocal --force
111            automake -f
112            autoconf
113            %configure
114            ;;
115         xvidtune-*)
116            # FIXME: run autotools junk to kick in our patch
117            autoreconf -if
118            %configure
119            ;;
120         *)
121            %configure
122            ;;
123      esac
124
125      make
126      popd
127   done
128}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132# Install all apps
133{
134   for app in * ; do
135      pushd $app
136      case $app in
137         *)
138            make install DESTDIR=$RPM_BUILD_ROOT
139            ;;
140      esac
141      popd
142   done
143}
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%defattr(-,root,root,-)
150%doc
151%{_bindir}/iceauth
152%{_bindir}/sessreg
153%{_bindir}/showrgb
154%{_bindir}/xcmsdb
155%{_bindir}/xgamma
156%{_bindir}/xhost
157%{_bindir}/xkeystone
158%{_bindir}/xmodmap
159%{_bindir}/xrandr
160%{_bindir}/xrdb
161%{_bindir}/xrefresh
162%{_bindir}/xset
163%{_bindir}/xsetmode
164%{_bindir}/xsetpointer
165%{_bindir}/xsetroot
166%{_bindir}/xstdcmap
167%{_bindir}/xvidtune
168%dir %{_datadir}/X11
169%{_datadir}/X11/rgb.txt
170%{_datadir}/X11/app-defaults/Xvidtune
171%{_mandir}/man1/iceauth.1*
172%{_mandir}/man1/sessreg.1*
173%{_mandir}/man1/showrgb.1*
174%{_mandir}/man1/xcmsdb.1*
175%{_mandir}/man1/xgamma.1*
176%{_mandir}/man1/xhost.1*
177%{_mandir}/man1/xmodmap.1*
178%{_mandir}/man1/xrandr.1*
179%{_mandir}/man1/xrdb.1*
180%{_mandir}/man1/xrefresh.1*
181%{_mandir}/man1/xset.1*
182%{_mandir}/man1/xsetmode.1*
183%{_mandir}/man1/xsetpointer.1*
184%{_mandir}/man1/xsetroot.1*
185%{_mandir}/man1/xstdcmap.1*
186%{_mandir}/man1/xvidtune.1*
187
188%changelog
189* Wed Apr 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-3
190- xrandr-1.4.2
191
192* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
193- iceauth-1.0.6
194- xhost-1.0.6
195- xmodmap-1.0.8
196- xrandr-1.4.1
197- xrdb-1.1.0
198- xrefresh-1.0.5
199- xset-1.2.3
200
201* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
202- rgb-1.0.5
203- sessreg-1.0.8
204- xrandr-1.4.0
205- xsetroot-1.1.1
206- xstdcmap-1.0.3
207- xvidtune-1.0.3
208
209* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-8
210- xmodmap-1.0.7
211
212* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-7
213- xgamma-1.0.5
214- xhost-1.0.5
215- xmodmap-1.0.6
216
217* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-6
218- xcmsdb-1.0.4
219
220* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
221- sessreg-1.0.7
222
223* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
224- iceauth-1.0.5
225- xcmsdb-1.0.3
226- xrandr-1.3.5
227- xset-1.2.2
228
229* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
230- delete Obsoletes: xorg-x11
231
232* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
233- xrdb-1.0.9
234  (including security fix for CVE-2011-0465)
235
236* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
237- xrdb-1.0.8
238
239* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
240- xgamma-1.0.4
241- xrdb-1.0.7
242- xrefresh-1.0.4
243- xset-1.2.1
244
245* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
246- iceauth-1.0.4
247- rgb-1.0.4
248- sessreg-1.0.6
249- xcmsdb-1.0.3
250- xhost-1.0.4
251- xmodmap-1.0.5
252- xrandr-1.3.4
253- xset-1.2.0
254- xsetroot-1.1.0
255- xstdcmap-1.0.2
256- xvidtune-1.0.2
257- drop Patch1100,1700,1710
258- add BuildRequires: libXcursor-devel
259- fix %%files
260
261* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
262- iceauth-1.0.3
263- sessreg-1.0.5
264- xcmsdb-1.0.2
265- xgamma-1.0.3
266- xhost-1.0.3
267- xmodmap-1.0.4
268- xrandr-1.3.2
269- xrdb-1.0.6
270- xrefresh-1.0.3
271- xset-1.1.0
272- xsetroot-1.0.3
273- drop xtrap (deprecated upstream)
274
275* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
276- xrandr-1.3.0
277
278* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
279- xrandr-1.2.99.4
280
281* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
282- rebuild with libXaw.so.7 (libXaw-1.0.5)
283
284* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
285- rgb 1.0.3
286- sessreg 1.0.4
287- xhost 1.0.2
288- xrandr 1.2.3
289- xrdb 1.0.5
290- xset 1.0.4
291- xsetpointer 1.0.1
292
293* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
294- new versioning policy
295
296* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
297- initial build for Vine Linux
298
299* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
300- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
301- xrandr-1.2.2-verify-crtc-against-prev-config.patch
302- Patches from upstream to fix some bug in xrandr app
303
304* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
305- sessreg 1.0.3
306- xgamma 1.0.2
307- xmodmap 1.0.3
308- xrdb 1.0.4
309- xset 1.0.3
310- xsetroot 1.0.2
311- Bump to 7.3
312
313* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
314- Rebuild for ppc toolchain bug
315
316* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
317- rebuild for toolchain bug
318
319* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
320- iceauth 1.0.2
321
322* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
323- xrandr 1.2.2
324
325* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
326- xrandr 1.2.1
327
328* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
329- Superstition bump to 7.2
330- xrandr 1.2.0
331
332* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
333- Fix man page globs and rebuild for FC7.
334
335* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
336- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
337
338* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
339- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
340- Add 'dist' tag to package release string.
341
342* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
343- rebuild
344
345- Update to rgb-1.0.2 from X11R7.1
346
347* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
348- Bump the package version to 7.1 to have it match the X11 release that the
349  tarballs came from going forward.
350- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
351- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
352
353* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
354- Clean up Source lines in spec file, and other minor cleanups.
355
356* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
357- Added a whackload of BuildRequires for bug (#191987)
358
359* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
360- Updated xmodmap, xrandr, xrdb, and xset.
361
362* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
363- Eliminate a spurious Xprint dependency from xset.
364
365* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
366- Drop lbxproxy, LBX is deprecated upstream
367- Update to xhost 1.0.1
368
369* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
370- bump again for double-long bug on ppc(64)
371
372* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
373- rebuilt for new gcc4.1 snapshot and glibc changes
374
375* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
376- Updated all packages to the versions from X11R7.0
377
378* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
379- Updated all packages to version 1.0.0 from X11R7 RC4
380- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
381- Updated lbxproxy-datadir-AtomControl-fix.patch
382- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
383- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
384
385* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
386- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
387
388* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
389- Bump "filesystem" Requires(pre) to 2.3.7-1.
390
391* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
392- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
393  independent data files from libdir to datadir.
394- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
395  data files from libdir to datadir.
396- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
397  into datadir.
398
399* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
400- require newer filesystem package (#172610)
401
402* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
403- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
404- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
405
406* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
407- Initial build, with all apps taken from X11R7 RC2
408- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
409  some packages.
Note: See TracBrowser for help on using the repository browser.