source: projects/specs/trunk/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 6256

Revision 6256, 11.3 KB checked in by Takemikaduchi, 12 years ago (diff)

totem: add configure option,
others: new upstream release

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 8%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.5.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.4.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.0.7.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.4.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.5.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.5.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.7.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.3.5.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.0.9.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.4.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.2.2.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.1.0.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.2.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.2.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62BuildRequires: libXcursor-devel
63# ENDNOTE
64
65# xrdb requires the C preprocessor to work properly
66Requires: cpp
67
68Requires: libXrandr
69
70Provides: iceauth rgb sessreg xcmsdb xgamma xhost
71Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
72Provides: xsetroot xstdcmap xvidtune
73
74# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
75# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
76# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
77# them to ensure upgrades work.
78Obsoletes: XFree86
79
80Vendor: Project Vine
81Distribution: Vine Linux
82
83%description
84A collection of utilities used to tweak and query the runtime configuration
85of the X server.
86
87%prep
88%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
89
90## %patch1100 -p0 -b .datadir-rgbpath-fix
91## %patch1700 -p1 -b .buffer-stomp
92## %patch1710 -p1 -b .xaw7
93
94
95%build
96
97# Build all apps
98{
99   for app in * ; do
100      pushd $app
101      case $app in
102         rgb-*)
103            # FIXME: run autotools junk to kick in our patch
104            aclocal --force
105            automake -f
106            autoconf
107            %configure ;# --with-rgb-db=%{_datadir}/X11
108            ;;
109         xset-*)
110            # FIXME: run autotools junk to kick in our patch
111            aclocal --force
112            automake -f
113            autoconf
114            %configure
115            ;;
116         xvidtune-*)
117            # FIXME: run autotools junk to kick in our patch
118            aclocal --force
119            automake -f
120            autoconf
121            %configure
122            ;;
123         *)
124            %configure
125            ;;
126      esac
127
128      make
129      popd
130   done
131}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135# Install all apps
136{
137   for app in * ; do
138      pushd $app
139      case $app in
140         *)
141            make install DESTDIR=$RPM_BUILD_ROOT
142            ;;
143      esac
144      popd
145   done
146}
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%files
152%defattr(-,root,root,-)
153%doc
154%{_bindir}/iceauth
155%{_bindir}/sessreg
156%{_bindir}/showrgb
157%{_bindir}/xcmsdb
158%{_bindir}/xgamma
159%{_bindir}/xhost
160%{_bindir}/xkeystone
161%{_bindir}/xmodmap
162%{_bindir}/xrandr
163%{_bindir}/xrdb
164%{_bindir}/xrefresh
165%{_bindir}/xset
166%{_bindir}/xsetmode
167%{_bindir}/xsetpointer
168%{_bindir}/xsetroot
169%{_bindir}/xstdcmap
170%{_bindir}/xvidtune
171%dir %{_datadir}/X11
172%{_datadir}/X11/rgb.txt
173%{_datadir}/X11/app-defaults/Xvidtune
174%{_mandir}/man1/iceauth.1*
175%{_mandir}/man1/sessreg.1*
176%{_mandir}/man1/showrgb.1*
177%{_mandir}/man1/xcmsdb.1*
178%{_mandir}/man1/xgamma.1*
179%{_mandir}/man1/xhost.1*
180%{_mandir}/man1/xmodmap.1*
181%{_mandir}/man1/xrandr.1*
182%{_mandir}/man1/xrdb.1*
183%{_mandir}/man1/xrefresh.1*
184%{_mandir}/man1/xset.1*
185%{_mandir}/man1/xsetmode.1*
186%{_mandir}/man1/xsetpointer.1*
187%{_mandir}/man1/xsetroot.1*
188%{_mandir}/man1/xstdcmap.1*
189%{_mandir}/man1/xvidtune.1*
190
191%changelog
192* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-8
193- xmodmap-1.0.7
194
195* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-7
196- xgamma-1.0.5
197- xhost-1.0.5
198- xmodmap-1.0.6
199
200* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-6
201- xcmsdb-1.0.4
202
203* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
204- sessreg-1.0.7
205
206* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
207- iceauth-1.0.5
208- xcmsdb-1.0.3
209- xrandr-1.3.5
210- xset-1.2.2
211
212* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
213- delete Obsoletes: xorg-x11
214
215* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
216- xrdb-1.0.9
217  (including security fix for CVE-2011-0465)
218
219* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
220- xrdb-1.0.8
221
222* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
223- xgamma-1.0.4
224- xrdb-1.0.7
225- xrefresh-1.0.4
226- xset-1.2.1
227
228* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
229- iceauth-1.0.4
230- rgb-1.0.4
231- sessreg-1.0.6
232- xcmsdb-1.0.3
233- xhost-1.0.4
234- xmodmap-1.0.5
235- xrandr-1.3.4
236- xset-1.2.0
237- xsetroot-1.1.0
238- xstdcmap-1.0.2
239- xvidtune-1.0.2
240- drop Patch1100,1700,1710
241- add BuildRequires: libXcursor-devel
242- fix %%files
243
244* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
245- iceauth-1.0.3
246- sessreg-1.0.5
247- xcmsdb-1.0.2
248- xgamma-1.0.3
249- xhost-1.0.3
250- xmodmap-1.0.4
251- xrandr-1.3.2
252- xrdb-1.0.6
253- xrefresh-1.0.3
254- xset-1.1.0
255- xsetroot-1.0.3
256- drop xtrap (deprecated upstream)
257
258* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
259- xrandr-1.3.0
260
261* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
262- xrandr-1.2.99.4
263
264* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
265- rebuild with libXaw.so.7 (libXaw-1.0.5)
266
267* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
268- rgb 1.0.3
269- sessreg 1.0.4
270- xhost 1.0.2
271- xrandr 1.2.3
272- xrdb 1.0.5
273- xset 1.0.4
274- xsetpointer 1.0.1
275
276* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
277- new versioning policy
278
279* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
280- initial build for Vine Linux
281
282* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
283- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
284- xrandr-1.2.2-verify-crtc-against-prev-config.patch
285- Patches from upstream to fix some bug in xrandr app
286
287* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
288- sessreg 1.0.3
289- xgamma 1.0.2
290- xmodmap 1.0.3
291- xrdb 1.0.4
292- xset 1.0.3
293- xsetroot 1.0.2
294- Bump to 7.3
295
296* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
297- Rebuild for ppc toolchain bug
298
299* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
300- rebuild for toolchain bug
301
302* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
303- iceauth 1.0.2
304
305* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
306- xrandr 1.2.2
307
308* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
309- xrandr 1.2.1
310
311* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
312- Superstition bump to 7.2
313- xrandr 1.2.0
314
315* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
316- Fix man page globs and rebuild for FC7.
317
318* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
319- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
320
321* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
322- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
323- Add 'dist' tag to package release string.
324
325* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
326- rebuild
327
328- Update to rgb-1.0.2 from X11R7.1
329
330* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
331- Bump the package version to 7.1 to have it match the X11 release that the
332  tarballs came from going forward.
333- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
334- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
335
336* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
337- Clean up Source lines in spec file, and other minor cleanups.
338
339* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
340- Added a whackload of BuildRequires for bug (#191987)
341
342* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
343- Updated xmodmap, xrandr, xrdb, and xset.
344
345* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
346- Eliminate a spurious Xprint dependency from xset.
347
348* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
349- Drop lbxproxy, LBX is deprecated upstream
350- Update to xhost 1.0.1
351
352* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
353- bump again for double-long bug on ppc(64)
354
355* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
356- rebuilt for new gcc4.1 snapshot and glibc changes
357
358* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
359- Updated all packages to the versions from X11R7.0
360
361* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
362- Updated all packages to version 1.0.0 from X11R7 RC4
363- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
364- Updated lbxproxy-datadir-AtomControl-fix.patch
365- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
366- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
367
368* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
369- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
370
371* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
372- Bump "filesystem" Requires(pre) to 2.3.7-1.
373
374* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
375- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
376  independent data files from libdir to datadir.
377- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
378  data files from libdir to datadir.
379- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
380  into datadir.
381
382* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
383- require newer filesystem package (#172610)
384
385* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
386- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
387- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
388
389* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
390- Initial build, with all apps taken from X11R7 RC2
391- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
392  some packages.
Note: See TracBrowser for help on using the repository browser.