source: projects/specs/trunk/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 2642

Revision 2642, 10.6 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.4.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.4.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.0.6.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.3.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.4.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.4.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.5.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.3.4.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.0.8.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.4.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.2.1.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.1.0.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.2.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.2.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62BuildRequires: libXcursor-devel
63# ENDNOTE
64
65# xrdb requires the C preprocessor to work properly
66Requires: cpp
67
68Requires: libXrandr
69
70Provides: iceauth rgb sessreg xcmsdb xgamma xhost
71Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
72Provides: xsetroot xstdcmap xvidtune
73
74# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
75# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
76# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
77# them to ensure upgrades work.
78Obsoletes: xorg-x11, XFree86
79
80%description
81A collection of utilities used to tweak and query the runtime configuration
82of the X server.
83
84%prep
85%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
86
87## %patch1100 -p0 -b .datadir-rgbpath-fix
88## %patch1700 -p1 -b .buffer-stomp
89## %patch1710 -p1 -b .xaw7
90
91
92%build
93
94# Build all apps
95{
96   for app in * ; do
97      pushd $app
98      case $app in
99         rgb-*)
100            # FIXME: run autotools junk to kick in our patch
101            aclocal --force
102            automake -f
103            autoconf
104            %configure ;# --with-rgb-db=%{_datadir}/X11
105            ;;
106         xset-*)
107            # FIXME: run autotools junk to kick in our patch
108            aclocal --force
109            automake -f
110            autoconf
111            %configure
112            ;;
113         xvidtune-*)
114            # FIXME: run autotools junk to kick in our patch
115            aclocal --force
116            automake -f
117            autoconf
118            %configure
119            ;;
120         *)
121            %configure
122            ;;
123      esac
124
125      make
126      popd
127   done
128}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132# Install all apps
133{
134   for app in * ; do
135      pushd $app
136      case $app in
137         *)
138            make install DESTDIR=$RPM_BUILD_ROOT
139            ;;
140      esac
141      popd
142   done
143}
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%defattr(-,root,root,-)
150%doc
151%{_bindir}/iceauth
152%{_bindir}/sessreg
153%{_bindir}/showrgb
154%{_bindir}/xcmsdb
155%{_bindir}/xgamma
156%{_bindir}/xhost
157%{_bindir}/xkeystone
158%{_bindir}/xmodmap
159%{_bindir}/xrandr
160%{_bindir}/xrdb
161%{_bindir}/xrefresh
162%{_bindir}/xset
163%{_bindir}/xsetmode
164%{_bindir}/xsetpointer
165%{_bindir}/xsetroot
166%{_bindir}/xstdcmap
167%{_bindir}/xvidtune
168%dir %{_datadir}/X11
169%{_datadir}/X11/rgb.txt
170%{_datadir}/X11/app-defaults/Xvidtune
171%{_mandir}/man1/iceauth.1*
172%{_mandir}/man1/sessreg.1*
173%{_mandir}/man1/showrgb.1*
174%{_mandir}/man1/xcmsdb.1*
175%{_mandir}/man1/xgamma.1*
176%{_mandir}/man1/xhost.1*
177%{_mandir}/man1/xmodmap.1*
178%{_mandir}/man1/xrandr.1*
179%{_mandir}/man1/xrdb.1*
180%{_mandir}/man1/xrefresh.1*
181%{_mandir}/man1/xset.1*
182%{_mandir}/man1/xsetmode.1*
183%{_mandir}/man1/xsetpointer.1*
184%{_mandir}/man1/xsetroot.1*
185%{_mandir}/man1/xstdcmap.1*
186%{_mandir}/man1/xvidtune.1*
187
188%changelog
189* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
190- xrdb-1.0.8
191
192* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
193- xgamma-1.0.4
194- xrdb-1.0.7
195- xrefresh-1.0.4
196- xset-1.2.1
197
198* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
199- iceauth-1.0.4
200- rgb-1.0.4
201- sessreg-1.0.6
202- xcmsdb-1.0.3
203- xhost-1.0.4
204- xmodmap-1.0.5
205- xrandr-1.3.4
206- xset-1.2.0
207- xsetroot-1.1.0
208- xstdcmap-1.0.2
209- xvidtune-1.0.2
210- drop Patch1100,1700,1710
211- add BuildRequires: libXcursor-devel
212- fix %%files
213
214* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
215- iceauth-1.0.3
216- sessreg-1.0.5
217- xcmsdb-1.0.2
218- xgamma-1.0.3
219- xhost-1.0.3
220- xmodmap-1.0.4
221- xrandr-1.3.2
222- xrdb-1.0.6
223- xrefresh-1.0.3
224- xset-1.1.0
225- xsetroot-1.0.3
226- drop xtrap (deprecated upstream)
227
228* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
229- xrandr-1.3.0
230
231* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
232- xrandr-1.2.99.4
233
234* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
235- rebuild with libXaw.so.7 (libXaw-1.0.5)
236
237* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
238- rgb 1.0.3
239- sessreg 1.0.4
240- xhost 1.0.2
241- xrandr 1.2.3
242- xrdb 1.0.5
243- xset 1.0.4
244- xsetpointer 1.0.1
245
246* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
247- new versioning policy
248
249* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
250- initial build for Vine Linux
251
252* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
253- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
254- xrandr-1.2.2-verify-crtc-against-prev-config.patch
255- Patches from upstream to fix some bug in xrandr app
256
257* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
258- sessreg 1.0.3
259- xgamma 1.0.2
260- xmodmap 1.0.3
261- xrdb 1.0.4
262- xset 1.0.3
263- xsetroot 1.0.2
264- Bump to 7.3
265
266* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
267- Rebuild for ppc toolchain bug
268
269* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
270- rebuild for toolchain bug
271
272* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
273- iceauth 1.0.2
274
275* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
276- xrandr 1.2.2
277
278* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
279- xrandr 1.2.1
280
281* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
282- Superstition bump to 7.2
283- xrandr 1.2.0
284
285* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
286- Fix man page globs and rebuild for FC7.
287
288* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
289- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
290
291* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
292- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
293- Add 'dist' tag to package release string.
294
295* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
296- rebuild
297
298- Update to rgb-1.0.2 from X11R7.1
299
300* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
301- Bump the package version to 7.1 to have it match the X11 release that the
302  tarballs came from going forward.
303- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
304- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
305
306* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
307- Clean up Source lines in spec file, and other minor cleanups.
308
309* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
310- Added a whackload of BuildRequires for bug (#191987)
311
312* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
313- Updated xmodmap, xrandr, xrdb, and xset.
314
315* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
316- Eliminate a spurious Xprint dependency from xset.
317
318* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
319- Drop lbxproxy, LBX is deprecated upstream
320- Update to xhost 1.0.1
321
322* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
323- bump again for double-long bug on ppc(64)
324
325* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
326- rebuilt for new gcc4.1 snapshot and glibc changes
327
328* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
329- Updated all packages to the versions from X11R7.0
330
331* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
332- Updated all packages to version 1.0.0 from X11R7 RC4
333- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
334- Updated lbxproxy-datadir-AtomControl-fix.patch
335- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
336- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
337
338* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
339- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
340
341* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
342- Bump "filesystem" Requires(pre) to 2.3.7-1.
343
344* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
345- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
346  independent data files from libdir to datadir.
347- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
348  data files from libdir to datadir.
349- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
350  into datadir.
351
352* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
353- require newer filesystem package (#172610)
354
355* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
356- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
357- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
358
359* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
360- Initial build, with all apps taken from X11R7 RC2
361- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
362  some packages.
Note: See TracBrowser for help on using the repository browser.