source: projects/specs/trunk/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.5
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.3.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.3.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.0.5.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.2.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.3.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.3.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.4.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.3.2.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.0.6.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.3.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.1.0.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.0.3.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.1.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.1.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62# ENDNOTE
63
64# xrdb requires the C preprocessor to work properly
65Requires: cpp
66
67Requires: libXrandr
68
69Provides: iceauth rgb sessreg xcmsdb xgamma xhost
70Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
71Provides: xsetroot xstdcmap xvidtune
72
73# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
74# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
75# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
76# them to ensure upgrades work.
77Obsoletes: xorg-x11, XFree86
78
79%description
80A collection of utilities used to tweak and query the runtime configuration
81of the X server.
82
83%prep
84%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
85
86%patch1100 -p0 -b .datadir-rgbpath-fix
87%patch1700 -p1 -b .buffer-stomp
88%patch1710 -p1 -b .xaw7
89
90
91%build
92
93# Build all apps
94{
95   for app in * ; do
96      pushd $app
97      case $app in
98         rgb-*)
99            # FIXME: run autotools junk to kick in our patch
100            aclocal --force
101            automake -f
102            autoconf
103            %configure ;# --with-rgb-db=%{_datadir}/X11
104            ;;
105         xset-*)
106            # FIXME: run autotools junk to kick in our patch
107            aclocal --force
108            automake -f
109            autoconf
110            %configure
111            ;;
112         xvidtune-*)
113            # FIXME: run autotools junk to kick in our patch
114            aclocal --force
115            automake -f
116            autoconf
117            %configure
118            ;;
119         *)
120            %configure
121            ;;
122      esac
123
124      make
125      popd
126   done
127}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131# Install all apps
132{
133   for app in * ; do
134      pushd $app
135      case $app in
136         *)
137            make install DESTDIR=$RPM_BUILD_ROOT
138            ;;
139      esac
140      popd
141   done
142}
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%files
148%defattr(-,root,root,-)
149%doc
150%{_bindir}/iceauth
151%{_bindir}/sessreg
152%{_bindir}/showrgb
153%{_bindir}/xcmsdb
154%{_bindir}/xgamma
155%{_bindir}/xhost
156%{_bindir}/xmodmap
157%{_bindir}/xrandr
158%{_bindir}/xrdb
159%{_bindir}/xrefresh
160%{_bindir}/xset
161%{_bindir}/xsetmode
162%{_bindir}/xsetpointer
163%{_bindir}/xsetroot
164%{_bindir}/xstdcmap
165%{_bindir}/xvidtune
166%dir %{_datadir}/X11
167%{_datadir}/X11/rgb.txt
168%{_datadir}/X11/app-defaults/Xvidtune
169%{_mandir}/man1/iceauth.1*
170%{_mandir}/man1/sessreg.1*
171%{_mandir}/man1/showrgb.1*
172%{_mandir}/man1/xcmsdb.1*
173%{_mandir}/man1/xgamma.1*
174%{_mandir}/man1/xhost.1*
175%{_mandir}/man1/xmodmap.1*
176%{_mandir}/man1/xrandr.1*
177%{_mandir}/man1/xrdb.1*
178%{_mandir}/man1/xrefresh.1*
179%{_mandir}/man1/xset.1*
180%{_mandir}/man1/xsetmode.1*
181%{_mandir}/man1/xsetpointer.1*
182%{_mandir}/man1/xsetroot.1*
183%{_mandir}/man1/xstdcmap.1*
184%{_mandir}/man1/xvidtune.1*
185
186%changelog
187* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
188- iceauth-1.0.3
189- sessreg-1.0.5
190- xcmsdb-1.0.2
191- xgamma-1.0.3
192- xhost-1.0.3
193- xmodmap-1.0.4
194- xrandr-1.3.2
195- xrdb-1.0.6
196- xrefresh-1.0.3
197- xset-1.1.0
198- xsetroot-1.0.3
199- drop xtrap (deprecated upstream)
200
201* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
202- xrandr-1.3.0
203
204* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
205- xrandr-1.2.99.4
206
207* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
208- rebuild with libXaw.so.7 (libXaw-1.0.5)
209
210* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
211- rgb 1.0.3
212- sessreg 1.0.4
213- xhost 1.0.2
214- xrandr 1.2.3
215- xrdb 1.0.5
216- xset 1.0.4
217- xsetpointer 1.0.1
218
219* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
220- new versioning policy
221
222* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
223- initial build for Vine Linux
224
225* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
226- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
227- xrandr-1.2.2-verify-crtc-against-prev-config.patch
228- Patches from upstream to fix some bug in xrandr app
229
230* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
231- sessreg 1.0.3
232- xgamma 1.0.2
233- xmodmap 1.0.3
234- xrdb 1.0.4
235- xset 1.0.3
236- xsetroot 1.0.2
237- Bump to 7.3
238
239* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
240- Rebuild for ppc toolchain bug
241
242* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
243- rebuild for toolchain bug
244
245* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
246- iceauth 1.0.2
247
248* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
249- xrandr 1.2.2
250
251* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
252- xrandr 1.2.1
253
254* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
255- Superstition bump to 7.2
256- xrandr 1.2.0
257
258* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
259- Fix man page globs and rebuild for FC7.
260
261* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
262- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
263
264* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
265- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
266- Add 'dist' tag to package release string.
267
268* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
269- rebuild
270
271- Update to rgb-1.0.2 from X11R7.1
272
273* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
274- Bump the package version to 7.1 to have it match the X11 release that the
275  tarballs came from going forward.
276- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
277- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
278
279* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
280- Clean up Source lines in spec file, and other minor cleanups.
281
282* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
283- Added a whackload of BuildRequires for bug (#191987)
284
285* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
286- Updated xmodmap, xrandr, xrdb, and xset.
287
288* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
289- Eliminate a spurious Xprint dependency from xset.
290
291* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
292- Drop lbxproxy, LBX is deprecated upstream
293- Update to xhost 1.0.1
294
295* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
296- bump again for double-long bug on ppc(64)
297
298* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
299- rebuilt for new gcc4.1 snapshot and glibc changes
300
301* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
302- Updated all packages to the versions from X11R7.0
303
304* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
305- Updated all packages to version 1.0.0 from X11R7 RC4
306- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
307- Updated lbxproxy-datadir-AtomControl-fix.patch
308- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
309- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
310
311* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
312- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
313
314* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
315- Bump "filesystem" Requires(pre) to 2.3.7-1.
316
317* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
318- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
319  independent data files from libdir to datadir.
320- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
321  data files from libdir to datadir.
322- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
323  into datadir.
324
325* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
326- require newer filesystem package (#172610)
327
328* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
329- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
330- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
331
332* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
333- Initial build, with all apps taken from X11R7 RC2
334- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
335  some packages.
Note: See TracBrowser for help on using the repository browser.