source: projects/specs/trunk/x/xorg-x11-resutils/xorg-x11-resutils-vl.spec @ 5808

Revision 5808, 4.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname resutils
2
3Summary: X.Org X11 X resource utilities
4Summary(ja): X.Org X11 X resource ユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/appres-1.0.3.tar.bz2
13Source1:  ftp://ftp.x.org/pub/individual/app/editres-1.0.5.tar.bz2
14Source2:  ftp://ftp.x.org/pub/individual/app/listres-1.0.3.tar.bz2
15Source3:  ftp://ftp.x.org/pub/individual/app/viewres-1.0.3.tar.bz2
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: pkgconfig
19BuildRequires: libX11-devel
20BuildRequires: libXt-devel
21BuildRequires: libXmu-devel
22BuildRequires: libXext-devel
23BuildRequires: libSM-devel
24BuildRequires: libICE-devel
25BuildRequires: libXaw-devel
26BuildRequires: libXdmcp-devel
27Requires(pre): xorg-x11-filesystem
28
29Provides: appres editres listres viewres
30
31# NOTE: appres, editres used to be in the XFree86/xorg-x11 package, whereas
32# oddly enough, the listres, viewres utilities were in the *-tools subpackage.
33Obsoletes: XFree86, XOrg
34Obsoletes: XFree86-tools, XOrg-tools
35
36%description
37A collection of utilities for managing X resources.
38
39%prep
40%setup -q -c %{name}-%{version} -a1 -a2 -a3
41
42%build
43# Build all apps
44{
45   for app in * ; do
46      pushd $app
47#      aclocal --force ; autoconf
48      %configure --disable-xprint
49      make
50      popd
51   done
52}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56# Install all apps
57{
58   for app in * ; do
59      pushd $app
60      make install DESTDIR=$RPM_BUILD_ROOT
61      popd
62   done
63}
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-,root,root,-)
70%doc
71%{_bindir}/appres
72%{_bindir}/editres
73%{_bindir}/listres
74%{_bindir}/viewres
75%dir %{_datadir}/X11
76%{_datadir}/X11/app-defaults/Editres
77%{_datadir}/X11/app-defaults/Editres-color
78%{_datadir}/X11/app-defaults/Viewres
79%{_datadir}/X11/app-defaults/Viewres-color
80%{_mandir}/man1/appres.1*
81%{_mandir}/man1/editres.1*
82%{_mandir}/man1/listres.1*
83%{_mandir}/man1/viewres.1*
84
85%changelog
86* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
87- listres-1.0.3
88
89* Sun Apr 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
90- appres-1.0.2
91- editres-1.0.4
92- listres-1.0.2
93- viewres-1.0.3
94- fix %%files
95
96* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
97- appres-1.0.2
98- editres-1.0.3
99
100* Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.1-1
101- initial build for Vine Linux
102
103* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.1-5
104- Autorebuild for GCC 4.3
105
106* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 7.1-4
107- Rebuild for build id
108
109* Tue Jan 23 2007 Adam Jackson <ajax@redhat.com> 7.1-3
110- appres 1.0.1
111
112* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
113- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
114- Add 'dist' tag to package release string.
115
116* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
117- rebuild
118
119* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
120- Bump package version to 7.1 to match the X11 release the packages were
121  last synced with.
122- Bump build dep to libXaw-devel >= 1.0.2-6, to pick up indirect dependency
123  on libXpm-devel which was fixed in that release.
124
125* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
126- Fix all SourceN lines in spec file to not have to update them every time.
127- Remove package ownership of mandir/libdir/etc.
128
129* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
130- bump again for double-long bug on ppc(64)
131
132* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
133- rebuilt for new gcc4.1 snapshot and glibc changes
134
135* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
136- Update all resource utils to version 1.0.1 from X11R7.0
137
138* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
139- Update all resource utils to version 1.0.0 from X11R7 RC4.
140- Move app-defaults files to _datadir
141- Change manpage dir from man1x to man1 to match RC4 default.
142- Added "BuildRequires: libX11-devel, libXt-devel"
143
144* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.1-3
145- require newer filesystem package (#172610)
146
147* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
148- Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
149  appres, editres used to be in the XFree86/xorg-x11 package, whereas
150  oddly enough, the listres, viewres utilities were in the *-tools subpackage.
151- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
152
153* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
154- Initial build, with all apps taken from X11R7 RC2
155- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
156  some packages.
Note: See TracBrowser for help on using the repository browser.