source: projects/specs/trunk/x/xorg-x11-proto-devel/xorg-x11-proto-devel-vl.spec @ 521

Revision 521, 20.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# INFO: When doing a bootstrap build on a new architecture, set this to 1 to
2# avoid build loops.
3%define build_bootstrap 0
4
5Summary: X.Org X11 Protocol headers
6Summary(ja): X.Org X11 プロトコルヘッダファイル
7Name: xorg-x11-proto-devel
8Version: 7.5
9Release: 1%{?_dist_release}
10License: MIT
11Group: Development/Libraries
12URL: http://www.x.org
13
14# Add virtual provides lazily as they get updated, so the server and libs
15# can depend on specific proto versions instead of this package's version.
16Source0:  ftp://ftp.x.org/pub/individual/proto/bigreqsproto-1.1.0.tar.bz2
17Source1:  ftp://ftp.x.org/pub/individual/proto/compositeproto-0.4.1.tar.bz2
18Provides: compositeproto = 0.4.1
19Source2:  ftp://ftp.x.org/pub/individual/proto/damageproto-1.2.0.tar.bz2
20Provides: damageproto = 1.2.0
21Source3:  ftp://ftp.x.org/pub/individual/proto/dmxproto-2.3.tar.bz2
22Source4:  ftp://ftp.x.org/pub/individual/proto/evieext-1.1.0.tar.bz2
23Source5:  ftp://ftp.x.org/pub/individual/proto/fixesproto-4.1.1.tar.bz2
24Provides: fixesproto = 4.1.1
25Source6:  ftp://ftp.x.org/pub/individual/proto/fontcacheproto-0.1.3.tar.bz2
26Source7:  ftp://ftp.x.org/pub/individual/proto/fontsproto-2.1.0.tar.bz2
27Source8:  ftp://ftp.x.org/pub/individual/proto/glproto-1.4.10.tar.bz2
28Provides: glproto = 1.4.10
29Source9:  ftp://ftp.x.org/pub/individual/proto/inputproto-2.0.tar.bz2
30Provides: inputproto = 2.0
31Source10: ftp://ftp.x.org/pub/individual/proto/kbproto-1.0.4.tar.bz2
32Provides: kbproto = 1.0.4
33Source13: ftp://ftp.x.org/pub/individual/proto/randrproto-1.3.1.tar.bz2
34Provides: randrproto = 1.3.1
35Source14: ftp://ftp.x.org/pub/individual/proto/recordproto-1.14.tar.bz2
36Source15: ftp://ftp.x.org/pub/individual/proto/renderproto-0.11.tar.bz2
37Provides: renderproto = 0.11
38Source16: ftp://ftp.x.org/pub/individual/proto/resourceproto-1.1.0.tar.bz2
39Source17: ftp://ftp.x.org/pub/individual/proto/scrnsaverproto-1.2.0.tar.bz2
40Provides: scrnsaverproto = 1.2.0
41Source18: ftp://ftp.x.org/pub/individual/proto/trapproto-3.4.3.tar.bz2
42Source19: ftp://ftp.x.org/pub/individual/proto/videoproto-2.3.0.tar.bz2
43Source20: ftp://ftp.x.org/pub/individual/proto/xcmiscproto-1.2.0.tar.bz2
44Source21: ftp://ftp.x.org/pub/individual/proto/xextproto-7.1.1.tar.bz2
45Provides: xextproto = 7.1.1
46Source22: ftp://ftp.x.org/pub/individual/proto/xf86bigfontproto-1.2.0.tar.bz2
47Source23: ftp://ftp.x.org/pub/individual/proto/xf86dgaproto-2.1.tar.bz2
48Provides: xf86dgaproto = 2.1
49Source24: ftp://ftp.x.org/pub/individual/proto/xf86driproto-2.1.0.tar.bz2
50Source25: ftp://ftp.x.org/pub/individual/proto/xf86miscproto-0.9.3.tar.bz2
51Source26: ftp://ftp.x.org/pub/individual/proto/xf86rushproto-1.1.2.tar.bz2
52Source27: ftp://ftp.x.org/pub/individual/proto/xf86vidmodeproto-2.3.tar.bz2
53Source28: ftp://ftp.x.org/pub/individual/proto/xineramaproto-1.2.tar.bz2
54Source29: ftp://ftp.x.org/pub/individual/proto/xproto-7.0.16.tar.bz2
55Provides: xproto = 7.0.16
56Source30: ftp://ftp.x.org/pub/individual/proto/xproxymanagementprotocol-1.0.3.tar.bz2
57Source31: http://xorg.freedesktop.org/archive/individual/proto/dri2proto-2.1.tar.bz2
58Provides: dri2proto = 2.1
59
60BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
61BuildArch: noarch
62BuildRequires: pkgconfig
63BuildRequires: xorg-x11-util-macros
64Obsoletes: XFree86-devel, XOrg-devel
65
66# NOTE: This dependency on xorg-x11-filesystem is required to work around
67# a nasty upgrade problem when going from FC4->FC5 or monolithic to
68# modular X.Org.  Bug #173384.
69Requires(pre): xorg-x11-filesystem >= 0.99.2-3
70
71%if ! %{build_bootstrap}
72Requires: mesa-libGL-devel
73Requires: libXau-devel
74%endif
75Requires: pkgconfig
76
77Vendor: Project Vine
78Distribution: Vine Linux
79Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
80
81%description
82X.Org X11 Protocol headers
83
84%prep
85%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a13 -a14 -a15 -a16 -a17 -a18 -a19 -a20 -a21 -a22 -a23 -a24 -a25 -a26 -a27 -a28 -a29 -a30 -a31
86
87%build
88
89# Proceed through each proto package directory, building them all
90for dir in $(ls -1) ; do
91        pushd $dir
92        # yes, this looks horrible, but it's to get the .pc files in datadir
93        %configure --libdir=%{_datadir}
94        make %{?_smp_mflags}
95        mv COPYING COPYING-${dir%%-*}
96        popd
97done
98
99%install
100rm -rf $RPM_BUILD_ROOT
101for dir in $(ls -1) ; do
102        pushd $dir
103        make install DESTDIR=$RPM_BUILD_ROOT
104        install -m 444 COPYING-${dir%%-*} $OLDPWD
105        popd
106done
107for i in composite damage fixes randr render ; do
108    mv $RPM_BUILD_ROOT/usr/share/doc/${i}proto/${i}proto.txt .
109done
110mv $RPM_BUILD_ROOT%{_docdir}/xproxymanagementprotocol/PM_spec .
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(-,root,root,-)
117%doc COPYING-*
118%doc compositeproto.txt
119%doc damageproto.txt
120%doc randrproto.txt
121%doc renderproto.txt
122%doc fixesproto.txt
123%doc PM_spec
124
125%dir %{_includedir}/GL
126%{_includedir}/GL/glxint.h
127%{_includedir}/GL/glxmd.h
128%{_includedir}/GL/glxproto.h
129%{_includedir}/GL/glxtokens.h
130%dir %{_includedir}/GL/internal
131%{_includedir}/GL/internal/glcore.h
132
133%dir %{_includedir}/X11
134%{_includedir}/X11/DECkeysym.h
135%{_includedir}/X11/HPkeysym.h
136%dir %{_includedir}/X11/PM
137%{_includedir}/X11/PM/PM.h
138%{_includedir}/X11/PM/PMproto.h
139%{_includedir}/X11/Sunkeysym.h
140%{_includedir}/X11/X.h
141%{_includedir}/X11/XF86keysym.h
142%{_includedir}/X11/XWDFile.h
143%{_includedir}/X11/Xalloca.h
144%{_includedir}/X11/Xarch.h
145%{_includedir}/X11/Xatom.h
146%{_includedir}/X11/Xdefs.h
147%{_includedir}/X11/Xfuncproto.h
148%{_includedir}/X11/Xfuncs.h
149%{_includedir}/X11/Xmd.h
150%{_includedir}/X11/Xos.h
151%{_includedir}/X11/Xos_r.h
152%{_includedir}/X11/Xosdefs.h
153%{_includedir}/X11/Xpoll.h
154%{_includedir}/X11/Xproto.h
155%{_includedir}/X11/Xprotostr.h
156%{_includedir}/X11/Xthreads.h
157%{_includedir}/X11/Xw32defs.h
158%{_includedir}/X11/Xwindows.h
159%{_includedir}/X11/Xwinsock.h
160%{_includedir}/X11/ap_keysym.h
161
162%dir %{_includedir}/X11/dri
163%{_includedir}/X11/dri/xf86dri.h
164%{_includedir}/X11/dri/xf86driproto.h
165%{_includedir}/X11/dri/xf86dristr.h
166
167%dir %{_includedir}/X11/extensions
168%{_includedir}/X11/extensions/EVI.h
169%{_includedir}/X11/extensions/EVIproto.h
170%{_includedir}/X11/extensions/XI.h
171%{_includedir}/X11/extensions/XI2.h
172%{_includedir}/X11/extensions/XI2proto.h
173%{_includedir}/X11/extensions/XIproto.h
174%{_includedir}/X11/extensions/XKB.h
175%{_includedir}/X11/extensions/XKBgeom.h
176%{_includedir}/X11/extensions/XKBproto.h
177%{_includedir}/X11/extensions/XKBsrv.h
178%{_includedir}/X11/extensions/XKBstr.h
179%{_includedir}/X11/extensions/XResproto.h
180%{_includedir}/X11/extensions/Xeviestr.h
181%{_includedir}/X11/extensions/Xv.h
182%{_includedir}/X11/extensions/XvMC.h
183%{_includedir}/X11/extensions/XvMCproto.h
184%{_includedir}/X11/extensions/Xvproto.h
185%{_includedir}/X11/extensions/ag.h
186%{_includedir}/X11/extensions/agproto.h
187%{_includedir}/X11/extensions/bigreqsproto.h
188%{_includedir}/X11/extensions/bigreqstr.h
189%{_includedir}/X11/extensions/composite.h
190%{_includedir}/X11/extensions/compositeproto.h
191%{_includedir}/X11/extensions/cup.h
192%{_includedir}/X11/extensions/cupproto.h
193%{_includedir}/X11/extensions/damageproto.h
194%{_includedir}/X11/extensions/damagewire.h
195%{_includedir}/X11/extensions/dbe.h
196%{_includedir}/X11/extensions/dbeproto.h
197%{_includedir}/X11/extensions/dmx.h
198%{_includedir}/X11/extensions/dmxproto.h
199%{_includedir}/X11/extensions/dpmsconst.h
200%{_includedir}/X11/extensions/dpmsproto.h
201%{_includedir}/X11/extensions/dri2proto.h
202%{_includedir}/X11/extensions/dri2tokens.h
203%{_includedir}/X11/extensions/evieproto.h
204%{_includedir}/X11/extensions/ge.h
205%{_includedir}/X11/extensions/geproto.h
206%{_includedir}/X11/extensions/lbx.h
207%{_includedir}/X11/extensions/lbxproto.h
208%{_includedir}/X11/extensions/mitmiscconst.h
209%{_includedir}/X11/extensions/mitmiscproto.h
210%{_includedir}/X11/extensions/multibufconst.h
211%{_includedir}/X11/extensions/multibufproto.h
212%{_includedir}/X11/extensions/panoramiXproto.h
213%{_includedir}/X11/extensions/randr.h
214%{_includedir}/X11/extensions/randrproto.h
215%{_includedir}/X11/extensions/recordconst.h
216%{_includedir}/X11/extensions/recordproto.h
217%{_includedir}/X11/extensions/recordstr.h
218%{_includedir}/X11/extensions/render.h
219%{_includedir}/X11/extensions/renderproto.h
220%{_includedir}/X11/extensions/saver.h
221%{_includedir}/X11/extensions/saverproto.h
222%{_includedir}/X11/extensions/secur.h
223%{_includedir}/X11/extensions/securproto.h
224%{_includedir}/X11/extensions/shapeconst.h
225%{_includedir}/X11/extensions/shapeproto.h
226%{_includedir}/X11/extensions/shm.h
227%{_includedir}/X11/extensions/shmproto.h
228%{_includedir}/X11/extensions/syncconst.h
229%{_includedir}/X11/extensions/syncproto.h
230%{_includedir}/X11/extensions/vldXvMC.h
231%{_includedir}/X11/extensions/xcmiscproto.h
232%{_includedir}/X11/extensions/xcmiscstr.h
233%{_includedir}/X11/extensions/xf86bigfont.h
234%{_includedir}/X11/extensions/xf86bigfproto.h
235%{_includedir}/X11/extensions/xf86bigfstr.h
236%{_includedir}/X11/extensions/xf86dga.h
237%{_includedir}/X11/extensions/xf86dga1const.h
238%{_includedir}/X11/extensions/xf86dga1proto.h
239%{_includedir}/X11/extensions/xf86dga1str.h
240%{_includedir}/X11/extensions/xf86dgaconst.h
241%{_includedir}/X11/extensions/xf86dgaproto.h
242%{_includedir}/X11/extensions/xf86dgastr.h
243%{_includedir}/X11/extensions/xf86misc.h
244%{_includedir}/X11/extensions/xf86mscstr.h
245%{_includedir}/X11/extensions/xf86vm.h
246%{_includedir}/X11/extensions/xf86vmproto.h
247%{_includedir}/X11/extensions/xf86vmstr.h
248%{_includedir}/X11/extensions/xfixesproto.h
249%{_includedir}/X11/extensions/xfixeswire.h
250%{_includedir}/X11/extensions/xtestconst.h
251%{_includedir}/X11/extensions/xtestext1const.h
252%{_includedir}/X11/extensions/xtestext1proto.h
253%{_includedir}/X11/extensions/xtestproto.h
254
255%dir %{_includedir}/X11/fonts
256%{_includedir}/X11/fonts/FS.h
257%{_includedir}/X11/fonts/FSproto.h
258%{_includedir}/X11/fonts/font.h
259%{_includedir}/X11/fonts/fontproto.h
260%{_includedir}/X11/fonts/fontstruct.h
261%{_includedir}/X11/fonts/fsmasks.h
262
263%{_includedir}/X11/keysym.h
264%{_includedir}/X11/keysymdef.h
265
266%{_datadir}/pkgconfig/bigreqsproto.pc
267%{_datadir}/pkgconfig/compositeproto.pc
268%{_datadir}/pkgconfig/damageproto.pc
269%{_datadir}/pkgconfig/dmxproto.pc
270%{_datadir}/pkgconfig/dri2proto.pc
271%{_datadir}/pkgconfig/evieproto.pc
272%{_datadir}/pkgconfig/fixesproto.pc
273%{_datadir}/pkgconfig/fontcacheproto.pc
274%{_datadir}/pkgconfig/fontsproto.pc
275%{_datadir}/pkgconfig/glproto.pc
276%{_datadir}/pkgconfig/inputproto.pc
277%{_datadir}/pkgconfig/kbproto.pc
278%{_datadir}/pkgconfig/randrproto.pc
279%{_datadir}/pkgconfig/recordproto.pc
280%{_datadir}/pkgconfig/renderproto.pc
281%{_datadir}/pkgconfig/resourceproto.pc
282%{_datadir}/pkgconfig/scrnsaverproto.pc
283%{_datadir}/pkgconfig/trapproto.pc
284%{_datadir}/pkgconfig/videoproto.pc
285%{_datadir}/pkgconfig/xcmiscproto.pc
286%{_datadir}/pkgconfig/xextproto.pc
287%{_datadir}/pkgconfig/xf86bigfontproto.pc
288%{_datadir}/pkgconfig/xf86dgaproto.pc
289%{_datadir}/pkgconfig/xf86driproto.pc
290%{_datadir}/pkgconfig/xf86miscproto.pc
291%{_datadir}/pkgconfig/xf86rushproto.pc
292%{_datadir}/pkgconfig/xf86vidmodeproto.pc
293%{_datadir}/pkgconfig/xineramaproto.pc
294%{_datadir}/pkgconfig/xproto.pc
295%{_datadir}/pkgconfig/xproxymngproto.pc
296
297%changelog
298* Sun Nov 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
299- bigreqsproto-1.1.0
300- compositeproto-0.4.1
301- damageproto-1.2.0
302- dmxproto-2.3
303- evieext-1.1.0
304- fixesproto-4.1.1
305- fontcacheproto-0.1.3
306- fontsproto-2.1.0
307- inputproto-2.0
308- kbproto-1.0.4
309- randrproto-1.3.1
310- recordproto-1.13
311- renderproto-0.11
312- resourceproto-1.1.0
313- scrnsaverproto-1.2.0
314- videoproto-2.3.0
315- xcmisproto-1.2.0
316- xextproto-7.1.1
317- xf86bigfontproto-1.2.0
318- xf86dgaproto-2.1
319- xf86driproto-2.1.0
320- xf86miscproto-0.9.3
321- xf86vidmodeproto-2.3
322- xineramaproto-1.2
323- xproto-7.0.16
324- xproxymanagementprotocol-1.0.3
325
326* Thu Jul 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-9
327- dri2protp-2.1
328- glproto-1.4.10
329
330* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-8
331- dri2proto-2.0
332
333* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4-7
334- changed Group to Development/Libraries
335
336* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-6
337- dri2proto-1.99.3
338
339* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-5
340- xproto-7.0.15
341- randrproto-1.3.0
342
343* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-4
344- xextproto-7.0.4
345
346* Sun Nov 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
347- inputproto-1.5.0
348
349* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
350- xproto-7.0.14
351
352* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
353- inputproto-1.4.4
354- randrproto-1.2.2
355
356* Tue Jul 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
357- xproto 7.0.13
358- xextproto 7.0.3
359- xf86driproto 2.0.4
360- inputproto 1.4.3
361- add dri2proto
362
363* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
364- new versioning policy
365
366* Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
367- build with mesa and libXau
368
369* Sat Jan 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl0
370- initial build for Vine Linux (bootstrap)
371
372* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 7.3-7
373- inputproto-1.4.2-card32.patch: Make sure CARD32 is defined on lp64.
374
375* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 7.3-6
376- renderproto 0.9.3
377
378* Fri Nov  9 2007 Kristian H淡gsberg <krh@redhat.com> - 7.3-5
379- Bump and rebuild.
380
381* Thu Oct 25 2007 Kristian H淡gsberg <krh@redhat.com> 7.3-4
382- Pull in new glproto to get proto structs for GLX_SGIX_pbuffer.
383
384* Thu Oct 11 2007 Adam Jackson <ajax@redhat.com> 7.3-3
385- BuildArch: noarch
386
387* Thu Oct 11 2007 Adam Jackson <ajax@redhat.com> 7.3-3
388- BuildArch: noarch
389
390* Thu Sep 27 2007 Adam Jackson <ajax@redhat.com> 7.3-2
391- Require libXau-devel when not doing arch bootstrap (#207391)
392
393* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
394- dgaproto 2.0.3
395- Bump to 7.3
396
397* Wed Aug 29 2007 Adam Jackson <ajax@redhat.com> 7.2-13
398- Remove the horrible header hack, in favor of proper fix in xserver itself.
399
400* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-12
401- Remove dri_interface.h.  It's not protocol, it belongs in Mesa.
402
403* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-11
404- compositeproto 0.4
405
406* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-10
407- inputproto-1.4.2-horrible-header-hack.patch: Re-add some #defines from
408  older inputproto to make old drivers build.  Do not commit this patch
409  upstream.
410
411* Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 7.2-9
412- inputproto 1.4.2
413
414* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 7.2-8
415- Add virtual provides for the subprotocols (#231156)
416
417* Mon Apr 02 2007 Adam Jackson <ajax@redhat.com> 7.2-7
418- inputproto 1.4.1
419
420* Mon Mar 12 2007 Adam Jackson <ajax@redhat.com> 7.2-6
421- Fix doc macros as per package review (#226641)
422
423* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-5
424- Package review cleanups (#226641)
425
426* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-4
427- Appease RPM. (#229336)
428
429* Fri Feb 23 2007 Adam Jackson <ajax@redhat.com> 7.2-3
430- damageproto 1.1.0
431
432* Mon Feb 19 2007 Adam Jackson <ajax@redhat.com> 7.2-2
433- randrproto 1.2.1
434
435* Mon Feb 12 2007 Adam Jackson <ajax@redhat.com> 7.2-1
436- randrproto 1.2
437- Superstition bump to 7.2
438
439* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 7.1-11
440- xproto 7.0.10
441
442* Tue Oct 3 2006 Adam Jackson <ajackson@redhat.com> 7.1-10
443- Install just enough LBX headers to make libXext build. (#203815)
444
445* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 7.1-9
446- rebuilt for unwind info generation, broken in gcc-4.1.1-21
447
448* Wed Sep 20 2006 Kristian H淡gsberg <krh@redhat.com> - 7.1-8.fc6
449- Update to 1.4.8 to get the finaly update of GLX_EXT_tfp opcodes.
450
451* Fri Sep  8 2006 Soren Sandmann <sandmann@redhat.com> 7.1-7.fc6
452- Remove printproto source. Rest of 175350.
453
454* Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> 7.1-6.fc6
455- Don't install xprint headers, as they are being moved to the libXp
456  package instead. Bug 175350.
457
458* Thu Jul 27 2006 Mike A. Harris <mharris@redhat.com> 7.1-5.fc6
459- Don't install LBX protocol headers, as LBX is obsoleted in the 7.1 release
460  and no longer supported.
461
462* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 7.1-4
463- Use dist tag.  Update to kbproto-1.0.3.
464
465* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> 7.1-3
466- Tag as 7.1-3.fc5.aiglx.
467
468* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> 7.1-3
469- Add dist tag.
470
471* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
472- rebuild
473
474* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-2
475- Update to xproto 7.0.7 for X11R7.1
476- Use "make install" instead of makeinstall macro.
477
478* Thu May 25 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
479- Bump package version-release to 7.1-1 for X.Org X11R7.1 release.
480
481* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 7.0-13
482- Update to glproto 1.4.7 for final EXT_tfp defines
483
484* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 7.0-12
485- Update to xproto 7.0.5 for misc fixes
486
487* Fri Apr 07 2006 Adam Jackson <ajackson@redhat.com> 7.0-10
488- Update to compositeproto-0.3.1 to fix big-endian LP64.
489
490* Sat Apr 01 2006 Adam Jackson <ajackson@redhat.com> 7.0-9
491- Update to scrnsaverproto-1.1
492
493* Mon Mar 20 2006 Adam Jackson <ajackson@redhat.com> 7.0-8
494- Fix the base URL.
495
496* Wed Mar 15 2006 Adam Jackson <ajackson@redhat.com> 7.0-7
497- Update to fixesproto-4.0, compositeproto-0.3, and glproto-1.4.6
498
499* Wed Mar 01 2006 Mike A. Harris <mharris@redhat.com> 7.0-6
500- Update to glproto-1.4.5
501- Remove xorg-x11-proto-devel-7.0-buffer-values.patch which is in 1.4.5.
502
503* Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> 7.0-5
504- require mesa-libGL-devel since it's needed by some of the headers
505
506* Sun Feb 19 2006 Ray Strode <rstrode@redhat.com> 7.0-4
507- Add back part of glproto-texture-from-drawable patch that didn't
508  get integrated for some reason
509
510* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 7.0-3
511- Update to glproto-1.4.4
512- Drop glproto-texture-from-drawable patch, which is integrated now.
513
514* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 7.0-2.3
515- bump again for double-long bug on ppc(64)
516
517* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 7.0-2.1
518- rebuilt for new gcc4.1 snapshot and glibc changes
519
520* Fri Jan 27 2006 Kristian H淡gsberg <krh@redhat.com> 7.0-2
521- Add glproto-texture-from-drawable.patch to add opcodes and tokens
522  for GLX_texture_from_drawable extension.
523
524* Fri Dec 23 2005 Mike A. Harris <mharris@redhat.com> 7.0-1
525- Update to damageproto-1.0.3, glproto-1.4.3, xf86driproto-2.0.2 from the
526  X11R7.0 final release.
527- Bump package version to 7.0 to match the X11R7 version, for no particularly
528  strong reason other than "it feels good".
529
530* Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.4-1
531- Update all proto tarballs to the RC4 release.
532
533* Wed Dec 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
534- Update to printproto-1.0.2, trapproto-3.4.2, xproto-7.0.3 from the
535  X11R7 RC3 release.
536
537* Mon Nov 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
538- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-1" to attempt to
539  workaround bug( #173384).
540
541* Thu Nov 17 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
542- Change Conflicts to "Obsoletes: XFree86-devel, xorg-x11-devel"
543
544* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
545- Update to X11R7 RC2 release, picking up new xproto-7.0.2.
546
547* Thu Oct 20 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
548- This package contains only C header files and pkg-config *.pc files,
549  and does not contain any ELF binaries or DSOs, so we disable debuginfo
550  generation.
551
552* Thu Oct 20 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
553- Update all tarballs to X11R7 RC1 release.
554- Remove panoramixproto, as it is now known as xineramaproto.
555- Remove glu.h and glx.h from file manifest, as they're provided by Mesa.
556- Added {_includedir}/GL/internal/dri_interface.h to file manifest.
557
558* Sun Oct 02 2005 Mike A. Harris <mharris@redhat.com> 0.0.1-3
559- Use Fedora-Extras style BuildRoot
560- Invoke make with _smp_mflags
561- Add full URLs to SourceN lines
562
563* Mon Sep 12 2005 Kristian H淡gsberg <krh@redhat.com> 0.0.1-2
564- Update to 20050912 cvs snapshot of kbproto.
565
566* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.0.1-1
567- Changed for loop in build section to use "ls -1" instead of find "*proto*"
568  when going through protocol dirs, as "evieext" just *HAD* to be named
569  something completely different from everything else, in true X.Org
570  inconsistency fashion.
571- Added Conflicts with XFree86-devel and xorg-x11-devel.
572
573* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.0.1-0
574- Initial build of xproto from X.Org modular CVS checkout and "make dist".
575- Since there are no upstream tarballs yet, and "make dist" generates
576  a "7.0" non-beta final version, I changed the version to 0.0 as I've no
577  idea what the intention is and want to avoid using Epoch later.
Note: See TracBrowser for help on using the repository browser.