source: projects/specs/trunk/x/xorg-x11-proto-devel/xorg-x11-proto-devel-vl.spec @ 5538

Revision 5538, 22.4 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# INFO: When doing a bootstrap build on a new architecture, set this to 1 to
2# avoid build loops.
3%define build_bootstrap 0
4
5Summary: X.Org X11 Protocol headers
6Summary(ja): X.Org X11 プロトコルヘッダファイル
7Name: xorg-x11-proto-devel
8Version: 7.6
9Release: 4%{?_dist_release}
10License: MIT
11Group: Development/Libraries
12URL: http://www.x.org
13
14# Add virtual provides lazily as they get updated, so the server and libs
15# can depend on specific proto versions instead of this package's version.
16Source0:  ftp://ftp.x.org/pub/individual/proto/bigreqsproto-1.1.1.tar.bz2
17Source1:  ftp://ftp.x.org/pub/individual/proto/compositeproto-0.4.2.tar.bz2
18Provides: compositeproto = 0.4.2
19Source2:  ftp://ftp.x.org/pub/individual/proto/damageproto-1.2.1.tar.bz2
20Provides: damageproto = 1.2.1
21Source3:  ftp://ftp.x.org/pub/individual/proto/dmxproto-2.3.1.tar.bz2
22Source4:  ftp://ftp.x.org/pub/individual/proto/evieext-1.1.1.tar.bz2
23Source5:  ftp://ftp.x.org/pub/individual/proto/fixesproto-5.0.tar.bz2
24Provides: fixesproto = 5.0
25Source6:  ftp://ftp.x.org/pub/individual/proto/fontcacheproto-0.1.3.tar.bz2
26Source7:  ftp://ftp.x.org/pub/individual/proto/fontsproto-2.1.1.tar.bz2
27Source8:  ftp://ftp.x.org/pub/individual/proto/glproto-1.4.15.tar.bz2
28Provides: glproto = 1.4.15
29Source9:  ftp://ftp.x.org/pub/individual/proto/inputproto-2.1.tar.bz2
30Provides: inputproto = 2.1
31Source10: ftp://ftp.x.org/pub/individual/proto/kbproto-1.0.5.tar.bz2
32Provides: kbproto = 1.0.5
33Source13: ftp://ftp.x.org/pub/individual/proto/randrproto-1.3.2.tar.bz2
34Provides: randrproto = 1.3.2
35Source14: ftp://ftp.x.org/pub/individual/proto/recordproto-1.14.1.tar.bz2
36Source15: ftp://ftp.x.org/pub/individual/proto/renderproto-0.11.1.tar.bz2
37Provides: renderproto = 0.11.1
38Source16: ftp://ftp.x.org/pub/individual/proto/resourceproto-1.2.0.tar.bz2
39Source17: ftp://ftp.x.org/pub/individual/proto/scrnsaverproto-1.2.1.tar.bz2
40Provides: scrnsaverproto = 1.2.1
41Source18: ftp://ftp.x.org/pub/individual/proto/trapproto-3.4.3.tar.bz2
42Source19: ftp://ftp.x.org/pub/individual/proto/videoproto-2.3.1.tar.bz2
43Source20: ftp://ftp.x.org/pub/individual/proto/xcmiscproto-1.2.1.tar.bz2
44Source21: ftp://ftp.x.org/pub/individual/proto/xextproto-7.2.0.tar.bz2
45Provides: xextproto = 7.2.0
46Source22: ftp://ftp.x.org/pub/individual/proto/xf86bigfontproto-1.2.0.tar.bz2
47Source23: ftp://ftp.x.org/pub/individual/proto/xf86dgaproto-2.1.tar.bz2
48Provides: xf86dgaproto = 2.1
49Source24: ftp://ftp.x.org/pub/individual/proto/xf86driproto-2.1.1.tar.bz2
50Source25: ftp://ftp.x.org/pub/individual/proto/xf86miscproto-0.9.3.tar.bz2
51Source26: ftp://ftp.x.org/pub/individual/proto/xf86rushproto-1.1.2.tar.bz2
52Source27: ftp://ftp.x.org/pub/individual/proto/xf86vidmodeproto-2.3.1.tar.bz2
53Source28: ftp://ftp.x.org/pub/individual/proto/xineramaproto-1.2.1.tar.bz2
54Source29: ftp://ftp.x.org/pub/individual/proto/xproto-7.0.22.tar.bz2
55Provides: xproto = 7.0.22
56Source30: ftp://ftp.x.org/pub/individual/proto/xproxymanagementprotocol-1.0.3.tar.bz2
57Source31: ftp://ftp.x.org/pub/individual/proto/dri2proto-2.6.tar.bz2
58Provides: dri2proto = 2.6
59
60BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
61BuildArch: noarch
62BuildRequires: pkgconfig
63BuildRequires: xorg-x11-util-macros
64Obsoletes: XFree86-devel, XOrg-devel
65
66# NOTE: This dependency on xorg-x11-filesystem is required to work around
67# a nasty upgrade problem when going from FC4->FC5 or monolithic to
68# modular X.Org.  Bug #173384.
69Requires(pre): xorg-x11-filesystem >= 0.99.2-3
70
71%if ! %{build_bootstrap}
72Requires: mesa-libGL-devel
73Requires: libXau-devel
74%endif
75Requires: pkgconfig
76
77Vendor: Project Vine
78Distribution: Vine Linux
79Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
80
81%description
82X.Org X11 Protocol headers
83
84%prep
85%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a13 -a14 -a15 -a16 -a17 -a18 -a19 -a20 -a21 -a22 -a23 -a24 -a25 -a26 -a27 -a28 -a29 -a30 -a31
86
87%build
88
89# Proceed through each proto package directory, building them all
90for dir in $(ls -1) ; do
91        pushd $dir
92        # yes, this looks horrible, but it's to get the .pc files in datadir
93        %configure --libdir=%{_datadir}
94        make %{?_smp_mflags}
95        mv COPYING COPYING-${dir%%-*}
96        popd
97done
98
99%install
100rm -rf $RPM_BUILD_ROOT
101for dir in $(ls -1) ; do
102        pushd $dir
103        make install DESTDIR=$RPM_BUILD_ROOT
104        install -m 444 COPYING-${dir%%-*} $OLDPWD
105        popd
106done
107for i in composite damage dri2 fixes randr render ; do
108    mv $RPM_BUILD_ROOT/usr/share/doc/${i}proto/${i}proto.txt .
109done
110mv $RPM_BUILD_ROOT%{_docdir}/xproxymanagementprotocol/PM_spec .
111
112mv $RPM_BUILD_ROOT%{_docdir}/videoproto/xv-protocol-v2.txt .
113mv $RPM_BUILD_ROOT%{_docdir}/resourceproto/resproto.txt .
114
115# remove xml file and directory
116for i in bigreqs dri2 fonts input record scrnsaver xcmisc xext x ; do
117    rm -rf $RPM_BUILD_ROOT/usr/share/doc/${i}proto
118done
119rm -rf $RPM_BUILD_ROOT/usr/share/doc/resourceproto
120
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(-,root,root,-)
127%doc COPYING-*
128%doc compositeproto.txt
129%doc damageproto.txt
130%doc dri2proto.txt
131%doc randrproto.txt
132%doc renderproto.txt
133%doc fixesproto.txt
134%doc resproto.txt
135%doc PM_spec
136
137%dir %{_includedir}/GL
138%{_includedir}/GL/glxint.h
139%{_includedir}/GL/glxmd.h
140%{_includedir}/GL/glxproto.h
141%{_includedir}/GL/glxtokens.h
142%dir %{_includedir}/GL/internal
143%{_includedir}/GL/internal/glcore.h
144
145%dir %{_includedir}/X11
146%{_includedir}/X11/DECkeysym.h
147%{_includedir}/X11/HPkeysym.h
148%dir %{_includedir}/X11/PM
149%{_includedir}/X11/PM/PM.h
150%{_includedir}/X11/PM/PMproto.h
151%{_includedir}/X11/Sunkeysym.h
152%{_includedir}/X11/X.h
153%{_includedir}/X11/XF86keysym.h
154%{_includedir}/X11/XWDFile.h
155%{_includedir}/X11/Xalloca.h
156%{_includedir}/X11/Xarch.h
157%{_includedir}/X11/Xatom.h
158%{_includedir}/X11/Xdefs.h
159%{_includedir}/X11/Xfuncproto.h
160%{_includedir}/X11/Xfuncs.h
161%{_includedir}/X11/Xmd.h
162%{_includedir}/X11/Xos.h
163%{_includedir}/X11/Xos_r.h
164%{_includedir}/X11/Xosdefs.h
165%{_includedir}/X11/Xpoll.h
166%{_includedir}/X11/Xproto.h
167%{_includedir}/X11/Xprotostr.h
168%{_includedir}/X11/Xthreads.h
169%{_includedir}/X11/Xw32defs.h
170%{_includedir}/X11/Xwindows.h
171%{_includedir}/X11/Xwinsock.h
172%{_includedir}/X11/ap_keysym.h
173
174%dir %{_includedir}/X11/dri
175%{_includedir}/X11/dri/xf86dri.h
176%{_includedir}/X11/dri/xf86driproto.h
177%{_includedir}/X11/dri/xf86dristr.h
178
179%dir %{_includedir}/X11/extensions
180%{_includedir}/X11/extensions/EVI.h
181%{_includedir}/X11/extensions/EVIproto.h
182%{_includedir}/X11/extensions/XI.h
183%{_includedir}/X11/extensions/XI2.h
184%{_includedir}/X11/extensions/XI2proto.h
185%{_includedir}/X11/extensions/XIproto.h
186%{_includedir}/X11/extensions/XKB.h
187%{_includedir}/X11/extensions/XKBgeom.h
188%{_includedir}/X11/extensions/XKBproto.h
189%{_includedir}/X11/extensions/XKBsrv.h
190%{_includedir}/X11/extensions/XKBstr.h
191%{_includedir}/X11/extensions/XResproto.h
192%{_includedir}/X11/extensions/Xeviestr.h
193%{_includedir}/X11/extensions/Xv.h
194%{_includedir}/X11/extensions/XvMC.h
195%{_includedir}/X11/extensions/XvMCproto.h
196%{_includedir}/X11/extensions/Xvproto.h
197%{_includedir}/X11/extensions/ag.h
198%{_includedir}/X11/extensions/agproto.h
199%{_includedir}/X11/extensions/bigreqsproto.h
200%{_includedir}/X11/extensions/bigreqstr.h
201%{_includedir}/X11/extensions/composite.h
202%{_includedir}/X11/extensions/compositeproto.h
203%{_includedir}/X11/extensions/cup.h
204%{_includedir}/X11/extensions/cupproto.h
205%{_includedir}/X11/extensions/damageproto.h
206%{_includedir}/X11/extensions/damagewire.h
207%{_includedir}/X11/extensions/dbe.h
208%{_includedir}/X11/extensions/dbeproto.h
209%{_includedir}/X11/extensions/dmx.h
210%{_includedir}/X11/extensions/dmxproto.h
211%{_includedir}/X11/extensions/dpmsconst.h
212%{_includedir}/X11/extensions/dpmsproto.h
213%{_includedir}/X11/extensions/dri2proto.h
214%{_includedir}/X11/extensions/dri2tokens.h
215%{_includedir}/X11/extensions/evieproto.h
216%{_includedir}/X11/extensions/fontcache.h
217%{_includedir}/X11/extensions/fontcacheP.h
218%{_includedir}/X11/extensions/fontcachstr.h
219%{_includedir}/X11/extensions/ge.h
220%{_includedir}/X11/extensions/geproto.h
221%{_includedir}/X11/extensions/lbx.h
222%{_includedir}/X11/extensions/lbxproto.h
223%{_includedir}/X11/extensions/mitmiscconst.h
224%{_includedir}/X11/extensions/mitmiscproto.h
225%{_includedir}/X11/extensions/multibufconst.h
226%{_includedir}/X11/extensions/multibufproto.h
227%{_includedir}/X11/extensions/panoramiXproto.h
228%{_includedir}/X11/extensions/randr.h
229%{_includedir}/X11/extensions/randrproto.h
230%{_includedir}/X11/extensions/recordconst.h
231%{_includedir}/X11/extensions/recordproto.h
232%{_includedir}/X11/extensions/recordstr.h
233%{_includedir}/X11/extensions/render.h
234%{_includedir}/X11/extensions/renderproto.h
235%{_includedir}/X11/extensions/saver.h
236%{_includedir}/X11/extensions/saverproto.h
237%{_includedir}/X11/extensions/secur.h
238%{_includedir}/X11/extensions/securproto.h
239%{_includedir}/X11/extensions/shapeconst.h
240%{_includedir}/X11/extensions/shapeproto.h
241%{_includedir}/X11/extensions/shapestr.h
242%{_includedir}/X11/extensions/shm.h
243%{_includedir}/X11/extensions/shmproto.h
244%{_includedir}/X11/extensions/shmstr.h
245%{_includedir}/X11/extensions/syncconst.h
246%{_includedir}/X11/extensions/syncproto.h
247%{_includedir}/X11/extensions/syncstr.h
248%{_includedir}/X11/extensions/vldXvMC.h
249%{_includedir}/X11/extensions/xcmiscproto.h
250%{_includedir}/X11/extensions/xcmiscstr.h
251%{_includedir}/X11/extensions/xf86bigfont.h
252%{_includedir}/X11/extensions/xf86bigfproto.h
253%{_includedir}/X11/extensions/xf86bigfstr.h
254%{_includedir}/X11/extensions/xf86dga.h
255%{_includedir}/X11/extensions/xf86dga1const.h
256%{_includedir}/X11/extensions/xf86dga1proto.h
257%{_includedir}/X11/extensions/xf86dga1str.h
258%{_includedir}/X11/extensions/xf86dgaconst.h
259%{_includedir}/X11/extensions/xf86dgaproto.h
260%{_includedir}/X11/extensions/xf86dgastr.h
261%{_includedir}/X11/extensions/xf86misc.h
262%{_includedir}/X11/extensions/xf86mscstr.h
263%{_includedir}/X11/extensions/xf86rush.h
264%{_includedir}/X11/extensions/xf86rushstr.h
265%{_includedir}/X11/extensions/xf86vm.h
266%{_includedir}/X11/extensions/xf86vmproto.h
267%{_includedir}/X11/extensions/xf86vmstr.h
268%{_includedir}/X11/extensions/xfixesproto.h
269%{_includedir}/X11/extensions/xfixeswire.h
270%{_includedir}/X11/extensions/xtestconst.h
271%{_includedir}/X11/extensions/xtestext1const.h
272%{_includedir}/X11/extensions/xtestext1proto.h
273%{_includedir}/X11/extensions/xtestproto.h
274%{_includedir}/X11/extensions/xtrapbits.h
275%{_includedir}/X11/extensions/xtrapddmi.h
276%{_includedir}/X11/extensions/xtrapdi.h
277%{_includedir}/X11/extensions/xtrapemacros.h
278%{_includedir}/X11/extensions/xtraplib.h
279%{_includedir}/X11/extensions/xtraplibp.h
280%{_includedir}/X11/extensions/xtrapproto.h
281
282%dir %{_includedir}/X11/fonts
283%{_includedir}/X11/fonts/FS.h
284%{_includedir}/X11/fonts/FSproto.h
285%{_includedir}/X11/fonts/font.h
286%{_includedir}/X11/fonts/fontproto.h
287%{_includedir}/X11/fonts/fontstruct.h
288%{_includedir}/X11/fonts/fsmasks.h
289
290%{_includedir}/X11/keysym.h
291%{_includedir}/X11/keysymdef.h
292
293%{_datadir}/pkgconfig/bigreqsproto.pc
294%{_datadir}/pkgconfig/compositeproto.pc
295%{_datadir}/pkgconfig/damageproto.pc
296%{_datadir}/pkgconfig/dmxproto.pc
297%{_datadir}/pkgconfig/dri2proto.pc
298%{_datadir}/pkgconfig/evieproto.pc
299%{_datadir}/pkgconfig/fixesproto.pc
300%{_datadir}/pkgconfig/fontcacheproto.pc
301%{_datadir}/pkgconfig/fontsproto.pc
302%{_datadir}/pkgconfig/glproto.pc
303%{_datadir}/pkgconfig/inputproto.pc
304%{_datadir}/pkgconfig/kbproto.pc
305%{_datadir}/pkgconfig/randrproto.pc
306%{_datadir}/pkgconfig/recordproto.pc
307%{_datadir}/pkgconfig/renderproto.pc
308%{_datadir}/pkgconfig/resourceproto.pc
309%{_datadir}/pkgconfig/scrnsaverproto.pc
310%{_datadir}/pkgconfig/trapproto.pc
311%{_datadir}/pkgconfig/videoproto.pc
312%{_datadir}/pkgconfig/xcmiscproto.pc
313%{_datadir}/pkgconfig/xextproto.pc
314%{_datadir}/pkgconfig/xf86bigfontproto.pc
315%{_datadir}/pkgconfig/xf86dgaproto.pc
316%{_datadir}/pkgconfig/xf86driproto.pc
317%{_datadir}/pkgconfig/xf86miscproto.pc
318%{_datadir}/pkgconfig/xf86rushproto.pc
319%{_datadir}/pkgconfig/xf86vidmodeproto.pc
320%{_datadir}/pkgconfig/xineramaproto.pc
321%{_datadir}/pkgconfig/xproto.pc
322%{_datadir}/pkgconfig/xproxymngproto.pc
323
324%changelog
325* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
326- glproto-1.4.15
327- inputproto-2.1
328
329* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
330- fixesproto-5.0
331- glproto-1.4.14
332- inputproto-2.0.2
333- resourceproto-1.2.0
334- xproto-7.0.22
335- dri2proto-2.6
336
337* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
338- xextproto-7.2.0
339
340* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
341- dmxproto-2.3.1
342- evieext-1.1.1
343- xf86driproto-2.1.1
344- xf86vidmodeproto-2.3.1
345- xineramaproto-1.2.1
346
347* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-6
348- inputproto-2.0.1
349- resourceproto-1.1.1
350- xproto-7.0.20
351
352* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-5
353- bigreqsproto-1.1.1
354- compositeproto-0.4.2
355- damageproto-1.2.1
356- fixesproto-4.1.2
357- fontsproto-2.1.1
358- glproto-1.4.12
359- kbproto-1.0.5
360- randrproto-1.3.2
361- recordproto-1.14.1
362- renderproto-0.11.1
363- scrnsaverproto-1.2.1
364- videoproto-2.3.1
365- xcmiscproto-1.2.1
366- xextproto-7.1.2
367- xproto-7.0.19
368
369* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
370- add %files
371  (add fontcache.h, fontcacheP.h.fontcachstr.h, xf86rush.h, xf86rushstr.h,
372       xtrapbits.h, xtrapddmi.h, xtrapdi.h, xtrapemacros.h, xtraplib.h,
373       xtraplibp.h, xtrapproto.h in %{_includedir}/X11/extensions)
374
375* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 7.5-3
376- build with rpm-4.8.1-1 for pkg-config file
377
378* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-2
379- glproto-1.4.11
380- dri2proto-2.3
381
382* Sun Nov 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
383- bigreqsproto-1.1.0
384- compositeproto-0.4.1
385- damageproto-1.2.0
386- dmxproto-2.3
387- evieext-1.1.0
388- fixesproto-4.1.1
389- fontcacheproto-0.1.3
390- fontsproto-2.1.0
391- inputproto-2.0
392- kbproto-1.0.4
393- randrproto-1.3.1
394- recordproto-1.13
395- renderproto-0.11
396- resourceproto-1.1.0
397- scrnsaverproto-1.2.0
398- videoproto-2.3.0
399- xcmisproto-1.2.0
400- xextproto-7.1.1
401- xf86bigfontproto-1.2.0
402- xf86dgaproto-2.1
403- xf86driproto-2.1.0
404- xf86miscproto-0.9.3
405- xf86vidmodeproto-2.3
406- xineramaproto-1.2
407- xproto-7.0.16
408- xproxymanagementprotocol-1.0.3
409
410* Thu Jul 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-9
411- dri2protp-2.1
412- glproto-1.4.10
413
414* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-8
415- dri2proto-2.0
416
417* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4-7
418- changed Group to Development/Libraries
419
420* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-6
421- dri2proto-1.99.3
422
423* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-5
424- xproto-7.0.15
425- randrproto-1.3.0
426
427* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-4
428- xextproto-7.0.4
429
430* Sun Nov 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
431- inputproto-1.5.0
432
433* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
434- xproto-7.0.14
435
436* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
437- inputproto-1.4.4
438- randrproto-1.2.2
439
440* Tue Jul 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
441- xproto 7.0.13
442- xextproto 7.0.3
443- xf86driproto 2.0.4
444- inputproto 1.4.3
445- add dri2proto
446
447* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
448- new versioning policy
449
450* Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
451- build with mesa and libXau
452
453* Sat Jan 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl0
454- initial build for Vine Linux (bootstrap)
455
456* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 7.3-7
457- inputproto-1.4.2-card32.patch: Make sure CARD32 is defined on lp64.
458
459* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 7.3-6
460- renderproto 0.9.3
461
462* Fri Nov  9 2007 Kristian H淡gsberg <krh@redhat.com> - 7.3-5
463- Bump and rebuild.
464
465* Thu Oct 25 2007 Kristian H淡gsberg <krh@redhat.com> 7.3-4
466- Pull in new glproto to get proto structs for GLX_SGIX_pbuffer.
467
468* Thu Oct 11 2007 Adam Jackson <ajax@redhat.com> 7.3-3
469- BuildArch: noarch
470
471* Thu Oct 11 2007 Adam Jackson <ajax@redhat.com> 7.3-3
472- BuildArch: noarch
473
474* Thu Sep 27 2007 Adam Jackson <ajax@redhat.com> 7.3-2
475- Require libXau-devel when not doing arch bootstrap (#207391)
476
477* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
478- dgaproto 2.0.3
479- Bump to 7.3
480
481* Wed Aug 29 2007 Adam Jackson <ajax@redhat.com> 7.2-13
482- Remove the horrible header hack, in favor of proper fix in xserver itself.
483
484* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-12
485- Remove dri_interface.h.  It's not protocol, it belongs in Mesa.
486
487* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-11
488- compositeproto 0.4
489
490* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-10
491- inputproto-1.4.2-horrible-header-hack.patch: Re-add some #defines from
492  older inputproto to make old drivers build.  Do not commit this patch
493  upstream.
494
495* Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 7.2-9
496- inputproto 1.4.2
497
498* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 7.2-8
499- Add virtual provides for the subprotocols (#231156)
500
501* Mon Apr 02 2007 Adam Jackson <ajax@redhat.com> 7.2-7
502- inputproto 1.4.1
503
504* Mon Mar 12 2007 Adam Jackson <ajax@redhat.com> 7.2-6
505- Fix doc macros as per package review (#226641)
506
507* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-5
508- Package review cleanups (#226641)
509
510* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-4
511- Appease RPM. (#229336)
512
513* Fri Feb 23 2007 Adam Jackson <ajax@redhat.com> 7.2-3
514- damageproto 1.1.0
515
516* Mon Feb 19 2007 Adam Jackson <ajax@redhat.com> 7.2-2
517- randrproto 1.2.1
518
519* Mon Feb 12 2007 Adam Jackson <ajax@redhat.com> 7.2-1
520- randrproto 1.2
521- Superstition bump to 7.2
522
523* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 7.1-11
524- xproto 7.0.10
525
526* Tue Oct 3 2006 Adam Jackson <ajackson@redhat.com> 7.1-10
527- Install just enough LBX headers to make libXext build. (#203815)
528
529* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 7.1-9
530- rebuilt for unwind info generation, broken in gcc-4.1.1-21
531
532* Wed Sep 20 2006 Kristian H淡gsberg <krh@redhat.com> - 7.1-8.fc6
533- Update to 1.4.8 to get the finaly update of GLX_EXT_tfp opcodes.
534
535* Fri Sep  8 2006 Soren Sandmann <sandmann@redhat.com> 7.1-7.fc6
536- Remove printproto source. Rest of 175350.
537
538* Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> 7.1-6.fc6
539- Don't install xprint headers, as they are being moved to the libXp
540  package instead. Bug 175350.
541
542* Thu Jul 27 2006 Mike A. Harris <mharris@redhat.com> 7.1-5.fc6
543- Don't install LBX protocol headers, as LBX is obsoleted in the 7.1 release
544  and no longer supported.
545
546* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 7.1-4
547- Use dist tag.  Update to kbproto-1.0.3.
548
549* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> 7.1-3
550- Tag as 7.1-3.fc5.aiglx.
551
552* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> 7.1-3
553- Add dist tag.
554
555* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
556- rebuild
557
558* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-2
559- Update to xproto 7.0.7 for X11R7.1
560- Use "make install" instead of makeinstall macro.
561
562* Thu May 25 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
563- Bump package version-release to 7.1-1 for X.Org X11R7.1 release.
564
565* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 7.0-13
566- Update to glproto 1.4.7 for final EXT_tfp defines
567
568* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 7.0-12
569- Update to xproto 7.0.5 for misc fixes
570
571* Fri Apr 07 2006 Adam Jackson <ajackson@redhat.com> 7.0-10
572- Update to compositeproto-0.3.1 to fix big-endian LP64.
573
574* Sat Apr 01 2006 Adam Jackson <ajackson@redhat.com> 7.0-9
575- Update to scrnsaverproto-1.1
576
577* Mon Mar 20 2006 Adam Jackson <ajackson@redhat.com> 7.0-8
578- Fix the base URL.
579
580* Wed Mar 15 2006 Adam Jackson <ajackson@redhat.com> 7.0-7
581- Update to fixesproto-4.0, compositeproto-0.3, and glproto-1.4.6
582
583* Wed Mar 01 2006 Mike A. Harris <mharris@redhat.com> 7.0-6
584- Update to glproto-1.4.5
585- Remove xorg-x11-proto-devel-7.0-buffer-values.patch which is in 1.4.5.
586
587* Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> 7.0-5
588- require mesa-libGL-devel since it's needed by some of the headers
589
590* Sun Feb 19 2006 Ray Strode <rstrode@redhat.com> 7.0-4
591- Add back part of glproto-texture-from-drawable patch that didn't
592  get integrated for some reason
593
594* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 7.0-3
595- Update to glproto-1.4.4
596- Drop glproto-texture-from-drawable patch, which is integrated now.
597
598* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 7.0-2.3
599- bump again for double-long bug on ppc(64)
600
601* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 7.0-2.1
602- rebuilt for new gcc4.1 snapshot and glibc changes
603
604* Fri Jan 27 2006 Kristian H淡gsberg <krh@redhat.com> 7.0-2
605- Add glproto-texture-from-drawable.patch to add opcodes and tokens
606  for GLX_texture_from_drawable extension.
607
608* Fri Dec 23 2005 Mike A. Harris <mharris@redhat.com> 7.0-1
609- Update to damageproto-1.0.3, glproto-1.4.3, xf86driproto-2.0.2 from the
610  X11R7.0 final release.
611- Bump package version to 7.0 to match the X11R7 version, for no particularly
612  strong reason other than "it feels good".
613
614* Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.4-1
615- Update all proto tarballs to the RC4 release.
616
617* Wed Dec 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
618- Update to printproto-1.0.2, trapproto-3.4.2, xproto-7.0.3 from the
619  X11R7 RC3 release.
620
621* Mon Nov 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
622- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-1" to attempt to
623  workaround bug( #173384).
624
625* Thu Nov 17 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
626- Change Conflicts to "Obsoletes: XFree86-devel, xorg-x11-devel"
627
628* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
629- Update to X11R7 RC2 release, picking up new xproto-7.0.2.
630
631* Thu Oct 20 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
632- This package contains only C header files and pkg-config *.pc files,
633  and does not contain any ELF binaries or DSOs, so we disable debuginfo
634  generation.
635
636* Thu Oct 20 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
637- Update all tarballs to X11R7 RC1 release.
638- Remove panoramixproto, as it is now known as xineramaproto.
639- Remove glu.h and glx.h from file manifest, as they're provided by Mesa.
640- Added {_includedir}/GL/internal/dri_interface.h to file manifest.
641
642* Sun Oct 02 2005 Mike A. Harris <mharris@redhat.com> 0.0.1-3
643- Use Fedora-Extras style BuildRoot
644- Invoke make with _smp_mflags
645- Add full URLs to SourceN lines
646
647* Mon Sep 12 2005 Kristian H淡gsberg <krh@redhat.com> 0.0.1-2
648- Update to 20050912 cvs snapshot of kbproto.
649
650* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.0.1-1
651- Changed for loop in build section to use "ls -1" instead of find "*proto*"
652  when going through protocol dirs, as "evieext" just *HAD* to be named
653  something completely different from everything else, in true X.Org
654  inconsistency fashion.
655- Added Conflicts with XFree86-devel and xorg-x11-devel.
656
657* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.0.1-0
658- Initial build of xproto from X.Org modular CVS checkout and "make dist".
659- Since there are no upstream tarballs yet, and "make dist" generates
660  a "7.0" non-beta final version, I changed the version to 0.0 as I've no
661  idea what the intention is and want to avoid using Epoch later.
Note: See TracBrowser for help on using the repository browser.