source: projects/specs/trunk/x/xorg-x11-drv-synaptics/xorg-x11-drv-synaptics-vl.spec @ 9108

Revision 9108, 9.5 KB checked in by Takemikaduchi, 9 years ago (diff)

xserver-1.16.2

Line 
1%define tarball xf86-input-synaptics
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/input
4
5Name:           xorg-x11-drv-synaptics
6Summary:        Xorg X11 synaptics input driver
7Summary(ja):    Xorg X11 synaptics 入力ドライバ
8Version:        1.8.1
9Release:        1%{?_dist_release}
10URL:            http://www.x.org
11License:        MIT
12Group:          User Interface/X Hardware Support
13
14Source0:        ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
15
16Source1:        50-synaptics.conf
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19ExcludeArch:    s390 s390x
20BuildRequires:  libtool, pkgconfig
21BuildRequires:  xorg-x11-server-sdk >= 1.6.0
22BuildRequires:  libX11-devel, libXi-devel, libXext-devel
23BuildRequires:  libXtst-devel
24BuildRequires:  libevdev-devel
25BuildRequires:  mtdev-devel
26BuildRequires:  xorg-x11-util-macros >= 1.3.0
27Requires:       xorg-x11-server-Xorg
28
29Provides:       synaptics = %{version}-%{release}
30Obsoletes:      synaptics < 0.15.0
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
37default operates in compatibility mode by emulating a standard mouse. However,
38by using a dedicated driver, more advanced features of the touchpad becomes
39available.
40
41Features:
42
43    * Movement with adjustable, non-linear acceleration and speed.
44    * Button events through short touching of the touchpad.
45    * Double-Button events through double short touching of the touchpad.
46    * Dragging through short touching and holding down the finger on the
47      touchpad.
48    * Middle and right button events on the upper and lower corner of the
49      touchpad.
50    * Vertical scrolling (button four and five events) through moving the
51      finger on the right side of the touchpad.
52    * The up/down button sends button four/five events.
53    * Horizontal scrolling (button six and seven events) through moving the
54      finger on the lower side of the touchpad.
55    * The multi-buttons send button four/five events, and six/seven events for
56      horizontal scrolling.
57    * Adjustable finger detection.
58      Multifinger taps: two finger for middle button and three finger for
59      right button events. (Needs hardware support. Not all models implement
60      this feature.)
61    * Run-time configuration using shared memory. This means you can change
62      parameter settings without restarting the X server.
63
64%description -l ja
65Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
66パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
67しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
68ます。
69
70機能:
71    * スピードと加速の調整が可能。
72    * タッチパッドに短く触れたらクリック。
73    * タッチパッドに2度短く触れたらダブルクリック。
74    * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
75    * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
76    * タッチパッドの右端を上下になぞる事で縦スクロール。
77      (ボタン4及びボタン5として動作)
78    * 上下ボタンをボタン4及びボタン5として動作。
79    * タッチパッドの下端を左右になぞることで横スクロール。
80      (ボタン6及びボタン7として動作)
81    * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
82    * 感度の調整が可能。
83    * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
84      (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
85    * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
86      設定を変更することができる。
87
88%prep
89%setup -q -n %{tarball}-%{version}
90
91%build
92autoreconf -v --install --force || exit 1
93%configure --disable-static
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install DESTDIR=$RPM_BUILD_ROOT
100
101# FIXME: Remove all libtool archives (*.la) from modules directory.  This
102# should be fixed in upstream Makefile.am or whatever.
103find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
104
105# install xorg.conf snippet
106install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
107install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root,-)
115%doc COPYING README
116%{_datadir}/X11/xorg.conf.d/*.conf
117%{driverdir}/synaptics_drv.so
118%{_bindir}/synclient
119%{_bindir}/syndaemon
120%{_mandir}/man4/synaptics.4*
121%{_mandir}/man1/synclient.1*
122%{_mandir}/man1/syndaemon.1*
123%{_includedir}/xorg/synaptics-properties.h
124%{_libdir}/pkgconfig/xorg-synaptics.pc
125
126%changelog
127* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
128- new upstream release
129
130* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
131- new upstream release
132- add BuildRequires: libevdev-devel
133
134* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
135- new upstream release
136
137* Wed Apr 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
138- new upstream release
139
140* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.2-1
141- new upstream release
142
143* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-1
144- new upstream release
145
146* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-1
147- new upstream release
148
149* Mon Jun 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
150- new upstream release
151
152* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
153- new upstream release
154- add BuildRequires: libXtst-devel
155
156* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.99.902-1
157- new upstream release
158- add BuildRequires: mtdev-devel
159
160* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.0-1
161- new upstream release
162
163* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
164- new upstream release
165
166* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
167- new upstream release
168
169* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.99.901-1
170- new upstream release
171
172* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-2
173- rebuild with xserver-1.9.2
174
175* Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
176- new upstream release
177
178* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-3
179- rebuild with rpm-4.8.1 for pkg-config file
180
181* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-2
182- move xorg.conf snippet to /usr/share/X11/xorg.conf.d
183
184* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
185- update to 1.2.2
186- drop hal support
187  - drop hal fdi policy
188  - remove R: hal
189- add xorg.conf snippet
190
191* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-3
192- rebuild with xserver-1.8rc (x86_64)
193
194* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
195- rebuild with xserver-1.8rc
196
197* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
198- new upstream release
199
200* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
201- new upstream release
202- add BR: xorg-x11-util-macros >= 1.3.0
203
204* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
205- new upstream release
206- remove Patch10: SHMconfig is not needed
207
208* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
209- new upstream release
210
211* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
212- new upstream release
213
214* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
215- new upstream release
216
217* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
218- use bundled fdi
219- add patch10 to enable SHMConfig on all synaptics devices.
220
221* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
222- new upstream release
223
224* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
225- new upstream version released from x.org
226- rename to xorg-x11-drv-synaptics
227- add Obsoletes/Provides synaptics
228- add patch1,2 from fedora
229  - patch1: reserve 5% on each side for edge detection.
230  - patch2: force a click if middle button emulation times out during ReadInput cycle.
231
232* Tue Jul  8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
233- fixed synaptics_drv.so path by using %%{_libdir}
234
235* Sun Jul  6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
236- add Patch0; add BuildRequires: libpciaccess-devel
237- built with xorg-x11-server-1.4.99.905
238
239* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
240- updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
241- built with xorg-x11
242- spec encoding converted to UTF-8
243
244* Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
245- source update.
246- build for VineSeed (4.0) Plus.
247
248* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
249- build for Vine Plus/3.0.
250
251* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
252- source update.
253- build for VineSeed Plus.
254
255* Mon Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
256- add man page synaptics.5.
257- build for VineSeed Plus.
258
259* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
260- build for Vine Plus/3.0.
261
262* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
263- source update.
264- build for VineSeed Plus.
265
266* Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
267- build for Vine Plus/3.0.
268
269* Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
270- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.