source: projects/specs/trunk/x/xorg-x11-drv-synaptics/xorg-x11-drv-synaptics-vl.spec @ 6369

Revision 6369, 8.9 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define tarball xf86-input-synaptics
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/input
4
5Name:           xorg-x11-drv-synaptics
6Summary:        Xorg X11 synaptics input driver
7Summary(ja):    Xorg X11 synaptics 入力ドライバ
8Version:        1.6.2
9Release:        1%{?_dist_release}
10URL:            http://www.x.org
11License:        MIT
12Group:          User Interface/X Hardware Support
13
14Source0:        ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
15
16Source1:        50-synaptics.conf
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19ExcludeArch:    s390 s390x
20BuildRequires:  libtool, pkgconfig
21BuildRequires:  xorg-x11-server-sdk >= 1.6.0
22BuildRequires:  libX11-devel, libXi-devel, libXext-devel
23BuildRequires:  libXtst-devel
24BuildRequires:  mtdev-devel
25BuildRequires:  xorg-x11-util-macros >= 1.3.0
26Requires:       xorg-x11-server-Xorg
27
28Provides:       synaptics = %{version}-%{release}
29Obsoletes:      synaptics < 0.15.0
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
36default operates in compatibility mode by emulating a standard mouse. However,
37by using a dedicated driver, more advanced features of the touchpad becomes
38available.
39
40Features:
41
42    * Movement with adjustable, non-linear acceleration and speed.
43    * Button events through short touching of the touchpad.
44    * Double-Button events through double short touching of the touchpad.
45    * Dragging through short touching and holding down the finger on the
46      touchpad.
47    * Middle and right button events on the upper and lower corner of the
48      touchpad.
49    * Vertical scrolling (button four and five events) through moving the
50      finger on the right side of the touchpad.
51    * The up/down button sends button four/five events.
52    * Horizontal scrolling (button six and seven events) through moving the
53      finger on the lower side of the touchpad.
54    * The multi-buttons send button four/five events, and six/seven events for
55      horizontal scrolling.
56    * Adjustable finger detection.
57      Multifinger taps: two finger for middle button and three finger for
58      right button events. (Needs hardware support. Not all models implement
59      this feature.)
60    * Run-time configuration using shared memory. This means you can change
61      parameter settings without restarting the X server.
62
63%description -l ja
64Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
65パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
66しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
67ます。
68
69機能:
70    * スピードと加速の調整が可能。
71    * タッチパッドに短く触れたらクリック。
72    * タッチパッドに2度短く触れたらダブルクリック。
73    * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
74    * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
75    * タッチパッドの右端を上下になぞる事で縦スクロール。
76      (ボタン4及びボタン5として動作)
77    * 上下ボタンをボタン4及びボタン5として動作。
78    * タッチパッドの下端を左右になぞることで横スクロール。
79      (ボタン6及びボタン7として動作)
80    * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
81    * 感度の調整が可能。
82    * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
83      (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
84    * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
85      設定を変更することができる。
86
87%prep
88%setup -q -n %{tarball}-%{version}
89
90%build
91autoreconf -v --install --force || exit 1
92%configure --disable-static
93make %{?_smp_mflags}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98make install DESTDIR=$RPM_BUILD_ROOT
99
100# FIXME: Remove all libtool archives (*.la) from modules directory.  This
101# should be fixed in upstream Makefile.am or whatever.
102find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
103
104# install xorg.conf snippet
105install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
106install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
107
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files
113%defattr(-,root,root,-)
114%doc COPYING README
115%{_datadir}/X11/xorg.conf.d/*.conf
116%{driverdir}/synaptics_drv.so
117%{_bindir}/synclient
118%{_bindir}/syndaemon
119%{_mandir}/man4/synaptics.4*
120%{_mandir}/man1/synclient.1*
121%{_mandir}/man1/syndaemon.1*
122%{_includedir}/xorg/synaptics-properties.h
123%{_includedir}/xorg/synaptics.h
124%{_libdir}/pkgconfig/xorg-synaptics.pc
125
126%changelog
127* Mon Jun 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
128- new upstream release
129
130* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
131- new upstream release
132- add BuildRequires: libXtst-devel
133
134* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.99.902-1
135- new upstream release
136- add BuildRequires: mtdev-devel
137
138* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.0-1
139- new upstream release
140
141* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
142- new upstream release
143
144* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
145- new upstream release
146
147* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.99.901-1
148- new upstream release
149
150* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-2
151- rebuild with xserver-1.9.2
152
153* Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
154- new upstream release
155
156* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-3
157- rebuild with rpm-4.8.1 for pkg-config file
158
159* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-2
160- move xorg.conf snippet to /usr/share/X11/xorg.conf.d
161
162* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
163- update to 1.2.2
164- drop hal support
165  - drop hal fdi policy
166  - remove R: hal
167- add xorg.conf snippet
168
169* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-3
170- rebuild with xserver-1.8rc (x86_64)
171
172* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
173- rebuild with xserver-1.8rc
174
175* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
176- new upstream release
177
178* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
179- new upstream release
180- add BR: xorg-x11-util-macros >= 1.3.0
181
182* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
183- new upstream release
184- remove Patch10: SHMconfig is not needed
185
186* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
187- new upstream release
188
189* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
190- new upstream release
191
192* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
193- new upstream release
194
195* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
196- use bundled fdi
197- add patch10 to enable SHMConfig on all synaptics devices.
198
199* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
200- new upstream release
201
202* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
203- new upstream version released from x.org
204- rename to xorg-x11-drv-synaptics
205- add Obsoletes/Provides synaptics
206- add patch1,2 from fedora
207  - patch1: reserve 5% on each side for edge detection.
208  - patch2: force a click if middle button emulation times out during ReadInput cycle.
209
210* Tue Jul  8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
211- fixed synaptics_drv.so path by using %%{_libdir}
212
213* Sun Jul  6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
214- add Patch0; add BuildRequires: libpciaccess-devel
215- built with xorg-x11-server-1.4.99.905
216
217* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
218- updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
219- built with xorg-x11
220- spec encoding converted to UTF-8
221
222* Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
223- source update.
224- build for VineSeed (4.0) Plus.
225
226* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
227- build for Vine Plus/3.0.
228
229* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
230- source update.
231- build for VineSeed Plus.
232
233* Sat Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
234- add man page synaptics.5.
235- build for VineSeed Plus.
236
237* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
238- build for Vine Plus/3.0.
239
240* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
241- source update.
242- build for VineSeed Plus.
243
244* Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
245- build for Vine Plus/3.0.
246
247* Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
248- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.