source: projects/specs/trunk/x/xorg-x11-drv-synaptics/xorg-x11-drv-synaptics-vl.spec @ 521

Revision 521, 7.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define tarball xf86-input-synaptics
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/input
4
5Name:           xorg-x11-drv-synaptics
6Summary:        Xorg X11 synaptics input driver
7Summary(ja):    Xorg X11 synaptics 入力ドライバ
8Version:        1.2.1
9Release:        1%{?_dist_release}
10URL:            http://www.x.org
11License:        MIT
12Group:          User Interface/X Hardware Support
13
14Source0:        ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17ExcludeArch:    s390 s390x
18BuildRequires:  libtool, pkgconfig
19BuildRequires:  xorg-x11-server-sdk >= 1.6.0
20BuildRequires:  libX11-devel, libXi-devel, libXext-devel
21BuildRequires:  xorg-x11-util-macros >= 1.3.0
22Requires:       xorg-x11-server-Xorg
23Requires:       hal
24
25Provides:       synaptics = %{version}-%{release}
26Obsoletes:      synaptics < 0.15.0
27
28
29%description
30This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
31default operates in compatibility mode by emulating a standard mouse. However,
32by using a dedicated driver, more advanced features of the touchpad becomes
33available.
34
35Features:
36
37    * Movement with adjustable, non-linear acceleration and speed.
38    * Button events through short touching of the touchpad.
39    * Double-Button events through double short touching of the touchpad.
40    * Dragging through short touching and holding down the finger on the
41      touchpad.
42    * Middle and right button events on the upper and lower corner of the
43      touchpad.
44    * Vertical scrolling (button four and five events) through moving the
45      finger on the right side of the touchpad.
46    * The up/down button sends button four/five events.
47    * Horizontal scrolling (button six and seven events) through moving the
48      finger on the lower side of the touchpad.
49    * The multi-buttons send button four/five events, and six/seven events for
50      horizontal scrolling.
51    * Adjustable finger detection.
52      Multifinger taps: two finger for middle button and three finger for
53      right button events. (Needs hardware support. Not all models implement
54      this feature.)
55    * Run-time configuration using shared memory. This means you can change
56      parameter settings without restarting the X server.
57
58%description -l ja
59Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
60パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
61しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
62ます。
63
64機能:
65    * スピードと加速の調整が可能。
66    * タッチパッドに短く触れたらクリック。
67    * タッチパッドに2度短く触れたらダブルクリック。
68    * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
69    * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
70    * タッチパッドの右端を上下になぞる事で縦スクロール。
71      (ボタン4及びボタン5として動作)
72    * 上下ボタンをボタン4及びボタン5として動作。
73    * タッチパッドの下端を左右になぞることで横スクロール。
74      (ボタン6及びボタン7として動作)
75    * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
76    * 感度の調整が可能。
77    * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
78      (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
79    * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
80      設定を変更することができる。
81
82%prep
83%setup -q -n %{tarball}-%{version}
84
85%build
86autoreconf -v --install --force || exit 1
87%configure --disable-static
88make %{?_smp_mflags}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make install DESTDIR=$RPM_BUILD_ROOT
94
95# FIXME: Remove all libtool archives (*.la) from modules directory.  This
96# should be fixed in upstream Makefile.am or whatever.
97find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
98
99install -d $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor
100install -m644 fdi/11-x11-synaptics.fdi $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%files
107%defattr(-,root,root,-)
108%doc COPYING README
109%{_datadir}/hal/fdi/policy/10osvendor/*
110%{driverdir}/synaptics_drv.so
111%{_bindir}/synclient
112%{_bindir}/syndaemon
113%{_mandir}/man4/synaptics.4*
114%{_mandir}/man1/synclient.1*
115%{_mandir}/man1/syndaemon.1*
116%{_includedir}/xorg/synaptics-properties.h
117%{_includedir}/xorg/synaptics.h
118%{_libdir}/pkgconfig/xorg-synaptics.pc
119
120%changelog
121* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
122- new upstream release
123
124* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
125- new upstream release
126- add BR: xorg-x11-util-macros >= 1.3.0
127
128* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
129- new upstream release
130- remove Patch10: SHMconfig is not needed
131
132* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
133- new upstream release
134
135* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
136- new upstream release
137
138* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
139- new upstream release
140
141* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
142- use bundled fdi
143- add patch10 to enable SHMConfig on all synaptics devices.
144
145* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
146- new upstream release
147
148* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
149- new upstream version released from x.org
150- rename to xorg-x11-drv-synaptics
151- add Obsoletes/Provides synaptics
152- add patch1,2 from fedora
153  - patch1: reserve 5% on each side for edge detection.
154  - patch2: force a click if middle button emulation times out during ReadInput cycle.
155
156* Tue Jul  8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
157- fixed synaptics_drv.so path by using %%{_libdir}
158
159* Sun Jul  6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
160- add Patch0; add BuildRequires: libpciaccess-devel
161- built with xorg-x11-server-1.4.99.905
162
163* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
164- updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
165- built with xorg-x11
166- spec encoding converted to UTF-8
167
168* Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
169- source update.
170- build for VineSeed (4.0) Plus.
171
172* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
173- build for Vine Plus/3.0.
174
175* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
176- source update.
177- build for VineSeed Plus.
178
179* Sat Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
180- add man page synaptics.5.
181- build for VineSeed Plus.
182
183* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
184- build for Vine Plus/3.0.
185
186* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
187- source update.
188- build for VineSeed Plus.
189
190* Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
191- build for Vine Plus/3.0.
192
193* Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
194- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.