source: projects/specs/trunk/x/xorg-x11-drv-synaptics/xorg-x11-drv-synaptics-vl.spec @ 4616

Revision 4616, 8.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define tarball xf86-input-synaptics
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/input
4
5Name:           xorg-x11-drv-synaptics
6Summary:        Xorg X11 synaptics input driver
7Summary(ja):    Xorg X11 synaptics 入力ドライバ
8Version:        1.4.1
9Release:        1%{?_dist_release}
10URL:            http://www.x.org
11License:        MIT
12Group:          User Interface/X Hardware Support
13
14Source0:        ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
15
16Source1:        50-synaptics.conf
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19ExcludeArch:    s390 s390x
20BuildRequires:  libtool, pkgconfig
21BuildRequires:  xorg-x11-server-sdk >= 1.6.0
22BuildRequires:  libX11-devel, libXi-devel, libXext-devel
23BuildRequires:  xorg-x11-util-macros >= 1.3.0
24Requires:       xorg-x11-server-Xorg
25
26Provides:       synaptics = %{version}-%{release}
27Obsoletes:      synaptics < 0.15.0
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
34default operates in compatibility mode by emulating a standard mouse. However,
35by using a dedicated driver, more advanced features of the touchpad becomes
36available.
37
38Features:
39
40    * Movement with adjustable, non-linear acceleration and speed.
41    * Button events through short touching of the touchpad.
42    * Double-Button events through double short touching of the touchpad.
43    * Dragging through short touching and holding down the finger on the
44      touchpad.
45    * Middle and right button events on the upper and lower corner of the
46      touchpad.
47    * Vertical scrolling (button four and five events) through moving the
48      finger on the right side of the touchpad.
49    * The up/down button sends button four/five events.
50    * Horizontal scrolling (button six and seven events) through moving the
51      finger on the lower side of the touchpad.
52    * The multi-buttons send button four/five events, and six/seven events for
53      horizontal scrolling.
54    * Adjustable finger detection.
55      Multifinger taps: two finger for middle button and three finger for
56      right button events. (Needs hardware support. Not all models implement
57      this feature.)
58    * Run-time configuration using shared memory. This means you can change
59      parameter settings without restarting the X server.
60
61%description -l ja
62Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
63パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
64しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
65ます。
66
67機能:
68    * スピードと加速の調整が可能。
69    * タッチパッドに短く触れたらクリック。
70    * タッチパッドに2度短く触れたらダブルクリック。
71    * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
72    * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
73    * タッチパッドの右端を上下になぞる事で縦スクロール。
74      (ボタン4及びボタン5として動作)
75    * 上下ボタンをボタン4及びボタン5として動作。
76    * タッチパッドの下端を左右になぞることで横スクロール。
77      (ボタン6及びボタン7として動作)
78    * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
79    * 感度の調整が可能。
80    * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
81      (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
82    * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
83      設定を変更することができる。
84
85%prep
86%setup -q -n %{tarball}-%{version}
87
88%build
89autoreconf -v --install --force || exit 1
90%configure --disable-static
91make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96make install DESTDIR=$RPM_BUILD_ROOT
97
98# FIXME: Remove all libtool archives (*.la) from modules directory.  This
99# should be fixed in upstream Makefile.am or whatever.
100find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
101
102# install xorg.conf snippet
103install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
104install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
105
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files
111%defattr(-,root,root,-)
112%doc COPYING README
113%{_datadir}/X11/xorg.conf.d/*.conf
114%{driverdir}/synaptics_drv.so
115%{_bindir}/synclient
116%{_bindir}/syndaemon
117%{_mandir}/man4/synaptics.4*
118%{_mandir}/man1/synclient.1*
119%{_mandir}/man1/syndaemon.1*
120%{_includedir}/xorg/synaptics-properties.h
121%{_includedir}/xorg/synaptics.h
122%{_libdir}/pkgconfig/xorg-synaptics.pc
123
124%changelog
125* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
126- new upstream release
127
128* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
129- new upstream release
130
131* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.99.901-1
132- new upstream release
133
134* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-2
135- rebuild with xserver-1.9.2
136
137* Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
138- new upstream release
139
140* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-3
141- rebuild with rpm-4.8.1 for pkg-config file
142
143* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-2
144- move xorg.conf snippet to /usr/share/X11/xorg.conf.d
145
146* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
147- update to 1.2.2
148- drop hal support
149  - drop hal fdi policy
150  - remove R: hal
151- add xorg.conf snippet
152
153* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-3
154- rebuild with xserver-1.8rc (x86_64)
155
156* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
157- rebuild with xserver-1.8rc
158
159* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
160- new upstream release
161
162* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
163- new upstream release
164- add BR: xorg-x11-util-macros >= 1.3.0
165
166* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
167- new upstream release
168- remove Patch10: SHMconfig is not needed
169
170* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
171- new upstream release
172
173* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
174- new upstream release
175
176* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
177- new upstream release
178
179* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
180- use bundled fdi
181- add patch10 to enable SHMConfig on all synaptics devices.
182
183* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
184- new upstream release
185
186* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
187- new upstream version released from x.org
188- rename to xorg-x11-drv-synaptics
189- add Obsoletes/Provides synaptics
190- add patch1,2 from fedora
191  - patch1: reserve 5% on each side for edge detection.
192  - patch2: force a click if middle button emulation times out during ReadInput cycle.
193
194* Tue Jul  8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
195- fixed synaptics_drv.so path by using %%{_libdir}
196
197* Sun Jul  6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
198- add Patch0; add BuildRequires: libpciaccess-devel
199- built with xorg-x11-server-1.4.99.905
200
201* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
202- updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
203- built with xorg-x11
204- spec encoding converted to UTF-8
205
206* Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
207- source update.
208- build for VineSeed (4.0) Plus.
209
210* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
211- build for Vine Plus/3.0.
212
213* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
214- source update.
215- build for VineSeed Plus.
216
217* Sat Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
218- add man page synaptics.5.
219- build for VineSeed Plus.
220
221* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
222- build for Vine Plus/3.0.
223
224* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
225- source update.
226- build for VineSeed Plus.
227
228* Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
229- build for Vine Plus/3.0.
230
231* Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
232- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.