source: projects/specs/trunk/x/xorg-x11-drv-synaptics/xorg-x11-drv-synaptics-vl.spec @ 10229

Revision 10229, 9.8 KB checked in by Takemikaduchi, 8 years ago (diff)

xserver-1.18.3

Line 
1%define tarball xf86-input-synaptics
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/input
4
5Name:           xorg-x11-drv-synaptics
6Summary:        Xorg X11 synaptics input driver
7Summary(ja):    Xorg X11 synaptics 入力ドライバ
8Version:        1.8.3
9Release:        1%{?_dist_release}
10URL:            http://www.x.org
11License:        MIT
12Group:          User Interface/X Hardware Support
13
14Source0:        ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
15
16Source1:        50-synaptics.conf
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19ExcludeArch:    s390 s390x
20BuildRequires:  libtool, pkgconfig
21BuildRequires:  xorg-x11-server-sdk >= 1.6.0
22BuildRequires:  libX11-devel, libXi-devel, libXext-devel
23BuildRequires:  libXtst-devel
24BuildRequires:  libevdev-devel
25BuildRequires:  mtdev-devel
26BuildRequires:  xorg-x11-util-macros >= 1.3.0
27Requires:       xorg-x11-server-Xorg
28
29Provides:       synaptics = %{version}-%{release}
30Obsoletes:      synaptics < 0.15.0
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
37default operates in compatibility mode by emulating a standard mouse. However,
38by using a dedicated driver, more advanced features of the touchpad becomes
39available.
40
41Features:
42
43    * Movement with adjustable, non-linear acceleration and speed.
44    * Button events through short touching of the touchpad.
45    * Double-Button events through double short touching of the touchpad.
46    * Dragging through short touching and holding down the finger on the
47      touchpad.
48    * Middle and right button events on the upper and lower corner of the
49      touchpad.
50    * Vertical scrolling (button four and five events) through moving the
51      finger on the right side of the touchpad.
52    * The up/down button sends button four/five events.
53    * Horizontal scrolling (button six and seven events) through moving the
54      finger on the lower side of the touchpad.
55    * The multi-buttons send button four/five events, and six/seven events for
56      horizontal scrolling.
57    * Adjustable finger detection.
58      Multifinger taps: two finger for middle button and three finger for
59      right button events. (Needs hardware support. Not all models implement
60      this feature.)
61    * Run-time configuration using shared memory. This means you can change
62      parameter settings without restarting the X server.
63
64%description -l ja
65Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
66パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
67しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
68ます。
69
70機能:
71    * スピードと加速の調整が可能。
72    * タッチパッドに短く触れたらクリック。
73    * タッチパッドに2度短く触れたらダブルクリック。
74    * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
75    * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
76    * タッチパッドの右端を上下になぞる事で縦スクロール。
77      (ボタン4及びボタン5として動作)
78    * 上下ボタンをボタン4及びボタン5として動作。
79    * タッチパッドの下端を左右になぞることで横スクロール。
80      (ボタン6及びボタン7として動作)
81    * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
82    * 感度の調整が可能。
83    * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
84      (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
85    * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
86      設定を変更することができる。
87
88%prep
89%setup -q -n %{tarball}-%{version}
90
91%build
92autoreconf -v --install --force || exit 1
93%configure --disable-static
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install DESTDIR=$RPM_BUILD_ROOT
100
101# FIXME: Remove all libtool archives (*.la) from modules directory.  This
102# should be fixed in upstream Makefile.am or whatever.
103find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
104
105# install xorg.conf snippet
106install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
107install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root,-)
115%doc COPYING README
116%{_datadir}/X11/xorg.conf.d/*.conf
117%{driverdir}/synaptics_drv.so
118%{_bindir}/synclient
119%{_bindir}/syndaemon
120%{_mandir}/man4/synaptics.4*
121%{_mandir}/man1/synclient.1*
122%{_mandir}/man1/syndaemon.1*
123%{_includedir}/xorg/synaptics-properties.h
124%{_libdir}/pkgconfig/xorg-synaptics.pc
125
126%changelog
127* Thu May 05 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
128- new upstream release
129
130* Sun Oct 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-2
131- rebuild with xserver-1.17.2
132
133* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
134- new upstream release
135
136* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
137- new upstream release
138
139* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
140- new upstream release
141- add BuildRequires: libevdev-devel
142
143* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
144- new upstream release
145
146* Wed Apr 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
147- new upstream release
148
149* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.2-1
150- new upstream release
151
152* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-1
153- new upstream release
154
155* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-1
156- new upstream release
157
158* Mon Jun 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
159- new upstream release
160
161* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
162- new upstream release
163- add BuildRequires: libXtst-devel
164
165* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.99.902-1
166- new upstream release
167- add BuildRequires: mtdev-devel
168
169* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.0-1
170- new upstream release
171
172* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
173- new upstream release
174
175* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
176- new upstream release
177
178* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.99.901-1
179- new upstream release
180
181* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-2
182- rebuild with xserver-1.9.2
183
184* Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
185- new upstream release
186
187* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-3
188- rebuild with rpm-4.8.1 for pkg-config file
189
190* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-2
191- move xorg.conf snippet to /usr/share/X11/xorg.conf.d
192
193* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
194- update to 1.2.2
195- drop hal support
196  - drop hal fdi policy
197  - remove R: hal
198- add xorg.conf snippet
199
200* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-3
201- rebuild with xserver-1.8rc (x86_64)
202
203* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
204- rebuild with xserver-1.8rc
205
206* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
207- new upstream release
208
209* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
210- new upstream release
211- add BR: xorg-x11-util-macros >= 1.3.0
212
213* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
214- new upstream release
215- remove Patch10: SHMconfig is not needed
216
217* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
218- new upstream release
219
220* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
221- new upstream release
222
223* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
224- new upstream release
225
226* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
227- use bundled fdi
228- add patch10 to enable SHMConfig on all synaptics devices.
229
230* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
231- new upstream release
232
233* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
234- new upstream version released from x.org
235- rename to xorg-x11-drv-synaptics
236- add Obsoletes/Provides synaptics
237- add patch1,2 from fedora
238  - patch1: reserve 5% on each side for edge detection.
239  - patch2: force a click if middle button emulation times out during ReadInput cycle.
240
241* Tue Jul  8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
242- fixed synaptics_drv.so path by using %%{_libdir}
243
244* Sun Jul  6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
245- add Patch0; add BuildRequires: libpciaccess-devel
246- built with xorg-x11-server-1.4.99.905
247
248* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
249- updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
250- built with xorg-x11
251- spec encoding converted to UTF-8
252
253* Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
254- source update.
255- build for VineSeed (4.0) Plus.
256
257* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
258- build for Vine Plus/3.0.
259
260* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
261- source update.
262- build for VineSeed Plus.
263
264* Mon Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
265- add man page synaptics.5.
266- build for VineSeed Plus.
267
268* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
269- build for Vine Plus/3.0.
270
271* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
272- source update.
273- build for VineSeed Plus.
274
275* Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
276- build for Vine Plus/3.0.
277
278* Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
279- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.