source: projects/specs/trunk/x/xorg-x11-drv-openchrome/xorg-x11-drv-openchrome-vl.spec @ 7707

Revision 7707, 8.5 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define tarball xf86-video-openchrome
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir       %{moduledir}/drivers
4
5%define cvsdate xxxxxxx
6
7%define with_xvmc 1
8
9Summary:        Xorg X11 openchrome video driver
10Summary(ja):    Xorg X11 openchrome ビデオドライバ
11Name:           xorg-x11-drv-openchrome
12Version:        0.3.3
13Release:        1%{?_dist_release}
14URL:            http://www.openchrome.org
15License:        MIT
16Group:          User Interface/X Hardware Support
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19Source0:        http://www.openchrome.org/releases/%{tarball}-%{version}.tar.bz2
20Source1:        openchrome.xinf
21
22# Patches from Fedora :
23Patch13:        openchrome-0.2.904-fix_tvout_flickering.patch
24
25ExclusiveArch:  %{ix86} x86_64
26
27BuildRequires:  pkgconfig
28BuildRequires:  xorg-x11-server-sdk
29BuildRequires:  automake
30BuildRequires:  libtool
31BuildRequires:  libX11-devel
32BuildRequires:  libXext-devel
33BuildRequires:  mesa-libGL-devel
34%if %{with_xvmc}
35BuildRequires:  libXvMC-devel
36%endif
37BuildRequires:  libdrm-devel >= 2.0-1
38BuildRequires:  libudev-devel
39Requires:       xorg-x11-server-Xorg
40
41Obsoletes:  XOrg-drv-via <= 0.2.2-4
42Provides:   xorg-x11-drv-via = 0.2.2-5
43
44%description
45X.Org X11 openchrome video driver.
46
47%if %{with_xvmc}
48%package devel
49Summary:        Xorg X11 openchrome video driver XvMC development package
50Summary(ja):    Xorg X11 openchrome ビデオドライバ XvMC 開発パッケージ
51Group:          Development/System
52Requires:       %{name} = %{version}-%{release}
53Obsoletes:      XOrg-drv-via-devel <= 0.2.2-4
54Provides:       xorg-x11-drv-via-devel = 0.2.2-5
55
56%description devel
57X.Org X11 openchrome video driver XvMC development package.
58%endif
59
60%prep
61%setup -q -n %{tarball}-%{version}
62#%patch0 -p0
63%patch13 -p0
64
65%build
66%configure --disable-static --enable-dri
67make
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72make install DESTDIR=$RPM_BUILD_ROOT
73
74mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
75install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/openchrome.xinf
76
77# FIXME: Remove all libtool archives (*.la) from modules directory.  This
78# should be fixed in upstream Makefile.am or whatever.
79find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post
85if [ -e /etc/X11/xorg.conf ]; then
86    sed -i "/Driver/s/via/openchrome/" /etc/X11/xorg.conf || :
87fi
88
89%files
90%defattr(-,root,root,-)
91%doc COPYING NEWS README
92%{driverdir}/openchrome_drv.so
93%{_datadir}/hwdata/videoaliases/openchrome.xinf
94%if %{with_xvmc}
95%{_libdir}/libchromeXvMC.so.1
96%{_libdir}/libchromeXvMC.so.1.0.0
97%{_libdir}/libchromeXvMCPro.so.1
98%{_libdir}/libchromeXvMCPro.so.1.0.0
99%endif
100%{_mandir}/man4/openchrome.4.gz
101
102%if %{with_xvmc}
103%files devel
104%defattr(-,root,root,-)
105%{_libdir}/libchromeXvMC.so
106%{_libdir}/libchromeXvMCPro.so
107%endif
108
109
110%changelog
111* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.3-1
112- new upstream release
113  (including security fix for CVE-2013-1994)
114
115* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.2-1
116- new upstream release
117
118* Sun Aug 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.0-1
119- new upstream release
120- add BuildRequires: libudev-devel
121
122* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.906-1
123- new upstream release
124- remove Patch1
125
126* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.905-1
127- new upstream release
128- remove Patch20 (openchrome-0.2.904-I420_Xv_surface_for_CME.patch)
129- add Patch1 (openchrome-0.2.905-xv_support_for_vx900.patch) from fedora
130
131* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-8
132- rebuild with xserver-1.11.1.902
133
134* Thu May 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-7
135- rebuild (missing to replace patch).
136
137* Wed May 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-6
138- update to svn trunk (r925)
139- delete Patch1
140
141* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-5
142- rebuild with xserver-1.10.0
143
144* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-4
145- rebuild with xserver-1.9.2
146
147* Tue Oct 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.904-3
148- update to svn trunk (r854)
149- add patch13,20 from fedora
150
151* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-2
152- rebuild with xserver-1.8rc
153
154* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.904-1
155- new upstream release
156
157* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.903-2
158- rebuild with X server 1.6.0
159
160* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.903-1
161- new upstream release
162
163* Sat May 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.902-1
164- initial build for Vine Linux
165
166* Thu Apr 17 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-3
167- Strip leading /trunk/ from patch #2 and #3.
168
169* Sun Apr 13 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-2
170- Add patch to properly report driver version in the libpciaccess code path.
171- Add patch to properly report chipset revision in the libpciaccess code path.
172
173* Wed Apr 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-1
174- New upstream release.
175- Re-enable AGPDMA for K8M800 and VM800, as the drm bug is fixed in kernel
176  >= 2.6.25rc7 (Patch #1).
177
178* Mon Mar 17 2008 Jesse Keating <jkeating@redhat.com> - 0.2.901-16
179- Remove dangerous unversioned obsoletes/provides.
180
181* Sun Mar 16 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-15
182- Update to latest svn snapshot (Rev. 553).
183
184* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-14
185- Revert to last good version of the libpciaccess patch.
186
187* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-13
188- Temporarily revert to old memory detection method. We need something that
189  works out of the box for F9 Beta.
190
191* Sat Mar 08 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-12
192- Yet another revision of the libpciaccess patch.
193
194* Fri Mar 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-11
195- Fix a typo in libpciaccess patch.
196
197* Fri Mar 07 2008 Adam Jackson <ajax@redhat.com> 0.2.901-10
198- Fix -devel subpackage to obsolete via-devel properly.
199
200* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-9
201- Fix libpciaccess patch.
202
203* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-8
204- Add patch to fix XV on LCD for VM800.
205- Improved libpciaccess patch.
206
207* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.901-7
208- Autorebuild for GCC 4.3
209
210* Wed Jan 23 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-6
211- Add patch to properly set fifo on P4M900.
212
213* Sat Jan 19 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-5
214- Add patch to replace xf86memcpy by plain memcpy.
215
216* Thu Jan 10 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-4
217- Another try at fixing the libpciaccess patch.
218
219* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-3
220- And now fix patch filename...
221
222* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-2
223- Fix broken libpciaccess patch.
224
225* Wed Jan 02 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-1
226- Update to 0.2.901.
227- Remove obsoleted patches.
228- Update libpciaccess patch.
229
230* Sat Dec 08 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-9
231- Add patch for preliminary libpciaccess support.
232
233* Wed Nov 28 2007 Adam Jackson <ajax@redhat.com> 0.2.900-8
234- Obsolete xorg-x11-drv-via.  The king is dead, long live the king.
235- Munge xorg.conf in %%post to change from via to openchrome.
236- Drive-by spec cleanups.
237
238* Fri Nov 02 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-7
239- Replace broken VT1625 NTSC patch.
240- Add patch to announce as release not as development build.
241- First official Fedora build.
242
243* Thu Oct 18 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-6
244- Update to official 0.2.900
245
246* Wed Oct 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-5
247- Update to release_0_3_0 branch rev. 410
248- Add VT1625 patch for 720x576 PAL
249
250* Mon Sep 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-4
251- Update to release_0_3_0 branch rev. 384 plus all changes from experimental
252  merged back
253- Remove upstream patch #2
254
255* Wed Aug 01 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-3
256- Update to release_0_3_0 branch rev. 380 (fix a bug with XvMC acceleration)
257- Add a patch to allow proper detection of DDR667 (patch #2)
258
259* Mon Jul 16 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-2
260- Update to release_0_3_0 branch rev. 373
261- Add release notes to %%doc
262
263* Thu Jul 05 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-1
264- Initial build (release_0_3_0 branch rev. 365)
265- Add some NTSC modes for the VT1625 (patch #1)
Note: See TracBrowser for help on using the repository browser.