source: projects/specs/trunk/x/xorg-x11-drv-openchrome/xorg-x11-drv-openchrome-vl.spec @ 698

Revision 698, 7.0 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1%define tarball xf86-video-openchrome
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir       %{moduledir}/drivers
4
5%define cvsdate xxxxxxx
6
7%define with_xvmc 1
8
9Summary:        Xorg X11 openchrome video driver
10Summary(ja):    Xorg X11 openchrome ビデオドライバ
11Name:           xorg-x11-drv-openchrome
12Version:        0.2.904
13Release:        2%{?_dist_release}
14URL:            http://www.openchrome.org
15License:        MIT
16Group:          User Interface/X Hardware Support
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19Source0:        http://www.openchrome.org/releases/%{tarball}-%{version}.tar.bz2
20Source1:        openchrome.xinf
21
22ExclusiveArch:  %{ix86} x86_64
23
24BuildRequires:  pkgconfig
25BuildRequires:  xorg-x11-server-sdk
26BuildRequires:  automake
27BuildRequires:  libtool
28BuildRequires:  libX11-devel
29BuildRequires:  libXext-devel
30BuildRequires:  mesa-libGL-devel
31%if %{with_xvmc}
32BuildRequires:  libXvMC-devel
33%endif
34BuildRequires:  libdrm-devel >= 2.0-1
35Requires:       xorg-x11-server-Xorg
36
37Obsoletes:  XOrg-drv-via <= 0.2.2-4
38Provides:   xorg-x11-drv-via = 0.2.2-5
39
40%description
41X.Org X11 openchrome video driver.
42
43%if %{with_xvmc}
44%package devel
45Summary:        Xorg X11 openchrome video driver XvMC development package
46Summary(ja):    Xorg X11 openchrome ビデオドライバ XvMC 開発パッケージ
47Group:          Development/System
48Requires:       %{name} = %{version}-%{release}
49Obsoletes:      XOrg-drv-via-devel <= 0.2.2-4
50Provides:       xorg-x11-drv-via-devel = 0.2.2-5
51
52%description devel
53X.Org X11 openchrome video driver XvMC development package.
54%endif
55
56%prep
57%setup -q -n %{tarball}-%{version}
58
59%build
60%configure --disable-static --enable-dri
61make
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66make install DESTDIR=$RPM_BUILD_ROOT
67
68mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
69install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/openchrome.xinf
70
71# FIXME: Remove all libtool archives (*.la) from modules directory.  This
72# should be fixed in upstream Makefile.am or whatever.
73find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post
79if [ -e /etc/X11/xorg.conf ]; then
80    sed -i "/Driver/s/via/openchrome/" /etc/X11/xorg.conf || :
81fi
82
83%files
84%defattr(-,root,root,-)
85%doc COPYING NEWS README
86%{driverdir}/openchrome_drv.so
87%{_datadir}/hwdata/videoaliases/openchrome.xinf
88%if %{with_xvmc}
89%{_libdir}/libchromeXvMC.so.1
90%{_libdir}/libchromeXvMC.so.1.0.0
91%{_libdir}/libchromeXvMCPro.so.1
92%{_libdir}/libchromeXvMCPro.so.1.0.0
93%endif
94%{_mandir}/man4/openchrome.4.gz
95
96%if %{with_xvmc}
97%files devel
98%defattr(-,root,root,-)
99%{_libdir}/libchromeXvMC.so
100%{_libdir}/libchromeXvMCPro.so
101%endif
102
103
104%changelog
105* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-2
106- rebuild with xserver-1.8rc
107
108* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.904-1
109- new upstream release
110
111* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.903-2
112- rebuild with X server 1.6.0
113
114* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.903-1
115- new upstream release
116
117* Sat May 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.902-1
118- initial build for Vine Linux
119
120* Thu Apr 17 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-3
121- Strip leading /trunk/ from patch #2 and #3.
122
123* Sun Apr 13 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-2
124- Add patch to properly report driver version in the libpciaccess code path.
125- Add patch to properly report chipset revision in the libpciaccess code path.
126
127* Wed Apr 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-1
128- New upstream release.
129- Re-enable AGPDMA for K8M800 and VM800, as the drm bug is fixed in kernel
130  >= 2.6.25rc7 (Patch #1).
131
132* Mon Mar 17 2008 Jesse Keating <jkeating@redhat.com> - 0.2.901-16
133- Remove dangerous unversioned obsoletes/provides.
134
135* Sun Mar 16 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-15
136- Update to latest svn snapshot (Rev. 553).
137
138* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-14
139- Revert to last good version of the libpciaccess patch.
140
141* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-13
142- Temporarily revert to old memory detection method. We need something that
143  works out of the box for F9 Beta.
144
145* Sat Mar 08 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-12
146- Yet another revision of the libpciaccess patch.
147
148* Fri Mar 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-11
149- Fix a typo in libpciaccess patch.
150
151* Fri Mar 07 2008 Adam Jackson <ajax@redhat.com> 0.2.901-10
152- Fix -devel subpackage to obsolete via-devel properly.
153
154* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-9
155- Fix libpciaccess patch.
156
157* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-8
158- Add patch to fix XV on LCD for VM800.
159- Improved libpciaccess patch.
160
161* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.901-7
162- Autorebuild for GCC 4.3
163
164* Wed Jan 23 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-6
165- Add patch to properly set fifo on P4M900.
166
167* Fri Jan 19 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-5
168- Add patch to replace xf86memcpy by plain memcpy.
169
170* Thu Jan 10 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-4
171- Another try at fixing the libpciaccess patch.
172
173* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-3
174- And now fix patch filename...
175
176* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-2
177- Fix broken libpciaccess patch.
178
179* Wed Jan 02 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-1
180- Update to 0.2.901.
181- Remove obsoleted patches.
182- Update libpciaccess patch.
183
184* Fri Dec 08 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-9
185- Add patch for preliminary libpciaccess support.
186
187* Wed Nov 28 2007 Adam Jackson <ajax@redhat.com> 0.2.900-8
188- Obsolete xorg-x11-drv-via.  The king is dead, long live the king.
189- Munge xorg.conf in %%post to change from via to openchrome.
190- Drive-by spec cleanups.
191
192* Fri Nov 02 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-7
193- Replace broken VT1625 NTSC patch.
194- Add patch to announce as release not as development build.
195- First official Fedora build.
196
197* Thu Oct 18 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-6
198- Update to official 0.2.900
199
200* Wed Oct 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-5
201- Update to release_0_3_0 branch rev. 410
202- Add VT1625 patch for 720x576 PAL
203
204* Mon Sep 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-4
205- Update to release_0_3_0 branch rev. 384 plus all changes from experimental
206  merged back
207- Remove upstream patch #2
208
209* Wed Aug 01 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-3
210- Update to release_0_3_0 branch rev. 380 (fix a bug with XvMC acceleration)
211- Add a patch to allow proper detection of DDR667 (patch #2)
212
213* Mon Jul 16 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-2
214- Update to release_0_3_0 branch rev. 373
215- Add release notes to %%doc
216
217* Thu Jul 05 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-1
218- Initial build (release_0_3_0 branch rev. 365)
219- Add some NTSC modes for the VT1625 (patch #1)
Note: See TracBrowser for help on using the repository browser.