source: projects/specs/trunk/x/xorg-x11-drv-openchrome/xorg-x11-drv-openchrome-vl.spec @ 9775

Revision 9775, 9.0 KB checked in by Takemikaduchi, 9 years ago (diff)

kernel-4.1, xserver-1.17.2, VirtualBox?-4.3.32, etc.

Line 
1%define tarball xf86-video-openchrome
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir       %{moduledir}/drivers
4
5%define cvsdate xxxxxxx
6
7%define with_xvmc 1
8
9Summary:        Xorg X11 openchrome video driver
10Summary(ja):    Xorg X11 openchrome ビデオドライバ
11Name:           xorg-x11-drv-openchrome
12Version:        0.3.3
13Release:        6%{?_dist_release}
14URL:            http://www.freedesktop.org/wiki/Openchrome/
15License:        MIT
16Group:          User Interface/X Hardware Support
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19Source0:        http://xorg.freedesktop.org/archive/individual/driver/%{tarball}-%{version}.tar.bz2
20Source1:        openchrome.xinf
21
22# Patches from Fedora :
23Patch13:        openchrome-0.2.904-fix_tvout_flickering.patch
24
25ExclusiveArch:  %{ix86} x86_64
26
27BuildRequires:  pkgconfig
28BuildRequires:  xorg-x11-server-sdk
29BuildRequires:  automake
30BuildRequires:  libtool
31BuildRequires:  libX11-devel
32BuildRequires:  libXext-devel
33BuildRequires:  mesa-libGL-devel
34%if %{with_xvmc}
35BuildRequires:  libXvMC-devel
36%endif
37BuildRequires:  libdrm-devel >= 2.0-1
38BuildRequires:  eudev-libudev-devel
39Requires:       xorg-x11-server-Xorg
40
41Obsoletes:  XOrg-drv-via <= 0.2.2-4
42Provides:   xorg-x11-drv-via = 0.2.2-5
43
44Vendor: Project Vine
45Distribution: Vine Linux
46
47%description
48X.Org X11 openchrome video driver.
49
50%if %{with_xvmc}
51%package devel
52Summary:        Xorg X11 openchrome video driver XvMC development package
53Summary(ja):    Xorg X11 openchrome ビデオドライバ XvMC 開発パッケージ
54Group:          Development/System
55Requires:       %{name} = %{version}-%{release}
56Obsoletes:      XOrg-drv-via-devel <= 0.2.2-4
57Provides:       xorg-x11-drv-via-devel = 0.2.2-5
58
59%description devel
60X.Org X11 openchrome video driver XvMC development package.
61%endif
62
63%prep
64%setup -q -n %{tarball}-%{version}
65#%patch0 -p0
66%patch13 -p0
67
68%build
69%configure --disable-static --enable-dri
70make
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75make install DESTDIR=$RPM_BUILD_ROOT
76
77mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
78install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/openchrome.xinf
79
80# FIXME: Remove all libtool archives (*.la) from modules directory.  This
81# should be fixed in upstream Makefile.am or whatever.
82find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post
88if [ -e /etc/X11/xorg.conf ]; then
89    sed -i "/Driver/s/via/openchrome/" /etc/X11/xorg.conf || :
90fi
91
92%files
93%defattr(-,root,root,-)
94%doc COPYING NEWS README
95%{driverdir}/openchrome_drv.so
96%{_datadir}/hwdata/videoaliases/openchrome.xinf
97%if %{with_xvmc}
98%{_libdir}/libchromeXvMC.so.1
99%{_libdir}/libchromeXvMC.so.1.0.0
100%{_libdir}/libchromeXvMCPro.so.1
101%{_libdir}/libchromeXvMCPro.so.1.0.0
102%endif
103%{_mandir}/man4/openchrome.4.gz
104
105%if %{with_xvmc}
106%files devel
107%defattr(-,root,root,-)
108%{_libdir}/libchromeXvMC.so
109%{_libdir}/libchromeXvMCPro.so
110%endif
111
112
113%changelog
114* Sun Oct 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.3-6
115- rebuild with xserver-1.17.2
116
117* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.3-5
118- rebuild with xserver-1.16.2
119
120* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.3-4
121- rebuild with xserver-1.15.2
122
123* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.3-3
124- change BuildRequires: eudev-libudev-devel instead of libudev-devel
125
126* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.3-2
127- rebuild with VineSeed environment
128
129* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.3-1
130- new upstream release
131  (including security fix for CVE-2013-1994)
132
133* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.2-1
134- new upstream release
135
136* Sun Aug 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.0-1
137- new upstream release
138- add BuildRequires: libudev-devel
139
140* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.906-1
141- new upstream release
142- remove Patch1
143
144* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.905-1
145- new upstream release
146- remove Patch20 (openchrome-0.2.904-I420_Xv_surface_for_CME.patch)
147- add Patch1 (openchrome-0.2.905-xv_support_for_vx900.patch) from fedora
148
149* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-8
150- rebuild with xserver-1.11.1.902
151
152* Thu May 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-7
153- rebuild (missing to replace patch).
154
155* Wed May 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-6
156- update to svn trunk (r925)
157- delete Patch1
158
159* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-5
160- rebuild with xserver-1.10.0
161
162* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-4
163- rebuild with xserver-1.9.2
164
165* Tue Oct 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.904-3
166- update to svn trunk (r854)
167- add patch13,20 from fedora
168
169* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-2
170- rebuild with xserver-1.8rc
171
172* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.904-1
173- new upstream release
174
175* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.903-2
176- rebuild with X server 1.6.0
177
178* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.903-1
179- new upstream release
180
181* Sat May 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.902-1
182- initial build for Vine Linux
183
184* Thu Apr 17 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-3
185- Strip leading /trunk/ from patch #2 and #3.
186
187* Sun Apr 13 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-2
188- Add patch to properly report driver version in the libpciaccess code path.
189- Add patch to properly report chipset revision in the libpciaccess code path.
190
191* Wed Apr 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-1
192- New upstream release.
193- Re-enable AGPDMA for K8M800 and VM800, as the drm bug is fixed in kernel
194  >= 2.6.25rc7 (Patch #1).
195
196* Mon Mar 17 2008 Jesse Keating <jkeating@redhat.com> - 0.2.901-16
197- Remove dangerous unversioned obsoletes/provides.
198
199* Sun Mar 16 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-15
200- Update to latest svn snapshot (Rev. 553).
201
202* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-14
203- Revert to last good version of the libpciaccess patch.
204
205* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-13
206- Temporarily revert to old memory detection method. We need something that
207  works out of the box for F9 Beta.
208
209* Sat Mar 08 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-12
210- Yet another revision of the libpciaccess patch.
211
212* Fri Mar 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-11
213- Fix a typo in libpciaccess patch.
214
215* Fri Mar 07 2008 Adam Jackson <ajax@redhat.com> 0.2.901-10
216- Fix -devel subpackage to obsolete via-devel properly.
217
218* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-9
219- Fix libpciaccess patch.
220
221* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-8
222- Add patch to fix XV on LCD for VM800.
223- Improved libpciaccess patch.
224
225* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.901-7
226- Autorebuild for GCC 4.3
227
228* Wed Jan 23 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-6
229- Add patch to properly set fifo on P4M900.
230
231* Sat Jan 19 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-5
232- Add patch to replace xf86memcpy by plain memcpy.
233
234* Thu Jan 10 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-4
235- Another try at fixing the libpciaccess patch.
236
237* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-3
238- And now fix patch filename...
239
240* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-2
241- Fix broken libpciaccess patch.
242
243* Wed Jan 02 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-1
244- Update to 0.2.901.
245- Remove obsoleted patches.
246- Update libpciaccess patch.
247
248* Sat Dec 08 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-9
249- Add patch for preliminary libpciaccess support.
250
251* Wed Nov 28 2007 Adam Jackson <ajax@redhat.com> 0.2.900-8
252- Obsolete xorg-x11-drv-via.  The king is dead, long live the king.
253- Munge xorg.conf in %%post to change from via to openchrome.
254- Drive-by spec cleanups.
255
256* Fri Nov 02 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-7
257- Replace broken VT1625 NTSC patch.
258- Add patch to announce as release not as development build.
259- First official Fedora build.
260
261* Thu Oct 18 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-6
262- Update to official 0.2.900
263
264* Wed Oct 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-5
265- Update to release_0_3_0 branch rev. 410
266- Add VT1625 patch for 720x576 PAL
267
268* Mon Sep 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-4
269- Update to release_0_3_0 branch rev. 384 plus all changes from experimental
270  merged back
271- Remove upstream patch #2
272
273* Wed Aug 01 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-3
274- Update to release_0_3_0 branch rev. 380 (fix a bug with XvMC acceleration)
275- Add a patch to allow proper detection of DDR667 (patch #2)
276
277* Mon Jul 16 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-2
278- Update to release_0_3_0 branch rev. 373
279- Add release notes to %%doc
280
281* Thu Jul 05 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-1
282- Initial build (release_0_3_0 branch rev. 365)
283- Add some NTSC modes for the VT1625 (patch #1)
Note: See TracBrowser for help on using the repository browser.