source: projects/specs/trunk/x/xorg-x11-drv-nouveau/xorg-x11-drv-nouveau-vl.spec @ 698

Revision 698, 10.9 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1%define tarball xf86-video-nouveau
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/drivers
4%define nouveau_version 0.0.16
5
6# Tarfile created using git
7# git clone git://git.freedesktop.org/git/nouveau/xf86-video-nouveau
8# git-archive --format=tar --prefix=xf86-video-nouveau-0.0.10/ %{git_version} | bzip2 > xf86-video-nouveau-0.0.10-%{gitdate}.tar.bz2
9
10%define gitdate 20100218
11%define git_version 2964702
12
13%define snapshot %{gitdate}git%{git_version}
14
15%define tarfile %{tarball}-%{nouveau_version}-%{snapshot}.tar.bz2
16
17Summary:   Xorg X11 nouveau video driver for NVIDIA graphics chipsets
18Summary(ja): Xorg X11 nouveau ビデオドライバ - NVIDIA グラフィックスチップセット用
19Name:      xorg-x11-drv-nouveau
20Version:   %{nouveau_version}
21Release:   2.%{snapshot}%{?_dist_release}
22URL:       http://www.x.org
23License:   MIT
24Group:     User Interface/X Hardware Support
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27# Fedora specific snapshot no upstream release
28Source0:   %{tarfile}
29
30ExcludeArch: s390 s390x
31
32BuildRequires: libtool automake autoconf
33BuildRequires: xorg-x11-server-sdk >= 1.7.0
34BuildRequires: libdrm-devel >= 2.4.18
35BuildRequires: mesa-libGL-devel
36BuildRequires: kernel-headers >= 2.6.32
37
38Requires:  hwdata
39Requires:  xorg-x11-server-Xorg > 1.7.0
40Requires:  libdrm >= 2.4.18
41
42Patch0: nouveau-bicubic-2x.patch
43Patch1: nouveau-bgnr.patch
44
45%description
46X.Org X11 nouveau video driver.
47
48%prep
49%setup -q -n %{tarball}-%{version}
50
51%patch0 -p1 -b .bicubic
52%patch1 -p1 -b .bgnr
53
54%build
55autoreconf -v --install
56%configure --disable-static --with-kms=yes
57
58make
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63make install DESTDIR=$RPM_BUILD_ROOT
64
65find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(-,root,root,-)
72%{driverdir}/nouveau_drv.so
73%{_mandir}/man4/nouveau.4*
74
75%changelog
76* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.16-2.20100218git2964702
77- rebuild with xserver-1.8rc
78
79* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.16-1.20100218git2964702
80- update to new git snapshot
81- BR: libdrm-devel >= 2.4.18
82
83* Wed Dec 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.15-1.20091216git03c7d6
84- initial build for Vine Linux
85- update to new git snapshot
86- BR: libdrm-devel >= 2.4.16
87
88* Thu Nov 05 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-17.20091105gite1c2efd
89- handle reloc failures more gracefully (rh#531058)
90- fix for rh#532322
91
92* Mon Nov 02 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-16.20091030git5587f40
93- force all pixmaps into system memory initally on low memory cards
94
95* Tue Oct 27 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-15.20091022git718a41b
96- misc fixes, initial NVA8 support
97
98* Thu Oct 09 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-14.20091008git3f020b0
99- update from upstream, fixes various issues, especially with recent xservers
100
101* Tue Sep 29 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-13.20090929gitdd8339f
102- fix driver to work again with recent EXA changes
103
104* Fri Sep 25 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-12.20090924gitde0b095
105- G80: small performance fix
106
107* Mon Sep 21 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-11.20090921gitdf95ebd
108- fix an accel pitch issue seen in rh#523281
109
110* Mon Sep 14 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-10.20090914git1b72020
111- wait for fbcon copy to complete before switching mode (rh#522688)
112
113* Thu Sep 10 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-9.20090910git806eaf6
114- fix a hang/crash issue that could occur during a modeset
115- nouveau-transition-hack.patch: drop, supported with driver pixmaps anyway
116
117* Wed Sep 09 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-8.20090904git2b5ec6a
118- nouveau-tile7000.patch: workaround some display corruption on G8x
119
120* Fri Sep 04 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-7.20090904git2b5ec6a
121- fix cursor being left enabled on wrong display
122
123* Thu Aug 27 2009 Adam Jackson <ajax@redhat.com> 0.0.15-6.20090820git569a17a
124- nouveau-bgnr.patch: Enable seamless plymouth->gdm transition.
125
126* Fri Aug 21 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-5.20090820git569a17a
127- a couple more minor fixes
128
129* Thu Aug 20 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-4.20090819gitfe2b5e6
130- various fixes from upstream, build pending new xorg-x11-server update
131
132* Tue Aug 11 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-3.20090810git85b1c86
133- wfb fixes, driver pixmaps enabled by default
134
135* Wed Aug 05 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-2.20090803git712064e
136- dri2 fixes, no wfb without kms, non-kms fb resize fixes, other misc fixes
137
138* Tue Aug 04 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-1.20090803git619103a
139- upstream update, misc fixes
140
141* Tue Jul 28 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-0.20090728git4d20547
142- Update to latest upstream
143
144* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.0.14-4.20090717gitb1b2330
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
146
147* Fri Jul 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-3.20090717gitb1b2330
148- somehow missed updated patches to go on top
149
150* Fri Jul 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-2.20090717gitb1b2330
151- build fixes for recent X changes
152
153* Wed Jul 15 2009 Adam Jackson <ajax@redhat.com> - 1:0.0.14-1.20090701git6d14327.1
154- ABI bump
155
156* Mon Jul 7 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-1.20090701git6d14327
157- update from upstream + bring back additional features found in F11
158
159* Fri Jun 26 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-0.20090625gitc0bf670
160- rebase onto latest upstream.  missing some features that were patched into
161  F11, they'll come back soon.
162
163* Fri Apr 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-29.20090417gitfa2f111
164- avoid post-beta hangs experienced by many people (rh#495764, rh#493222).
165  - the bug here was relatively harmless, but exposed a more serious issue
166    which has been fixed in libdrm-2.4.6-6.fc11
167- kms: speed up transitions, they could take a couple of seconds previously
168- framebuffer resize support (rh#495838, rh#487356, lots of dups)
169
170* Wed Apr 15 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-27.20090413git7100c06
171- fix rh#495843
172
173* Mon Apr 13 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-26.20090413git7100c06
174- nouveau-fedora.patch: split out into indivdual functionality
175- nv50: disable acceleration on NVAx chipsets, it won't work properly yet
176- drop nouveau-eedid.patch, it's upstream now
177
178* Wed Apr 08 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-25.20090408gitd8545e6
179- correct logic error in vbios parser (rh#493981)
180
181* Wed Apr 08 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-24.20090408git960a5c8
182- modify nv50 ddc regs again, fix kms edid property
183
184* Tue Apr 07 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-23.20090407git11451ca
185- upstream update: rh#492399, nv50 PROM fixes
186
187* Sat Apr 04 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-22.20090404git836d985
188- use consistent connector names across all modesetting paths
189- rh#493981
190
191* Fri Apr 03 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-21.20090403git11be9a9
192- upstream update, loads of modesetting fixes
193- rh#492819, rh#492427, rh#492289, rh#492289
194
195* Mon Mar 30 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-20.20090330git9d46930
196- xv bugfix
197
198* Mon Mar 30 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-19.20090330git9213c39
199- fix rh#492239, and various modesetting changes
200- nouveau-eedid.patch: remove nv50 hunk, is upstream now
201
202* Fri Mar 27 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-18.20090327gitf1907dc
203- nv50: add default modes to mode pool for lvds panels (rh#492360)
204- kms: fix getting edid blob from kernel
205
206* Fri Mar 27 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-17.20090327gitf431e20
207- fix partially obscured xv rendering without compmgr (rh#492227,rh#492229,rh#492428)
208- fix crash when rotation requested (fdo#20848)
209- additional sanity checks for kernel modesetting enabled
210
211* Thu Mar 26 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-16.20090326git01cee29
212- update, should fix rh#497173
213
214* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-15.20090324git4067ab4
215- more ppc build fixes
216
217* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-14.20090323git3063486
218- fix ppc build
219
220* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-13.20090323gitd80fe78
221- modesetting fixes, should handle rh#487456
222
223* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-12.20090318git3e7fa97
224- upstream update, various fixes to pre-nv50 modesetting, cleanups
225
226* Fri Mar 13 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-11.20090313git79d23d8
227- kms: dpms fixes
228- kms: nicer reporting of output properties to users
229- improve init paths, more robust
230- support for multiple xservers (fast user switching)
231
232* Tue Mar 10 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-10.20090310git8f9a580
233- upstream update, should fix #455194
234
235* Mon Mar 09 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-9.20090309gited9bd88
236- upstream update, fixes
237- store used vbios image in /var/run, will potentially help debugging later
238
239* Thu Mar 05 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-8.20090305git42f99e6
240- upstream update, fixes
241- kms: support gamma and dpms calls
242- kms: nicer transition to gdm from plymouth
243
244* Mon Mar 02 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-7.20090302gite6c3b98
245- upstream update, fixes
246
247* Fri Feb 27 2009 Adam Jackson <ajax@redhat.com> 0.0.12-6.20090224gitd91fc78
248- nouveau-eedid.patch: Do EEDID.
249
250* Tue Feb 24 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-5.20090224gitd91fc78
251- improve description of package
252
253* Tue Feb 24 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-4.20090224gitd91fc78
254- new upstream snapshot
255
256* Tue Feb 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-1.20090216git7b25a30
257- fixes from upstream
258- append git version to tarball filename
259
260* Mon Feb 16 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-1.20090213git2573c06
261- latest snapshot
262- add patches to improve G80/G90 desktop performance
263
264* Sat Feb 7 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-3.20090205git945f0cb
265- build with kms paths enabled, so things don't blow up with kms turned on
266
267* Thu Feb 5 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-1.20090205git945f0cb
268- latest snapshot - kernel interface 0.0.12
269
270* Tue Feb 03 2009 Kyle McMartin <kyle@redhat.com> 0.0.11-2.20090106git133c1a5
271- add build-dep on mesa (missing GL/gl.h due to glxint.h)
272
273* Tue Jan 13 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.11-1.20090106git133c1a5
274- update to latest snapshot
275
276* Wed Nov 19 2008 Dave Airlie <airlied@redhat.com> 0.0.11-1.20081119git65b956f
277- update to latest upstream snapshot
278
279* Tue Sep 02 2008 Dave Airlie <airlied@redhat.com> 0.0.11-1.20080902git6dd8ad4
280- update to snapshot with new kernel interface 0.0.11
281
282* Tue May 20 2008 Dave Airlie <airlied@redhat.com> 0.0.10-3.20080520git9c1d87f
283- update to latest snapshot - enables randr12
284
285* Tue Apr 08 2008 Dave Airlie <airlied@redhat.com> 0.0.10-2.20080408git0991281
286- Update to latest snapshot
287
288* Tue Mar 11 2008 Dave Airlie <airlied@redhat.com> 1:0.0.10-1.20080311git460cb26
289- update to latest snapshot
290
291* Fri Feb 29 2008 Dave Airlie <airlied@redhat.com> 1:0.0.10-1.20080221git5db7920
292- Initial package for nouveau driver.
Note: See TracBrowser for help on using the repository browser.