source: projects/specs/trunk/x/xorg-x11-drv-mga/xorg-x11-drv-mga-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define tarball xf86-video-mga
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir       %{moduledir}/drivers
4
5%define gitdate 20080102
6
7Summary:   Xorg X11 mga video driver
8Summary(ja):   Xorg X11 mga ビデオドライバ
9Name:      xorg-x11-drv-mga
10Version:   1.4.11
11Release:   1%{?_dist_release}
12Epoch:     1
13URL:       http://www.x.org
14License:   MIT
15Group:     User Interface/X Hardware Support
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18Source0:   ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
19#Source0:    %{tarball}-%{gitdate}.tar.bz2
20Source1:    mga.xinf
21
22Patch0: mga-1.4.5-no-hal-advertising.patch
23Patch1: mga-1.4.6.1-get-client-pointer.patch
24
25ExcludeArch: s390 s390x
26
27BuildRequires: autoconf automake libtool
28BuildRequires: xorg-x11-server-sdk >= 1.6
29BuildRequires: mesa-libGL-devel >= 6.4-4
30BuildRequires: libdrm-devel >= 2.0-1
31
32Requires:  hwdata
33Requires:  xorg-x11-server-Xorg
34
35%description
36X.Org X11 mga video driver.
37
38%prep
39%setup -q -n %{tarball}-%{version}
40%patch0 -p1 -b .hal
41%patch1 -p1 -b .gcp
42
43%build
44autoreconf -v --install || exit 1
45%configure --disable-static
46make %{?_smp_mflags}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51make install DESTDIR=$RPM_BUILD_ROOT
52
53mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
54install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
55
56find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(-,root,root,-)
63%{driverdir}/mga_drv.so
64%{_datadir}/hwdata/videoaliases/mga.xinf
65%{_mandir}/man4/mga.4*
66
67%changelog
68* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.11-1
69- new upstream release
70
71* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-2
72- rebuild with xorg-server-1.6
73
74* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1:1.4.9-1
75- revert to 1.4.9
76- add Epoch: 1
77
78* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.100-1
79- new upstream release
80
81* Sat May 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
82- initial build for Vine Linux
83
84* Fri Feb 22 2008 Adam Jackson <ajax@redhat.com> 1.4.8-1
85- mga 1.4.8
86
87* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.7-2.20080102
88- Autorebuild for GCC 4.3
89
90* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 1.4.7-1.20080102
91- Rebuild for new server ABI.
92
93* Wed Jan 02 2008 Adam Jackson <ajax@redhat.com> 1.4.7-0.20080102
94- Today's git snapshot for pciaccess goodness.
95- mga-1.4.7-death-to-cfb.patch: Remove what little cfb support there was.
96- mga-1.4.7-alloca.patch: Fix ALLOCATE_LOCAL references.
97
98* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.4.6.1-6
99- Rebuild for PPC toolchain bug
100
101* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 1.4.6.1-5
102- Use %%{?_smp_mflags}.
103
104* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 1.4.6.1-4
105- Update Requires and BuildRequires.  Add Requires: hwdata.
106
107* Mon Feb 26 2007 Adam Jackson <ajax@redhat.com> 1.4.6.1-3
108- Late-bind a call into a loadable module
109- Disown the module directory
110
111* Fri Feb 16 2007 Adam Jackson <ajax@redhat.com> 1.4.6.1-2
112- ExclusiveArch -> ExcludeArch
113- DRI on all arches
114
115* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.4.6.1-1
116- Update to 1.4.6.1
117
118* Mon Dec 4 2006 Adam Jackson <ajax@redhat.com> 1.4.5-2
119- mga-1.4.5-no-hal-advertising.patch: Don't link to the HAL module as it's
120  non-free.
121
122* Fri Dec 1 2006 Adam Jackson <ajax@redhat.com> 1.4.5-1
123- Update to 1.4.5.
124
125* Fri Aug 18 2006 Kristian Høgsberg <krh@redhat.com> 1.4.1-5.fc6
126- Add Tilman Sauerbecks patch to fix DRI locking.
127
128* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.4.1-4.1
129- rebuild
130
131* Thu Jul  6 2006 Adam Jackson <ajackson@redhat.com> 1.4.1-4
132- mga.xinf updates.  Add G200SE cards, remove Impression and Mistral IDs
133  (since they do not and never have worked), and comment each line with
134  the appropriate card name.
135
136* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.4.1-3
137- Added with_dri conditionalization (not yet working for non-dri case).
138- Added "BuildRequires: libdrm-devel >= 2.0-1" for (#192358).
139- Added "BuildRequires: mesa-libGL-devel >= 6.4-4".
140- Bumped sdk dep to pick up proto-devel indirectly.
141
142* Sun Apr  9 2006 Adam Jackson <ajackson@redhat.com> 1.4.1-2
143- Update to 1.4.1 from 7.1RC1.
144
145* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.2.1.3-1.2
146- bump again for double-long bug on ppc(64)
147
148* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.2.1.3-1.1
149- rebuilt for new gcc4.1 snapshot and glibc changes
150
151* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.2.1.3-1
152- Updated xorg-x11-drv-mga to version 1.2.1.3 from X11R7.0
153
154* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.2.1.2-1
155- Updated xorg-x11-drv-mga to version 1.2.1.2 from X11R7 RC4
156- Removed 'x' suffix from manpage dirs to match RC4 upstream.
157
158* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.2.1-1
159- Updated xorg-x11-drv-mga to version 1.2.1 from X11R7 RC2
160
161* Fri Nov 4 2005 Mike A. Harris <mharris@redhat.com> 1.2.0.1-1
162- Updated xorg-x11-drv-mga to version 1.2.0.1 from X11R7 RC1
163- Fix *.la file removal.
164- Remove hardware specific {_bindir}/stormdwg utility.
165
166* Mon Oct 3 2005 Mike A. Harris <mharris@redhat.com> 1.1.2-1
167- Update BuildRoot to use Fedora Packaging Guidelines.
168- Deglob file manifest.
169- Limit "ExclusiveArch" to x86, x86_64, ia64, ppc
170
171* Fri Sep 2 2005 Mike A. Harris <mharris@redhat.com> 1.1.2-0
172- Initial spec file for mga video driver generated automatically
173  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.