source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 7705

Revision 7705, 20.8 KB checked in by daisuke, 11 years ago (diff)

xorg-x11-drv-intel: update to 2.21.8, use SNA by default.

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20110817
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.21.8
10Release:   1%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# vine patch
24
25
26ExclusiveArch: %{ix86} x86_64 ia64
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: autoconf, automake, libtool
29BuildRequires: xorg-x11-server-sdk >= 1.7.99
30BuildRequires: libXvMC-devel
31BuildRequires: libGL-devel >= 7.10
32BuildRequires: libdrm-devel >= 2.4.25
33BuildRequires: kernel-headers >= 2.6.33
34BuildRequires: libudev-devel
35BuildRequires: libxcb-devel >= 1.5
36BuildRequires: xcb-util-devel
37
38Requires:  hwdata
39Requires:  xorg-x11-server-Xorg
40Requires:  xcb-util
41
42Obsoletes: xorg-x11-drv-i810
43Provides: xorg-x11-drv-i810
44
45#Conflicts:  kudzu < 1.2.42-1
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51X.Org X11 Intel video driver.
52
53%package devel
54Summary:   Xorg X11 Intel video driver XvMC development package
55Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
56Group:     Development/System
57Requires:  %{name} = %{epoch}:%{version}-%{release}
58Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
59
60%description devel
61X.Org X11 Intel video driver XvMC development package.
62
63%package -n intel-gpu-tools
64Summary:    Debugging tools for Intel graphics chips
65Group:      Development/Tools
66
67%description -n intel-gpu-tools
68Debugging tools for Intel graphics chips
69
70
71%prep
72%setup -q -n xf86-video-intel-%{version} -b3
73
74%patch10 -p1 -b .vga-clock
75
76%build
77autoreconf -vi
78
79%configure \
80  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
81  --enable-dri --enable-xvmc \
82  --enable-sna --enable-uxa \
83  --with-default-accel=sna \
84  --enable-xaa=no
85make
86
87pushd ../intel-gpu-tools-%{gputoolsdate}
88autoreconf -v --install
89%configure
90make
91popd
92
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97make install DESTDIR=$RPM_BUILD_ROOT
98mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
99install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
100
101pushd ../intel-gpu-tools-%{gputoolsdate}
102make install DESTDIR=$RPM_BUILD_ROOT
103popd
104
105
106find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%triggerpostun -- XOrg < 7.0
112if (grep -q i810 /etc/X11/xorg.conf)
113then
114  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
115  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
116fi ||:
117
118%files
119%defattr(-,root,root,-)
120%{driverdir}/intel_drv.so
121%{_datadir}/hwdata/videoaliases/intel.xinf
122%{_libdir}/libI810XvMC.so.*
123%{_libdir}/libIntelXvMC.so.*
124%{_mandir}/man4/i*
125
126%files devel
127%defattr(-,root,root,-)
128%{_libdir}/libI810XvMC.so
129%{_libdir}/libIntelXvMC.so
130
131%files -n intel-gpu-tools
132%defattr(-,root,root,-)
133%{_bindir}/*
134%{_mandir}/man1/intel_*.1*
135
136
137%changelog
138* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
139- new upstream release
140- change default accel method to sna.
141
142* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
143- new upstream release
144
145* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
146- new upstream release
147
148* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
149- new upstream release
150
151* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
152- new upstream release
153
154* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
155- new upstream release
156
157* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
158- new upstream release
159
160* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
161- new upstream release
162
163* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
164- new upstream release
165
166* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
167- new upstream release
168
169* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
170- new upstream release
171
172* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
173- rebuild with xcb-util-0.3.9
174
175* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
176- disable sna, enable uxa
177
178* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
179- new upstream release
180
181* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
182- rebuild with xserver-1.12.0
183
184* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
185- new upstream release
186- enable sna
187
188* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
189- disable sna/vmap
190
191* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
192- new upstram release
193- disable copy-fb patch
194
195* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
196- rebuild with xserver-1.11.1.902
197
198* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
199- add --enable-sna --enable-vmap
200
201* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
202- new upstream release
203
204* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
205- rebuild with xcb-util-0.3.8
206- drop Patch200
207
208* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
209- update to disable copy_fb on sandybridge/ivybridge
210
211* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
212- update intel.xinf
213- add patch10 from fedora
214  - Clamp VGA pixel clock to 250MHz,
215    anything higher's going to look awful anyway. (#559426)
216
217* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
218- drop patch1-3 and replaced with new patch1 from git master
219- add Patch200 to disable DRI on SandyBridge/IvyBridge
220- update intel-gpu-tools
221
222* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
223- add Patch1-3 from upstream
224
225* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
226- new upstream release
227- drop upstream patches: 107-115
228- temporary disabled patch101
229- BR: libdrm >= 2.4.25
230
231* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
232- add Patch101-115 from ubuntu/debian package
233  - Patch101: Plymouth integration patch
234  - Patch107: Check null return from uxa_acquire_solid()
235  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
236  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
237  - Patch110,114: Cherry picks to fix a large number of build warnings.
238  - Patch111: Fix clipped window plane offset
239  - Patch112: Fix issue where vertical green line and strange colors
240              shows up when playing gstreamer with certain videos,
241              when dragged.  (LP 460677)
242  - Patch113: Fixes GPU lockup during login with
243              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
244              error messages listed in the gpu dump text. (LP 710321)
245  - Patch115: Don't fill up Xorg.0.log with
246              "get vblank counter failed: Invalid argument" warnings.
247   
248* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
249- rebuild with xserver-1.10.0
250
251* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
252- new upstream release
253
254* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
255- new upstream release
256
257* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
258- rebuild with xserver-1.9.2
259
260* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
261- new upstream release
262- add Patch40: fix uxa planemask (backported)
263- add Patch61: add support for backlight on macbooks
264- add Patch62: disable page flipping for stability
265
266* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
267- new upstream release
268- drop patch70
269
270* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
271- rebuild again with xserver-1.8rc
272
273* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
274- add intel-gpu-tools as sub-package
275- rebuild with libdrm-2.4.18
276
277* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
278- new upstream release
279- import Patch1,2,60,70 from fedora
280- add BR: kernel-headers >= 2.6.33 (new drm header required)
281- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
282- add BR; libudev-devel and autoreconf for Patch60
283
284* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
285- rebuild with libdrm-2.4.17
286
287* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
288- new upstream release
289
290* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
291- new upstream release (hopefully fixes severe issues w/ efifb)
292- drop all patches already upstreamed; import Patch20/21 from Fedora
293
294* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
295- import Patch121,122 from ubuntu
296- build with libdrm-2.4.12 which fixes vt switch crash
297
298* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
299- apply patch114 to fix Xv with non-GEM kernel
300
301* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
302- update to 2.6.3
303- add patch106,107,115,118,119,120 from ubuntu
304  - add Patch106: remove triple buffering
305  - add Patch107: remove page flipping
306  - add Patch115: fix crash Xv overlay
307  - add Patch118: drop legacy3d
308  - add Patch119: fix crashes in drm bo
309  - add Patch120: fix vt switch
310- add patch130-134 from upstream git
311  - add Patch130: fix another vt switch leak
312  - add Patch131: Create known output configuration at EnterVT time
313  - add Patch132: fix leak of some 965 render state on VT switch
314  - add Patch133: fix crash with fake bufmgr and UXA
315  - add Patch134: fix EnterVT/LeaveVT
316  - add Patch135: add new chip supoprt
317
318
319* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
320- revert to 2.6.1, add Epoch
321- add Patch103-121 from ubuntu
322
323* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
324- new upstream release
325
326* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
327- new upstream release
328
329* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
330- new upstream release
331
332* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
333- add Patch5 - Dont die on irq handler failure
334
335* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
336- new upstream release
337- add BR: libdrm-devel >= 2.4.0-3
338
339* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
340- import Patch10,11,12 from ubuntu
341
342* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
343- new upstream release
344- add triggerpostun script to replace i810 driver to intel driver
345
346* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
347- new upstream release
348
349* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
350- new upstream release
351- rename i810.xinf to intel.xinf
352- update intel.xinf (add Intel 4 series)
353
354* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
355- rebuild with new xserver
356
357* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
358- new upstream release
359
360* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
361- new upstream release
362
363* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
364- new upstream release
365
366* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
367- initial build for Vine Linux
368
369* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
370- Rebuild for new server ABI.
371- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
372
373* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
374- hook up ch7017 (bz#408471)
375
376* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
377- xf86-video-intel 2.2.0
378
379* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
380- xf86-video-intel 2.1.99.
381- Drop the i810 driver.  Time to move on.
382- Require xserver 1.4.99.1
383
384* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
385- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
386
387* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
388- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
389  for textured Xv to use as an offscreen pixmap so xv actually works under
390  compiz - granted it may be unusably slow but at least stuff shows up.
391
392* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
393- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
394- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
395
396* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
397- intel-2.1.1-quirk-update.patch - update quirks from master
398
399* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
400- i810.xinf: Flip everything over to -intel by default now.  Still install
401  i810 driver just in case.
402
403* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
404- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
405
406* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
407- xf86-video-intel 2.1.1.
408
409* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
410- xf86-video-intel 2.1.0.
411
412* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
413- Update Requires and BuildRequires.
414
415* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
416- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
417  965GME, G33, Q33, and Q35 chips.
418
419* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
420- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
421  DRI clients are active, for better battery life.
422
423* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
424- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
425
426* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
427- xf86-video-intel 2.0.0.  Change the version number to match, why not.
428- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
429  rename this at some point.
430
431* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
432- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
433  915GM.
434
435* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
436- i810.xinf: More intel whitelisting (#214011, #234877)
437
438* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
439- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
440- i810.xinf: Point 965GM support at the intel driver since it's not present
441  in old i810.
442
443* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
444- xf86-video-intel-1.9.93 (RC3).
445
446* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
447- fix typo with 945GM pci id from my laptop
448
449* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
450- xf86-video-intel 1.9.92 (RC2).
451
452* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
453- Updated modesetting driver to one that will actually work with a 1.3 server.
454
455* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
456- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
457- Remove ivch and ch7017 from the install since they aren't hooked up to the
458  code anywhere
459- Disown the module
460
461* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
462- update modesetting driver to git snapshot from today
463
464* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
465- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
466
467* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
468- rebuilt for unwind info generation, broken in gcc-4.1.1-21
469
470* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
471- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
472  actually require kudzu to run.
473
474* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
475- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
476
477* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
478- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
479- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
480  driver match the corresponding terrible heuristic in the server.
481
482* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
483- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
484  correctly distinguish between Mac Mini and Macbook Pro.
485
486* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
487- i810.xinf: PCI IDs for i965.
488
489* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
490- i810.xinf: Uppercase PCI IDs.
491
492* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
493- Update i810 to 1.6.5, should fix DRI.
494- Add kuzdu requires.
495- i810.xinf: Start whitelisting devices over to intel.
496
497* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
498- intel-driver-rename.patch: Fix the driver name in more places so it'll,
499  you know, load.
500
501* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
502- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
503  LFP special casing in favor of the blacklist.
504
505* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
506- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
507  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
508  and is selected with Driver "intel" in xorg.conf.  Individual devices will
509  whitelist over to "intel" until that branch gets merged into head.
510- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
511- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
512  the BIOS is known to lie.
513
514* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
515- Today's snapshot: I2C bus creation fix.
516
517* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
518- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
519  clock when computing the modes list.
520- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
521  in centimeters as the size of the display in pixels.
522
523* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
524- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
525  probing.
526
527* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
528- Update again for a mode comparison bugfix.
529
530* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
531- Update to today's git; crash fixes, better pre-915 support, slightly better
532  autoconfigurability.
533
534* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
535- rebuild
536
537* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
538- Fix Revision number to match naming policy.
539
540* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
541- Add back modesetting changes.
542
543* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
544- Roll back modesetting changes and build for fc5 aiglx repo.
545
546* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
547- Snapshot of the git modesetting branch.
548
549* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
550- Update i810.xinf to include entries for E7221 and 945GM.
551
552* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
553- Add with_dri macro to spec file, and conditionalize build time DRI support
554
555* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
556- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
557  to pick up proto-devel as well.
558
559* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
560- Rebuild for 7.1 ABI fix.
561
562* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
563- Bump for fc5-bling build.
564
565* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
566- Update to 1.6.0 from 7.1RC1.
567
568* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
569- Add patch to add missing #include's, specifically assert.h.
570
571* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
572- Update to CVS snapshot of 20060322.
573
574* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
575- rebuilt for new gcc4.1 snapshot and glibc changes
576
577* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
578- Added 8086:2772 mapping to i810.xinf for bug (#178451)
579
580* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
581- Added 8086:2592 mapping to i810.xinf for bug (#172884)
582
583* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
584- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
585
586* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
587- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
588- Removed 'x' suffix from manpage dirs to match RC4 upstream.
589
590* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
591- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
592
593* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
594- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
595- Fix *.la file removal.
596- Added 'devel' subpackage for XvMC .so
597- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
598
599* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
600- Update BuildRoot to use Fedora Packaging Guidelines.
601- Deglob file manifest.
602- Limit "ExclusiveArch" to x86, x86_64, ia64
603
604* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
605- Initial spec file for i810 video driver generated automatically
606  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.