source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 7571

Revision 7571, 20.5 KB checked in by daisuke, 11 years ago (diff)

xorg-x11-drv-intel: update to 2.21.5

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20110817
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.21.5
10Release:   1%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# vine patch
24
25
26ExclusiveArch: %{ix86} x86_64 ia64
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: autoconf, automake, libtool
29BuildRequires: xorg-x11-server-sdk >= 1.7.99
30BuildRequires: libXvMC-devel
31BuildRequires: libGL-devel >= 7.10
32BuildRequires: libdrm-devel >= 2.4.25
33BuildRequires: kernel-headers >= 2.6.33
34BuildRequires: libudev-devel
35BuildRequires: libxcb-devel >= 1.5
36BuildRequires: xcb-util-devel
37
38Requires:  hwdata
39Requires:  xorg-x11-server-Xorg
40Requires:  xcb-util
41
42Obsoletes: xorg-x11-drv-i810
43Provides: xorg-x11-drv-i810
44
45#Conflicts:  kudzu < 1.2.42-1
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51X.Org X11 Intel video driver.
52
53%package devel
54Summary:   Xorg X11 Intel video driver XvMC development package
55Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
56Group:     Development/System
57Requires:  %{name} = %{epoch}:%{version}-%{release}
58Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
59
60%description devel
61X.Org X11 Intel video driver XvMC development package.
62
63%package -n intel-gpu-tools
64Summary:    Debugging tools for Intel graphics chips
65Group:      Development/Tools
66
67%description -n intel-gpu-tools
68Debugging tools for Intel graphics chips
69
70
71%prep
72%setup -q -n xf86-video-intel-%{version} -b3
73
74%patch10 -p1 -b .vga-clock
75
76%build
77autoreconf -vi
78
79%configure \
80  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
81  --enable-dri --enable-xvmc \
82  --enable-sna --enable-uxa \
83  --with-default-accel=uxa
84make
85
86pushd ../intel-gpu-tools-%{gputoolsdate}
87autoreconf -v --install
88%configure
89make
90popd
91
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96make install DESTDIR=$RPM_BUILD_ROOT
97mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
98install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
99
100pushd ../intel-gpu-tools-%{gputoolsdate}
101make install DESTDIR=$RPM_BUILD_ROOT
102popd
103
104
105find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%triggerpostun -- XOrg < 7.0
111if (grep -q i810 /etc/X11/xorg.conf)
112then
113  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
114  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
115fi ||:
116
117%files
118%defattr(-,root,root,-)
119%{driverdir}/intel_drv.so
120%{_datadir}/hwdata/videoaliases/intel.xinf
121%{_libdir}/libI810XvMC.so.*
122%{_libdir}/libIntelXvMC.so.*
123%{_mandir}/man4/i*
124
125%files devel
126%defattr(-,root,root,-)
127%{_libdir}/libI810XvMC.so
128%{_libdir}/libIntelXvMC.so
129
130%files -n intel-gpu-tools
131%defattr(-,root,root,-)
132%{_bindir}/*
133%{_mandir}/man1/intel_*.1*
134
135
136%changelog
137* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
138- new upstream release
139
140* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
141- new upstream release
142
143* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
144- new upstream release
145
146* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
147- new upstream release
148
149* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
150- new upstream release
151
152* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
153- new upstream release
154
155* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
156- new upstream release
157
158* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
159- new upstream release
160
161* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
162- new upstream release
163
164* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
165- rebuild with xcb-util-0.3.9
166
167* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
168- disable sna, enable uxa
169
170* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
171- new upstream release
172
173* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
174- rebuild with xserver-1.12.0
175
176* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
177- new upstream release
178- enable sna
179
180* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
181- disable sna/vmap
182
183* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
184- new upstram release
185- disable copy-fb patch
186
187* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
188- rebuild with xserver-1.11.1.902
189
190* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
191- add --enable-sna --enable-vmap
192
193* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
194- new upstream release
195
196* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
197- rebuild with xcb-util-0.3.8
198- drop Patch200
199
200* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
201- update to disable copy_fb on sandybridge/ivybridge
202
203* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
204- update intel.xinf
205- add patch10 from fedora
206  - Clamp VGA pixel clock to 250MHz,
207    anything higher's going to look awful anyway. (#559426)
208
209* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
210- drop patch1-3 and replaced with new patch1 from git master
211- add Patch200 to disable DRI on SandyBridge/IvyBridge
212- update intel-gpu-tools
213
214* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
215- add Patch1-3 from upstream
216
217* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
218- new upstream release
219- drop upstream patches: 107-115
220- temporary disabled patch101
221- BR: libdrm >= 2.4.25
222
223* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
224- add Patch101-115 from ubuntu/debian package
225  - Patch101: Plymouth integration patch
226  - Patch107: Check null return from uxa_acquire_solid()
227  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
228  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
229  - Patch110,114: Cherry picks to fix a large number of build warnings.
230  - Patch111: Fix clipped window plane offset
231  - Patch112: Fix issue where vertical green line and strange colors
232              shows up when playing gstreamer with certain videos,
233              when dragged.  (LP 460677)
234  - Patch113: Fixes GPU lockup during login with
235              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
236              error messages listed in the gpu dump text. (LP 710321)
237  - Patch115: Don't fill up Xorg.0.log with
238              "get vblank counter failed: Invalid argument" warnings.
239   
240* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
241- rebuild with xserver-1.10.0
242
243* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
244- new upstream release
245
246* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
247- new upstream release
248
249* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
250- rebuild with xserver-1.9.2
251
252* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
253- new upstream release
254- add Patch40: fix uxa planemask (backported)
255- add Patch61: add support for backlight on macbooks
256- add Patch62: disable page flipping for stability
257
258* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
259- new upstream release
260- drop patch70
261
262* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
263- rebuild again with xserver-1.8rc
264
265* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
266- add intel-gpu-tools as sub-package
267- rebuild with libdrm-2.4.18
268
269* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
270- new upstream release
271- import Patch1,2,60,70 from fedora
272- add BR: kernel-headers >= 2.6.33 (new drm header required)
273- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
274- add BR; libudev-devel and autoreconf for Patch60
275
276* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
277- rebuild with libdrm-2.4.17
278
279* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
280- new upstream release
281
282* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
283- new upstream release (hopefully fixes severe issues w/ efifb)
284- drop all patches already upstreamed; import Patch20/21 from Fedora
285
286* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
287- import Patch121,122 from ubuntu
288- build with libdrm-2.4.12 which fixes vt switch crash
289
290* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
291- apply patch114 to fix Xv with non-GEM kernel
292
293* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
294- update to 2.6.3
295- add patch106,107,115,118,119,120 from ubuntu
296  - add Patch106: remove triple buffering
297  - add Patch107: remove page flipping
298  - add Patch115: fix crash Xv overlay
299  - add Patch118: drop legacy3d
300  - add Patch119: fix crashes in drm bo
301  - add Patch120: fix vt switch
302- add patch130-134 from upstream git
303  - add Patch130: fix another vt switch leak
304  - add Patch131: Create known output configuration at EnterVT time
305  - add Patch132: fix leak of some 965 render state on VT switch
306  - add Patch133: fix crash with fake bufmgr and UXA
307  - add Patch134: fix EnterVT/LeaveVT
308  - add Patch135: add new chip supoprt
309
310
311* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
312- revert to 2.6.1, add Epoch
313- add Patch103-121 from ubuntu
314
315* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
316- new upstream release
317
318* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
319- new upstream release
320
321* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
322- new upstream release
323
324* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
325- add Patch5 - Dont die on irq handler failure
326
327* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
328- new upstream release
329- add BR: libdrm-devel >= 2.4.0-3
330
331* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
332- import Patch10,11,12 from ubuntu
333
334* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
335- new upstream release
336- add triggerpostun script to replace i810 driver to intel driver
337
338* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
339- new upstream release
340
341* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
342- new upstream release
343- rename i810.xinf to intel.xinf
344- update intel.xinf (add Intel 4 series)
345
346* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
347- rebuild with new xserver
348
349* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
350- new upstream release
351
352* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
353- new upstream release
354
355* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
356- new upstream release
357
358* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
359- initial build for Vine Linux
360
361* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
362- Rebuild for new server ABI.
363- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
364
365* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
366- hook up ch7017 (bz#408471)
367
368* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
369- xf86-video-intel 2.2.0
370
371* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
372- xf86-video-intel 2.1.99.
373- Drop the i810 driver.  Time to move on.
374- Require xserver 1.4.99.1
375
376* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
377- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
378
379* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
380- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
381  for textured Xv to use as an offscreen pixmap so xv actually works under
382  compiz - granted it may be unusably slow but at least stuff shows up.
383
384* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
385- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
386- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
387
388* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
389- intel-2.1.1-quirk-update.patch - update quirks from master
390
391* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
392- i810.xinf: Flip everything over to -intel by default now.  Still install
393  i810 driver just in case.
394
395* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
396- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
397
398* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
399- xf86-video-intel 2.1.1.
400
401* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
402- xf86-video-intel 2.1.0.
403
404* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
405- Update Requires and BuildRequires.
406
407* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
408- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
409  965GME, G33, Q33, and Q35 chips.
410
411* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
412- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
413  DRI clients are active, for better battery life.
414
415* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
416- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
417
418* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
419- xf86-video-intel 2.0.0.  Change the version number to match, why not.
420- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
421  rename this at some point.
422
423* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
424- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
425  915GM.
426
427* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
428- i810.xinf: More intel whitelisting (#214011, #234877)
429
430* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
431- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
432- i810.xinf: Point 965GM support at the intel driver since it's not present
433  in old i810.
434
435* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
436- xf86-video-intel-1.9.93 (RC3).
437
438* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
439- fix typo with 945GM pci id from my laptop
440
441* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
442- xf86-video-intel 1.9.92 (RC2).
443
444* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
445- Updated modesetting driver to one that will actually work with a 1.3 server.
446
447* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
448- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
449- Remove ivch and ch7017 from the install since they aren't hooked up to the
450  code anywhere
451- Disown the module
452
453* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
454- update modesetting driver to git snapshot from today
455
456* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
457- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
458
459* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
460- rebuilt for unwind info generation, broken in gcc-4.1.1-21
461
462* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
463- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
464  actually require kudzu to run.
465
466* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
467- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
468
469* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
470- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
471- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
472  driver match the corresponding terrible heuristic in the server.
473
474* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
475- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
476  correctly distinguish between Mac Mini and Macbook Pro.
477
478* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
479- i810.xinf: PCI IDs for i965.
480
481* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
482- i810.xinf: Uppercase PCI IDs.
483
484* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
485- Update i810 to 1.6.5, should fix DRI.
486- Add kuzdu requires.
487- i810.xinf: Start whitelisting devices over to intel.
488
489* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
490- intel-driver-rename.patch: Fix the driver name in more places so it'll,
491  you know, load.
492
493* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
494- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
495  LFP special casing in favor of the blacklist.
496
497* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
498- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
499  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
500  and is selected with Driver "intel" in xorg.conf.  Individual devices will
501  whitelist over to "intel" until that branch gets merged into head.
502- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
503- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
504  the BIOS is known to lie.
505
506* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
507- Today's snapshot: I2C bus creation fix.
508
509* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
510- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
511  clock when computing the modes list.
512- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
513  in centimeters as the size of the display in pixels.
514
515* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
516- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
517  probing.
518
519* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
520- Update again for a mode comparison bugfix.
521
522* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
523- Update to today's git; crash fixes, better pre-915 support, slightly better
524  autoconfigurability.
525
526* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
527- rebuild
528
529* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
530- Fix Revision number to match naming policy.
531
532* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
533- Add back modesetting changes.
534
535* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
536- Roll back modesetting changes and build for fc5 aiglx repo.
537
538* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
539- Snapshot of the git modesetting branch.
540
541* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
542- Update i810.xinf to include entries for E7221 and 945GM.
543
544* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
545- Add with_dri macro to spec file, and conditionalize build time DRI support
546
547* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
548- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
549  to pick up proto-devel as well.
550
551* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
552- Rebuild for 7.1 ABI fix.
553
554* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
555- Bump for fc5-bling build.
556
557* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
558- Update to 1.6.0 from 7.1RC1.
559
560* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
561- Add patch to add missing #include's, specifically assert.h.
562
563* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
564- Update to CVS snapshot of 20060322.
565
566* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
567- rebuilt for new gcc4.1 snapshot and glibc changes
568
569* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
570- Added 8086:2772 mapping to i810.xinf for bug (#178451)
571
572* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
573- Added 8086:2592 mapping to i810.xinf for bug (#172884)
574
575* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
576- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
577
578* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
579- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
580- Removed 'x' suffix from manpage dirs to match RC4 upstream.
581
582* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
583- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
584
585* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
586- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
587- Fix *.la file removal.
588- Added 'devel' subpackage for XvMC .so
589- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
590
591* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
592- Update BuildRoot to use Fedora Packaging Guidelines.
593- Deglob file manifest.
594- Limit "ExclusiveArch" to x86, x86_64, ia64
595
596* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
597- Initial spec file for i810 video driver generated automatically
598  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.