source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 711

Revision 711, 16.4 KB checked in by daisuke, 14 years ago (diff)

update to 2.11.0

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20090908
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.11.0
10Release:   1%{?_dist_release}
11URL:       http://www.x.org
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19Patch1: kill-svideo.patch
20
21Patch2: intel-2.11.0-copy-fb.patch
22
23# patches from fedora - needs to be upstreamed
24Patch20: intel-2.8.0-kms-get-crtc.patch
25Patch30: intel-2.11.0-lvds-first.patch
26
27Patch60: uevent.patch
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: mesa-libGL-devel
35BuildRequires: libdrm-devel >= 2.4.16
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50%description
51X.Org X11 Intel video driver.
52
53%package devel
54Summary:   Xorg X11 Intel video driver XvMC development package
55Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
56Group:     Development/System
57Requires:  %{name} = %{epoch}:%{version}-%{release}
58Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
59
60%description devel
61X.Org X11 Intel video driver XvMC development package.
62
63%package -n intel-gpu-tools
64Summary:    Debugging tools for Intel graphics chips
65Group:      Development/Tools
66
67%description -n intel-gpu-tools
68Debugging tools for Intel graphics chips
69
70
71%prep
72%setup -q -n xf86-video-intel-%{version} -b3
73
74%patch1 -p1 -b .svideo
75%patch2 -p1 -b .copy-fb
76%patch20 -p1 -b .get-crtc
77%patch30 -p1 -b .lvds-first
78%patch60 -p1 -b .uevent
79
80%build
81autoreconf -vi
82
83%configure \
84  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
85  --enable-dri --enable-xvmc
86make
87
88pushd ../intel-gpu-tools-%{gputoolsdate}
89autoreconf -v --install
90%configure
91make
92popd
93
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98make install DESTDIR=$RPM_BUILD_ROOT
99mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
100install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
101
102pushd ../intel-gpu-tools-%{gputoolsdate}
103make install DESTDIR=$RPM_BUILD_ROOT
104popd
105
106
107find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%triggerpostun -- XOrg < 7.0
113if (grep -q i810 /etc/X11/xorg.conf)
114then
115  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
116  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
117fi ||:
118
119%files
120%defattr(-,root,root,-)
121%{driverdir}/intel_drv.so
122%{_datadir}/hwdata/videoaliases/intel.xinf
123%{_libdir}/libI810XvMC.so.*
124%{_libdir}/libIntelXvMC.so.*
125%{_mandir}/man4/i*
126
127%files devel
128%defattr(-,root,root,-)
129%{_libdir}/libI810XvMC.so
130%{_libdir}/libIntelXvMC.so
131
132%files -n intel-gpu-tools
133%defattr(-,root,root,-)
134%{_bindir}/intel_*
135%{_mandir}/man1/intel_*.1*
136
137
138%changelog
139* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
140- new upstream release
141- drop patch70
142
143* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
144- rebuild again with xserver-1.8rc
145
146* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
147- add intel-gpu-tools as sub-package
148- rebuild with libdrm-2.4.18
149
150* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
151- new upstream release
152- import Patch1,2,60,70 from fedora
153- add BR: kernel-headers >= 2.6.33 (new drm header required)
154- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
155- add BR; libudev-devel and autoreconf for Patch60
156
157* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
158- rebuild with libdrm-2.4.17
159
160* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
161- new upstream release
162
163* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
164- new upstream release (hopefully fixes severe issues w/ efifb)
165- drop all patches already upstreamed; import Patch20/21 from Fedora
166
167* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
168- import Patch121,122 from ubuntu
169- build with libdrm-2.4.12 which fixes vt switch crash
170
171* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
172- apply patch114 to fix Xv with non-GEM kernel
173
174* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
175- update to 2.6.3
176- add patch106,107,115,118,119,120 from ubuntu
177  - add Patch106: remove triple buffering
178  - add Patch107: remove page flipping
179  - add Patch115: fix crash Xv overlay
180  - add Patch118: drop legacy3d
181  - add Patch119: fix crashes in drm bo
182  - add Patch120: fix vt switch
183- add patch130-134 from upstream git
184  - add Patch130: fix another vt switch leak
185  - add Patch131: Create known output configuration at EnterVT time
186  - add Patch132: fix leak of some 965 render state on VT switch
187  - add Patch133: fix crash with fake bufmgr and UXA
188  - add Patch134: fix EnterVT/LeaveVT
189  - add Patch135: add new chip supoprt
190
191
192* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
193- revert to 2.6.1, add Epoch
194- add Patch103-121 from ubuntu
195
196* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
197- new upstream release
198
199* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
200- new upstream release
201
202* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
203- new upstream release
204
205* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
206- add Patch5 - Dont die on irq handler failure
207
208* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
209- new upstream release
210- add BR: libdrm-devel >= 2.4.0-3
211
212* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
213- import Patch10,11,12 from ubuntu
214
215* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
216- new upstream release
217- add triggerpostun script to replace i810 driver to intel driver
218
219* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
220- new upstream release
221
222* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
223- new upstream release
224- rename i810.xinf to intel.xinf
225- update intel.xinf (add Intel 4 series)
226
227* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
228- rebuild with new xserver
229
230* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
231- new upstream release
232
233* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
234- new upstream release
235
236* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
237- new upstream release
238
239* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
240- initial build for Vine Linux
241
242* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
243- Rebuild for new server ABI.
244- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
245
246* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
247- hook up ch7017 (bz#408471)
248
249* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
250- xf86-video-intel 2.2.0
251
252* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
253- xf86-video-intel 2.1.99.
254- Drop the i810 driver.  Time to move on.
255- Require xserver 1.4.99.1
256
257* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
258- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
259
260* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
261- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
262  for textured Xv to use as an offscreen pixmap so xv actually works under
263  compiz - granted it may be unusably slow but at least stuff shows up.
264
265* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
266- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
267- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
268
269* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
270- intel-2.1.1-quirk-update.patch - update quirks from master
271
272* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
273- i810.xinf: Flip everything over to -intel by default now.  Still install
274  i810 driver just in case.
275
276* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
277- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
278
279* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
280- xf86-video-intel 2.1.1.
281
282* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
283- xf86-video-intel 2.1.0.
284
285* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
286- Update Requires and BuildRequires.
287
288* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
289- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
290  965GME, G33, Q33, and Q35 chips.
291
292* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
293- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
294  DRI clients are active, for better battery life.
295
296* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
297- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
298
299* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
300- xf86-video-intel 2.0.0.  Change the version number to match, why not.
301- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
302  rename this at some point.
303
304* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
305- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
306  915GM.
307
308* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
309- i810.xinf: More intel whitelisting (#214011, #234877)
310
311* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
312- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
313- i810.xinf: Point 965GM support at the intel driver since it's not present
314  in old i810.
315
316* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
317- xf86-video-intel-1.9.93 (RC3).
318
319* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
320- fix typo with 945GM pci id from my laptop
321
322* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
323- xf86-video-intel 1.9.92 (RC2).
324
325* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
326- Updated modesetting driver to one that will actually work with a 1.3 server.
327
328* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
329- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
330- Remove ivch and ch7017 from the install since they aren't hooked up to the
331  code anywhere
332- Disown the module
333
334* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
335- update modesetting driver to git snapshot from today
336
337* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
338- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
339
340* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
341- rebuilt for unwind info generation, broken in gcc-4.1.1-21
342
343* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
344- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
345  actually require kudzu to run.
346
347* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
348- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
349
350* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
351- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
352- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
353  driver match the corresponding terrible heuristic in the server.
354
355* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
356- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
357  correctly distinguish between Mac Mini and Macbook Pro.
358
359* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
360- i810.xinf: PCI IDs for i965.
361
362* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
363- i810.xinf: Uppercase PCI IDs.
364
365* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
366- Update i810 to 1.6.5, should fix DRI.
367- Add kuzdu requires.
368- i810.xinf: Start whitelisting devices over to intel.
369
370* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
371- intel-driver-rename.patch: Fix the driver name in more places so it'll,
372  you know, load.
373
374* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
375- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
376  LFP special casing in favor of the blacklist.
377
378* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
379- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
380  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
381  and is selected with Driver "intel" in xorg.conf.  Individual devices will
382  whitelist over to "intel" until that branch gets merged into head.
383- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
384- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
385  the BIOS is known to lie.
386
387* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
388- Today's snapshot: I2C bus creation fix.
389
390* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
391- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
392  clock when computing the modes list.
393- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
394  in centimeters as the size of the display in pixels.
395
396* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
397- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
398  probing.
399
400* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
401- Update again for a mode comparison bugfix.
402
403* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
404- Update to today's git; crash fixes, better pre-915 support, slightly better
405  autoconfigurability.
406
407* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
408- rebuild
409
410* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
411- Fix Revision number to match naming policy.
412
413* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
414- Add back modesetting changes.
415
416* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
417- Roll back modesetting changes and build for fc5 aiglx repo.
418
419* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
420- Snapshot of the git modesetting branch.
421
422* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
423- Update i810.xinf to include entries for E7221 and 945GM.
424
425* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
426- Add with_dri macro to spec file, and conditionalize build time DRI support
427
428* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
429- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
430  to pick up proto-devel as well.
431
432* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
433- Rebuild for 7.1 ABI fix.
434
435* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
436- Bump for fc5-bling build.
437
438* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
439- Update to 1.6.0 from 7.1RC1.
440
441* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
442- Add patch to add missing #include's, specifically assert.h.
443
444* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
445- Update to CVS snapshot of 20060322.
446
447* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
448- rebuilt for new gcc4.1 snapshot and glibc changes
449
450* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
451- Added 8086:2772 mapping to i810.xinf for bug (#178451)
452
453* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
454- Added 8086:2592 mapping to i810.xinf for bug (#172884)
455
456* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
457- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
458
459* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
460- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
461- Removed 'x' suffix from manpage dirs to match RC4 upstream.
462
463* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
464- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
465
466* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
467- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
468- Fix *.la file removal.
469- Added 'devel' subpackage for XvMC .so
470- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
471
472* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
473- Update BuildRoot to use Fedora Packaging Guidelines.
474- Deglob file manifest.
475- Limit "ExclusiveArch" to x86, x86_64, ia64
476
477* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
478- Initial spec file for i810 video driver generated automatically
479  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.