source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 6819

Revision 6819, 20.1 KB checked in by daisuke, 12 years ago (diff)

update to 2.20.8

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20110817
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.20.8
10Release:   1%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# vine patch
24
25
26ExclusiveArch: %{ix86} x86_64 ia64
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: autoconf, automake, libtool
29BuildRequires: xorg-x11-server-sdk >= 1.7.99
30BuildRequires: libXvMC-devel
31BuildRequires: libGL-devel >= 7.10
32BuildRequires: libdrm-devel >= 2.4.25
33BuildRequires: kernel-headers >= 2.6.33
34BuildRequires: libudev-devel
35BuildRequires: libxcb-devel >= 1.5
36BuildRequires: xcb-util-devel
37
38Requires:  hwdata
39Requires:  xorg-x11-server-Xorg
40Requires:  xcb-util
41
42Obsoletes: xorg-x11-drv-i810
43Provides: xorg-x11-drv-i810
44
45#Conflicts:  kudzu < 1.2.42-1
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51X.Org X11 Intel video driver.
52
53%package devel
54Summary:   Xorg X11 Intel video driver XvMC development package
55Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
56Group:     Development/System
57Requires:  %{name} = %{epoch}:%{version}-%{release}
58Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
59
60%description devel
61X.Org X11 Intel video driver XvMC development package.
62
63%package -n intel-gpu-tools
64Summary:    Debugging tools for Intel graphics chips
65Group:      Development/Tools
66
67%description -n intel-gpu-tools
68Debugging tools for Intel graphics chips
69
70
71%prep
72%setup -q -n xf86-video-intel-%{version} -b3
73
74%patch10 -p1 -b .vga-clock
75
76%build
77autoreconf -vi
78
79%configure \
80  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
81  --enable-dri --enable-xvmc \
82  --enable-uxa
83make
84
85pushd ../intel-gpu-tools-%{gputoolsdate}
86autoreconf -v --install
87%configure
88make
89popd
90
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95make install DESTDIR=$RPM_BUILD_ROOT
96mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
97install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
98
99pushd ../intel-gpu-tools-%{gputoolsdate}
100make install DESTDIR=$RPM_BUILD_ROOT
101popd
102
103
104find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%triggerpostun -- XOrg < 7.0
110if (grep -q i810 /etc/X11/xorg.conf)
111then
112  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
113  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
114fi ||:
115
116%files
117%defattr(-,root,root,-)
118%{driverdir}/intel_drv.so
119%{_datadir}/hwdata/videoaliases/intel.xinf
120%{_libdir}/libI810XvMC.so.*
121%{_libdir}/libIntelXvMC.so.*
122%{_mandir}/man4/i*
123
124%files devel
125%defattr(-,root,root,-)
126%{_libdir}/libI810XvMC.so
127%{_libdir}/libIntelXvMC.so
128
129%files -n intel-gpu-tools
130%defattr(-,root,root,-)
131%{_bindir}/intel_*
132%{_mandir}/man1/intel_*.1*
133
134
135%changelog
136* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
137- new upstream release
138
139* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
140- new upstream release
141
142* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
143- new upstream release
144
145* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
146- new upstream release
147
148* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
149- rebuild with xcb-util-0.3.9
150
151* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
152- disable sna, enable uxa
153
154* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
155- new upstream release
156
157* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
158- rebuild with xserver-1.12.0
159
160* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
161- new upstream release
162- enable sna
163
164* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
165- disable sna/vmap
166
167* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
168- new upstram release
169- disable copy-fb patch
170
171* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
172- rebuild with xserver-1.11.1.902
173
174* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
175- add --enable-sna --enable-vmap
176
177* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
178- new upstream release
179
180* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
181- rebuild with xcb-util-0.3.8
182- drop Patch200
183
184* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
185- update to disable copy_fb on sandybridge/ivybridge
186
187* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
188- update intel.xinf
189- add patch10 from fedora
190  - Clamp VGA pixel clock to 250MHz,
191    anything higher's going to look awful anyway. (#559426)
192
193* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
194- drop patch1-3 and replaced with new patch1 from git master
195- add Patch200 to disable DRI on SandyBridge/IvyBridge
196- update intel-gpu-tools
197
198* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
199- add Patch1-3 from upstream
200
201* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
202- new upstream release
203- drop upstream patches: 107-115
204- temporary disabled patch101
205- BR: libdrm >= 2.4.25
206
207* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
208- add Patch101-115 from ubuntu/debian package
209  - Patch101: Plymouth integration patch
210  - Patch107: Check null return from uxa_acquire_solid()
211  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
212  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
213  - Patch110,114: Cherry picks to fix a large number of build warnings.
214  - Patch111: Fix clipped window plane offset
215  - Patch112: Fix issue where vertical green line and strange colors
216              shows up when playing gstreamer with certain videos,
217              when dragged.  (LP 460677)
218  - Patch113: Fixes GPU lockup during login with
219              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
220              error messages listed in the gpu dump text. (LP 710321)
221  - Patch115: Don't fill up Xorg.0.log with
222              "get vblank counter failed: Invalid argument" warnings.
223   
224* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
225- rebuild with xserver-1.10.0
226
227* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
228- new upstream release
229
230* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
231- new upstream release
232
233* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
234- rebuild with xserver-1.9.2
235
236* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
237- new upstream release
238- add Patch40: fix uxa planemask (backported)
239- add Patch61: add support for backlight on macbooks
240- add Patch62: disable page flipping for stability
241
242* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
243- new upstream release
244- drop patch70
245
246* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
247- rebuild again with xserver-1.8rc
248
249* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
250- add intel-gpu-tools as sub-package
251- rebuild with libdrm-2.4.18
252
253* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
254- new upstream release
255- import Patch1,2,60,70 from fedora
256- add BR: kernel-headers >= 2.6.33 (new drm header required)
257- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
258- add BR; libudev-devel and autoreconf for Patch60
259
260* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
261- rebuild with libdrm-2.4.17
262
263* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
264- new upstream release
265
266* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
267- new upstream release (hopefully fixes severe issues w/ efifb)
268- drop all patches already upstreamed; import Patch20/21 from Fedora
269
270* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
271- import Patch121,122 from ubuntu
272- build with libdrm-2.4.12 which fixes vt switch crash
273
274* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
275- apply patch114 to fix Xv with non-GEM kernel
276
277* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
278- update to 2.6.3
279- add patch106,107,115,118,119,120 from ubuntu
280  - add Patch106: remove triple buffering
281  - add Patch107: remove page flipping
282  - add Patch115: fix crash Xv overlay
283  - add Patch118: drop legacy3d
284  - add Patch119: fix crashes in drm bo
285  - add Patch120: fix vt switch
286- add patch130-134 from upstream git
287  - add Patch130: fix another vt switch leak
288  - add Patch131: Create known output configuration at EnterVT time
289  - add Patch132: fix leak of some 965 render state on VT switch
290  - add Patch133: fix crash with fake bufmgr and UXA
291  - add Patch134: fix EnterVT/LeaveVT
292  - add Patch135: add new chip supoprt
293
294
295* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
296- revert to 2.6.1, add Epoch
297- add Patch103-121 from ubuntu
298
299* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
300- new upstream release
301
302* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
303- new upstream release
304
305* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
306- new upstream release
307
308* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
309- add Patch5 - Dont die on irq handler failure
310
311* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
312- new upstream release
313- add BR: libdrm-devel >= 2.4.0-3
314
315* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
316- import Patch10,11,12 from ubuntu
317
318* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
319- new upstream release
320- add triggerpostun script to replace i810 driver to intel driver
321
322* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
323- new upstream release
324
325* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
326- new upstream release
327- rename i810.xinf to intel.xinf
328- update intel.xinf (add Intel 4 series)
329
330* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
331- rebuild with new xserver
332
333* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
334- new upstream release
335
336* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
337- new upstream release
338
339* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
340- new upstream release
341
342* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
343- initial build for Vine Linux
344
345* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
346- Rebuild for new server ABI.
347- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
348
349* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
350- hook up ch7017 (bz#408471)
351
352* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
353- xf86-video-intel 2.2.0
354
355* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
356- xf86-video-intel 2.1.99.
357- Drop the i810 driver.  Time to move on.
358- Require xserver 1.4.99.1
359
360* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
361- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
362
363* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
364- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
365  for textured Xv to use as an offscreen pixmap so xv actually works under
366  compiz - granted it may be unusably slow but at least stuff shows up.
367
368* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
369- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
370- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
371
372* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
373- intel-2.1.1-quirk-update.patch - update quirks from master
374
375* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
376- i810.xinf: Flip everything over to -intel by default now.  Still install
377  i810 driver just in case.
378
379* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
380- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
381
382* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
383- xf86-video-intel 2.1.1.
384
385* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
386- xf86-video-intel 2.1.0.
387
388* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
389- Update Requires and BuildRequires.
390
391* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
392- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
393  965GME, G33, Q33, and Q35 chips.
394
395* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
396- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
397  DRI clients are active, for better battery life.
398
399* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
400- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
401
402* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
403- xf86-video-intel 2.0.0.  Change the version number to match, why not.
404- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
405  rename this at some point.
406
407* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
408- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
409  915GM.
410
411* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
412- i810.xinf: More intel whitelisting (#214011, #234877)
413
414* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
415- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
416- i810.xinf: Point 965GM support at the intel driver since it's not present
417  in old i810.
418
419* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
420- xf86-video-intel-1.9.93 (RC3).
421
422* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
423- fix typo with 945GM pci id from my laptop
424
425* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
426- xf86-video-intel 1.9.92 (RC2).
427
428* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
429- Updated modesetting driver to one that will actually work with a 1.3 server.
430
431* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
432- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
433- Remove ivch and ch7017 from the install since they aren't hooked up to the
434  code anywhere
435- Disown the module
436
437* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
438- update modesetting driver to git snapshot from today
439
440* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
441- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
442
443* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
444- rebuilt for unwind info generation, broken in gcc-4.1.1-21
445
446* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
447- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
448  actually require kudzu to run.
449
450* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
451- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
452
453* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
454- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
455- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
456  driver match the corresponding terrible heuristic in the server.
457
458* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
459- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
460  correctly distinguish between Mac Mini and Macbook Pro.
461
462* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
463- i810.xinf: PCI IDs for i965.
464
465* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
466- i810.xinf: Uppercase PCI IDs.
467
468* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
469- Update i810 to 1.6.5, should fix DRI.
470- Add kuzdu requires.
471- i810.xinf: Start whitelisting devices over to intel.
472
473* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
474- intel-driver-rename.patch: Fix the driver name in more places so it'll,
475  you know, load.
476
477* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
478- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
479  LFP special casing in favor of the blacklist.
480
481* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
482- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
483  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
484  and is selected with Driver "intel" in xorg.conf.  Individual devices will
485  whitelist over to "intel" until that branch gets merged into head.
486- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
487- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
488  the BIOS is known to lie.
489
490* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
491- Today's snapshot: I2C bus creation fix.
492
493* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
494- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
495  clock when computing the modes list.
496- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
497  in centimeters as the size of the display in pixels.
498
499* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
500- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
501  probing.
502
503* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
504- Update again for a mode comparison bugfix.
505
506* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
507- Update to today's git; crash fixes, better pre-915 support, slightly better
508  autoconfigurability.
509
510* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
511- rebuild
512
513* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
514- Fix Revision number to match naming policy.
515
516* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
517- Add back modesetting changes.
518
519* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
520- Roll back modesetting changes and build for fc5 aiglx repo.
521
522* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
523- Snapshot of the git modesetting branch.
524
525* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
526- Update i810.xinf to include entries for E7221 and 945GM.
527
528* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
529- Add with_dri macro to spec file, and conditionalize build time DRI support
530
531* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
532- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
533  to pick up proto-devel as well.
534
535* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
536- Rebuild for 7.1 ABI fix.
537
538* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
539- Bump for fc5-bling build.
540
541* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
542- Update to 1.6.0 from 7.1RC1.
543
544* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
545- Add patch to add missing #include's, specifically assert.h.
546
547* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
548- Update to CVS snapshot of 20060322.
549
550* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
551- rebuilt for new gcc4.1 snapshot and glibc changes
552
553* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
554- Added 8086:2772 mapping to i810.xinf for bug (#178451)
555
556* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
557- Added 8086:2592 mapping to i810.xinf for bug (#172884)
558
559* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
560- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
561
562* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
563- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
564- Removed 'x' suffix from manpage dirs to match RC4 upstream.
565
566* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
567- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
568
569* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
570- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
571- Fix *.la file removal.
572- Added 'devel' subpackage for XvMC .so
573- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
574
575* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
576- Update BuildRoot to use Fedora Packaging Guidelines.
577- Deglob file manifest.
578- Limit "ExclusiveArch" to x86, x86_64, ia64
579
580* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
581- Initial spec file for i810 video driver generated automatically
582  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.