source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 5755

Revision 5755, 19.4 KB checked in by daisuke, 12 years ago (diff)

update to 2.18.0, enable SNA again

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20110817
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.18.0
10Release:   1%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79#%patch101 -p1 -b .copy-fb
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc \
87  --enable-sna
88make
89
90pushd ../intel-gpu-tools-%{gputoolsdate}
91autoreconf -v --install
92%configure
93make
94popd
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DESTDIR=$RPM_BUILD_ROOT
101mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
102install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
103
104pushd ../intel-gpu-tools-%{gputoolsdate}
105make install DESTDIR=$RPM_BUILD_ROOT
106popd
107
108
109find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%triggerpostun -- XOrg < 7.0
115if (grep -q i810 /etc/X11/xorg.conf)
116then
117  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
118  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
119fi ||:
120
121%files
122%defattr(-,root,root,-)
123%{driverdir}/intel_drv.so
124%{_datadir}/hwdata/videoaliases/intel.xinf
125%{_libdir}/libI810XvMC.so.*
126%{_libdir}/libIntelXvMC.so.*
127%{_mandir}/man4/i*
128
129%files devel
130%defattr(-,root,root,-)
131%{_libdir}/libI810XvMC.so
132%{_libdir}/libIntelXvMC.so
133
134%files -n intel-gpu-tools
135%defattr(-,root,root,-)
136%{_bindir}/intel_*
137%{_mandir}/man1/intel_*.1*
138
139
140%changelog
141* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-3
142- new upstream release
143- enable sna
144
145* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
146- disable sna/vmap
147
148* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
149- new upstram release
150- disable copy-fb patch
151
152* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
153- rebuild with xserver-1.11.1.902
154
155* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
156- add --enable-sna --enable-vmap
157
158* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
159- new upstream release
160
161* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
162- rebuild with xcb-util-0.3.8
163- drop Patch200
164
165* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
166- update to disable copy_fb on sandybridge/ivybridge
167
168* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
169- update intel.xinf
170- add patch10 from fedora
171  - Clamp VGA pixel clock to 250MHz,
172    anything higher's going to look awful anyway. (#559426)
173
174* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
175- drop patch1-3 and replaced with new patch1 from git master
176- add Patch200 to disable DRI on SandyBridge/IvyBridge
177- update intel-gpu-tools
178
179* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
180- add Patch1-3 from upstream
181
182* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
183- new upstream release
184- drop upstream patches: 107-115
185- temporary disabled patch101
186- BR: libdrm >= 2.4.25
187
188* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
189- add Patch101-115 from ubuntu/debian package
190  - Patch101: Plymouth integration patch
191  - Patch107: Check null return from uxa_acquire_solid()
192  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
193  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
194  - Patch110,114: Cherry picks to fix a large number of build warnings.
195  - Patch111: Fix clipped window plane offset
196  - Patch112: Fix issue where vertical green line and strange colors
197              shows up when playing gstreamer with certain videos,
198              when dragged.  (LP 460677)
199  - Patch113: Fixes GPU lockup during login with
200              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
201              error messages listed in the gpu dump text. (LP 710321)
202  - Patch115: Don't fill up Xorg.0.log with
203              "get vblank counter failed: Invalid argument" warnings.
204   
205* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
206- rebuild with xserver-1.10.0
207
208* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
209- new upstream release
210
211* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
212- new upstream release
213
214* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
215- rebuild with xserver-1.9.2
216
217* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
218- new upstream release
219- add Patch40: fix uxa planemask (backported)
220- add Patch61: add support for backlight on macbooks
221- add Patch62: disable page flipping for stability
222
223* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
224- new upstream release
225- drop patch70
226
227* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
228- rebuild again with xserver-1.8rc
229
230* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
231- add intel-gpu-tools as sub-package
232- rebuild with libdrm-2.4.18
233
234* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
235- new upstream release
236- import Patch1,2,60,70 from fedora
237- add BR: kernel-headers >= 2.6.33 (new drm header required)
238- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
239- add BR; libudev-devel and autoreconf for Patch60
240
241* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
242- rebuild with libdrm-2.4.17
243
244* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
245- new upstream release
246
247* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
248- new upstream release (hopefully fixes severe issues w/ efifb)
249- drop all patches already upstreamed; import Patch20/21 from Fedora
250
251* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
252- import Patch121,122 from ubuntu
253- build with libdrm-2.4.12 which fixes vt switch crash
254
255* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
256- apply patch114 to fix Xv with non-GEM kernel
257
258* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
259- update to 2.6.3
260- add patch106,107,115,118,119,120 from ubuntu
261  - add Patch106: remove triple buffering
262  - add Patch107: remove page flipping
263  - add Patch115: fix crash Xv overlay
264  - add Patch118: drop legacy3d
265  - add Patch119: fix crashes in drm bo
266  - add Patch120: fix vt switch
267- add patch130-134 from upstream git
268  - add Patch130: fix another vt switch leak
269  - add Patch131: Create known output configuration at EnterVT time
270  - add Patch132: fix leak of some 965 render state on VT switch
271  - add Patch133: fix crash with fake bufmgr and UXA
272  - add Patch134: fix EnterVT/LeaveVT
273  - add Patch135: add new chip supoprt
274
275
276* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
277- revert to 2.6.1, add Epoch
278- add Patch103-121 from ubuntu
279
280* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
281- new upstream release
282
283* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
284- new upstream release
285
286* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
287- new upstream release
288
289* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
290- add Patch5 - Dont die on irq handler failure
291
292* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
293- new upstream release
294- add BR: libdrm-devel >= 2.4.0-3
295
296* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
297- import Patch10,11,12 from ubuntu
298
299* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
300- new upstream release
301- add triggerpostun script to replace i810 driver to intel driver
302
303* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
304- new upstream release
305
306* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
307- new upstream release
308- rename i810.xinf to intel.xinf
309- update intel.xinf (add Intel 4 series)
310
311* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
312- rebuild with new xserver
313
314* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
315- new upstream release
316
317* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
318- new upstream release
319
320* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
321- new upstream release
322
323* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
324- initial build for Vine Linux
325
326* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
327- Rebuild for new server ABI.
328- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
329
330* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
331- hook up ch7017 (bz#408471)
332
333* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
334- xf86-video-intel 2.2.0
335
336* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
337- xf86-video-intel 2.1.99.
338- Drop the i810 driver.  Time to move on.
339- Require xserver 1.4.99.1
340
341* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
342- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
343
344* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
345- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
346  for textured Xv to use as an offscreen pixmap so xv actually works under
347  compiz - granted it may be unusably slow but at least stuff shows up.
348
349* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
350- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
351- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
352
353* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
354- intel-2.1.1-quirk-update.patch - update quirks from master
355
356* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
357- i810.xinf: Flip everything over to -intel by default now.  Still install
358  i810 driver just in case.
359
360* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
361- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
362
363* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
364- xf86-video-intel 2.1.1.
365
366* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
367- xf86-video-intel 2.1.0.
368
369* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
370- Update Requires and BuildRequires.
371
372* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
373- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
374  965GME, G33, Q33, and Q35 chips.
375
376* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
377- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
378  DRI clients are active, for better battery life.
379
380* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
381- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
382
383* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
384- xf86-video-intel 2.0.0.  Change the version number to match, why not.
385- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
386  rename this at some point.
387
388* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
389- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
390  915GM.
391
392* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
393- i810.xinf: More intel whitelisting (#214011, #234877)
394
395* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
396- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
397- i810.xinf: Point 965GM support at the intel driver since it's not present
398  in old i810.
399
400* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
401- xf86-video-intel-1.9.93 (RC3).
402
403* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
404- fix typo with 945GM pci id from my laptop
405
406* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
407- xf86-video-intel 1.9.92 (RC2).
408
409* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
410- Updated modesetting driver to one that will actually work with a 1.3 server.
411
412* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
413- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
414- Remove ivch and ch7017 from the install since they aren't hooked up to the
415  code anywhere
416- Disown the module
417
418* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
419- update modesetting driver to git snapshot from today
420
421* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
422- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
423
424* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
425- rebuilt for unwind info generation, broken in gcc-4.1.1-21
426
427* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
428- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
429  actually require kudzu to run.
430
431* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
432- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
433
434* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
435- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
436- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
437  driver match the corresponding terrible heuristic in the server.
438
439* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
440- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
441  correctly distinguish between Mac Mini and Macbook Pro.
442
443* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
444- i810.xinf: PCI IDs for i965.
445
446* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
447- i810.xinf: Uppercase PCI IDs.
448
449* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
450- Update i810 to 1.6.5, should fix DRI.
451- Add kuzdu requires.
452- i810.xinf: Start whitelisting devices over to intel.
453
454* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
455- intel-driver-rename.patch: Fix the driver name in more places so it'll,
456  you know, load.
457
458* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
459- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
460  LFP special casing in favor of the blacklist.
461
462* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
463- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
464  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
465  and is selected with Driver "intel" in xorg.conf.  Individual devices will
466  whitelist over to "intel" until that branch gets merged into head.
467- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
468- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
469  the BIOS is known to lie.
470
471* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
472- Today's snapshot: I2C bus creation fix.
473
474* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
475- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
476  clock when computing the modes list.
477- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
478  in centimeters as the size of the display in pixels.
479
480* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
481- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
482  probing.
483
484* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
485- Update again for a mode comparison bugfix.
486
487* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
488- Update to today's git; crash fixes, better pre-915 support, slightly better
489  autoconfigurability.
490
491* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
492- rebuild
493
494* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
495- Fix Revision number to match naming policy.
496
497* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
498- Add back modesetting changes.
499
500* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
501- Roll back modesetting changes and build for fc5 aiglx repo.
502
503* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
504- Snapshot of the git modesetting branch.
505
506* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
507- Update i810.xinf to include entries for E7221 and 945GM.
508
509* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
510- Add with_dri macro to spec file, and conditionalize build time DRI support
511
512* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
513- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
514  to pick up proto-devel as well.
515
516* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
517- Rebuild for 7.1 ABI fix.
518
519* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
520- Bump for fc5-bling build.
521
522* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
523- Update to 1.6.0 from 7.1RC1.
524
525* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
526- Add patch to add missing #include's, specifically assert.h.
527
528* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
529- Update to CVS snapshot of 20060322.
530
531* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
532- rebuilt for new gcc4.1 snapshot and glibc changes
533
534* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
535- Added 8086:2772 mapping to i810.xinf for bug (#178451)
536
537* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
538- Added 8086:2592 mapping to i810.xinf for bug (#172884)
539
540* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
541- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
542
543* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
544- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
545- Removed 'x' suffix from manpage dirs to match RC4 upstream.
546
547* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
548- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
549
550* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
551- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
552- Fix *.la file removal.
553- Added 'devel' subpackage for XvMC .so
554- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
555
556* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
557- Update BuildRoot to use Fedora Packaging Guidelines.
558- Deglob file manifest.
559- Limit "ExclusiveArch" to x86, x86_64, ia64
560
561* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
562- Initial spec file for i810 video driver generated automatically
563  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.