source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 3899

Revision 3899, 18.5 KB checked in by daisuke, 13 years ago (diff)

xorg-x11-drv-intel:

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.15.0
10Release:   3%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# patches from upstream git
20# http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
21Patch1: xf86-video-intel-2.15.0-git9d6e02.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27# disable DRI on SandyBridge/IvyBridge for now.
28Patch200: intel-2.15.0-sandybridge-disable-dri.patch
29
30
31ExclusiveArch: %{ix86} x86_64 ia64
32BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33BuildRequires: autoconf, automake, libtool
34BuildRequires: xorg-x11-server-sdk >= 1.7.99
35BuildRequires: libXvMC-devel
36BuildRequires: libGL-devel >= 7.10
37BuildRequires: libdrm-devel >= 2.4.25
38BuildRequires: kernel-headers >= 2.6.33
39BuildRequires: libudev-devel
40BuildRequires: libxcb-devel >= 1.5
41BuildRequires: xcb-util-devel
42
43Requires:  hwdata
44Requires:  xorg-x11-server-Xorg
45Requires:  xcb-util
46
47Obsoletes: xorg-x11-drv-i810
48Provides: xorg-x11-drv-i810
49
50#Conflicts:  kudzu < 1.2.42-1
51
52%description
53X.Org X11 Intel video driver.
54
55%package devel
56Summary:   Xorg X11 Intel video driver XvMC development package
57Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
58Group:     Development/System
59Requires:  %{name} = %{epoch}:%{version}-%{release}
60Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
61
62%description devel
63X.Org X11 Intel video driver XvMC development package.
64
65%package -n intel-gpu-tools
66Summary:    Debugging tools for Intel graphics chips
67Group:      Development/Tools
68
69%description -n intel-gpu-tools
70Debugging tools for Intel graphics chips
71
72
73%prep
74%setup -q -n xf86-video-intel-%{version} -b3
75
76%patch1 -p1 -b .git9d6e02
77
78#%patch101 -p1 -b .copy-fb
79
80%patch200 -p1 -b .disable-dri
81
82%build
83autoreconf -vi
84
85%configure \
86  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
87  --enable-dri --enable-xvmc
88make
89
90pushd ../intel-gpu-tools-%{gputoolsdate}
91autoreconf -v --install
92%configure
93make
94popd
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DESTDIR=$RPM_BUILD_ROOT
101mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
102install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
103
104pushd ../intel-gpu-tools-%{gputoolsdate}
105make install DESTDIR=$RPM_BUILD_ROOT
106popd
107
108
109find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%triggerpostun -- XOrg < 7.0
115if (grep -q i810 /etc/X11/xorg.conf)
116then
117  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
118  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
119fi ||:
120
121%files
122%defattr(-,root,root,-)
123%{driverdir}/intel_drv.so
124%{_datadir}/hwdata/videoaliases/intel.xinf
125%{_libdir}/libI810XvMC.so.*
126%{_libdir}/libIntelXvMC.so.*
127%{_mandir}/man4/i*
128
129%files devel
130%defattr(-,root,root,-)
131%{_libdir}/libI810XvMC.so
132%{_libdir}/libIntelXvMC.so
133
134%files -n intel-gpu-tools
135%defattr(-,root,root,-)
136%{_bindir}/intel_*
137%{_mandir}/man1/intel_*.1*
138
139
140%changelog
141* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
142- drop patch1-3 and replaced with new patch1 from git master
143- add Patch200 to disable DRI on SandyBridge/IvyBridge
144- update intel-gpu-tools
145
146* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
147- add Patch1-3 from upstream
148
149* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
150- new upstream release
151- drop upstream patches: 107-115
152- temporary disabled patch101
153- BR: libdrm >= 2.4.25
154
155* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
156- add Patch101-115 from ubuntu/debian package
157  - Patch101: Plymouth integration patch
158  - Patch107: Check null return from uxa_acquire_solid()
159  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
160  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
161  - Patch110,114: Cherry picks to fix a large number of build warnings.
162  - Patch111: Fix clipped window plane offset
163  - Patch112: Fix issue where vertical green line and strange colors
164              shows up when playing gstreamer with certain videos,
165              when dragged.  (LP 460677)
166  - Patch113: Fixes GPU lockup during login with
167              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
168              error messages listed in the gpu dump text. (LP 710321)
169  - Patch115: Don't fill up Xorg.0.log with
170              "get vblank counter failed: Invalid argument" warnings.
171   
172* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
173- rebuild with xserver-1.10.0
174
175* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
176- new upstream release
177
178* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
179- new upstream release
180
181* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
182- rebuild with xserver-1.9.2
183
184* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
185- new upstream release
186- add Patch40: fix uxa planemask (backported)
187- add Patch61: add support for backlight on macbooks
188- add Patch62: disable page flipping for stability
189
190* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
191- new upstream release
192- drop patch70
193
194* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
195- rebuild again with xserver-1.8rc
196
197* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
198- add intel-gpu-tools as sub-package
199- rebuild with libdrm-2.4.18
200
201* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
202- new upstream release
203- import Patch1,2,60,70 from fedora
204- add BR: kernel-headers >= 2.6.33 (new drm header required)
205- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
206- add BR; libudev-devel and autoreconf for Patch60
207
208* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
209- rebuild with libdrm-2.4.17
210
211* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
212- new upstream release
213
214* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
215- new upstream release (hopefully fixes severe issues w/ efifb)
216- drop all patches already upstreamed; import Patch20/21 from Fedora
217
218* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
219- import Patch121,122 from ubuntu
220- build with libdrm-2.4.12 which fixes vt switch crash
221
222* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
223- apply patch114 to fix Xv with non-GEM kernel
224
225* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
226- update to 2.6.3
227- add patch106,107,115,118,119,120 from ubuntu
228  - add Patch106: remove triple buffering
229  - add Patch107: remove page flipping
230  - add Patch115: fix crash Xv overlay
231  - add Patch118: drop legacy3d
232  - add Patch119: fix crashes in drm bo
233  - add Patch120: fix vt switch
234- add patch130-134 from upstream git
235  - add Patch130: fix another vt switch leak
236  - add Patch131: Create known output configuration at EnterVT time
237  - add Patch132: fix leak of some 965 render state on VT switch
238  - add Patch133: fix crash with fake bufmgr and UXA
239  - add Patch134: fix EnterVT/LeaveVT
240  - add Patch135: add new chip supoprt
241
242
243* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
244- revert to 2.6.1, add Epoch
245- add Patch103-121 from ubuntu
246
247* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
248- new upstream release
249
250* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
251- new upstream release
252
253* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
254- new upstream release
255
256* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
257- add Patch5 - Dont die on irq handler failure
258
259* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
260- new upstream release
261- add BR: libdrm-devel >= 2.4.0-3
262
263* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
264- import Patch10,11,12 from ubuntu
265
266* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
267- new upstream release
268- add triggerpostun script to replace i810 driver to intel driver
269
270* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
271- new upstream release
272
273* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
274- new upstream release
275- rename i810.xinf to intel.xinf
276- update intel.xinf (add Intel 4 series)
277
278* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
279- rebuild with new xserver
280
281* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
282- new upstream release
283
284* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
285- new upstream release
286
287* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
288- new upstream release
289
290* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
291- initial build for Vine Linux
292
293* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
294- Rebuild for new server ABI.
295- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
296
297* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
298- hook up ch7017 (bz#408471)
299
300* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
301- xf86-video-intel 2.2.0
302
303* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
304- xf86-video-intel 2.1.99.
305- Drop the i810 driver.  Time to move on.
306- Require xserver 1.4.99.1
307
308* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
309- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
310
311* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
312- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
313  for textured Xv to use as an offscreen pixmap so xv actually works under
314  compiz - granted it may be unusably slow but at least stuff shows up.
315
316* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
317- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
318- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
319
320* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
321- intel-2.1.1-quirk-update.patch - update quirks from master
322
323* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
324- i810.xinf: Flip everything over to -intel by default now.  Still install
325  i810 driver just in case.
326
327* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
328- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
329
330* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
331- xf86-video-intel 2.1.1.
332
333* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
334- xf86-video-intel 2.1.0.
335
336* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
337- Update Requires and BuildRequires.
338
339* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
340- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
341  965GME, G33, Q33, and Q35 chips.
342
343* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
344- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
345  DRI clients are active, for better battery life.
346
347* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
348- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
349
350* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
351- xf86-video-intel 2.0.0.  Change the version number to match, why not.
352- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
353  rename this at some point.
354
355* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
356- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
357  915GM.
358
359* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
360- i810.xinf: More intel whitelisting (#214011, #234877)
361
362* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
363- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
364- i810.xinf: Point 965GM support at the intel driver since it's not present
365  in old i810.
366
367* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
368- xf86-video-intel-1.9.93 (RC3).
369
370* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
371- fix typo with 945GM pci id from my laptop
372
373* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
374- xf86-video-intel 1.9.92 (RC2).
375
376* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
377- Updated modesetting driver to one that will actually work with a 1.3 server.
378
379* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
380- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
381- Remove ivch and ch7017 from the install since they aren't hooked up to the
382  code anywhere
383- Disown the module
384
385* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
386- update modesetting driver to git snapshot from today
387
388* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
389- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
390
391* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
392- rebuilt for unwind info generation, broken in gcc-4.1.1-21
393
394* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
395- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
396  actually require kudzu to run.
397
398* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
399- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
400
401* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
402- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
403- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
404  driver match the corresponding terrible heuristic in the server.
405
406* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
407- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
408  correctly distinguish between Mac Mini and Macbook Pro.
409
410* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
411- i810.xinf: PCI IDs for i965.
412
413* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
414- i810.xinf: Uppercase PCI IDs.
415
416* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
417- Update i810 to 1.6.5, should fix DRI.
418- Add kuzdu requires.
419- i810.xinf: Start whitelisting devices over to intel.
420
421* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
422- intel-driver-rename.patch: Fix the driver name in more places so it'll,
423  you know, load.
424
425* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
426- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
427  LFP special casing in favor of the blacklist.
428
429* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
430- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
431  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
432  and is selected with Driver "intel" in xorg.conf.  Individual devices will
433  whitelist over to "intel" until that branch gets merged into head.
434- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
435- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
436  the BIOS is known to lie.
437
438* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
439- Today's snapshot: I2C bus creation fix.
440
441* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
442- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
443  clock when computing the modes list.
444- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
445  in centimeters as the size of the display in pixels.
446
447* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
448- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
449  probing.
450
451* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
452- Update again for a mode comparison bugfix.
453
454* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
455- Update to today's git; crash fixes, better pre-915 support, slightly better
456  autoconfigurability.
457
458* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
459- rebuild
460
461* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
462- Fix Revision number to match naming policy.
463
464* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
465- Add back modesetting changes.
466
467* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
468- Roll back modesetting changes and build for fc5 aiglx repo.
469
470* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
471- Snapshot of the git modesetting branch.
472
473* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
474- Update i810.xinf to include entries for E7221 and 945GM.
475
476* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
477- Add with_dri macro to spec file, and conditionalize build time DRI support
478
479* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
480- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
481  to pick up proto-devel as well.
482
483* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
484- Rebuild for 7.1 ABI fix.
485
486* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
487- Bump for fc5-bling build.
488
489* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
490- Update to 1.6.0 from 7.1RC1.
491
492* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
493- Add patch to add missing #include's, specifically assert.h.
494
495* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
496- Update to CVS snapshot of 20060322.
497
498* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
499- rebuilt for new gcc4.1 snapshot and glibc changes
500
501* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
502- Added 8086:2772 mapping to i810.xinf for bug (#178451)
503
504* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
505- Added 8086:2592 mapping to i810.xinf for bug (#172884)
506
507* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
508- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
509
510* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
511- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
512- Removed 'x' suffix from manpage dirs to match RC4 upstream.
513
514* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
515- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
516
517* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
518- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
519- Fix *.la file removal.
520- Added 'devel' subpackage for XvMC .so
521- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
522
523* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
524- Update BuildRoot to use Fedora Packaging Guidelines.
525- Deglob file manifest.
526- Limit "ExclusiveArch" to x86, x86_64, ia64
527
528* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
529- Initial spec file for i810 video driver generated automatically
530  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.