source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 3746

Revision 3746, 18.3 KB checked in by daisuke, 13 years ago (diff)

xorg-x11-drv-intel: add 3 upstream patch

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20090908
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.15.0
10Release:   2%{?_dist_release}
11URL:       http://www.x.org
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# upstream patches
20Patch1: intel-2.15.0-unsigned-promotion-batch-overflows.patch
21Patch2: intel-2.15.0-increase-video-state-emission.patch
22Patch3: intel-2.15.0-use-swapbufferwait.patch
23
24# import from ubuntu/debian package
25Patch101: intel-2.15.0-copy-fb.patch
26
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50%description
51X.Org X11 Intel video driver.
52
53%package devel
54Summary:   Xorg X11 Intel video driver XvMC development package
55Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
56Group:     Development/System
57Requires:  %{name} = %{epoch}:%{version}-%{release}
58Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
59
60%description devel
61X.Org X11 Intel video driver XvMC development package.
62
63%package -n intel-gpu-tools
64Summary:    Debugging tools for Intel graphics chips
65Group:      Development/Tools
66
67%description -n intel-gpu-tools
68Debugging tools for Intel graphics chips
69
70
71%prep
72%setup -q -n xf86-video-intel-%{version} -b3
73
74%patch1 -p1 -b .unsigned-promotion-batch-overflows
75%patch2 -p1 -b .increase-video-state-emission
76%patch3 -p1 -b .use-swapbufferwait
77#%patch101 -p1 -b .copy-fb
78
79%build
80autoreconf -vi
81
82%configure \
83  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
84  --enable-dri --enable-xvmc
85make
86
87pushd ../intel-gpu-tools-%{gputoolsdate}
88autoreconf -v --install
89%configure
90make
91popd
92
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97make install DESTDIR=$RPM_BUILD_ROOT
98mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
99install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
100
101pushd ../intel-gpu-tools-%{gputoolsdate}
102make install DESTDIR=$RPM_BUILD_ROOT
103popd
104
105
106find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%triggerpostun -- XOrg < 7.0
112if (grep -q i810 /etc/X11/xorg.conf)
113then
114  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
115  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
116fi ||:
117
118%files
119%defattr(-,root,root,-)
120%{driverdir}/intel_drv.so
121%{_datadir}/hwdata/videoaliases/intel.xinf
122%{_libdir}/libI810XvMC.so.*
123%{_libdir}/libIntelXvMC.so.*
124%{_mandir}/man4/i*
125
126%files devel
127%defattr(-,root,root,-)
128%{_libdir}/libI810XvMC.so
129%{_libdir}/libIntelXvMC.so
130
131%files -n intel-gpu-tools
132%defattr(-,root,root,-)
133%{_bindir}/intel_*
134%{_mandir}/man1/intel_*.1*
135
136
137%changelog
138* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
139- add Patch1-3 from upstream
140
141* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
142- new upstream release
143- drop upstream patches: 107-115
144- temporary disabled patch101
145- BR: libdrm >= 2.4.25
146
147* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
148- add Patch101-115 from ubuntu/debian package
149  - Patch101: Plymouth integration patch
150  - Patch107: Check null return from uxa_acquire_solid()
151  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
152  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
153  - Patch110,114: Cherry picks to fix a large number of build warnings.
154  - Patch111: Fix clipped window plane offset
155  - Patch112: Fix issue where vertical green line and strange colors
156              shows up when playing gstreamer with certain videos,
157              when dragged.  (LP 460677)
158  - Patch113: Fixes GPU lockup during login with
159              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
160              error messages listed in the gpu dump text. (LP 710321)
161  - Patch115: Don't fill up Xorg.0.log with
162              "get vblank counter failed: Invalid argument" warnings.
163   
164* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
165- rebuild with xserver-1.10.0
166
167* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
168- new upstream release
169
170* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
171- new upstream release
172
173* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
174- rebuild with xserver-1.9.2
175
176* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
177- new upstream release
178- add Patch40: fix uxa planemask (backported)
179- add Patch61: add support for backlight on macbooks
180- add Patch62: disable page flipping for stability
181
182* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
183- new upstream release
184- drop patch70
185
186* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
187- rebuild again with xserver-1.8rc
188
189* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
190- add intel-gpu-tools as sub-package
191- rebuild with libdrm-2.4.18
192
193* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
194- new upstream release
195- import Patch1,2,60,70 from fedora
196- add BR: kernel-headers >= 2.6.33 (new drm header required)
197- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
198- add BR; libudev-devel and autoreconf for Patch60
199
200* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
201- rebuild with libdrm-2.4.17
202
203* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
204- new upstream release
205
206* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
207- new upstream release (hopefully fixes severe issues w/ efifb)
208- drop all patches already upstreamed; import Patch20/21 from Fedora
209
210* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
211- import Patch121,122 from ubuntu
212- build with libdrm-2.4.12 which fixes vt switch crash
213
214* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
215- apply patch114 to fix Xv with non-GEM kernel
216
217* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
218- update to 2.6.3
219- add patch106,107,115,118,119,120 from ubuntu
220  - add Patch106: remove triple buffering
221  - add Patch107: remove page flipping
222  - add Patch115: fix crash Xv overlay
223  - add Patch118: drop legacy3d
224  - add Patch119: fix crashes in drm bo
225  - add Patch120: fix vt switch
226- add patch130-134 from upstream git
227  - add Patch130: fix another vt switch leak
228  - add Patch131: Create known output configuration at EnterVT time
229  - add Patch132: fix leak of some 965 render state on VT switch
230  - add Patch133: fix crash with fake bufmgr and UXA
231  - add Patch134: fix EnterVT/LeaveVT
232  - add Patch135: add new chip supoprt
233
234
235* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
236- revert to 2.6.1, add Epoch
237- add Patch103-121 from ubuntu
238
239* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
240- new upstream release
241
242* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
243- new upstream release
244
245* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
246- new upstream release
247
248* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
249- add Patch5 - Dont die on irq handler failure
250
251* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
252- new upstream release
253- add BR: libdrm-devel >= 2.4.0-3
254
255* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
256- import Patch10,11,12 from ubuntu
257
258* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
259- new upstream release
260- add triggerpostun script to replace i810 driver to intel driver
261
262* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
263- new upstream release
264
265* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
266- new upstream release
267- rename i810.xinf to intel.xinf
268- update intel.xinf (add Intel 4 series)
269
270* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
271- rebuild with new xserver
272
273* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
274- new upstream release
275
276* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
277- new upstream release
278
279* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
280- new upstream release
281
282* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
283- initial build for Vine Linux
284
285* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
286- Rebuild for new server ABI.
287- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
288
289* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
290- hook up ch7017 (bz#408471)
291
292* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
293- xf86-video-intel 2.2.0
294
295* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
296- xf86-video-intel 2.1.99.
297- Drop the i810 driver.  Time to move on.
298- Require xserver 1.4.99.1
299
300* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
301- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
302
303* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
304- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
305  for textured Xv to use as an offscreen pixmap so xv actually works under
306  compiz - granted it may be unusably slow but at least stuff shows up.
307
308* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
309- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
310- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
311
312* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
313- intel-2.1.1-quirk-update.patch - update quirks from master
314
315* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
316- i810.xinf: Flip everything over to -intel by default now.  Still install
317  i810 driver just in case.
318
319* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
320- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
321
322* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
323- xf86-video-intel 2.1.1.
324
325* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
326- xf86-video-intel 2.1.0.
327
328* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
329- Update Requires and BuildRequires.
330
331* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
332- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
333  965GME, G33, Q33, and Q35 chips.
334
335* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
336- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
337  DRI clients are active, for better battery life.
338
339* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
340- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
341
342* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
343- xf86-video-intel 2.0.0.  Change the version number to match, why not.
344- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
345  rename this at some point.
346
347* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
348- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
349  915GM.
350
351* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
352- i810.xinf: More intel whitelisting (#214011, #234877)
353
354* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
355- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
356- i810.xinf: Point 965GM support at the intel driver since it's not present
357  in old i810.
358
359* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
360- xf86-video-intel-1.9.93 (RC3).
361
362* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
363- fix typo with 945GM pci id from my laptop
364
365* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
366- xf86-video-intel 1.9.92 (RC2).
367
368* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
369- Updated modesetting driver to one that will actually work with a 1.3 server.
370
371* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
372- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
373- Remove ivch and ch7017 from the install since they aren't hooked up to the
374  code anywhere
375- Disown the module
376
377* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
378- update modesetting driver to git snapshot from today
379
380* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
381- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
382
383* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
384- rebuilt for unwind info generation, broken in gcc-4.1.1-21
385
386* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
387- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
388  actually require kudzu to run.
389
390* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
391- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
392
393* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
394- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
395- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
396  driver match the corresponding terrible heuristic in the server.
397
398* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
399- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
400  correctly distinguish between Mac Mini and Macbook Pro.
401
402* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
403- i810.xinf: PCI IDs for i965.
404
405* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
406- i810.xinf: Uppercase PCI IDs.
407
408* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
409- Update i810 to 1.6.5, should fix DRI.
410- Add kuzdu requires.
411- i810.xinf: Start whitelisting devices over to intel.
412
413* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
414- intel-driver-rename.patch: Fix the driver name in more places so it'll,
415  you know, load.
416
417* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
418- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
419  LFP special casing in favor of the blacklist.
420
421* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
422- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
423  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
424  and is selected with Driver "intel" in xorg.conf.  Individual devices will
425  whitelist over to "intel" until that branch gets merged into head.
426- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
427- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
428  the BIOS is known to lie.
429
430* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
431- Today's snapshot: I2C bus creation fix.
432
433* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
434- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
435  clock when computing the modes list.
436- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
437  in centimeters as the size of the display in pixels.
438
439* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
440- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
441  probing.
442
443* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
444- Update again for a mode comparison bugfix.
445
446* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
447- Update to today's git; crash fixes, better pre-915 support, slightly better
448  autoconfigurability.
449
450* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
451- rebuild
452
453* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
454- Fix Revision number to match naming policy.
455
456* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
457- Add back modesetting changes.
458
459* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
460- Roll back modesetting changes and build for fc5 aiglx repo.
461
462* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
463- Snapshot of the git modesetting branch.
464
465* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
466- Update i810.xinf to include entries for E7221 and 945GM.
467
468* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
469- Add with_dri macro to spec file, and conditionalize build time DRI support
470
471* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
472- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
473  to pick up proto-devel as well.
474
475* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
476- Rebuild for 7.1 ABI fix.
477
478* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
479- Bump for fc5-bling build.
480
481* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
482- Update to 1.6.0 from 7.1RC1.
483
484* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
485- Add patch to add missing #include's, specifically assert.h.
486
487* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
488- Update to CVS snapshot of 20060322.
489
490* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
491- rebuilt for new gcc4.1 snapshot and glibc changes
492
493* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
494- Added 8086:2772 mapping to i810.xinf for bug (#178451)
495
496* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
497- Added 8086:2592 mapping to i810.xinf for bug (#172884)
498
499* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
500- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
501
502* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
503- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
504- Removed 'x' suffix from manpage dirs to match RC4 upstream.
505
506* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
507- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
508
509* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
510- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
511- Fix *.la file removal.
512- Added 'devel' subpackage for XvMC .so
513- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
514
515* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
516- Update BuildRoot to use Fedora Packaging Guidelines.
517- Deglob file manifest.
518- Limit "ExclusiveArch" to x86, x86_64, ia64
519
520* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
521- Initial spec file for i810 video driver generated automatically
522  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.