source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 3466

Revision 3466, 17.9 KB checked in by daisuke, 13 years ago (diff)

xor-x11-drv-intel: upgrade to 2.15.0, drop all patches

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20090908
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.15.0
10Release:   1%{?_dist_release}
11URL:       http://www.x.org
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# import from ubuntu/debian package
20Patch101: intel-2.15.0-copy-fb.patch
21
22ExclusiveArch: %{ix86} x86_64 ia64
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires: autoconf, automake, libtool
25BuildRequires: xorg-x11-server-sdk >= 1.7.99
26BuildRequires: libXvMC-devel
27BuildRequires: libGL-devel >= 7.10
28BuildRequires: libdrm-devel >= 2.4.25
29BuildRequires: kernel-headers >= 2.6.33
30BuildRequires: libudev-devel
31BuildRequires: libxcb-devel >= 1.5
32BuildRequires: xcb-util-devel
33
34Requires:  hwdata
35Requires:  xorg-x11-server-Xorg
36Requires:  xcb-util
37
38Obsoletes: xorg-x11-drv-i810
39Provides: xorg-x11-drv-i810
40
41#Conflicts:  kudzu < 1.2.42-1
42
43%description
44X.Org X11 Intel video driver.
45
46%package devel
47Summary:   Xorg X11 Intel video driver XvMC development package
48Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
49Group:     Development/System
50Requires:  %{name} = %{epoch}:%{version}-%{release}
51Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
52
53%description devel
54X.Org X11 Intel video driver XvMC development package.
55
56%package -n intel-gpu-tools
57Summary:    Debugging tools for Intel graphics chips
58Group:      Development/Tools
59
60%description -n intel-gpu-tools
61Debugging tools for Intel graphics chips
62
63
64%prep
65%setup -q -n xf86-video-intel-%{version} -b3
66
67#%patch101 -p1 -b .copy-fb
68
69%build
70autoreconf -vi
71
72%configure \
73  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
74  --enable-dri --enable-xvmc
75make
76
77pushd ../intel-gpu-tools-%{gputoolsdate}
78autoreconf -v --install
79%configure
80make
81popd
82
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87make install DESTDIR=$RPM_BUILD_ROOT
88mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
89install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
90
91pushd ../intel-gpu-tools-%{gputoolsdate}
92make install DESTDIR=$RPM_BUILD_ROOT
93popd
94
95
96find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%triggerpostun -- XOrg < 7.0
102if (grep -q i810 /etc/X11/xorg.conf)
103then
104  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
105  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
106fi ||:
107
108%files
109%defattr(-,root,root,-)
110%{driverdir}/intel_drv.so
111%{_datadir}/hwdata/videoaliases/intel.xinf
112%{_libdir}/libI810XvMC.so.*
113%{_libdir}/libIntelXvMC.so.*
114%{_mandir}/man4/i*
115
116%files devel
117%defattr(-,root,root,-)
118%{_libdir}/libI810XvMC.so
119%{_libdir}/libIntelXvMC.so
120
121%files -n intel-gpu-tools
122%defattr(-,root,root,-)
123%{_bindir}/intel_*
124%{_mandir}/man1/intel_*.1*
125
126
127%changelog
128* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
129- new upstream release
130- drop upstream patches: 107-115
131- temporary disabled patch101
132- BR: libdrm >= 2.4.25
133
134* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
135- add Patch101-115 from ubuntu/debian package
136  - Patch101: Plymouth integration patch
137  - Patch107: Check null return from uxa_acquire_solid()
138  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
139  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
140  - Patch110,114: Cherry picks to fix a large number of build warnings.
141  - Patch111: Fix clipped window plane offset
142  - Patch112: Fix issue where vertical green line and strange colors
143              shows up when playing gstreamer with certain videos,
144              when dragged.  (LP 460677)
145  - Patch113: Fixes GPU lockup during login with
146              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
147              error messages listed in the gpu dump text. (LP 710321)
148  - Patch115: Don't fill up Xorg.0.log with
149              "get vblank counter failed: Invalid argument" warnings.
150   
151* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
152- rebuild with xserver-1.10.0
153
154* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
155- new upstream release
156
157* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
158- new upstream release
159
160* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
161- rebuild with xserver-1.9.2
162
163* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
164- new upstream release
165- add Patch40: fix uxa planemask (backported)
166- add Patch61: add support for backlight on macbooks
167- add Patch62: disable page flipping for stability
168
169* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
170- new upstream release
171- drop patch70
172
173* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
174- rebuild again with xserver-1.8rc
175
176* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
177- add intel-gpu-tools as sub-package
178- rebuild with libdrm-2.4.18
179
180* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
181- new upstream release
182- import Patch1,2,60,70 from fedora
183- add BR: kernel-headers >= 2.6.33 (new drm header required)
184- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
185- add BR; libudev-devel and autoreconf for Patch60
186
187* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
188- rebuild with libdrm-2.4.17
189
190* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
191- new upstream release
192
193* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
194- new upstream release (hopefully fixes severe issues w/ efifb)
195- drop all patches already upstreamed; import Patch20/21 from Fedora
196
197* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
198- import Patch121,122 from ubuntu
199- build with libdrm-2.4.12 which fixes vt switch crash
200
201* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
202- apply patch114 to fix Xv with non-GEM kernel
203
204* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
205- update to 2.6.3
206- add patch106,107,115,118,119,120 from ubuntu
207  - add Patch106: remove triple buffering
208  - add Patch107: remove page flipping
209  - add Patch115: fix crash Xv overlay
210  - add Patch118: drop legacy3d
211  - add Patch119: fix crashes in drm bo
212  - add Patch120: fix vt switch
213- add patch130-134 from upstream git
214  - add Patch130: fix another vt switch leak
215  - add Patch131: Create known output configuration at EnterVT time
216  - add Patch132: fix leak of some 965 render state on VT switch
217  - add Patch133: fix crash with fake bufmgr and UXA
218  - add Patch134: fix EnterVT/LeaveVT
219  - add Patch135: add new chip supoprt
220
221
222* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
223- revert to 2.6.1, add Epoch
224- add Patch103-121 from ubuntu
225
226* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
227- new upstream release
228
229* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
230- new upstream release
231
232* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
233- new upstream release
234
235* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
236- add Patch5 - Dont die on irq handler failure
237
238* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
239- new upstream release
240- add BR: libdrm-devel >= 2.4.0-3
241
242* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
243- import Patch10,11,12 from ubuntu
244
245* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
246- new upstream release
247- add triggerpostun script to replace i810 driver to intel driver
248
249* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
250- new upstream release
251
252* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
253- new upstream release
254- rename i810.xinf to intel.xinf
255- update intel.xinf (add Intel 4 series)
256
257* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
258- rebuild with new xserver
259
260* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
261- new upstream release
262
263* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
264- new upstream release
265
266* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
267- new upstream release
268
269* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
270- initial build for Vine Linux
271
272* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
273- Rebuild for new server ABI.
274- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
275
276* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
277- hook up ch7017 (bz#408471)
278
279* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
280- xf86-video-intel 2.2.0
281
282* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
283- xf86-video-intel 2.1.99.
284- Drop the i810 driver.  Time to move on.
285- Require xserver 1.4.99.1
286
287* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
288- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
289
290* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
291- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
292  for textured Xv to use as an offscreen pixmap so xv actually works under
293  compiz - granted it may be unusably slow but at least stuff shows up.
294
295* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
296- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
297- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
298
299* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
300- intel-2.1.1-quirk-update.patch - update quirks from master
301
302* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
303- i810.xinf: Flip everything over to -intel by default now.  Still install
304  i810 driver just in case.
305
306* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
307- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
308
309* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
310- xf86-video-intel 2.1.1.
311
312* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
313- xf86-video-intel 2.1.0.
314
315* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
316- Update Requires and BuildRequires.
317
318* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
319- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
320  965GME, G33, Q33, and Q35 chips.
321
322* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
323- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
324  DRI clients are active, for better battery life.
325
326* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
327- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
328
329* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
330- xf86-video-intel 2.0.0.  Change the version number to match, why not.
331- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
332  rename this at some point.
333
334* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
335- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
336  915GM.
337
338* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
339- i810.xinf: More intel whitelisting (#214011, #234877)
340
341* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
342- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
343- i810.xinf: Point 965GM support at the intel driver since it's not present
344  in old i810.
345
346* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
347- xf86-video-intel-1.9.93 (RC3).
348
349* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
350- fix typo with 945GM pci id from my laptop
351
352* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
353- xf86-video-intel 1.9.92 (RC2).
354
355* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
356- Updated modesetting driver to one that will actually work with a 1.3 server.
357
358* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
359- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
360- Remove ivch and ch7017 from the install since they aren't hooked up to the
361  code anywhere
362- Disown the module
363
364* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
365- update modesetting driver to git snapshot from today
366
367* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
368- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
369
370* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
371- rebuilt for unwind info generation, broken in gcc-4.1.1-21
372
373* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
374- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
375  actually require kudzu to run.
376
377* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
378- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
379
380* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
381- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
382- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
383  driver match the corresponding terrible heuristic in the server.
384
385* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
386- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
387  correctly distinguish between Mac Mini and Macbook Pro.
388
389* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
390- i810.xinf: PCI IDs for i965.
391
392* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
393- i810.xinf: Uppercase PCI IDs.
394
395* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
396- Update i810 to 1.6.5, should fix DRI.
397- Add kuzdu requires.
398- i810.xinf: Start whitelisting devices over to intel.
399
400* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
401- intel-driver-rename.patch: Fix the driver name in more places so it'll,
402  you know, load.
403
404* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
405- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
406  LFP special casing in favor of the blacklist.
407
408* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
409- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
410  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
411  and is selected with Driver "intel" in xorg.conf.  Individual devices will
412  whitelist over to "intel" until that branch gets merged into head.
413- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
414- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
415  the BIOS is known to lie.
416
417* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
418- Today's snapshot: I2C bus creation fix.
419
420* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
421- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
422  clock when computing the modes list.
423- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
424  in centimeters as the size of the display in pixels.
425
426* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
427- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
428  probing.
429
430* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
431- Update again for a mode comparison bugfix.
432
433* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
434- Update to today's git; crash fixes, better pre-915 support, slightly better
435  autoconfigurability.
436
437* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
438- rebuild
439
440* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
441- Fix Revision number to match naming policy.
442
443* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
444- Add back modesetting changes.
445
446* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
447- Roll back modesetting changes and build for fc5 aiglx repo.
448
449* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
450- Snapshot of the git modesetting branch.
451
452* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
453- Update i810.xinf to include entries for E7221 and 945GM.
454
455* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
456- Add with_dri macro to spec file, and conditionalize build time DRI support
457
458* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
459- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
460  to pick up proto-devel as well.
461
462* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
463- Rebuild for 7.1 ABI fix.
464
465* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
466- Bump for fc5-bling build.
467
468* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
469- Update to 1.6.0 from 7.1RC1.
470
471* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
472- Add patch to add missing #include's, specifically assert.h.
473
474* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
475- Update to CVS snapshot of 20060322.
476
477* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
478- rebuilt for new gcc4.1 snapshot and glibc changes
479
480* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
481- Added 8086:2772 mapping to i810.xinf for bug (#178451)
482
483* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
484- Added 8086:2592 mapping to i810.xinf for bug (#172884)
485
486* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
487- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
488
489* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
490- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
491- Removed 'x' suffix from manpage dirs to match RC4 upstream.
492
493* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
494- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
495
496* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
497- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
498- Fix *.la file removal.
499- Added 'devel' subpackage for XvMC .so
500- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
501
502* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
503- Update BuildRoot to use Fedora Packaging Guidelines.
504- Deglob file manifest.
505- Limit "ExclusiveArch" to x86, x86_64, ia64
506
507* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
508- Initial spec file for i810 video driver generated automatically
509  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.