source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 2893

Revision 2893, 18.6 KB checked in by daisuke, 13 years ago (diff)

xorg-x11-drv-intel: import patches from ubuntu/debian package

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20090908
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.14.0
10Release:   3%{?_dist_release}
11URL:       http://www.x.org
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# import from ubuntu/debian package
20Patch101: intel-2.14.0-copy-fb.patch
21Patch107: intel-2.14.0-solid_nullptr_check.patch
22Patch108: intel-2.14.0-undo_dmg_trans_before_append.patch
23Patch109: intel-2.14.0-dont_reconstruct_glyph_cache_on_rotate.patch
24Patch110: intel-2.14.0-warnings_cleanup.patch
25Patch111: intel-2.14.0-fix_clipped_window_plane_offset.patch
26Patch112: intel-2.14.0-fix_error_in_4c4ad555.patch
27Patch113: intel-2.14.0-remove_broken_max_base_addresses.patch
28Patch114: intel-2.14.0-warnings_cleanup_part_2.patch
29Patch115: intel-2.14.0-quell_vblank_counter_failed.patch
30
31ExclusiveArch: %{ix86} x86_64 ia64
32BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33BuildRequires: autoconf, automake, libtool
34BuildRequires: xorg-x11-server-sdk >= 1.7.99
35BuildRequires: libXvMC-devel
36BuildRequires: libGL-devel >= 7.10
37BuildRequires: libdrm-devel >= 2.4.23
38BuildRequires: kernel-headers >= 2.6.33
39BuildRequires: libudev-devel
40BuildRequires: libxcb-devel >= 1.5
41BuildRequires: xcb-util-devel
42
43Requires:  hwdata
44Requires:  xorg-x11-server-Xorg
45Requires:  xcb-util
46
47Obsoletes: xorg-x11-drv-i810
48Provides: xorg-x11-drv-i810
49
50#Conflicts:  kudzu < 1.2.42-1
51
52%description
53X.Org X11 Intel video driver.
54
55%package devel
56Summary:   Xorg X11 Intel video driver XvMC development package
57Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
58Group:     Development/System
59Requires:  %{name} = %{epoch}:%{version}-%{release}
60Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
61
62%description devel
63X.Org X11 Intel video driver XvMC development package.
64
65%package -n intel-gpu-tools
66Summary:    Debugging tools for Intel graphics chips
67Group:      Development/Tools
68
69%description -n intel-gpu-tools
70Debugging tools for Intel graphics chips
71
72
73%prep
74%setup -q -n xf86-video-intel-%{version} -b3
75
76%patch101 -p1 -b .copy-fb
77%patch107 -p1 -b .solid_nullptr_check
78%patch108 -p1 -b .undo_dmg_trans_before_append
79%patch109 -p1 -b .dont_reconstruct_glyph_cache_on_rotate
80%patch110 -p1 -b .warnings_cleanup
81%patch111 -p1 -b .fix_clipped_window_plane_offset
82%patch112 -p1 -b .fix_error_in_4c4ad555
83%patch113 -p1 -b .remove_broken_max_base_addresses
84%patch114 -p1 -b .warnings_cleanup_part_2
85%patch115 -p1 -b .quell_vblank_counter_failed
86
87%build
88autoreconf -vi
89
90%configure \
91  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
92  --enable-dri --enable-xvmc
93make
94
95pushd ../intel-gpu-tools-%{gputoolsdate}
96autoreconf -v --install
97%configure
98make
99popd
100
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105make install DESTDIR=$RPM_BUILD_ROOT
106mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
107install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
108
109pushd ../intel-gpu-tools-%{gputoolsdate}
110make install DESTDIR=$RPM_BUILD_ROOT
111popd
112
113
114find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%triggerpostun -- XOrg < 7.0
120if (grep -q i810 /etc/X11/xorg.conf)
121then
122  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
123  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
124fi ||:
125
126%files
127%defattr(-,root,root,-)
128%{driverdir}/intel_drv.so
129%{_datadir}/hwdata/videoaliases/intel.xinf
130%{_libdir}/libI810XvMC.so.*
131%{_libdir}/libIntelXvMC.so.*
132%{_mandir}/man4/i*
133
134%files devel
135%defattr(-,root,root,-)
136%{_libdir}/libI810XvMC.so
137%{_libdir}/libIntelXvMC.so
138
139%files -n intel-gpu-tools
140%defattr(-,root,root,-)
141%{_bindir}/intel_*
142%{_mandir}/man1/intel_*.1*
143
144
145%changelog
146* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
147- add Patch101-115 from ubuntu/debian package
148  - Patch101: Plymouth integration patch
149  - Patch107: Check null return from uxa_acquire_solid()
150  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
151  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
152  - Patch110,114: Cherry picks to fix a large number of build warnings.
153  - Patch111: Fix clipped window plane offset
154  - Patch112: Fix issue where vertical green line and strange colors
155              shows up when playing gstreamer with certain videos,
156              when dragged.  (LP 460677)
157  - Patch113: Fixes GPU lockup during login with
158              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
159              error messages listed in the gpu dump text. (LP 710321)
160  - Patch115: Don't fill up Xorg.0.log with
161              "get vblank counter failed: Invalid argument" warnings.
162   
163* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
164- rebuild with xserver-1.10.0
165
166* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
167- new upstream release
168
169* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
170- new upstream release
171
172* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
173- rebuild with xserver-1.9.2
174
175* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
176- new upstream release
177- add Patch40: fix uxa planemask (backported)
178- add Patch61: add support for backlight on macbooks
179- add Patch62: disable page flipping for stability
180
181* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
182- new upstream release
183- drop patch70
184
185* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
186- rebuild again with xserver-1.8rc
187
188* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
189- add intel-gpu-tools as sub-package
190- rebuild with libdrm-2.4.18
191
192* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
193- new upstream release
194- import Patch1,2,60,70 from fedora
195- add BR: kernel-headers >= 2.6.33 (new drm header required)
196- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
197- add BR; libudev-devel and autoreconf for Patch60
198
199* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
200- rebuild with libdrm-2.4.17
201
202* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
203- new upstream release
204
205* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
206- new upstream release (hopefully fixes severe issues w/ efifb)
207- drop all patches already upstreamed; import Patch20/21 from Fedora
208
209* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
210- import Patch121,122 from ubuntu
211- build with libdrm-2.4.12 which fixes vt switch crash
212
213* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
214- apply patch114 to fix Xv with non-GEM kernel
215
216* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
217- update to 2.6.3
218- add patch106,107,115,118,119,120 from ubuntu
219  - add Patch106: remove triple buffering
220  - add Patch107: remove page flipping
221  - add Patch115: fix crash Xv overlay
222  - add Patch118: drop legacy3d
223  - add Patch119: fix crashes in drm bo
224  - add Patch120: fix vt switch
225- add patch130-134 from upstream git
226  - add Patch130: fix another vt switch leak
227  - add Patch131: Create known output configuration at EnterVT time
228  - add Patch132: fix leak of some 965 render state on VT switch
229  - add Patch133: fix crash with fake bufmgr and UXA
230  - add Patch134: fix EnterVT/LeaveVT
231  - add Patch135: add new chip supoprt
232
233
234* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
235- revert to 2.6.1, add Epoch
236- add Patch103-121 from ubuntu
237
238* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
239- new upstream release
240
241* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
242- new upstream release
243
244* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
245- new upstream release
246
247* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
248- add Patch5 - Dont die on irq handler failure
249
250* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
251- new upstream release
252- add BR: libdrm-devel >= 2.4.0-3
253
254* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
255- import Patch10,11,12 from ubuntu
256
257* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
258- new upstream release
259- add triggerpostun script to replace i810 driver to intel driver
260
261* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
262- new upstream release
263
264* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
265- new upstream release
266- rename i810.xinf to intel.xinf
267- update intel.xinf (add Intel 4 series)
268
269* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
270- rebuild with new xserver
271
272* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
273- new upstream release
274
275* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
276- new upstream release
277
278* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
279- new upstream release
280
281* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
282- initial build for Vine Linux
283
284* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
285- Rebuild for new server ABI.
286- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
287
288* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
289- hook up ch7017 (bz#408471)
290
291* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
292- xf86-video-intel 2.2.0
293
294* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
295- xf86-video-intel 2.1.99.
296- Drop the i810 driver.  Time to move on.
297- Require xserver 1.4.99.1
298
299* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
300- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
301
302* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
303- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
304  for textured Xv to use as an offscreen pixmap so xv actually works under
305  compiz - granted it may be unusably slow but at least stuff shows up.
306
307* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
308- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
309- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
310
311* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
312- intel-2.1.1-quirk-update.patch - update quirks from master
313
314* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
315- i810.xinf: Flip everything over to -intel by default now.  Still install
316  i810 driver just in case.
317
318* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
319- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
320
321* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
322- xf86-video-intel 2.1.1.
323
324* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
325- xf86-video-intel 2.1.0.
326
327* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
328- Update Requires and BuildRequires.
329
330* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
331- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
332  965GME, G33, Q33, and Q35 chips.
333
334* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
335- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
336  DRI clients are active, for better battery life.
337
338* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
339- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
340
341* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
342- xf86-video-intel 2.0.0.  Change the version number to match, why not.
343- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
344  rename this at some point.
345
346* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
347- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
348  915GM.
349
350* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
351- i810.xinf: More intel whitelisting (#214011, #234877)
352
353* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
354- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
355- i810.xinf: Point 965GM support at the intel driver since it's not present
356  in old i810.
357
358* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
359- xf86-video-intel-1.9.93 (RC3).
360
361* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
362- fix typo with 945GM pci id from my laptop
363
364* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
365- xf86-video-intel 1.9.92 (RC2).
366
367* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
368- Updated modesetting driver to one that will actually work with a 1.3 server.
369
370* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
371- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
372- Remove ivch and ch7017 from the install since they aren't hooked up to the
373  code anywhere
374- Disown the module
375
376* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
377- update modesetting driver to git snapshot from today
378
379* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
380- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
381
382* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
383- rebuilt for unwind info generation, broken in gcc-4.1.1-21
384
385* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
386- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
387  actually require kudzu to run.
388
389* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
390- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
391
392* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
393- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
394- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
395  driver match the corresponding terrible heuristic in the server.
396
397* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
398- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
399  correctly distinguish between Mac Mini and Macbook Pro.
400
401* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
402- i810.xinf: PCI IDs for i965.
403
404* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
405- i810.xinf: Uppercase PCI IDs.
406
407* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
408- Update i810 to 1.6.5, should fix DRI.
409- Add kuzdu requires.
410- i810.xinf: Start whitelisting devices over to intel.
411
412* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
413- intel-driver-rename.patch: Fix the driver name in more places so it'll,
414  you know, load.
415
416* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
417- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
418  LFP special casing in favor of the blacklist.
419
420* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
421- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
422  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
423  and is selected with Driver "intel" in xorg.conf.  Individual devices will
424  whitelist over to "intel" until that branch gets merged into head.
425- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
426- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
427  the BIOS is known to lie.
428
429* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
430- Today's snapshot: I2C bus creation fix.
431
432* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
433- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
434  clock when computing the modes list.
435- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
436  in centimeters as the size of the display in pixels.
437
438* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
439- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
440  probing.
441
442* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
443- Update again for a mode comparison bugfix.
444
445* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
446- Update to today's git; crash fixes, better pre-915 support, slightly better
447  autoconfigurability.
448
449* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
450- rebuild
451
452* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
453- Fix Revision number to match naming policy.
454
455* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
456- Add back modesetting changes.
457
458* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
459- Roll back modesetting changes and build for fc5 aiglx repo.
460
461* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
462- Snapshot of the git modesetting branch.
463
464* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
465- Update i810.xinf to include entries for E7221 and 945GM.
466
467* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
468- Add with_dri macro to spec file, and conditionalize build time DRI support
469
470* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
471- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
472  to pick up proto-devel as well.
473
474* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
475- Rebuild for 7.1 ABI fix.
476
477* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
478- Bump for fc5-bling build.
479
480* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
481- Update to 1.6.0 from 7.1RC1.
482
483* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
484- Add patch to add missing #include's, specifically assert.h.
485
486* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
487- Update to CVS snapshot of 20060322.
488
489* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
490- rebuilt for new gcc4.1 snapshot and glibc changes
491
492* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
493- Added 8086:2772 mapping to i810.xinf for bug (#178451)
494
495* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
496- Added 8086:2592 mapping to i810.xinf for bug (#172884)
497
498* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
499- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
500
501* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
502- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
503- Removed 'x' suffix from manpage dirs to match RC4 upstream.
504
505* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
506- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
507
508* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
509- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
510- Fix *.la file removal.
511- Added 'devel' subpackage for XvMC .so
512- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
513
514* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
515- Update BuildRoot to use Fedora Packaging Guidelines.
516- Deglob file manifest.
517- Limit "ExclusiveArch" to x86, x86_64, ia64
518
519* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
520- Initial spec file for i810 video driver generated automatically
521  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.