source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 7889

Revision 7889, 21.1 KB checked in by daisuke, 11 years ago (diff)

update to 2.21.15

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8%define gputoolsdate 20130611
9%else
10%define accel sna
11%define gputoolsdate 20110817
12%endif
13
14Summary:   Xorg X11 Intel video driver
15Summary(ja):   Xorg X11 Intel ビデオドライバ
16Name:      xorg-x11-drv-intel
17Epoch:     1
18Version:   2.21.15
19Release:   1%{?_dist_release}
20URL:       http://intellinuxgraphics.org/
21License:   MIT
22Group:     User Interface/X Hardware Support
23
24Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
25Source2:   intel.xinf
26Source3:   intel-gpu-tools-%{gputoolsdate1}.tar.bz2
27Source4:   intel-gpu-tools-%{gputoolsdate2}.tar.bz2
28
29# vine patch
30
31
32ExclusiveArch: %{ix86} x86_64 ia64
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34BuildRequires: autoconf, automake, libtool
35BuildRequires: xorg-x11-server-sdk >= 1.7.99
36BuildRequires: libXvMC-devel
37BuildRequires: libGL-devel >= 7.10
38BuildRequires: libdrm-devel >= 2.4.25
39BuildRequires: kernel-headers >= 2.6.33
40BuildRequires: libudev-devel
41BuildRequires: libxcb-devel >= 1.5
42BuildRequires: xcb-util-devel
43BuildRequires: cairo-devel
44
45Requires:  hwdata
46Requires:  xorg-x11-server-Xorg
47Requires:  xcb-util
48
49Obsoletes: xorg-x11-drv-i810
50Provides: xorg-x11-drv-i810
51
52#Conflicts:  kudzu < 1.2.42-1
53
54Vendor: Project Vine
55Distribution: Vine Linux
56Packager: daisuke
57
58%description
59X.Org X11 Intel video driver.
60
61%package devel
62Summary:   Xorg X11 Intel video driver XvMC development package
63Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
64Group:     Development/System
65Requires:  %{name} = %{epoch}:%{version}-%{release}
66Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
67
68%description devel
69X.Org X11 Intel video driver XvMC development package.
70
71%package -n intel-gpu-tools
72Summary:    Debugging tools for Intel graphics chips
73Group:      Development/Tools
74
75%description -n intel-gpu-tools
76Debugging tools for Intel graphics chips
77
78
79%prep
80%setup -q -n xf86-video-intel-%{version} -b3 -b4
81
82%build
83autoreconf -vi
84
85%if "%{?_dist_release}" < "vl7"
86export CFLAGS="-I/usr/include/X11/dri"
87%endif
88
89%configure \
90  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
91  --enable-dri --enable-xvmc \
92  --enable-sna --enable-uxa \
93  --with-default-accel=%{accel} \
94  --enable-xaa=no
95make
96
97pushd ../intel-gpu-tools-%{gputoolsdate}
98autoreconf -v --install
99%configure --disable-nouveau --disable-dumper
100make
101popd
102
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107make install DESTDIR=$RPM_BUILD_ROOT
108mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
109install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
110
111pushd ../intel-gpu-tools-%{gputoolsdate}
112make install DESTDIR=$RPM_BUILD_ROOT
113popd
114
115
116find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%triggerpostun -- XOrg < 7.0
122if (grep -q i810 /etc/X11/xorg.conf)
123then
124  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
125  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
126fi ||:
127
128%files
129%defattr(-,root,root,-)
130%{driverdir}/intel_drv.so
131%{_datadir}/hwdata/videoaliases/intel.xinf
132%{_libdir}/libI810XvMC.so.*
133%{_libdir}/libIntelXvMC.so.*
134%{_mandir}/man4/i*
135
136%files devel
137%defattr(-,root,root,-)
138%{_libdir}/libI810XvMC.so
139%{_libdir}/libIntelXvMC.so
140
141%files -n intel-gpu-tools
142%defattr(-,root,root,-)
143%{_bindir}/*
144%{_mandir}/man1/intel_*.1*
145
146
147%changelog
148* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
149- new upstream release
150
151* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
152- new upstream release
153- change default accel method to sna.
154
155* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
156- new upstream release
157
158* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
159- new upstream release
160
161* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
162- new upstream release
163
164* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
165- new upstream release
166
167* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
168- new upstream release
169
170* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
171- new upstream release
172
173* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
174- new upstream release
175
176* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
177- new upstream release
178
179* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
180- new upstream release
181
182* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
183- new upstream release
184
185* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
186- rebuild with xcb-util-0.3.9
187
188* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
189- disable sna, enable uxa
190
191* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
192- new upstream release
193
194* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
195- rebuild with xserver-1.12.0
196
197* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
198- new upstream release
199- enable sna
200
201* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
202- disable sna/vmap
203
204* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
205- new upstram release
206- disable copy-fb patch
207
208* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
209- rebuild with xserver-1.11.1.902
210
211* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
212- add --enable-sna --enable-vmap
213
214* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
215- new upstream release
216
217* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
218- rebuild with xcb-util-0.3.8
219- drop Patch200
220
221* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
222- update to disable copy_fb on sandybridge/ivybridge
223
224* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
225- update intel.xinf
226- add patch10 from fedora
227  - Clamp VGA pixel clock to 250MHz,
228    anything higher's going to look awful anyway. (#559426)
229
230* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
231- drop patch1-3 and replaced with new patch1 from git master
232- add Patch200 to disable DRI on SandyBridge/IvyBridge
233- update intel-gpu-tools
234
235* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
236- add Patch1-3 from upstream
237
238* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
239- new upstream release
240- drop upstream patches: 107-115
241- temporary disabled patch101
242- BR: libdrm >= 2.4.25
243
244* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
245- add Patch101-115 from ubuntu/debian package
246  - Patch101: Plymouth integration patch
247  - Patch107: Check null return from uxa_acquire_solid()
248  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
249  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
250  - Patch110,114: Cherry picks to fix a large number of build warnings.
251  - Patch111: Fix clipped window plane offset
252  - Patch112: Fix issue where vertical green line and strange colors
253              shows up when playing gstreamer with certain videos,
254              when dragged.  (LP 460677)
255  - Patch113: Fixes GPU lockup during login with
256              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
257              error messages listed in the gpu dump text. (LP 710321)
258  - Patch115: Don't fill up Xorg.0.log with
259              "get vblank counter failed: Invalid argument" warnings.
260   
261* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
262- rebuild with xserver-1.10.0
263
264* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
265- new upstream release
266
267* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
268- new upstream release
269
270* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
271- rebuild with xserver-1.9.2
272
273* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
274- new upstream release
275- add Patch40: fix uxa planemask (backported)
276- add Patch61: add support for backlight on macbooks
277- add Patch62: disable page flipping for stability
278
279* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
280- new upstream release
281- drop patch70
282
283* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
284- rebuild again with xserver-1.8rc
285
286* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
287- add intel-gpu-tools as sub-package
288- rebuild with libdrm-2.4.18
289
290* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
291- new upstream release
292- import Patch1,2,60,70 from fedora
293- add BR: kernel-headers >= 2.6.33 (new drm header required)
294- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
295- add BR; libudev-devel and autoreconf for Patch60
296
297* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
298- rebuild with libdrm-2.4.17
299
300* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
301- new upstream release
302
303* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
304- new upstream release (hopefully fixes severe issues w/ efifb)
305- drop all patches already upstreamed; import Patch20/21 from Fedora
306
307* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
308- import Patch121,122 from ubuntu
309- build with libdrm-2.4.12 which fixes vt switch crash
310
311* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
312- apply patch114 to fix Xv with non-GEM kernel
313
314* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
315- update to 2.6.3
316- add patch106,107,115,118,119,120 from ubuntu
317  - add Patch106: remove triple buffering
318  - add Patch107: remove page flipping
319  - add Patch115: fix crash Xv overlay
320  - add Patch118: drop legacy3d
321  - add Patch119: fix crashes in drm bo
322  - add Patch120: fix vt switch
323- add patch130-134 from upstream git
324  - add Patch130: fix another vt switch leak
325  - add Patch131: Create known output configuration at EnterVT time
326  - add Patch132: fix leak of some 965 render state on VT switch
327  - add Patch133: fix crash with fake bufmgr and UXA
328  - add Patch134: fix EnterVT/LeaveVT
329  - add Patch135: add new chip supoprt
330
331
332* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
333- revert to 2.6.1, add Epoch
334- add Patch103-121 from ubuntu
335
336* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
337- new upstream release
338
339* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
340- new upstream release
341
342* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
343- new upstream release
344
345* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
346- add Patch5 - Dont die on irq handler failure
347
348* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
349- new upstream release
350- add BR: libdrm-devel >= 2.4.0-3
351
352* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
353- import Patch10,11,12 from ubuntu
354
355* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
356- new upstream release
357- add triggerpostun script to replace i810 driver to intel driver
358
359* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
360- new upstream release
361
362* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
363- new upstream release
364- rename i810.xinf to intel.xinf
365- update intel.xinf (add Intel 4 series)
366
367* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
368- rebuild with new xserver
369
370* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
371- new upstream release
372
373* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
374- new upstream release
375
376* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
377- new upstream release
378
379* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
380- initial build for Vine Linux
381
382* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
383- Rebuild for new server ABI.
384- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
385
386* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
387- hook up ch7017 (bz#408471)
388
389* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
390- xf86-video-intel 2.2.0
391
392* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
393- xf86-video-intel 2.1.99.
394- Drop the i810 driver.  Time to move on.
395- Require xserver 1.4.99.1
396
397* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
398- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
399
400* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
401- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
402  for textured Xv to use as an offscreen pixmap so xv actually works under
403  compiz - granted it may be unusably slow but at least stuff shows up.
404
405* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
406- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
407- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
408
409* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
410- intel-2.1.1-quirk-update.patch - update quirks from master
411
412* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
413- i810.xinf: Flip everything over to -intel by default now.  Still install
414  i810 driver just in case.
415
416* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
417- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
418
419* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
420- xf86-video-intel 2.1.1.
421
422* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
423- xf86-video-intel 2.1.0.
424
425* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
426- Update Requires and BuildRequires.
427
428* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
429- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
430  965GME, G33, Q33, and Q35 chips.
431
432* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
433- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
434  DRI clients are active, for better battery life.
435
436* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
437- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
438
439* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
440- xf86-video-intel 2.0.0.  Change the version number to match, why not.
441- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
442  rename this at some point.
443
444* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
445- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
446  915GM.
447
448* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
449- i810.xinf: More intel whitelisting (#214011, #234877)
450
451* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
452- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
453- i810.xinf: Point 965GM support at the intel driver since it's not present
454  in old i810.
455
456* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
457- xf86-video-intel-1.9.93 (RC3).
458
459* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
460- fix typo with 945GM pci id from my laptop
461
462* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
463- xf86-video-intel 1.9.92 (RC2).
464
465* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
466- Updated modesetting driver to one that will actually work with a 1.3 server.
467
468* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
469- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
470- Remove ivch and ch7017 from the install since they aren't hooked up to the
471  code anywhere
472- Disown the module
473
474* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
475- update modesetting driver to git snapshot from today
476
477* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
478- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
479
480* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
481- rebuilt for unwind info generation, broken in gcc-4.1.1-21
482
483* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
484- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
485  actually require kudzu to run.
486
487* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
488- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
489
490* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
491- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
492- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
493  driver match the corresponding terrible heuristic in the server.
494
495* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
496- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
497  correctly distinguish between Mac Mini and Macbook Pro.
498
499* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
500- i810.xinf: PCI IDs for i965.
501
502* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
503- i810.xinf: Uppercase PCI IDs.
504
505* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
506- Update i810 to 1.6.5, should fix DRI.
507- Add kuzdu requires.
508- i810.xinf: Start whitelisting devices over to intel.
509
510* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
511- intel-driver-rename.patch: Fix the driver name in more places so it'll,
512  you know, load.
513
514* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
515- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
516  LFP special casing in favor of the blacklist.
517
518* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
519- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
520  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
521  and is selected with Driver "intel" in xorg.conf.  Individual devices will
522  whitelist over to "intel" until that branch gets merged into head.
523- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
524- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
525  the BIOS is known to lie.
526
527* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
528- Today's snapshot: I2C bus creation fix.
529
530* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
531- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
532  clock when computing the modes list.
533- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
534  in centimeters as the size of the display in pixels.
535
536* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
537- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
538  probing.
539
540* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
541- Update again for a mode comparison bugfix.
542
543* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
544- Update to today's git; crash fixes, better pre-915 support, slightly better
545  autoconfigurability.
546
547* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
548- rebuild
549
550* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
551- Fix Revision number to match naming policy.
552
553* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
554- Add back modesetting changes.
555
556* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
557- Roll back modesetting changes and build for fc5 aiglx repo.
558
559* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
560- Snapshot of the git modesetting branch.
561
562* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
563- Update i810.xinf to include entries for E7221 and 945GM.
564
565* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
566- Add with_dri macro to spec file, and conditionalize build time DRI support
567
568* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
569- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
570  to pick up proto-devel as well.
571
572* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
573- Rebuild for 7.1 ABI fix.
574
575* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
576- Bump for fc5-bling build.
577
578* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
579- Update to 1.6.0 from 7.1RC1.
580
581* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
582- Add patch to add missing #include's, specifically assert.h.
583
584* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
585- Update to CVS snapshot of 20060322.
586
587* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
588- rebuilt for new gcc4.1 snapshot and glibc changes
589
590* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
591- Added 8086:2772 mapping to i810.xinf for bug (#178451)
592
593* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
594- Added 8086:2592 mapping to i810.xinf for bug (#172884)
595
596* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
597- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
598
599* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
600- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
601- Removed 'x' suffix from manpage dirs to match RC4 upstream.
602
603* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
604- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
605
606* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
607- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
608- Fix *.la file removal.
609- Added 'devel' subpackage for XvMC .so
610- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
611
612* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
613- Update BuildRoot to use Fedora Packaging Guidelines.
614- Deglob file manifest.
615- Limit "ExclusiveArch" to x86, x86_64, ia64
616
617* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
618- Initial spec file for i810 video driver generated automatically
619  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.