source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 579

Revision 579, 16.3 KB checked in by daisuke, 14 years ago (diff)

xorg-x11-drv-intel-2.10.0-2

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20090908
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.10.0
10Release:   2%{?_dist_release}
11URL:       http://www.x.org
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:    intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19Patch1: kill-svideo.patch
20Patch2: copy-fb.patch
21
22# patches from fedora - needs to be upstreamed
23Patch20: intel-2.8.0-kms-get-crtc.patch
24Patch21: intel-2.8.0-lvds-first.patch
25
26Patch60: uevent.patch
27Patch70: lvds-modes.patch
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk
33BuildRequires: libXvMC-devel
34BuildRequires: mesa-libGL-devel
35BuildRequires: libdrm-devel >= 2.4.16
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50%description
51X.Org X11 Intel video driver.
52
53%package devel
54Summary:   Xorg X11 Intel video driver XvMC development package
55Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
56Group:     Development/System
57Requires:  %{name} = %{epoch}:%{version}-%{release}
58Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
59
60%description devel
61X.Org X11 Intel video driver XvMC development package.
62
63%package -n intel-gpu-tools
64Summary:    Debugging tools for Intel graphics chips
65Group:      Development/Tools
66
67%description -n intel-gpu-tools
68Debugging tools for Intel graphics chips
69
70
71%prep
72%setup -q -n xf86-video-intel-%{version} -b3
73
74%patch1 -p1 -b .svideo
75%patch2 -p1 -b .copy-fb
76%patch20 -p1 -b .get-crtc
77%patch21 -p1 -b .lvds-first
78%patch60 -p1 -b .uevent
79%patch70 -p1 -b .lvds-modes
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc
87make
88
89pushd ../intel-gpu-tools-%{gputoolsdate}
90autoreconf -v --install
91%configure
92make
93popd
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install DESTDIR=$RPM_BUILD_ROOT
100mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
101install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
102
103pushd ../intel-gpu-tools-%{gputoolsdate}
104make install DESTDIR=$RPM_BUILD_ROOT
105popd
106
107
108find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%triggerpostun -- XOrg < 7.0
114if (grep -q i810 /etc/X11/xorg.conf)
115then
116  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
117  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
118fi ||:
119
120%files
121%defattr(-,root,root,-)
122%{driverdir}/intel_drv.so
123%{_datadir}/hwdata/videoaliases/intel.xinf
124%{_libdir}/libI810XvMC.so.*
125%{_libdir}/libIntelXvMC.so.*
126%{_mandir}/man4/i*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libI810XvMC.so
131%{_libdir}/libIntelXvMC.so
132
133%files -n intel-gpu-tools
134%defattr(-,root,root,-)
135%{_bindir}/intel_*
136%{_mandir}/man1/intel_*.1*
137
138
139%changelog
140* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-2
141- add intel-gpu-tools as sub-package
142- rebuild with libdrm-2.4.18
143
144* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-1
145- new upstream release
146- import Patch1,2,60,70 from fedora
147- add BR: kernel-headers >= 2.6.33 (new drm header required)
148- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
149- add BR; libudev-devel and autoreconf for Patch60
150
151* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
152- rebuild with libdrm-2.4.17
153
154* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
155- new upstream release
156
157* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
158- new upstream release (hopefully fixes severe issues w/ efifb)
159- drop all patches already upstreamed; import Patch20/21 from Fedora
160
161* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
162- import Patch121,122 from ubuntu
163- build with libdrm-2.4.12 which fixes vt switch crash
164
165* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
166- apply patch114 to fix Xv with non-GEM kernel
167
168* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
169- update to 2.6.3
170- add patch106,107,115,118,119,120 from ubuntu
171  - add Patch106: remove triple buffering
172  - add Patch107: remove page flipping
173  - add Patch115: fix crash Xv overlay
174  - add Patch118: drop legacy3d
175  - add Patch119: fix crashes in drm bo
176  - add Patch120: fix vt switch
177- add patch130-134 from upstream git
178  - add Patch130: fix another vt switch leak
179  - add Patch131: Create known output configuration at EnterVT time
180  - add Patch132: fix leak of some 965 render state on VT switch
181  - add Patch133: fix crash with fake bufmgr and UXA
182  - add Patch134: fix EnterVT/LeaveVT
183  - add Patch135: add new chip supoprt
184
185
186* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
187- revert to 2.6.1, add Epoch
188- add Patch103-121 from ubuntu
189
190* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
191- new upstream release
192
193* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
194- new upstream release
195
196* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
197- new upstream release
198
199* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
200- add Patch5 - Dont die on irq handler failure
201
202* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
203- new upstream release
204- add BR: libdrm-devel >= 2.4.0-3
205
206* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
207- import Patch10,11,12 from ubuntu
208
209* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
210- new upstream release
211- add triggerpostun script to replace i810 driver to intel driver
212
213* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
214- new upstream release
215
216* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
217- new upstream release
218- rename i810.xinf to intel.xinf
219- update intel.xinf (add Intel 4 series)
220
221* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
222- rebuild with new xserver
223
224* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
225- new upstream release
226
227* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
228- new upstream release
229
230* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
231- new upstream release
232
233* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
234- initial build for Vine Linux
235
236* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
237- Rebuild for new server ABI.
238- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
239
240* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
241- hook up ch7017 (bz#408471)
242
243* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
244- xf86-video-intel 2.2.0
245
246* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
247- xf86-video-intel 2.1.99.
248- Drop the i810 driver.  Time to move on.
249- Require xserver 1.4.99.1
250
251* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
252- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
253
254* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
255- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
256  for textured Xv to use as an offscreen pixmap so xv actually works under
257  compiz - granted it may be unusably slow but at least stuff shows up.
258
259* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
260- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
261- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
262
263* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
264- intel-2.1.1-quirk-update.patch - update quirks from master
265
266* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
267- i810.xinf: Flip everything over to -intel by default now.  Still install
268  i810 driver just in case.
269
270* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
271- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
272
273* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
274- xf86-video-intel 2.1.1.
275
276* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
277- xf86-video-intel 2.1.0.
278
279* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
280- Update Requires and BuildRequires.
281
282* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
283- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
284  965GME, G33, Q33, and Q35 chips.
285
286* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
287- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
288  DRI clients are active, for better battery life.
289
290* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
291- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
292
293* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
294- xf86-video-intel 2.0.0.  Change the version number to match, why not.
295- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
296  rename this at some point.
297
298* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
299- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
300  915GM.
301
302* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
303- i810.xinf: More intel whitelisting (#214011, #234877)
304
305* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
306- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
307- i810.xinf: Point 965GM support at the intel driver since it's not present
308  in old i810.
309
310* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
311- xf86-video-intel-1.9.93 (RC3).
312
313* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
314- fix typo with 945GM pci id from my laptop
315
316* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
317- xf86-video-intel 1.9.92 (RC2).
318
319* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
320- Updated modesetting driver to one that will actually work with a 1.3 server.
321
322* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
323- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
324- Remove ivch and ch7017 from the install since they aren't hooked up to the
325  code anywhere
326- Disown the module
327
328* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
329- update modesetting driver to git snapshot from today
330
331* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
332- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
333
334* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
335- rebuilt for unwind info generation, broken in gcc-4.1.1-21
336
337* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
338- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
339  actually require kudzu to run.
340
341* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
342- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
343
344* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
345- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
346- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
347  driver match the corresponding terrible heuristic in the server.
348
349* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
350- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
351  correctly distinguish between Mac Mini and Macbook Pro.
352
353* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
354- i810.xinf: PCI IDs for i965.
355
356* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
357- i810.xinf: Uppercase PCI IDs.
358
359* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
360- Update i810 to 1.6.5, should fix DRI.
361- Add kuzdu requires.
362- i810.xinf: Start whitelisting devices over to intel.
363
364* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
365- intel-driver-rename.patch: Fix the driver name in more places so it'll,
366  you know, load.
367
368* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
369- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
370  LFP special casing in favor of the blacklist.
371
372* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
373- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
374  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
375  and is selected with Driver "intel" in xorg.conf.  Individual devices will
376  whitelist over to "intel" until that branch gets merged into head.
377- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
378- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
379  the BIOS is known to lie.
380
381* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
382- Today's snapshot: I2C bus creation fix.
383
384* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
385- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
386  clock when computing the modes list.
387- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
388  in centimeters as the size of the display in pixels.
389
390* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
391- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
392  probing.
393
394* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
395- Update again for a mode comparison bugfix.
396
397* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
398- Update to today's git; crash fixes, better pre-915 support, slightly better
399  autoconfigurability.
400
401* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
402- rebuild
403
404* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
405- Fix Revision number to match naming policy.
406
407* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
408- Add back modesetting changes.
409
410* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
411- Roll back modesetting changes and build for fc5 aiglx repo.
412
413* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
414- Snapshot of the git modesetting branch.
415
416* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
417- Update i810.xinf to include entries for E7221 and 945GM.
418
419* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
420- Add with_dri macro to spec file, and conditionalize build time DRI support
421
422* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
423- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
424  to pick up proto-devel as well.
425
426* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
427- Rebuild for 7.1 ABI fix.
428
429* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
430- Bump for fc5-bling build.
431
432* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
433- Update to 1.6.0 from 7.1RC1.
434
435* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
436- Add patch to add missing #include's, specifically assert.h.
437
438* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
439- Update to CVS snapshot of 20060322.
440
441* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
442- rebuilt for new gcc4.1 snapshot and glibc changes
443
444* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
445- Added 8086:2772 mapping to i810.xinf for bug (#178451)
446
447* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
448- Added 8086:2592 mapping to i810.xinf for bug (#172884)
449
450* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
451- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
452
453* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
454- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
455- Removed 'x' suffix from manpage dirs to match RC4 upstream.
456
457* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
458- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
459
460* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
461- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
462- Fix *.la file removal.
463- Added 'devel' subpackage for XvMC .so
464- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
465
466* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
467- Update BuildRoot to use Fedora Packaging Guidelines.
468- Deglob file manifest.
469- Limit "ExclusiveArch" to x86, x86_64, ia64
470
471* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
472- Initial spec file for i810 video driver generated automatically
473  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.