source: projects/specs/trunk/x/xorg-x11-apps/xorg-x11-apps-vl.spec @ 5538

Revision 5538, 10.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname apps
2
3Summary: X.Org X11 applications
4Summary(ja): X.Org X11 アプリケーション
5Name: xorg-x11-%{pkgname}
6# NOTE: The package version should be set to the X11 major release from which
7# the OS release is based upon.
8Version: 7.6
9Release: 5%{?_dist_release}
10License: MIT/X11
11Group: User Interface/X
12URL: http://www.x.org
13
14# Clock apps
15Source0:  ftp://ftp.x.org/pub/individual/app/oclock-1.0.2.tar.bz2
16Source1:  ftp://ftp.x.org/pub/individual/app/xclock-1.0.5.tar.bz2
17# X Window Dump (xwd) utilities
18Source2:  ftp://ftp.x.org/pub/individual/app/xwd-1.0.4.tar.bz2
19Source3:  ftp://ftp.x.org/pub/individual/app/xwud-1.0.3.tar.bz2
20Source4:  ftp://ftp.x.org/pub/individual/app/xpr-1.0.3.tar.bz2
21# Miscellaneous other applications
22Source5:  ftp://ftp.x.org/pub/individual/app/luit-1.1.0.tar.bz2
23Source6:  ftp://ftp.x.org/pub/individual/app/x11perf-1.5.4.tar.bz2
24Source7:  ftp://ftp.x.org/pub/individual/app/xbiff-1.0.3.tar.bz2
25Source8:  ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.1.tar.bz2
26Source9:  ftp://ftp.x.org/pub/individual/app/xconsole-1.0.4.tar.bz2
27Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.4.tar.bz2
28Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.1.tar.bz2
29Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.3.tar.bz2
30Source13: ftp://ftp.x.org/pub/individual/app/xload-1.1.0.tar.bz2
31Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.3.tar.bz2
32Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.4.tar.bz2
33Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.3.tar.bz2
34Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.5.4.tar.bz2
35Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.4.1.tar.bz2
36
37Patch2: xconsole-1.0.3-streams-me-softer.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40BuildRequires: autoconf, automake
41BuildRequires: pkgconfig
42BuildRequires: xorg-x11-util-macros
43BuildRequires: xorg-x11-xbitmaps
44BuildRequires: zlib-devel
45BuildRequires: libfontenc-devel
46BuildRequires: libX11-devel
47BuildRequires: libXmu-devel
48BuildRequires: libXext-devel
49BuildRequires: libXt-devel
50BuildRequires: libXaw-devel
51BuildRequires: libXpm-devel
52BuildRequires: libXft-devel
53BuildRequires: libXrender-devel
54BuildRequires: libxkbfile-devel
55BuildRequires: libXcursor-devel
56BuildRequires: libpng-devel
57BuildRequires: libXfixes-devel
58BuildRequires: libXi-devel
59
60Requires(pre): xorg-x11-filesystem
61
62Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
63Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
64
65# NOTE: xwd, xwud, luit used to be in these.
66Obsoletes: XFree86, XOrg
67# NOTE: x11perf, xclipboard used to be in these.
68Obsoletes: XFree86-tools, XOrg-tools
69
70Vendor: Project Vine
71Distribution: Vine Linux
72
73%description
74A collection of common X Window System applications.
75
76%prep
77%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
78## %patch2 -p0 -b .streams-me-softer
79
80%build
81# Build all apps
82{
83   for app in * ; do
84      pushd $app
85
86      case $app in
87         x11perf*)
88            aclocal ; automake ; autoconf
89         ;;
90         luit*)
91            autoconf
92         ;;
93      esac
94
95      %configure --disable-xprint
96      make
97      popd
98   done
99}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103# Install all apps
104{
105   for app in * ; do
106      pushd $app
107      make install DESTDIR=$RPM_BUILD_ROOT
108      popd
109   done
110}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(-,root,root,-)
117#%doc
118%{_bindir}/luit
119%{_bindir}/oclock
120%{_bindir}/x11perf
121%{_bindir}/x11perfcomp
122%{_bindir}/xbiff
123%{_bindir}/xcalc
124%{_bindir}/xclipboard
125%{_bindir}/xclock
126%{_bindir}/xconsole
127%{_bindir}/xcursorgen
128%{_bindir}/xcutsel
129%{_bindir}/xdpr
130%{_bindir}/xeyes
131%{_bindir}/xinput
132%{_bindir}/xkill
133%{_bindir}/xload
134%{_bindir}/xlogo
135%{_bindir}/xmag
136%{_bindir}/xmessage
137%{_bindir}/xpr
138%{_bindir}/xwd
139%{_bindir}/xwud
140%dir %{_datadir}/X11
141%{_datadir}/X11/app-defaults/Clock-color
142%{_datadir}/X11/app-defaults/XCalc
143%{_datadir}/X11/app-defaults/XCalc-color
144%{_datadir}/X11/app-defaults/XClipboard
145%{_datadir}/X11/app-defaults/XClock
146%{_datadir}/X11/app-defaults/XClock-color
147%{_datadir}/X11/app-defaults/XConsole
148%{_datadir}/X11/app-defaults/XLoad
149%{_datadir}/X11/app-defaults/XLogo
150%{_datadir}/X11/app-defaults/XLogo-color
151%{_datadir}/X11/app-defaults/Xmag
152%{_datadir}/X11/app-defaults/Xmessage
153%{_datadir}/X11/app-defaults/Xmessage-color
154%dir %{_libdir}/X11/x11perfcomp
155%{_libdir}/X11/x11perfcomp/Xmark
156%{_libdir}/X11/x11perfcomp/fillblnk
157%{_libdir}/X11/x11perfcomp/perfboth
158%{_libdir}/X11/x11perfcomp/perfratio
159#%dir %{_mandir}/man1x
160%{_mandir}/man1/xcursorgen.1*
161%{_mandir}/man1/Xmark.1*
162%{_mandir}/man1/luit.1*
163%{_mandir}/man1/oclock.1*
164%{_mandir}/man1/x11perf.1*
165%{_mandir}/man1/x11perfcomp.1*
166%{_mandir}/man1/xbiff.1*
167%{_mandir}/man1/xcalc.1*
168%{_mandir}/man1/xclipboard.1*
169%{_mandir}/man1/xclock.1*
170%{_mandir}/man1/xconsole.1*
171%{_mandir}/man1/xcutsel.1*
172%{_mandir}/man1/xdpr.1*
173%{_mandir}/man1/xeyes.1*
174%{_mandir}/man1/xinput.1*
175%{_mandir}/man1/xkill.1*
176%{_mandir}/man1/xload.1*
177%{_mandir}/man1/xlogo.1*
178%{_mandir}/man1/xmag.1*
179%{_mandir}/man1/xmessage.1*
180%{_mandir}/man1/xpr.1*
181%{_mandir}/man1/xwd.1*
182%{_mandir}/man1/xwud.1*
183
184%changelog
185* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
186- xinput-1.5.4
187
188* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
189- x11perf-1.5.4
190
191* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
192- xcalc-1.0.4.1
193
194* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
195- xbiff-1.0.3
196
197* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
198- x11perf-1.5.3
199
200* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
201- xwd-1.0.4
202- wud-1.0.3
203- xclipboard-1.1.1
204- xcursorgen-1.0.4
205- xeyes-1.1.1
206- xkill-1.0.3
207- xinput-1.5.3
208- xcalc-1.0.4
209
210* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
211- oclock-1.0.2
212- xlock-1.0.5
213- xconsole-1.0.4
214- luit-1.1.0
215- x11perf-1.5.2
216- xbiff-1.0.2
217- xlogo-1.0.3
218- xload-1.1.0
219- xmag-1.0.4
220- xinput-1.5.2
221- drop Patch2
222- add BuildRequires: libXi-devel
223
224* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
225- luit-1.0.5
226- xeyes-1.1.0
227- xlogo-1.0.2
228- xmessage-1.0.3
229- xinput-1.5.1
230- added xcalc-1.0.3 <wishes:161>
231
232* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
233- xclock-1.0.4
234- xwd-1.0.3
235- xwud-1.0.2
236- xpr-1.0.3
237- luit-1.0.4
238- x11perf-1.5.1
239- xclipboard-1.1.0
240- xcursorgen-1.0.3
241- xeyes-1.0.991
242- xkill-1.0.2
243- xmag-1.0.3
244- xinput-1.5.0
245
246* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
247- xinput-1.4.2
248
249* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
250- xinput-1.4.1
251
252* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
253- bump to 7.4 version
254- add xinput-1.3.0
255
256* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
257- xwd 1.0.2
258- luit 1.0.3
259- x11perf 1.5
260
261* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
262- new versioning policy
263
264* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
265- initial build for Vine Linux
266
267* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
268- xconsole 1.0.3
269- xmessage 1.0.2
270- Bump to 7.3-1
271
272* Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
273- luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
274- bump to 7.2 version
275
276* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
277- Fix man page globs and rebuild for FC7.
278
279* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
280- Fix race condition in luit (Bug 197165).
281
282* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
283- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
284- Add 'dist' tag to package release string.
285
286* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
287- rebuild
288
289* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
290- Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
291- Artificially inflate package version-release to 7.1 to match the X11R7.1
292  release that all of the tarballs are taken from.
293- Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
294- Add temporary dependency on autoconf, automake for brew builds.
295
296* Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
297- Add more BuildRequires to fix mock builds.  (#191896)
298
299* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
300- Updated xclock and xconsole
301
302* Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
303- Bump x11perf to 1.4.1 from upstream.
304
305* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
306- Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
307
308* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
309- bump again for double-long bug on ppc(64)
310
311* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
312- rebuilt for new gcc4.1 snapshot and glibc changes
313
314* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
315- Upgraded all apps to version 1.0.1 from X11R7.0
316
317* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
318- Upgraded all apps to version 1.0.0 from X11R7 RC4.
319- Changed manpage dir from man1x to man1 to match upstream default now.
320- Dropped all of the datadir-cleanups patches added in the previous build.
321- Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
322  to put the helper scripts in datadir.
323- Added --disable-xprint to configure, as a great symbolic jesture.
324
325* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
326- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
327  (#173384)
328- Added the following patches, and invoke aclocal/automake/autoconf on them
329  to force app-defaults and other datafiles into _datadir instead of _libdir:
330  - oclock-0.99.1-oclock-datadir-cleanups.patch
331  - x11perf-0.99.1-x11perf-datadir-cleanups.patch
332  - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
333  - xclock-0.99.1-xclock-datadir-cleanups.patch
334  - xconsole-0.99.2-xconsole-datadir-cleanups.patch
335  - xload-0.99.1-xload-datadir-cleanups.patch
336  - xlogo-0.99.1-xlogo-datadir-cleanups.patch
337  - xmag-0.99.1-xmag-datadir-cleanups.patch
338  - xmessage-0.99.1-xmessage-datadir-cleanups.patch
339- Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
340
341* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
342- add Requires(pre) on newer filesystem package (#172610)
343
344* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
345- Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
346  various utils have moved here from there in monolithic X packaging.
347- Add "BuildRequires: xbitmaps-devel" for xbiff.
348- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
349
350* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
351- Initial build, with all apps taken from X11R7 RC2.
352- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
353  some packages.
354- Temporary hack to move xcursorgen manpage to 'man1' dir.
Note: See TracBrowser for help on using the repository browser.