source: projects/specs/trunk/x/xorg-x11-apps/xorg-x11-apps-vl.spec @ 4616

Revision 4616, 10.5 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define pkgname apps
2
3Summary: X.Org X11 applications
4Summary(ja): X.Org X11 アプリケーション
5Name: xorg-x11-%{pkgname}
6# NOTE: The package version should be set to the X11 major release from which
7# the OS release is based upon.
8Version: 7.6
9Release: 4%{?_dist_release}
10License: MIT/X11
11Group: User Interface/X
12URL: http://www.x.org
13
14# Clock apps
15Source0:  ftp://ftp.x.org/pub/individual/app/oclock-1.0.2.tar.bz2
16Source1:  ftp://ftp.x.org/pub/individual/app/xclock-1.0.5.tar.bz2
17# X Window Dump (xwd) utilities
18Source2:  ftp://ftp.x.org/pub/individual/app/xwd-1.0.4.tar.bz2
19Source3:  ftp://ftp.x.org/pub/individual/app/xwud-1.0.3.tar.bz2
20Source4:  ftp://ftp.x.org/pub/individual/app/xpr-1.0.3.tar.bz2
21# Miscellaneous other applications
22Source5:  ftp://ftp.x.org/pub/individual/app/luit-1.1.0.tar.bz2
23Source6:  ftp://ftp.x.org/pub/individual/app/x11perf-1.5.4.tar.bz2
24Source7:  ftp://ftp.x.org/pub/individual/app/xbiff-1.0.3.tar.bz2
25Source8:  ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.1.tar.bz2
26Source9:  ftp://ftp.x.org/pub/individual/app/xconsole-1.0.4.tar.bz2
27Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.4.tar.bz2
28Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.1.tar.bz2
29Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.3.tar.bz2
30Source13: ftp://ftp.x.org/pub/individual/app/xload-1.1.0.tar.bz2
31Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.3.tar.bz2
32Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.4.tar.bz2
33Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.3.tar.bz2
34Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.5.3.tar.bz2
35Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.4.1.tar.bz2
36
37Patch2: xconsole-1.0.3-streams-me-softer.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40BuildRequires: autoconf, automake
41BuildRequires: pkgconfig
42BuildRequires: xorg-x11-util-macros
43BuildRequires: xorg-x11-xbitmaps
44BuildRequires: zlib-devel
45BuildRequires: libfontenc-devel
46BuildRequires: libX11-devel
47BuildRequires: libXmu-devel
48BuildRequires: libXext-devel
49BuildRequires: libXt-devel
50BuildRequires: libXaw-devel
51BuildRequires: libXpm-devel
52BuildRequires: libXft-devel
53BuildRequires: libXrender-devel
54BuildRequires: libxkbfile-devel
55BuildRequires: libXcursor-devel
56BuildRequires: libpng-devel
57BuildRequires: libXfixes-devel
58BuildRequires: libXi-devel
59
60Requires(pre): xorg-x11-filesystem
61
62Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
63Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
64
65# NOTE: xwd, xwud, luit used to be in these.
66Obsoletes: XFree86, XOrg
67# NOTE: x11perf, xclipboard used to be in these.
68Obsoletes: XFree86-tools, XOrg-tools
69
70Vendor: Project Vine
71Distribution: Vine Linux
72
73%description
74A collection of common X Window System applications.
75
76%prep
77%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
78## %patch2 -p0 -b .streams-me-softer
79
80%build
81# Build all apps
82{
83   for app in * ; do
84      pushd $app
85
86      case $app in
87         x11perf*)
88            aclocal ; automake ; autoconf
89         ;;
90         luit*)
91            autoconf
92         ;;
93      esac
94
95      %configure --disable-xprint
96      make
97      popd
98   done
99}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103# Install all apps
104{
105   for app in * ; do
106      pushd $app
107      make install DESTDIR=$RPM_BUILD_ROOT
108      popd
109   done
110}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(-,root,root,-)
117#%doc
118%{_bindir}/luit
119%{_bindir}/oclock
120%{_bindir}/x11perf
121%{_bindir}/x11perfcomp
122%{_bindir}/xbiff
123%{_bindir}/xcalc
124%{_bindir}/xclipboard
125%{_bindir}/xclock
126%{_bindir}/xconsole
127%{_bindir}/xcursorgen
128%{_bindir}/xcutsel
129%{_bindir}/xdpr
130%{_bindir}/xeyes
131%{_bindir}/xinput
132%{_bindir}/xkill
133%{_bindir}/xload
134%{_bindir}/xlogo
135%{_bindir}/xmag
136%{_bindir}/xmessage
137%{_bindir}/xpr
138%{_bindir}/xwd
139%{_bindir}/xwud
140%dir %{_datadir}/X11
141%{_datadir}/X11/app-defaults/Clock-color
142%{_datadir}/X11/app-defaults/XCalc
143%{_datadir}/X11/app-defaults/XCalc-color
144%{_datadir}/X11/app-defaults/XClipboard
145%{_datadir}/X11/app-defaults/XClock
146%{_datadir}/X11/app-defaults/XClock-color
147%{_datadir}/X11/app-defaults/XConsole
148%{_datadir}/X11/app-defaults/XLoad
149%{_datadir}/X11/app-defaults/XLogo
150%{_datadir}/X11/app-defaults/XLogo-color
151%{_datadir}/X11/app-defaults/Xmag
152%{_datadir}/X11/app-defaults/Xmessage
153%{_datadir}/X11/app-defaults/Xmessage-color
154%dir %{_libdir}/X11/x11perfcomp
155%{_libdir}/X11/x11perfcomp/Xmark
156%{_libdir}/X11/x11perfcomp/fillblnk
157%{_libdir}/X11/x11perfcomp/perfboth
158%{_libdir}/X11/x11perfcomp/perfratio
159#%dir %{_mandir}/man1x
160%{_mandir}/man1/xcursorgen.1*
161%{_mandir}/man1/Xmark.1*
162%{_mandir}/man1/luit.1*
163%{_mandir}/man1/oclock.1*
164%{_mandir}/man1/x11perf.1*
165%{_mandir}/man1/x11perfcomp.1*
166%{_mandir}/man1/xbiff.1*
167%{_mandir}/man1/xcalc.1*
168%{_mandir}/man1/xclipboard.1*
169%{_mandir}/man1/xclock.1*
170%{_mandir}/man1/xconsole.1*
171%{_mandir}/man1/xcutsel.1*
172%{_mandir}/man1/xdpr.1*
173%{_mandir}/man1/xeyes.1*
174%{_mandir}/man1/xinput.1*
175%{_mandir}/man1/xkill.1*
176%{_mandir}/man1/xload.1*
177%{_mandir}/man1/xlogo.1*
178%{_mandir}/man1/xmag.1*
179%{_mandir}/man1/xmessage.1*
180%{_mandir}/man1/xpr.1*
181%{_mandir}/man1/xwd.1*
182%{_mandir}/man1/xwud.1*
183
184%changelog
185* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
186- x11perf-1.5.4
187
188* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
189- xcalc-1.0.4.1
190
191* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
192- xbiff-1.0.3
193
194* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
195- x11perf-1.5.3
196
197* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
198- xwd-1.0.4
199- wud-1.0.3
200- xclipboard-1.1.1
201- xcursorgen-1.0.4
202- xeyes-1.1.1
203- xkill-1.0.3
204- xinput-1.5.3
205- xcalc-1.0.4
206
207* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
208- oclock-1.0.2
209- xlock-1.0.5
210- xconsole-1.0.4
211- luit-1.1.0
212- x11perf-1.5.2
213- xbiff-1.0.2
214- xlogo-1.0.3
215- xload-1.1.0
216- xmag-1.0.4
217- xinput-1.5.2
218- drop Patch2
219- add BuildRequires: libXi-devel
220
221* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
222- luit-1.0.5
223- xeyes-1.1.0
224- xlogo-1.0.2
225- xmessage-1.0.3
226- xinput-1.5.1
227- added xcalc-1.0.3 <wishes:161>
228
229* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
230- xclock-1.0.4
231- xwd-1.0.3
232- xwud-1.0.2
233- xpr-1.0.3
234- luit-1.0.4
235- x11perf-1.5.1
236- xclipboard-1.1.0
237- xcursorgen-1.0.3
238- xeyes-1.0.991
239- xkill-1.0.2
240- xmag-1.0.3
241- xinput-1.5.0
242
243* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
244- xinput-1.4.2
245
246* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
247- xinput-1.4.1
248
249* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
250- bump to 7.4 version
251- add xinput-1.3.0
252
253* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
254- xwd 1.0.2
255- luit 1.0.3
256- x11perf 1.5
257
258* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
259- new versioning policy
260
261* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
262- initial build for Vine Linux
263
264* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
265- xconsole 1.0.3
266- xmessage 1.0.2
267- Bump to 7.3-1
268
269* Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
270- luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
271- bump to 7.2 version
272
273* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
274- Fix man page globs and rebuild for FC7.
275
276* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
277- Fix race condition in luit (Bug 197165).
278
279* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
280- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
281- Add 'dist' tag to package release string.
282
283* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
284- rebuild
285
286* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
287- Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
288- Artificially inflate package version-release to 7.1 to match the X11R7.1
289  release that all of the tarballs are taken from.
290- Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
291- Add temporary dependency on autoconf, automake for brew builds.
292
293* Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
294- Add more BuildRequires to fix mock builds.  (#191896)
295
296* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
297- Updated xclock and xconsole
298
299* Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
300- Bump x11perf to 1.4.1 from upstream.
301
302* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
303- Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
304
305* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
306- bump again for double-long bug on ppc(64)
307
308* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
309- rebuilt for new gcc4.1 snapshot and glibc changes
310
311* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
312- Upgraded all apps to version 1.0.1 from X11R7.0
313
314* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
315- Upgraded all apps to version 1.0.0 from X11R7 RC4.
316- Changed manpage dir from man1x to man1 to match upstream default now.
317- Dropped all of the datadir-cleanups patches added in the previous build.
318- Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
319  to put the helper scripts in datadir.
320- Added --disable-xprint to configure, as a great symbolic jesture.
321
322* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
323- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
324  (#173384)
325- Added the following patches, and invoke aclocal/automake/autoconf on them
326  to force app-defaults and other datafiles into _datadir instead of _libdir:
327  - oclock-0.99.1-oclock-datadir-cleanups.patch
328  - x11perf-0.99.1-x11perf-datadir-cleanups.patch
329  - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
330  - xclock-0.99.1-xclock-datadir-cleanups.patch
331  - xconsole-0.99.2-xconsole-datadir-cleanups.patch
332  - xload-0.99.1-xload-datadir-cleanups.patch
333  - xlogo-0.99.1-xlogo-datadir-cleanups.patch
334  - xmag-0.99.1-xmag-datadir-cleanups.patch
335  - xmessage-0.99.1-xmessage-datadir-cleanups.patch
336- Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
337
338* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
339- add Requires(pre) on newer filesystem package (#172610)
340
341* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
342- Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
343  various utils have moved here from there in monolithic X packaging.
344- Add "BuildRequires: xbitmaps-devel" for xbiff.
345- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
346
347* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
348- Initial build, with all apps taken from X11R7 RC2.
349- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
350  some packages.
351- Temporary hack to move xcursorgen manpage to 'man1' dir.
Note: See TracBrowser for help on using the repository browser.